
357© Jennifer Harder 2024 
J. Harder, A Beginner’s Guide to Digital Image Repair in Photoshop: Volume 1,  
https://doi.org/10.1007/979-8-8688-0450-2_7

CHAPTER 7

Masks, Selections, 
and Filling in the 
Gaps: Part 2
In this chapter, we will be continuing the discussion on selection 

tools from Chapter 6. Then we will be working in the Select and Mask 

workspace. We will look at additional selection options for color range, 

focus area, and sky and finally discover how to save and load selections.

Note this chapter does contain projects found in the Volume 1 
Chapter 7 folder.

Note some of the tools I discuss in this chapter can also be found 
in my book Accurate Layer Selections Using Photoshop’s Selection 
Tools.  In that book, the focus was on working with illustrations; 
however, in this book, the focus will be on photos that are digitally 
repaired.
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�Complex Selection Tools
As selections become more complex, you need to rely on other selection 

tools. The three that are used here are the Magic Wand Tool, Object 

Selection Tool, and Quick Selection Tool. Refer to Figure 7-1.

Figure 7-1.  Tools panel has three complex selection tools

Let’s look at those tools next. You can use a duplicate (Image ➤ 

Duplicate) of the tower_selection_image_final.psd file to practice.

�Magic Wand Tool (W)
When you need to select areas of similar colors, the Magic Wand tool 

can help you do that. Many of the selection options are similar to the 

Rectangular Marquee tool, so you can refer to that section for more details 

in Chapter 6. Click an area of color, such as the sky, if you want to select it 

and then use the Shift key when you want to add to the selection. You can 

use Edit ➤ Undo (Ctrl/CMD+Z) if you want to go back a step in what you 

have selected. Refer to Figure 7-2.
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Figure 7-2.  Use the Magic Wand tool to select various clouds 
in the sky

Look from left to right at the Options bar panel. Refer to Figure 7-3.

Figure 7-3.  Magic Wand Tool Options bar panel

After the tool’s preset picker, you will find the same selection options 

as the Rectangular Marquee tool in Chapter 6: New Selection, Add To 

selection, Subtract from selection, and Intersect with selection.

The next option is the sample size, which refers to the number of pixels 

sampled by the tool. Refer to Figure 7-4.
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Figure 7-4.  Magic Wand tool Options bar panel with the list of 
sample size options

This is similar to the Eyedropper Tool (I) which samples color pixels as 

well for the purpose of creating a swatch as seen in the Tools panel. Refer 

to Figure 7-5.

Figure 7-5.  Eyedropper Tool Options bar panel can add a new 
swatch to the Tools foreground

However, when the Magic Wand Tool samples, upon click it creates a 

selection. The sample size by default is set to point sample, but there are 

other presets you can access from the drop-down list, such as 3x3 Average, 

which will sample a larger area. Refer to Figure 7-4.

The next setting is tolerance (0–225), which sets the range when 

sampling colors. Generally, when sampling colors, I will leave it at the 

default of 32, but sometimes a lower setting will give you a more precise 
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selection. In the case of the sky, to select more of it faster, I may want to 

raise the setting to about 100, which would get most of the sky-blue area 

selected in one click. Refer to Figure 7-6.

Figure 7-6.  Magic Wand tool Options bar panel with the tolerances 
changed from 32 to 100, resulting in a faster selection in the image
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However, this tolerance choice can vary from project to project. So, 32 

is a good starting point.

By default, anti-alias is enabled to smooth the edge transition. 

Contiguous is also enabled when you want to sample bordering pixels to 

make a larger selection, as I have done here.

Sample All Layers by default is disabled and is fine when you are 

selecting from the background layer (Layer 0), but you should enable 

this setting, for example, if you are working on the above (Layer 1) when 

you want to sample colors from that layer or multiple layers to get a more 

accurate selection. Refer to Figure 7-7.

Figure 7-7.  Layers panel working with the Magic Wand Tool options 
on Layer 1 with Sample All Layers active
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The next settings, Select Subject and Select and Mask, are more 

complex settings and workspaces, which we will review after discussing 

the next two selection tools. Refer to Figure 7-8.

Figure 7-8.  Magic Wand tool Options bar panel with Select Subject 
and Select and Mask buttons

As you click and Shift-click to add to your selection, for example, you 

may want to add the blue sky that is inside of the tower to your selection. 

Note that, as you work, you can enter and exit the Quick Mask Mode (Q) 

at any time and refine your selection. In this case, I may want to clean 

up the selection around the top of the tower, as when I selected a higher 

tolerance, it selected this area as well. Refer to Figure 7-9.
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Figure 7-9.  Viewing the selection of the sky in Quick Mask Mode 
reveals that some of the tower was selected as well because it had a 
similar color contrast threshold or tolerance with the sky

So, I would likely spend some time zoomed in with my Brush or Eraser 

Tool masking that area of the selection, then exit Quick Mask Mode to 

review the selection again. Refer to Figure 7-10.
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Figure 7-10.  Use the Eraser tool in Quick Mask Mode to clean up the 
sky selection and then exit Quick Mask Mode to review

�Object Selection Tool (W)
The Object Selection Tool is used to quickly select objects that it recognizes 

and creates a surrounding selection. It has some similar selection features 

like the Rectangular Marquee tool, but many differences as well. How you 

select depends on what mode and settings are enabled in the Options bar 

panel. Let’s continue with the unicorn.psd example used in Chapter 6. 

Refer to Figure 7-11.
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Figure 7-11.  Use the Object Selection tool for a quick selection of 
the unicorn

Look from left to right at the Options bar panel. Refer to Figure 7-12.

Figure 7-12.  Object Selection Tool Options bar panel

After the tool’s preset picker, you will find the same selection options as 

the Rectangular Marquee tool: New Selection, Add, Subtract, and Intersect 

with selection. In this example, we want to create a New Selection, but we 

are going to let the Object Finder do the work for us.
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When using this tool, make sure that the Object Finder checkbox is 

enabled. This will then allow you access to the next set of buttons. The 

refresh button (rotating arrows) allows you to refresh the selection setting 

for the Object Finder. Refer to Figure 7-13.

Figure 7-13.  Object Selection Tool Options bar panel with various 
Object Finder settings that can be accessed from the gear menu

The next button (square with three inner shapes) allows you to show 

all objects (hold down the N key if you need to toggle the preview mode). 

Even some bushes have the potential of being selected if that was your 

intent. Refer to Figures 7-13 and 7-14.

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



368

Figure 7-14.  Multiple objects could be selected using the Object 
Selection tool

The gear icon (see Figure 7-13) has additional options that control the 

overlay, such as Object Subtract which finds and automatically subtracts 

an object within a defined region. This could be the area between the 

unicorn’s front legs. Object Finder mode is by default set to auto refresh 

radio button, but you can change the setting to manual refresh by selecting 

that option. The other Overlay Options are for Color (Magenta), Outline 

(1.5px), Opacity (100%), and whether to show the overlay (auto, always, or 

never). Leave at the Auto radio button setting.

The next setting is the mode of selection. You can either use a 

Rectangular Marquee called Rectangle to create your selection or the 

option of Lasso. Refer to Figure 7-15.

Figure 7-15.  Object Selection Tool Options bar panel’s mode options
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As you saw earlier with the Lasso tool, the mode of Lasso may get you a 

closer accurate selection. Refer to Figure 7-16.

Figure 7-16.  Use the mode of Rectangle or Lasso to get Object Finder 
to detect what you want to select

However, rather than dragging over or around the object because 

Object Finder is already set to detect the unicorn, simply clicking with your 

tool is enough regardless of the mode. Refer to Figure 7-17.
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Figure 7-17.  An accurate selection was created of the unicorn using 
the Object Selection Tool

The next option, Sample All Layers, by default is disabled, but when 

you want to sample colors from multiple layers to get a more accurate 

selection, enable this setting. Refer to Figure 7-18.
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Figure 7-18.  Object Selection Tool Options bar panel with Hard Edge 
settings enabled and the current selection

The next option is Hard Edge, which when enabled enforces a hard 

edge on the selection. The next button is an alert that allows you to provide 

feedback on the selection results. Refer to Figure 7-19.
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Figure 7-19.  Object Selection Tool Options bar panel 
feedback button

In this example, I thought this tool did a much better job and was faster 

than the Magnetic Lasso tool.

The next options, Select Subject and Select and Mask, are more 

complex settings and workspaces, which we will review after discussing 

the next selection tool. Refer to Figure 7-20.

Figure 7-20.  Object Selection Tool Options bar panel with the Select 
Subject and Select and Mask buttons

As with other selection tools, you can enter and exit the Quick Mask 

Mode (Q) at any time and refine your selection as you work, for example, 

the area around the hoofs or horn which may need some refinement. Refer 

to Figure 7-21.
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Figure 7-21.  The selection around the horn of the unicorn may need 
some refinement in Quick Mask Mode

You can review this selection that I saved in the unicorn_final.psd 

file. Likewise, try this tool on the tower_selection_image_final.psd and 

compare the results.
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�Quick Selection Tool (W)
The Quick Selection tool in some ways operates similarly to a brush 

to create a wide range selection when you drag over an area. Use a 

duplicate (Image ➤ Duplicate) of the file squirrel_selection.psd. Refer to 

Figure 7-22.

Figure 7-22.  Use the Quick Selection Tool when you want to create a 
selection around a furry creature
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Note that you may prefer to use the Object Selection Tool for this 

example. However, sometimes, when you add to or subtract from a 

selection quickly around the fur or hair, this can be a better option, as there 

may be situations where the Object Selection Tool fails to recognize the 

object, or you don’t want to enter Quick Mask Mode right away.

For the Quick Selection Tool, look from left to right at the Options bar 

panel. Refer to Figure 7-23.

Figure 7-23.  Quick Selection Tool Options bar panel

After the tool’s preset picker, you can use the brush buttons to create 

a new selection, add to the selection, or subtract from the selection. The 

default setting is add, since you want the selection to increase. If you want 

to remove some of the selection, switch to that option and paint out some 

areas. Refer to Figure 7-24.

Figure 7-24.  Quick Selection Tool Options bar panel for creating 
new, adding to, or subtracting from the selection
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The brush options drop-down list allows you to set the selection 

brush’s size, hardness, spacing, angle, roundness, and dynamic control size 

(off, pen pressure, or stylus wheel). As you switch between brush options, 

the settings will remain the same. Refer to Figure 7-25.

Figure 7-25.  Quick Selection Tool Options bar panel for 
brush options

The next option again is the brush angle that is the same as the one 

displayed in the brush options. Refer to Figure 7-26.

Figure 7-26.  Quick Selection Tool Options bar panel for Angle, 
Sample All Layers, Enhance Edge, Select Subject, and Select and 
Mask buttons
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Sample All Layers by default is disabled, but when you want to sample 

colors from multiple layers to get a more accurate selection, enable this 

setting. The next setting is Enhanced Edge; when enabled, it allows for the 

selection’s edge to automatically reduce the roughness or jaggedness of the 

selection boundary. Areas around the squirrel’s tail might be best for this 

setting. Refer to Figure 7-27.

Figure 7-27.  Quick Selection Tool Options bar panel with Enhance 
Edge enabled

The selection flows closer to the subject’s boundaries applying the 

edge refinement.

This can be done manually in the Select and Mask workspace as you 

will see shortly.

The next button is Select Subject, which we will explore in more 

detail now.
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�Understanding the Select Subject Button
The Select Subject button, as you have noticed, is included with the Magic 

Wand, Object Selection, and Quick Selection tools. This option can also be 

accessed via the Select menu. Refer to Figure 7-28.

Figure 7-28.  Quick Selection Tool Options bar panel with Select 
Subject button options

The purpose of this button is to create a selection from the most 

prominent objects in the image; by default, it is set to Device for quicker 

results, but you can also set it to Cloud for detailed results. Leave on Device 

for now. When you click this button and you already have a selection, click 

OK to the message, and a new selection will be created around the object. 

Refer to Figure 7-29.

Figure 7-29.  Warning message that appears when the Select Subject 
button is clicked and a selection is already active

In this example, you will notice that the squirrel’s feet were removed from 

the selection because they are a close color match with the brown wood. In 

this case, you could return to the Quick Selection tool and paint back (Add to 

Selection) that part of the selection now missing. Refer to Figure 7-30.
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Figure 7-30.  Select Subject may not select all parts of the squirrel, 
and you may need to use the Quick Selection tool to paint back parts 
of the selection

As with other selection tools, you can enter and exit the Quick Mask 

Mode (Q) at any time and refine your selection as you work with the Brush 

or Eraser tools, such as the fur on the squirrel’s tail, or you can use the next 

button called Select and Mask.
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�Working with the Select and Mask Workspace
The Select and Mask button, which is available to all the selection tools, 

which we have discussed so far in this chapter and the marquee and lasso 

tools in Chapter 6, after you have created your selection allows you to work 

in a complex workspace for further editing and refinement of the selection. 

This workspace can also be accessed via the Select menu (Select ➤ Select 

and Mask).

In my book that I mentioned at the beginning of this chapter, I have 

used this workspace to refine a selection on an illustration. However, Select 

and Mask is ideal for photos where you have a lot of fine details that need 

selection, such as hair and fur. We will continue to work on the squirrel 

selection on the background layer. Refer to Figure 7-31.

Figure 7-31.  In the Layers panel, I am on the Background Layer 
when the Select and Mask button is clicked
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Let’s explore that area now by clicking that button to enter the 

workspace.

This workspace has several tools, an Options bar, and a Properties 

panel for creating your mask selection. Refer to Figure 7-32.

Figure 7-32.  Working in the Select and Mask workspace

The tools that you can use in this section are described here and can be 

found on the left-hand side of the workspace, while the Properties panel is 

found on the right. Refer to Figure 7-33.
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Figure 7-33.  Select and Mask workspace tools and Properties panel 
in View Mode

Note I will explain the Properties panel in a moment, but for now, your 

view is set to Onion Skin (O) which shows a semitransparent area around 

your selection. However, as you work you may preview to set your view to 

Marching Ants (M) as you have seen with other selections. For now, leave 

on Onion Skin mode. First, we will review the tools and then look at those 

viewing properties later.

�Quick Selection Tool (W)

Similar to the Quick Selection Tool outside of the workspace, this tool 

allows you to paint by clicking and dragging a selection mask based on 

color and texture similarities. Refer to the Options bar panel and look from 

left to right. Refer to Figure 7-34.
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Figure 7-34.  Select and Mask workspace tools Quick Selection Tool 
Options bar panel

As you paint, the options let you add to the selection or subtract from 

the selection and change the brush size (1–5000). Here, I added a bit more 

selection around the squirrel’s tail. Refer to Figure 7-35.

Figure 7-35.  Paint with the Quick Selection Tool to add more of the 
squirrel fur on the tail to the selection
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If there is more than one layer, you can choose to Sample All Layers; 

however, if you are working on the current layer to create a selection, then 

leave this option unchecked. Refer to Figure 7-34.

Within the workspace, you can also use the same settings of Select 

Subject when you want to create a selection from the most prominent 

objects in the image. By default, it is set to Device. Refer to Figure 7-36.

Figure 7-36.  Select and Mask workspace tools Quick Selection Tool 
Options bar panel, Select Subject and Refine Hair buttons

However, there is a new button in this area called Refine Hair which is 

available to all the selection tools in this workspace.

Refine Hair is used when you want to find and refine hair around the 

selection. Adobe recommends that you use it when you have set the Refine 

Mode of Object Aware in the Properties panel. We will look at that area 

after reviewing the rest of the workspace’s tools. However, you can click 

that button now to see the results as it appears to feather that area around 

the furry tail a bit more. Refer to Figure 7-37.
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Figure 7-37.  Try the Refine Hair button on the squirrel and preview 
the results

�Refine Edge Brush Tool (R)

This tool is also for selections and is very similar to the Brush tool in this 

workspace, but it is used for refining the edge or border areas of your 

selection. You can brush over an area like hair and fur to get finer selection 

details. Try brushing around some of the furry edges of the squirrel’s body 

to practice.

Refer to the Options bar panel, and looking from left to right, you will 

notice that it shares many of the same options as the Quick Selection Tool. 

Refer to Figure 7-38.

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



386

Figure 7-38.  Select and Mask workspace tools Refine Edge Brush 
Tool Options bar panel

However, unlike the Quick Selection Tool, while you add (expand 

detection area) and subtract (restore orignal edge) from your selection, 

you have more options to change the brush’s size, hardness, spacing, angle, 

roundness, as well as dynamic control size options if using a stylus. Refer 

to Figure 7-39.

Figure 7-39.  Select and Mask workspace tools Quick Selection Tool 
Options bar panel Brush options
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The angle of the brush can also be set outside the drop-down list. Refer 

to the Quick Selection tool if you need more details on the setting of the 

Sample All Layers checkbox, Select Subject button, and Refine Hair button. 

Refer to Figure 7-38.

�Brush Tool (B)

After using the Quick Selection Tool and Refine Edge Brush tool, you 

can use the Brush tool to clean up remaining details by adding to or 

subtracting from the selection. The options for this tool, found in the 

Options bar panel, are similar to the previously mentioned tools, Quick 

Selection and Refine Edge Brush. Refer to those tools if you need more 

details on Brush options list, angle, Sample All Layers, and the Select 

Subject and Refine Hair buttons. Refer to Figure 7-40.

Figure 7-40.  Select and Mask workspace tools Brush Tool Options 
bar panel set to add to selection

Here, I tried painting a bit with the subtract from selection option 

outside the squirrel as I noticed that some areas outside of its fuzzy tail on 

the right were also being picked up. Refer to Figure 7-41.
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Figure 7-41.  Select and Mask workspace tools Brush Tool Options 
bar panel set to subtract from selection and painting out areas on the 
right of the squirrel’s tail
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�Object Selection Tool (W)

The Object Selection tool is basically identical to the same tool outside of 

the workspace. Drag out a Rectangular Marquee or Lasso loop around the 

object you want to select. Refer to Figure 7-42.

Figure 7-42.  A quicker selection of most of the squirrel could be done 
in the Select and Mask workspace with the Object Selection tool

Or in this case, just click. The Object Finder uses the application to 

identify and detect select objects within an image and then creates and refines 

the current selections. You can refer to the section on Object Selection tool 

earlier in the chapter. However, I will just mention that this tool in the Select 

and Mask workspace assumes that a selection is already present, and so no 

new selection button is available; you either add, subtract, or intersect with 

the selection. Be aware of this difference should other selections you made 

surrounding the squirrel be added to this selection as well. You may need to 

then subtract those unrequired objects.

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



390

For reference, view the Options bar panel from left to right. Refer to 

Figure 7-43.

Figure 7-43.  Select and Mask workspace tools Object Selection Tool 
Options bar panel

The other settings which are the same are Enable the Object Finder 

checkbox, refresh icon, and show all objects option button. Set any addition 

options using the gear icon drop-down menu. Refer to Figure 7-43.

Then choose the selection mode of either rectangle or lasso. You 

can choose to enable the settings of “Sample All Layers” and Hard Edge 

checkboxes. Next to the feedback button is the Select Subject and Refine 

Hair buttons; refer to the Quick Selection Tool if you need more details on 

those settings. Refer to Figure 7-44.

Figure 7-44.  Select and Mask workspace tools Object Selection Tool 
Options bar panel set to Rectangle or Lasso mode

After using this tool, you can return to the other previously mentioned 

tools at any time to clean up your selection.

�Lasso Tool (L) and Polygonal Lasso Tool (L)

These last two selection tools are found together and are basically the same 

as the tools found outside the workspace and mentioned in Chapter 6.  

Use the Lasso when you want to loop around and create a selection in a 

free hand style or use the Polygonal Lasso when you want to quickly create 
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straight edge segments for a selection. Remember, with the Polygonal 

Lasso, to close your selection when you click the starting point and the O 

symbol appears or double-click. Use the Delete/Backspace key if you need 

to go back a step as you create the selection. Refer to Figure 7-45.

Figure 7-45.  Select and Mask workspace tools Lasso and 
Polygonal Lasso

Unlike the tools outside the workspace, here there is no New selection 

button; you can either add, subtract, or intersect with the selection. Refer 

to the Options bar panel from left to right. Refer to Figure 7-46.

Figure 7-46.  Select and Mask workspace tools Lasso Tool Options 
bar panel

Refer to the Quick Selection tool if you need more details on the 

Sample All Layers checkbox, the Select Subject button, and the Refine 

Hair button.

In this example, neither of these tools are required, but be sure to test 

them on your own projects.

�Hand Tool (H)

As you have seen from Chapter 2 and onward, make sure to use your Hand 

tool when you need to navigate around an image, especially if you are 

zoomed in. The Hand tool Options bar also allows you to scroll all opened 

document windows, if more than one document is open, as well as zoom 

in to 100%, Fit Screen, or Fill Screen when you click that button. Refer to 

Figure 7-47.
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Figure 7-47.  Select and Mask workspace tools Hand Tool Options 
bar panel

While in the workspace, you can still use the Spacebar key to access 

the tool.

�Zoom Tool (Z)

Use the Zoom Tool and its options to zoom in and magnify or zoom out. 

In the Options panel bar, there are some similar settings to the Hand tool. 

However, you can also enable the settings of Resize Windows to Fit, Zoom 

All Windows, and Scrubby Zoom. Refer to Figure 7-48.

Figure 7-48.  Select and Mask workspace tools Zoom Tool Options 
bar panel

While in the workspace, you can also use the commands of Ctrl/

CMD++, Ctrl/CMD+-, and Ctrl/CMD+0.

Note  In this workspace, you do not have access to the History 
panel; use Ctrl/CMD+Z if you need to undo a step.

�Properties Panel

The panel on the right is the Properties panel, which can also help you 

view and refine the selection. Its settings change based on which view you 

choose in View Mode. Refer to Figure 7-49.
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Figure 7-49.  Select and Mask workspace tools Properties panel with 
view options
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View Mode

This mode allows you to set how you want to view your selection, and 

you can use the drop-down menu to choose different modes such as the 

following:

Onion Skin (O): View against a semitransparent background. This 

transparency can be adjusted with the slider (0–100%). I left this setting at 

20% transparency in the examples shown earlier. Refer to Figure 7-49.

Marching Ants (M): Like the selections outside the workspace, this 

makes it appear like moving dashed lines, known as marching ants. It 

can also reveal some areas that you may still not have selected or masked 

enough. Refer to Figure 7-50.

Figure 7-50.  Properties panel View Mode Marching Ants
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Overlay (V): Similar to a Quick Mask Mode, you can set a red overlay to 

work with your tools. You can also control the overlay’s opacity (0–100%), 

color using the color picker, and “Indicates” in that overlay for Masked 

Areas or Selected Areas using the list. Leave on Masked Areas. I set my 

opacity at 48% as 100% is a bit too intense to look at while masking. Refer 

to Figure 7-51.

Figure 7-51.  Properties panel View Mode overlay and options

On Black (A): This places the selection on a black background area; 

you can set the Opacity level slider (0–100%). The default is 50%. However, 

for dark animals like the squirrel, this may not be an ideal color. Refer to 

Figure 7-52.
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Figure 7-52.  Properties panel View Mode On Black and Opacity slider

On White (T): This places the selection on a white background area; 

you can set the Opacity level slider (0–100%). The default is 50%. The 

mask in this case is a bit difficult to see as there are a lot of bright areas 

surrounding the squirrel. Refer to Figure 7-53.

Figure 7-53.  Properties panel View Mode On White and Opacity slider
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Black and White (K): This visualizes the selection as black and white. 

This is similar to how it will appear as a layer mask or saved channel 

selection as you will see later in the chapter and Chapter 8. It can give you 

a good idea of whether the mask is fading correctly or not. But in this case, 

you cannot see the actual squirrel. Refer to Figure 7-54.

Figure 7-54.  Properties panel View Mode Black and White

On Layers (Y): The selection is surrounded by an area of transparency. 

This can help us visualize what would actually be selected and could be 

copied to a new layer outside of this workspace. Refer to Figure 7-55.
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Figure 7-55.  Properties panel View Mode On Layers

Pressing the F key will allow you to cycle through the views, while 

pressing the X key to toggle temporarily disables all views.

Depending on the view that you are using, you can set other options. 

Refer to Figure 7-56.
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Figure 7-56.  Properties panel View Mode options outside of the 
View menu

Show Edge (J): This displays the area of refinement created by the 

Refine Edge Brush Tool. By default, this option is disabled, but here is how 

it might appear in Onion Skin View Mode. Refer to Figure 7-57.

Figure 7-57.  Properties panel with Show Edge (J) enabled
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Show Original (P): View the original selection when you started. By 

default, this setting is disabled. Refer to Figure 7-56.

Real-time refinement: This will render an accurate preview of the 

changes. However, while brushing, the update preview may slow down.

High Quality Preview: If enabled, a high-quality preview is displayed; 

when unchecked, a low-quality preview is displayed. Keep unchecked 

while brushing as this may affect performance.

Preset: Once you create your ideal viewing presets, you can save, load, 

and delete them, when you choose that option from the list. The current 

preset is set to default, but you can create your own custom settings as you 

work. They are saved as .SLM files. Refer to Figure 7-56.

Remember settings: When enabled, it remembers the current settings 

should you exit the workspace while working on your selection. Currently, 

I have that setting disabled. Refer to Figure 7-56.

Pause here for a moment to find your ideal View settings and then, 

before continuing with the next settings in your Properties panel, use your 

brush tools to clean up the selection, adding or subtracting as you work. 

I use the Overlay view mode and Brush to clean up my selection. Then I 

switch between the Quick Selection Tool and Refine Edge Brush Tool to get 

a better selection. Adjust your brush size as required; a smaller size may 

give you a better selection. Refer to Figure 7-58.
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Figure 7-58.  Use the Overlay view mode and various brush tools in 
the Select and Mask workspace to continue to refine the selection

View in other view modes to compare, and when happy with your 

selection results, continue on to the next section in the Properties panel.

Refine Mode

When working with the current brushes such as the Refine Edge Brush 

tool, you can choose one of two options. Currently, you have been working 

in Color Aware mode. Refer to Figure 7-59.

Figure 7-59.  Properties panel Refine Mode settings
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Color Aware: Recommended for simple or contrasting backgrounds.

Object Aware: Recommended for hair, fur, or complex background 

when using the Refine Hair button or Edge Detection.

When you switch modes, you will get the following alert message. Click 

OK to proceed or cancel. Refer to Figure 7-60.

Figure 7-60.  Alert that appears when you switch between modes

I’ll click OK and proceed to the next section of the Properties panel 

while in Object Aware mode. At this point, your current selection should 

be unchanged.

Edge Detection

There are two settings in this section. Refer to Figure 7-61.

Figure 7-61.  Properties panel Edge Detection settings
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Radius: This determines the size (0–250px) of the edge of the selection 

of the refinement area. A small radius gives a sharper edge, while a large 

one will give a softer edge. Currently, it has been set to 0 pixels. However, if 

increasing the size of the radius to 80px, you can see that the edge area in 

some areas around the feet increases and blurs. Refer to Figure 7-62.

Figure 7-62.  Altering the radius may change selection around the 
edge of the squirrel

Smart Radius: Enable this option when you want to automatically adapt 

the radius to the image edges. This can allow for variable widths, such as 

when dealing with hair that is near shoulders in portrait images. The hair 

would likely need a greater refinement than the shoulders, the shoulders 

being a more consistent area. This can also reduce some of the fuzziness of 

the refined edge around the feet area for this example. Refer to Figure 7-63.
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Figure 7-63.  Adding the setting of Smart Radius can also alter the 
selection around the squirrel

Remember, you can view this radius when in your view mode you have 

enabled the Show Edge option. Refer to Figure 7-64.

Figure 7-64.  Enabling Show Edge in the Properties panel View 
Mode setting
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Knowing this, I’ll reduce the Edge Detection radius down to 0px, but 

I can leave my Smart Radius on, and I may want to use my Brush tool 

to clean up some of those gaps inside the body in the overlay except for 

around the tail. Refer to Figure 7-65.

Figure 7-65.  Adjust the Radius setting and paint areas around the 
squirrel to clean the selection up

Turn the Show Edge settings off and continue to use your brush, as 

required, after you disabled the setting. Then continue on to the next 

section in the Properties panel. Refer to Figure 7-66.
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Figure 7-66.  Turn off Show Edge after making adjustments on 
the overlay

Global Refinements

Further refinements to the edge of a selection can then be made using the 

sliders and buttons. These changes affect the overall selection. Refer to 

Figure 7-67.
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Figure 7-67.  Properties panel Global Refinements options

Smooth (0–100): This smooths the jagged selection edges. In this case, 

I left the settings at zero, but a higher setting did cause the selection to alter 

near the squirrel’s ears, and I want the selection, instead, to be tight. Refer 

to Figure 7-68.

Figure 7-68.  Move the smooth slider to view how the mask changes
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Feather (0–1000px): This softens and blurs the selection edge. Too high 

a setting can cause overall blurring, making your selection disappear. In 

this case, I left the selection on 0px. Refer to Figure 7-69.

Figure 7-69.  Feather slider set to 1000px (preview) and then set 
back to 0px

Contrast (0–100%): Increase or decrease the contrast or transition of the 

selection edge. As a suggestion you may prefer to use this slider and the Edge 

Detection and Smart Radius option in combination with the Refine Edge 

Brush Tool you looked at earlier. Too high a setting may make the transition 

too abrupt and jagged. In this case, I left it at 0%. Refer to Figure 7-70.

Figure 7-70.  Contrast slider set to 100% (preview) and then set 
back to 0%

Shift Edge (–100%,0, +100%): Contract or expand the selection edge. 

Negative values move the soft-edged borders inward or use positive values 

to move the borders outward. Adobe says shifting these borders inward 
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can help remove unwanted background colors from selection edges. 

Here, you can see an inward shift of –52%, an outward shift of +52%, and 

the default settings of 0% on the back of the head of the squirrel. Refer to 

Figure 7-71.

Figure 7-71.  Move the Shift Edge slider to see how it affects 
the overlay

Clear Selection: This removes the current selection in the preview area. 

Use Ctrl/CMD+Z right away if that was not your intent.

Invert: This inverts the current selection. Click Invert again to return 

the selection back to its earlier state. Refer to Figure 7-72.
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Figure 7-72.  Properties panel Clear Selection and Invert selection 
and then click Invert again to get it back to the original selection 
setting displayed as a black & white overlay

Once you are happy with the results, you will want to output your 

selection. The viewing option of black on white can certainly show you 

how far you have come with your selection. Refer to Figure 7-72.

Output Settings

The following Output settings to consider are seen next in Figure 7-73.
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Figure 7-73.  Properties panel Output settings

Decontaminate Colors: This removes the color fringe from the image, 

replacing it with the color of the nearby pixels. It is disabled by default.

When enabled, the strength of color replacement is proportionate to 

the softness of selection edges. Adjust the Amount slider to change the 

decontamination amount. The Amount of 100% (maximum strength) 

is the highest value. Because this option changes pixel color, it requires 

output to a new layer, with or without a layer mask or a document, but not 

as a selection. In this case, you want to retain the original layer, so you can 

revert to it if needed.

In this example, I find that it does make the squirrel tail bushier, but 

then some of the highlights on the edge of the fur are lost and covered by 

the new color. So, in this situation, I will keep the options disabled. Refer to 

Figure 7-74.
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Figure 7-74.  Decontaminate Colors makes the squirrel’s tail appear 
bushier but may add colors I don’t want to the selection

Output to: Depending upon the options chosen, you can choose one 

of the following output types: Selection, Layer Mask, New Layer, and New 

Document. Some options can also be combined with a Layer Mask. Layer 

masks will be looked at shortly in Chapter 8. For now, use the option of 

Selection. Refer to Figure 7-75.

Figure 7-75.  Properties panel Output settings Output To options list

The last option buttons in the Properties panel are reset, OK to commit 

changes, and Cancel to exit. Refer to Figure 7-76.
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Figure 7-76.  Properties panel Output settings: reset, OK, and 
Cancel buttons

In this case, I chose the Output of Selection and clicked OK.

This selection will then be active on the canvas.

We will discuss saving a selection in a moment (Select ➤ Save 

Selection), as this is important if you ever want to refine the selection 

further at a later date using Select and Mask. Refer to Figure 7-77.

Figure 7-77.  Final squirrel selection made

However, I just want to point out a few other selection options you may 

want to consider as well.
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Refer to the following link if you need more information on Select 

and Mask:

https://helpx.adobe.com/photoshop/using/select-mask.html

Make sure to save (File ➤ Save) any of your open files at this point.

�Other Selection Options You May Want 
to Explore from the Select Menu
Three other selection options that are found in the Select menu, which you 

may want to consider, are

•	 Color Range

•	 Focus Area

•	 Sky

I will give you a brief overview of what each of these is used for should 

you have similar projects.

�Color Range
Color Range is a good option when you need to select specific colors 

within a photo that may be scattered throughout, such as selecting the 

blue areas of the sky which is broken up by trees and their branches, in the 

earlier winter snow image from Chapter 3. Use the file Snow_Content_
color_range.psd to practice.

This kind of selection would take a lot of time using the Magic Wand 

Tool from this chapter, so using this Select ➤ Color Range dialog box can 

speed up the process. Refer to Figure 7-78.
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Figure 7-78.  Sampling the sky using the Color Range dialog box

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



416

Click a color area in the sky to begin setting your color range.

The settings found in this dialog box are as follows:

Select: This drop-down list lets you select a specific color using 

sampled colors, a range such as reds, greens, shadow, highlights, skin 

tones, or out of gamut colors that may not print accurately. Out of gamut 

will be explored in Volume 2. Color ranges that are not present cannot be 

selected. Refer to Figure 7-79.

Figure 7-79.  Color Range dialog box with select color settings list

Detect Faces: When enabled, it allows for more accurate skin tone 

selection if faces are present.

Localized Color Clusters: This is enabled by default to make 

contiguous selection.

Fuzziness (0–200): The slider is used to adjust the falloff beyond the 

selection boundaries or how wide a range of colors is in the selection.

Range (0–100%): Use the slider to adjust the range of the selection 

or how far or near the color is from the localize color clusters. Refer to 

Figure 7-80.
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Figure 7-80.  Color Range dialog box settings

As the settings are changed, the preview area lets you view by selection 

or image. By default, it is set to selection. Then use the selection preview 

options list to preview as a selection mask on the canvas (grayscale, black 

matte, white matte); by default, it is set to none, and your actual image 

will not have an overlay. However, choosing a setting of Quick Mask will 

show you what areas will be part of the selection or masked in red. Refer to 

Figure 7-81.
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Figure 7-81.  Color Range dialog box settings for various 
preview modes
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The other eyedropper buttons on the right allows you to make a 

selection on the canvas, add to the selection, or subtract from the selection 

sample. You can also invert the selection if the checkbox is enabled. Refer 

to Figure 7-82.

Figure 7-82.  Color Range dialog box eyedropper tools, Invert 
checkbox, and buttons

Presets that you create can be loaded and saved. The file is saved 

as .AXT.

Click OK to confirm the settings or Cancel to exit.

Tip H old down the Alt/Option key if you need to turn the Cancel 
button into a Reset button and click to undo current settings.

You can find more details on color range at the following link:

https://helpx.adobe.com/photoshop/using/selecting-color-

range-image.html
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I will just mention that once your selection is active, you can use 

the Quick Mask Mode or Select and Mask to refine the selection further 

as some of the snow, which is blue in the lower area, would have been 

selected as well.

�Focus Area
Focus Area, as you will notice, has some similarities to Select and Mask. 

It also has access to the Select and Mask workspace should you need to 

access it for fine-tuning. Use this option when you want to select areas in 

an image that are in focus. In this case, we could use it to make a selection 

of the area of the garden outside that is framed by the pillars. The area 

inside is rather dark, but you may want a selection of the garden for 

another project.

Open the focus_garden.psd file and while on Layer 0, then use the 

Select ➤ Focus Area dialog box to preview what happens next. Refer to 

Figure 7-83.
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Figure 7-83.  Select the inner area of the framed door using the Focus 
Area dialog box
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The settings in this dialog box include the following:

View Mode: Like the Select and Mask workspace, you can set various 

view modes. Refer to that section earlier in the chapter if you need more 

details. By default, it is set to On White (T). Refer to Figure 7-84.

Figure 7-84.  Focus Area dialog box View Mode and the result of the 
preview selection On White

Toggle the Preview checkbox to see the original image. Note that this 

area does not have an Onion Skin option but has different modes called On 

Layers (Y) to reveal the layer masked by the selection and Reveal Layer (R) 

to view the entire layer without masking.

Parameters: In-Focus Range (0–7.5) is used to adjust the fine-tuning 

of the focus area to broaden or narrow the selection; by default, it is set to 

3.0 when the auto calculation setting is enabled. If you move the slider, the 

auto setting becomes disabled. Refer to Figure 7-85.
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Figure 7-85.  Focus Area dialog box Parameters options

Advanced: Image Noise Level (0.002–0.100) can be increased if too 

much background is selected in a noisy image. In this example, by default, 

it is set to 0.029 when the auto calculation setting is enabled. If you move 

the slider, the auto setting becomes disabled.

Output: Like the Select and Mask workspace, you can set an output 

option such as a selection, layer mask, new layer, or document. Refer to 

that section earlier in the chapter if you need more details. For now, leave 

at Selection. Refer to Figure 7-86.

Figure 7-86.  Focus Area dialog box Output options
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•	 Soften Edge: When enabled, it runs additional 

processing to soften or feather the edges.

	 The tools on the left include

•	 Zoom tool (Z): For zooming in (Alt/Option-click) or 

zooming out.

•	 Hand tool (H): For moving about the canvas.

•	 Focus area add tool (E): Adds to selection. Use the 

brush to add back to the selection.

•	 Focus area subtract tool (E): Subtracts from selection. 

Use the brush to remove parts of the selection. Refer to 

Figure 7-87.	
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Figure 7-87.  Focus Area dialog box tools

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



426

Click OK to commit or Cancel to exit. Upon Clicking OK, you will have 

an active selection. Refer to Figures 7-86 and 7-87.

Tip H old down the Alt/Option key if you need to turn the Cancel 
button into a Reset button.

For more information on this tool, refer to the following link:

https://helpx.adobe.com/photoshop/using/select-area-

focus.html

�Sky Selection
Select ➤ Sky is a very quick selection option and allows you to select areas 

of the sky while on the background layer if you want to edit your otherwise 

dull sky. You can see that here in the garden image (garden_clone_stamp_
final.psd) from Chapter 3. Refer to Figure 7-88.

Figure 7-88.  Use sky selection when you need to select the sky area of 
an image quickly
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Note that some skies are quite complex to select, so using Color Range 

may be a better option, and you still may need to refine this selection 

using Quick Mask Mode (Q) or Select and Mask. However, we will look at 

another sky selection workspace in Chapter 8 (see Sky Replacement).

�Saving Selections in the Channels Panel
Once you have created a complex selection using any or a combination 

of tools, it can be frustrating to then click another selection tool by 

mistake and lose the entire selection that you carefully crafted. Or in other 

situations, you may want to return to that selection later in the project to 

edit further, another day. As you saw earlier in the chapter, the Select and 

Mask has a wide variety of options for output, including layer mask, but 

when you just want to save a selection upon exiting the workspace, while it 

is active, choose Select ➤ Save Selection. In this case, the selection around 

the squirrel was active in the copy of the squirrel_selection.psd file. Refer 

to Figure 7-89.
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Figure 7-89.  Use the Save Selection dialog box to save an active 
selection

When the dialog box opens, you can save the destination in the current 

document, a new document and then as a new channel, or as a layer mask 

on a current layer. Next, you can give it a name. In this case, the operation 
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is to create a new channel, but if it is an already saved channel, you can 

select it from the list, you can add, subtract, or intersect with it. If you 

have other channels already saved, you will have the additional option of 

replacing that channel.

Click OK to save the selection in the Channels panel. You can now 

safely Select ➤ Deselect the selection. Refer to Figure 7-90.

Figure 7-90.  Selections are saved in the Channels panel under the 
main color channels

�Load a Selection
If you need to load a saved selection from the Channels panel, choose 

Select ➤ Load selection. In my case, I already have saved my squirrel 

selection, so if you need to practice, you can look at the file squirrel_
selection_final.psd. Refer to Figure 7-91.
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Figure 7-91.  Load a selection using the Load Selection dialog box

Select the source document and the channel name. Alternatively, 

you can enable invert to reverse the loaded selection. In this case, the 

operation is a new selection. However, if you have a selection already 

active, you can add to selection, subtract from selection, or intersect with 

the selection. Click OK to exit and the selection is loaded on the canvas as 

seen in Figure 7-89.

�Creating Separate Channel Selections 
from an RGB Photo
Besides adding selections to your Channels panel, you will notice that this 

panel holds the three RGB channels (Red, Green, Blue) and a composite of 

those channels called RGB. Refer to Figure 7-92.

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



431

Figure 7-92.  All channels or selections can be loaded to create an 
active selection

These should not be confused with layers even though the layout looks 

similar, and you can turn the visibility eyes on and off to see a grayscale 

image of each channel. You can load individual channels to create 

selections, and this could later assist you with your work in Volume 2. 

Whether a channel or a selection, you can load it by Ctrl/CMD-clicking the 

thumbnail image in the panel to load the selection.

Note  In Volume 2, we will see how to adjust the RGB channels to 
affect color using adjustment layers. For now, while working with the 
Channels panel to have your RGB channels’ (separate and composite) 
visibility eyes on and selected, the selection channel’s visibility eye 
is off and deselected to avoid entering a masked state. Refer to 
Figure 7-92.

Save (File ➤ Save) any of your open files at this point.
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�Summary
In this chapter, we used three selection tools, the Select and Mask 

workspace, and several selection options found in the Select menu that 

can assist when we want to save and load a selection to eventually fill in 

the gaps and missing details using the tools from Chapters 3–5. In the next 

chapter, we will look at how to add layer masks as well as work with various 

workspaces to fill in gaps with selected and generated content.
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