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CHAPTER 3

Tools for Photo 
Restoration: Part 1
Photoshop, as we have seen, has quite a few tools in the Tools panel, and 

to a beginner user, this can be quite overwhelming. I know for myself this 

was the case when I started using Photoshop. I often did not know where 

to begin or what tool to use. Over time, you will discover that some tools 

are ideal for photo restoration, while others are better for more artistic and 

abstract projects. Nevertheless, many tools can be used in combination, 

and you need to identify what the issue or damage actually is in the image 

before you use one particular tool. In other situations, different tools can 

fix the same damage, but you may prefer how one corrects over the other.

In this chapter, I will explain to you some of the main tools in the Tools 

panel I like to use for photo restoration or “healing” the damage, as well 

as some that can enhance your work or correct minor spot damage. Note, 

you may not use all these for every project. In this chapter as well as the 

following chapters, we will be using the Layers panel and try to work in 

the least destructive way possible so that you can go back at any time and 

correct your errors. You will be able to do that if you make sure that, as you 

saw in Chapter 2, you save a duplicate of your scan as a .psd document.
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Note this chapter does contain projects found in the Volume 1 
Chapter 3 folder. Some tools mentioned in this chapter have also 
been mentioned in my previous books, Accurate Layer Selections 
Using Photoshop’s Selection Tools and Perspective Warps and Distorts 
with Adobe Tools: Volume 1, but with new information presented as 
it relates to photographic images. As you work on each project in 
this chapter, make sure to create a duplicate (Image ➤ Duplicate), 
as mentioned in Chapter 2, so that you do not override the original 
artwork, and click OK to the message in the dialog box. Refer to 
Figure 3-1.

Figure 3-1.  Duplicate Image dialog box

Remember, as you work, to use the Move, Zoom, and Hand tools as 

well as the related key commands that were mentioned in Chapter 2. As 

well, use your History panel or Edit ➤ Undo (Ctrl/CMD+Z) if you make a 

mistake and need to revert a few steps. Refer to Figure 3-2.

Chapter 3  Tools for Photo Restoration: Part 1

https://doi.org/10.1007/979-8-8688-0450-2_3
https://doi.org/10.1007/979-8-8688-0450-2_2
https://doi.org/10.1007/979-8-8688-0450-2_2


115

Figure 3-2.  Move, Zoom, and Hand Tools and History panel

Tip  When you save (File ➤ Save) your files later as a suggestion, 
you can also add your initials to the name so that you do not override 
the original file, for example, practice_file_JH.psd.

�Identifying Photo Damage/Issues 
and Working with the Healing Tools
In Photoshop, there are currently a collection of seven tools thought of as 

the “Healing Tools.” These tools can be used to digitally cover or fix such 

things as patching rips, creases, and stains as well as cover white spots, 

dust, and reflections where details are missing. This would be considered 

repairing an image to bring it back to its original state. However, if you are 

not as concerned about the authenticity and would just like a nice photo 

to display, you can also go a step further and fix cosmetic issues such as 

blemishes or add missing parts to a person that would be beyond the 

original borders of the canvas. You could also add copies of trees to fill in 

gaps or remove unnecessary details in the picture, such as powerlines, a 
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person, animals, or an object that is blocking part of an otherwise good 

photo. You may feel the removal of this item from the image is necessary so 

that you can enjoy the image without distraction. Refer to Figure 3-3.

Figure 3-3.  Before photo of a woman at the beach and after photo 
with the woman removed from the scene

We will see here a few before and afters of how this could appear or 

look while using each tool. However, the suggestions I present here are not 

an exhaustive list, and each damaged photo will have its own challenges. 

As mentioned in Chapter 2, sometimes more than one issue needs 
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correction. So, before you start working with just any tool, look at the photo 

and decide what kind of repair this photo needs to look its best. Then you 

need to identify the correct tool to use for that job. Let’s look at a few of 

these one at a time.

The main tools that I consider to be part of this “healing” collection are

•	 Clone Stamp Tool and Clone Source Panel

•	 Spot Healing Brush Tool

•	 Remove Tool

•	 Healing Brush Tool

•	 Patch Tool

•	 Content-Aware Move Tool

•	 Red Eye Tool

Refer to Figure 3-4.
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Figure 3-4.  Tools panel: The Clone Stamp Tool with various healing 
brushes and tools and Clone Source panel with menu options

Because this is a beginner guidebook, I will not go into all the details, 

but at least this will get you started on working with the tools. I will also 

provide links for reference. Remember to use Edit ➤ Undo (Ctrl/CMD+Z) 

or your History panel if you need to undo a step as you work.
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�Clone Stamp Tool (S) and Clone Source Panel
The Clone Stamp Tool can be selected from the Tools panel and used by 

itself with the Options bar panel, or it can be used in conjunction with the 

Clone Source panel. Refer to Figures 3-4 and 3-5.

Figure 3-5.  The Clone Stamp Tool Options bar panel

This is often the default tool to gravitate to when you need to correct or 

cover basic damage.

Let’s start to practice with the file army_practice_healing_clone.psd. 

Open it in Photoshop and make a duplicate of the file (Image ➤ Duplicate) 

as mentioned in Chapter 2. Refer to Figure 3-6.

Figure 3-6.  Damaged black and white photo of army men practicing 
moving injured soldiers

To give some background on this particular photo, this is a landscape 

picture that was longer than 11 inches, and so it needed to be scanned in 

two sections before I could start to work on it. The second half of the image 
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was then copied into the first file, and the crop tool was expanded so that 

both halves on separate layers could be placed side by side. (See cropping 

later in Chapter 5.) The two layers were then moved separately with the 

Move tool and rotated slightly so that they were level and could be merged 

as one image using the menu command of Layer ➤ Flatten image.

In this case, I have supplied it to you as a single flattened image and 

have blurred the faces of the people in the photo. In your own projects, 

you would not blur faces if working on a personal historical project unless 

specifically asked to do so by a client, as you would generally want to keep 

the faces clear so that you could research and identify if these were known 

people in your ancestry. I will discuss basic blurring later in Chapter 4 and 

again how to create an overall blur with a mask in Volume 2.

Coming back to the image and examining it more closely with the 

Zoom and Hand tools (Spacebar), you can see that there are several 

identifiable rips and creases; some of the rips also appear to have a slight 

reddish color to them. Refer to Figure 3-7.
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Figure 3-7.  Inspecting crease lines and cracks in the photo print 
using the Zoom and Hand tools

This was due to the image remaining slightly bent under the weight of 

the scanner lid when the scanner scanned the area due to the fact that the 

whole image could not sit on the scanner glass flat. I could have scanned 

this image as a grayscale; however, I wanted to retain the original yellow 

tone of the paper for now.
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Spend a moment identifying the areas of damage as well as any 

scratches or white dots that probably do not fit with the original scene.

The Clone Stamp tool is an ideal candidate, for this image, to start with. 

Select that tool now. Refer to Figure 3-8.

Figure 3-8.  Tools panel, Clone Stamp Tool

To practice with the tool, Alt/Option-click a location next to the rip. 

This is to get a source of pixels for repairing that are not damaged, and 

then just click another location once or twice over the crease or rip that 

you want to cover. Refer to Figure 3-9.
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Figure 3-9.  Finding a clone source and then repairing some of the 
damages with the clone source tool on the grass

For the moment, use Edit ➤ Undo, the History panel, or  

Ctrl/CMD+Z. Currently, what was done could be considered destructive, 

and you may want to make alternations as you cover the rip. Refer to 

Figure 3-10.
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Figure 3-10.  Moving back a few steps using the History panel

After you have undone the last cloning step, go to your Layers panel 

and click the Create a new layer button, and a new layer will appear 

where you will continue to use the Clone Stamp Tool moving forward, in a 

moment. Refer to Figure 3-11.
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Figure 3-11.  Use the Layers panel to create a new Layer and then 
work on the new Layer

Before you do that, let’s review our options in the Options bar panel 

from left to right. Refer to Figure 3-12.

Figure 3-12.  The Clone Stamp Tool Options bar panel
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The first option is the tool presets picker, which is used to store the 

custom setting you may create after you have used this tool for a while so 

that you can reuse them again in other projects. Note that tool presets can 

also be accessed from the Window ➤ Tool Preset panel as mentioned in 

Chapter 2. Refer to Figure 3-13.

Figure 3-13.  Options bar panel Clone Stamp tool presets and related 
tool presets menu settings

You would then see the Brush preset picker. This drop-down menu 

allows you to adjust the brush’s size (1–5000px), hardness (0–100%), and 

angle/roundness. The angle is controlled by moving the preview arrow; 

when horizontal and pointing right, it is at 0°. The angle can be adjusted 

by rotating the arrow around the brush (–180,0,180°). Roundness is 

whether the brush is fully round or elliptical. Use the round handles on 

the preview to move the brush roundness in or out (0–100%). The angle is 
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more apparent when you alter roundness giving a narrow angled brush. By 

default, you should in most cases leave the angle at 0° and the roundness at 

100%. Using the brush preview and search, look for a recently used brush 

or one actually stored in your Brushes panel. Refer to Figure 3-14.

Figure 3-14.  Options bar panel Clone Stamp tool Brush preset 
picker options

Note that you can search through the brushes found in the various 
folders. These brushes are used by other brush tools and are all 
located in the Brushes panel. Refer to Figure 3-15.
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Figure 3-15.  Brushes panel options

Use the lower slider in the Brush preset picker menu when you need 

to enlarge the preview of the brushes. In the Options bar panel, the next 

button, resembling a paint brush on a folder, will allow you to access more 

brush settings in the Brush Settings panel. Refer to Figure 3-16.
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Figure 3-16.  Options bar panel Clone Stamp tool options and toggle 
to Brush Settings panel and menu options

While our focus in this book is not on using all the brush settings, I will 

just point out that you can add more specialized settings to your brush 

via this panel, which includes adjusting shaped dynamics and textures. 

However, in most cases, if you want to alter just the default settings, you 

would be using the main tab “Brush Tip Shape,” which includes the same 

settings as the Brush preset picker of size diameter (1–5000px), angle 

(–180,0,180°), roundness (0–100%), and hardness (0–100%).

However, there are other options to flip the brush on the X (horizontal) 

and Y (vertical). By default, they are left unchecked. You can also alter the 

spacing (1–1000%) which is at a default of 25%. Move the sliders to alter the 

settings and look at the preview. Refer to Figure 3-16.
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If you are interested in settings beyond this book, you may want to 

check out my book Perspective Warps and Distorts with Adobe Tools: 

Volume 1 as well as the following link: https://helpx.adobe.com/

photoshop/using/creating-modifying-brushes.html.

The next button in the Options bar panel resembling a stamp allows 

you to toggle to the Clone Source panel. Refer to Figure 3-17.

Figure 3-17.  Options bar panel Clone Stamp tool option to access the 
Clone Source panel and menu options
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The Clone Source panel allows you to have up to five clone source 

points, each with their own settings. By default, it is set to Source 1, which 

is somewhere in the document, when you Alt/Option-click a location. 

Refer to Figure 3-18.

Figure 3-18.  Clone Source panel options for two sources

However, a clone source can be from other open documents as well 

if you Alt/Option-click in them first. You could set this as Source 2 if 

you select that icon in the panel first. In this example, we are only using 

Source 1.

Some of the options in this panel are for buttons for flipping the clone 

horizontally and vertically. Scale the clone source with linkage to the ratio 

by percentage for width (W) and height (H) (1.0–400.0%). Offsetting the 

clone are (X, Y), in this case, pixels. You can change the angle of the clone 

(–360, 0, 360°); by default, it is set to 0. Reset using the counterclockwise 

arrow button. This is not the same as the angle of brush; in this case, you 

are altering the angle of the inner clone source. Refer to Figure 3-17.
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You can change the Frame Offset and lock the frame. However, leave 

this setting at 0 and unlocked as this is used more for frames as you would 

find in an animation or video file. Refer to Figure 3-17.

You can also show and hide the various overlay settings, such as set its 

opacity (0–100%); by default, it is set to show overlay as Normal, but you 

can set other overlay modes so that you can see the underlying setting as 

you paint. By default, the show overlay checkbox is enabled and is set to 

100% Opacity Normal blending mode, so you can see your cloned source 

pixels accurately as you paint. The Clipped setting is enabled, Auto Hide 

disabled, and Invert disabled. Refer to Figure 3-17.

Returning to the Options bar panel, if you don’t like painting an exact 

clone source and want to blend pixel colors as you stamp, you can also try 

other brush options like changing from Mode: Normal to Multiply. These 

are blend settings also called Effect mode. How these overlaying Blending 

Modes affect the overall blend of the underlying colors of a layer will be 

delved into in Volume 2. However, in this book, keep the tool setting on 

Normal for now so that you can use the clone stamp at the default setting 

without altering from the original colors as you clone. Refer to Figure 3-19.
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Figure 3-19.  Options bar panel Clone Stamp tool blend modes

Next, for Opacity the range is 1–100%; if you want to fade the clone as 

you paint, use the slider to adjust Opacity. Generally, when I need to cover 

an area, I will leave the Opacity at 100%, but feather the edges of my brush 

by setting the hardness down to a lower percentage such as 0% using the 

earlier described setting in the Brush preset picker. However, there will 

be times where you will find, when working with the tool, a lower Opacity 

percentage may create a better blend. Refer to Figure 3-20.
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Figure 3-20.  Options bar panel Clone Stamp tool brush preset, 
Opacity options, Flow options, Angle and Align options

Next to Opacity is the round icon with a pen that can be toggled on or 

off. It is called “Always use Pressure for Opacity; when off, the brush preset 

controls the pressure” by default. I usually leave this setting disabled.

Next is the flow setting which controls the Flow rate (1–100%), which 

you can adjust with its slider. I leave this at the default of 100%.

Next to it is the icon button resembling a spray paint gun called 

“Enable airbrush-style build-up effects.” I leave this button by 

default toggled off. However, experiment with it as it may give a more 

blended effect.

Next, you can set the Brush angle (–180,0,180°) of the brush. This 

option is also found in the Brush preset picker and Brush Settings panel; by 

default, this should be set to 0°. When you set it in one location, it changes 

in the other locations to the same setting. Refer to Figure 3-20.

When Aligned is enabled, you use the same offset for each stroke. 

This is more apparent when you click and Shift-click in different locations 

to create a clone in a straight line or click and then Shift-drag. Refer to 

Figure 3-21.
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Figure 3-21.  Options bar panel Clone Stamp tool Align option and 
aligning the brush

�Working on More Than One Layer in a  
Nondestructive Way

At this point, as we saw earlier, you could start to stamp on your 

background layer with the Clone Stamp and use the options in the Options 

bar panel I have presented so far. However, this can be destructive as you 

are working on the background, and once pixels are altered, they are set, 

unless you use the History panel or Ctrl/CMD+Z right away. To avoid 

this, that is why you created a clear blank layer in the Layers panel. Make 

sure that it is currently selected; in this example, it is Layer 1. Refer to 

Figure 3-22.
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Figure 3-22.  Layers panel working on the new layer with the Clone 
Stamp Tool

While working with the Clone Stamp Tool, you can now focus on the 

Options bar panel and choose to sample using Current & Below. Other 

options would be Current Layer, which is best with single layers but again 

is destructive, or All Layers if you are trying to clone some information 

from a layer above. Refer to Figure 3-23.

Figure 3-23.  Options bar panel Clone Stamp Tool sample and 
pressure options

This would sample from all current visible layers but may sample 

from layers you did not intend to. You can, however, select the next option 

that looks like a black and white circle with a slash “turn on to ignore 

adjustment layers when cloning”; this option by default is off. We will 

look at adjustment layers in more detail in Volume 2. For now, use the 

Sample option of Current & Below as you sample this will prevent you from 

sampling from any additional layers you add above later.
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The final setting that looks like a pen in a target icon is “Always use 

Pressure for Size. When off, Brush Preset controls pressure”; this option 

is by default off and is generally used when working with a stylus. Refer to 

Figure 3-23.

�Putting Your Knowledge into Practice

Now that you know your options for the Clone Stamp Tool, on the selected 

blank layer with your Clone Stamp, select a clone source, Alt/Option-click 

and then begin clicking to cover that affected area with surrounding pixels 

to make the crease or rip disappear.

Learning how to work with this tool is very important as you will 

discover some cloning appears better when you adjust the size and 

hardness of the brush using the sliders in the Brush preset picker as 

you work.

For example, areas of wood or stone may be best with a medium-sized 

brush with a hard edge, but the sky, grass, or areas of the skin or cloth 

may be better with a smaller-sized brush or a hardness of 0% for better 

blending. Refer to Figure 3-24.
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Figure 3-24.  Adjusting the Clone Stamp brush size and covering 
the damage

You also need to spend time and experiment with the Brush Settings 

(Figure 3-16) and Clone Source panels (Figure 3-17) to get the best blend.

Slowly work on one rip at a time; remember to zoom in with the Zoom 

tool or use your Hand tool (Spacebar) as you work to moving about the 

canvas from one rip to the next.

Avoid using the Move tool as you do not want to move your cloned 

areas on the new layer by mistake.

As you work, frequently Alt/Option-click in a new location near the 

rip to get a similar source clone. Use sources from both sides of the rip for 

a better blend. And use your Clone Stamp Tool’s source overlay preview 

as a guide especially when dealing with straight edges that need to line up 

like bricks or edges of buildings so that the joins do not appear wavy or 

crooked.
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As you cover the rip, try not to incorporate another part of a 

different rip.

Rather than dragging the Clone Stamp Tool, try a combination of 

clicking and then frequently changing the clone source location until you 

have covered the rip you want and then move on to the next location.

You can use Edit ➤ Undo or the History panel at any time as you work. 

Refer to Figure 3-25.

Figure 3-25.  Use your History panel when you need to go back a 
few steps

Note, if there is less detail around the rip, such as areas in the grass, a 

large brush might be OK. However, when working on areas of high detail, 

such as on clothing, try a smaller-sized brush as you work on the above 

Layer 1. Refer to Figure 3-26.
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Figure 3-26.  Options bar panel Clone Stamp tool options, adjusting 
the brush size

Once you have completed covering a rip, try turning the new layer in the 

Layers panel off and back on using the visibility eye. Refer to Figure 3-27.

Figure 3-27.  Repairing the long rip in the photo and then using the 
Layer’s visibility to review the correction so far
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In my case, I was able to clone and cover the rip; however, there is 

still some redness I was not able to remove around the boot, and that will 

require a color correction with an Adjustment layer and possibly a layer 

mask to isolate the area. Color adjustments with masks will be looked at in 

more detail in Volume 2. Refer to Figure 3-27.

Also, try lowering and then raising the selected layer’s opacity to 0% 

and then back to 100% using the Layers panel Opacity slider if you need to 

see how you are progressing at this point. Refer to Figure 3-28.

Figure 3-28.  Lower the Layer’s opacity if you need to see the damage 
to review the correction
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Rather than using Edit ➤ Undo all the time as you learn more about 

the healing tools in this chapter, you may want to use the Clone Stamp in 

combination with the Eraser Tool to remove your pixel mistakes, which I 

will discuss in more detail in the section “Other Tools for Restoration” in 

Chapter 4. Refer to Figure 3-29.

Figure 3-29.  Tools panel’s Clone Stamp Tool and Eraser tool

Tip  While working with any brush, you can quickly decrease or 
increase the brush’s size by using the left bracket [ or right bracket ]  
on your keyboard. This makes it easier to change sizes rather than 
having to access the Options bar panel’s Brush preset picker. Refer to 
Figure 3-30.

Figure 3-30.  Decrease or increase your brush size using the 
bracket keys
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You can continue to work on this army image on your own, fixing other 

rips and imperfections with the Clone Stamp tool. Or you can return to 

the file again later in the chapter once you have learned a bit more about 

the other related healing tools, such as the Spot Healing Brush tool, which 

we will look at next, and later the Healing Brush tool. Then see the “Photo 

Project” section at the end of Chapter 5 for more information.

Save (File ➤ Save) your work so far. Refer to file army_practice_
healing_clone_p1_final.psd if you need to see my progress.

At this point, try this Clone Stamp tool on a more colorful image, such 

as a copy of the file garden_clone_stamp.psd or one of your own images 

that you scanned. In this example, while working on a new layer, try 

removing some of the thin wires that appear to block the sky, or try adding 

more flowers to another location in the garden. Refer to Figure 3-31.

Chapter 3  Tools for Photo Restoration: Part 1

https://doi.org/10.1007/979-8-8688-0450-2_5


144

Figure 3-31.  Use the Clone Stamp Tool to remove powerlines or add 
flowers on a new layer

Make sure to save (File ➤ Save) each of your files as you work on them. 

Refer to file garden_clone_stamp_final.psd for reference.
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Note that the Pattern Stamp Tool (S) found with the Clone Stamp is 
not discussed in this book as this is more for adding artistic effects 
to an image. If you are interested in this tool, you can refer to my 
Perspective Warps and Distorts with Adobe Tools: Volume 1 book 
mentioned earlier in this chapter or the following link as it is also 
used by the application Photoshop Elements and has similar options. 
Refer to Figure 3-32: https://helpx.adobe.com/ 
photoshop-elements/using/patterns.html.

Figure 3-32.  The Pattern Stamp Tool is found with the Clone 
Stamp Tool

The next set of tools share some similarities and differences to the 

Clone Stamp; let’s look at them next. Refer to Figure 3-33.

Figure 3-33.  Various healing brush tools

Chapter 3  Tools for Photo Restoration: Part 1

https://helpx.adobe.com/photoshop-elements/using/patterns.html
https://helpx.adobe.com/photoshop-elements/using/patterns.html


146

�Spot Healing Brush Tool (J)
The Spot Healing Brush Tool is often a tool used for cosmetic touch-ups on 

a face or skin, such as various imperfections like acne or scars. However, 

this tool does not have to be used just for the face; it can be for small spots 

of missing information, such as reflections and stains on a damaged image, 

or for removing a time stamp. You can try that out on the file  

deer_spot_healing.psd. Refer to Figure 3-34.

Figure 3-34.  Photo of some deer in the winter woods

In this case, part of the time stamp is in the lower right covering the 

silhouette of a deer in the forest. The time stamp is distracting, and you 

may not even notice that deer in the image. As you did with the Clone 

Stamp Tool, make a duplicate file (Image ➤ Duplicate) to work with.

As with the Clone Stamp Tool, working on a new layer is best, so you do 

not destroy the original artwork. Refer to that tool for more details. Refer to 

Figure 3-35.
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Figure 3-35.  Use the Layers panel to create a new layer

After you select the tool, you can review its options in the Options bar 

panel from left to right. Refer to Figure 3-36.

Figure 3-36.  Options bar panel Spot Healing Brush Tool options

Beside the tool’s preset picker, you will find the Brush option’s drop- 

down menu, which includes, for only round or elliptical brushes, a setting 

for size, hardness, spacing, angle, and roundness, and you can use the 

preview to adjust for angle and roundness manually. Optionally, you can 

also work with a stylus for this tool and set the size based on pen pressure 

or stylus wheel or turn it off. Note that you will only be able to use round or 

elliptical brush heads. Refer to Figure 3-37.
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Figure 3-37.  Options bar panel Spot Healing Brush tool options 
for brushes

When working with this brush, Adobe recommends making the brush 

a bit bigger than the imperfection so that it will cover it when you click. 

For skin or blurry regions of the photo as in the army image, reducing the 

hardness of the brush may be a good idea for better blending and then 

clicking once or twice on several areas. Refer to Figure 3-38.
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Figure 3-38.  Using the brush to heal spots on the army man’s arm. 
Options bar panel Spot Healing Brush tool options

However, for the deer picture, around the time stamp, I will use a brush 

with a hardness of 100%.

The painting mode also allows for various types of color blending as 

you paint over an area, but as a beginner, start with the default mode of 

Normal to test. However, using an option like Replace may preserve some 

details from the original photo, such as film grain and texture. In this 

example, you want to cover and blend parts of the time stamp, so a Normal 

mode setting is best. Refer to Figure 3-39.
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Figure 3-39.  Options bar panel Spot Healing Brush Tool options for 
painting mode

The next area called Type refers to how the brush will handle the 

blend. The options are as follows:

Content-Aware: This is the default setting. Unlike the Clone Stamp 

where you have to Alt/Option-click to get a source to start the Spot Heal 

Brush tool, this setting compares the image content nearby to fill the 

selection with realistic details as well as accounting for shadow and object 

edges. Refer to Figure 3-40.

Figure 3-40.  Options bar panel Spot Healing Brush tool options 
for Type

Create Texture: This allows you to create a texture with the pixels from 

pixels within the selection, but may not be best for restoration and leave a 

grainy effect.
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Proximity Match: This is another good option to test as it uses pixels 

that surround the selection to patch the area. It comes with an extra setting 

called diffusion (1–7) that is set to a default of 5 and appears at the end of 

the Options bar panel. Diffusion creates a pattern-like blur which can vary 

in strength based on the settings you choose. It controls how quickly the 

pasted region adapts to the surrounding image. Select a lower value for 

images with grain or fine details or a higher value for smooth/blurry areas. 

Refer to Figure 3-41.

Figure 3-41.  Options bar panel Spot Healing Brush tool options set 
to Type of Proximity Match

In this case, I left it on the Type option of Content-Aware as this created 

the closest blend to cover the numbers.

When working with this tool, as you did with the Clone Stamp, work on 

a new layer by adding it using the Layers panel. Refer to Figure 3-42.
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Figure 3-42.  Options bar panel Spot Healing Brush tool options and 
working on a New Layer in the Layers panel

Then in the tool’s Options bar panel, enable the Sample All layers to 

get details from your background layer and other visible layers if present. 

In the Options bar, the Brush angle is the same angle set when you set 

the brush options from its menu. The last or second to last icon, which 

looks like a target, is “Always use Pressure for Size. When off, Brush Preset 

controls pressure”; this option is by default off and is generally used when 

working with a stylus. Refer to Figure 3-42.

In this example, rather than clicking a single spot to heal, try dragging 

with your brush over a larger area that you want to heal. When you release 

the brush, that number in the time stamp should be hidden and appear 

with the darker color of the deer’s body. Refer to Figure 3-43.
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Figure 3-43.  Removing the time stamp that is covering the deer

Try this on other areas of the time stamp until all the numbers are 

removed. Sometimes, dragging in smaller sections is best rather than 

around the whole number. Use Edit ➤ Undo or Ctrl/CMD+Z if your first 

attempt does not work as you expected. Turn the eye on Layer 1 in the 

Layers panel off and on to review your results. Then save your file.

You can compare the results to my deer_spot_healing_final.psd.

�Remove Tool (J)
The Remove tool is a relatively new tool to the healing tool collection, and, 

as its name says, it is meant to remove a selection from the image. This 

could be anything, such as an unwanted object, plant, or even an animal 

or person, and it is replaced with other surrounding details to make it 
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appear that the object was never there. We will use the file person_on_
the_beach_remove.psd. Make sure to create a duplicate of the file (Image 

➤ Duplicate). Refer to Figure 3-44.

Figure 3-44.  Woman looking for rocks at the beach

As with the Clone Stamp Tool, working on a new layer in the Layers 

panel is best, so you do not destroy the original artwork. Refer to 

Figure 3-45.
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Figure 3-45.  Working on a new Layer in the Layers panel

Make sure to zoom in to the object you want to remove. Use the key 

commands of Ctrl/CMD++ and Ctrl/CMD+- as you work, so you do not 

lose your overlay while painting it.

Before you use the tool, review its options in the Options bar panel 

from left to right. Refer to Figure 3-46.

Figure 3-46.  Options bar panel Remove Tool options

Beside the tool’s preset picker is the add to brushed area (+) and 

subtract from brushed area (-) icons. These are used for painting a 

selection overlay when you have the option “Remove after each stroke” 

disabled. Add to brush area is by default on. Refer to Figure 3-47.
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Figure 3-47.  Painting a magenta overlay and removing parts of the 
overlay with the Remove tool

After making a brush stroke, the (-) button can be used to erase part 

of the magenta overlay selection. Now brush again to remove some of the 

overlay. As you work, switch between the (+) and (-) buttons to refine the 

overlay. However, leaving a bit of overlay into the water is a good idea, and 

with this tool you do not have to be exact with your edge, but you should 

fill in your entire overlay area, not leaving any gaps on the body. You can 

also adjust the size of the brush by typing in the number (1–5000) or using 

the slider. Refer to Figure 3-48.
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Figure 3-48.  Options bar panel Remove tool brush tool options

Next is the button “Always use Pressure for Size”; this option is by 

default off and is generally used when working with a stylus.

The gear icon has a pop-up menu that allows you to change the overlay 

setting of color (magenta) and opacity (25%). The overlay helps you to 

refine your selection area. Refer to Figure 3-49.

Figure 3-49.  Options bar panel Remove tool options for overlay and 
stroke settings

As mentioned, because you are working on a new blank layer above 

the background, make sure to enable the “Sample all layers” checkbox. 

Rather than build up an overlay area, you can enable “Remove after each 

stroke” when you want to remove the area overlay after a single stroke. 

However, for this example, leave that checkbox disabled. Lastly, on the far 

right, you can reset your settings using the counterclockwise arrow icon to 

reset all strokes or commit your overlay settings using the check (Commit) 

button. Refer to Figure 3-49 and Figure 3-50.

Chapter 3  Tools for Photo Restoration: Part 1



158

Figure 3-50.  Completed overlay and removal of the woman on 
the beach
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This example was fairly easy to work with, and the selection blended in 

very nicely to the surrounding landscape, and the person is gone. In your 

file, turn the eye on Layer 1 off and on to see the difference and then make 

sure to save your work (File ➤ Save). Refer to file person_on_the_beach_
remove_final.psd for reference.

You can see how easy it is to remove the person from the surrounding 

content. However, keep in mind that for more complicated backgrounds, you 

may need to do some additional clone stamping or use the Remove tool again 

if the new area does not quite turn out as you envisioned, as in practicing 

with the file example person_2_remove.psd. Remember as you remove the 

person, remove parts of the man’s shadow as well. Refer to Figure 3-51.
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Figure 3-51.  Removal, using the Remove tool, of the man from the 
historical site

Chapter 3  Tools for Photo Restoration: Part 1



161

Try this out as well on an object in the tulip_remove.psd, but again, 

once complete, observe what is replicated during the overlay and decide if 

you need to use another healing tool to complete the transformation such 

as aligning the rows of flowers. Refer to Figure 3-52.

Figure 3-52.  Removal of the unwanted structure from the Tulip field 
after creating an overlay

Save your work (File ➤ Save) at this point, and you can review the 

mentioned files person_2_remove_final.psd and tulip_remove_
final.psd.

In Chapter 8, you can try similar results with the Content-Aware Fill 

workspace.
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�Healing Brush Tool (J)
The Healing Brush Tool shares similarities with the Spot Healing Brush 

Tool and the Clone Stamp Tool and can also access the Clone Source 

panel. You can refer to those tools for certain details. The Healing Brush 

generally works in a larger area like the Clone Stamp and requires an Alt/

Option-click on a sample spot.

While you can use the Healing Brush Tool on the skin or clothing as in the 

army image, it can also be used to heal other materials. Refer to Figure 3-53.

Figure 3-53.  Working with the Healing Brush Tool to remove crease 
lines from the army man’s stocking and the grass
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As with the Clone Stamp Tool, working on a new layer is best, so you 

do not destroy the original artwork. Its purpose is to blend and match the 

texture, lighting, shading, and transparency of surrounding sampled pixels 

so that they will blend with the area you are trying to repair.

Let’s try this tool with the big_room_healing_brush.psd file and make 

a duplicate (Image ➤ Duplicate) of the file to work on. In this example, we 

want to fix the glare on the floor so that it is not quite so visible. Refer to 

Figure 3-54.

Figure 3-54.  Use the Healing Brush tool to lessen reflections on 
the floor
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Once you select the tool, you can review its options in the Options bar 

panel from left to right. Refer to Figure 3-55.

Figure 3-55.  Options bar panel Healing Brush tool options

Next to the tool’s preset picker is the Brush Options menu where you 

can set the brush’s size, hardness, spacing, angle, and roundness using 

either the text boxes, sliders, or brush preview; refer to the Spot Healing 

Brush tool for more information, but note that it can only be used for 

round or elliptical brushes. Refer to Figure 3-56.

Figure 3-56.  Options bar panel Healing Brush Tool options for brush 
presets and the Clone Source panel

Beside the menu is the Clone Source panel toggle button; refer to the 

Clone Source panel for more information on how to use this.
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Painting mode by default should be set to Normal or Replace, but you 

can choose other options for more artistic effects. Refer to the Spot Healing 

Brush tool for more information. For this project, keep the Mode: Normal 

option. Refer to Figure 3-57.

Figure 3-57.  Options bar panel Healing Brush tool painting 
mode options

When doing a photo restoration project, I recommend working with 

the Source set to Sampled and review the options and continue to set the 

additional options on the right. Refer to Figure 3-58.

Figure 3-58.  Options bar panel Healing Brush tool Source options of 
Sampled or Pattern
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Note  If the Source is Pattern, then you will be working with patterns 
that are found originally from the Patterns panel, which we will not be 
going into much detail in this book. I will mention Patterns in regard 
to Fill layers in Volume 2. Keep the Source on Sampled as you work in 
this chapter. Refer to Figure 3-58.

Aligned as with the Clone Stamp tool is good to be enabled when you 

sample the same offset for each stroke. In this example, I kept Aligned 

disabled. If you have used older versions of this tool from 2014 or earlier 

and prefer those settings, you can enable the “Use Legacy” checkbox, but 

this will disable the diffusion settings on the far right which you do not 

want to do in this example. Refer to Figure 3-59.

Figure 3-59.  Options bar panel Healing Brush tool options for 
alignment, legacy, sample options, angle, pressure, and diffusion

As with the Clone Stamp tool, work on a new layer above the 

background and change the sample setting to “Current & Below”; the other 

settings of Current Layer and All Layers are also available in the list. Beside 

the list, you can click the button “Turn on to ignore adjustment layers 

when healing” if required and if they are present. We will look at these 

kinds of layers in Volume 2. Refer to Figure 3-60.

Chapter 3  Tools for Photo Restoration: Part 1



167

Figure 3-60.  Options bar panel Healing Brush tool options setting 
when working on a New Layer in the Layers panel

The Brush angle (–180,0, 180°) is the same angle set when you set the 

brush options. The second to last icon, “Always use Pressure for Size. When 

off, Brush Preset controls pressure,” is by default off and is generally used 

when working with a stylus. The diffusion option (1–7) is set to a default of 

5 and is the same as the Spot Healing Brush. Refer to Figure 3-60.

One tip to remember if working on a spot or reflection is to use a  

brush larger than the area you want to heal. However, this is a narrow 

room, so you can stamp or drag the brush along as required. In this case, 

I Alt/Option-clicked a source area on the floor. I started with a brush size 

of 51px and a hardness of 100% and then clicked and dragged around the 

edges of the reflection, gradually moving inward. Refer to Figure 3-61.
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Figure 3-61.  Using the Healing Brush tool will create a blurred heal 
covering

What you may notice with this brush, even though it has a hard edge, 

is that it blurs the edges of the stamp, and you need to Alt/Option-click to 

create a new clone source as you work on your next click. To keep the wood 

grain, I moved in an up or down direction to keep an accurate source. 

The floor in this example appears rather blurry and not crisp. Refer to 

Figure 3-62.
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Figure 3-62.  Move in an up or down motion to create a more 
accurate blur healing with the brush

Also, you do want to make sure the wood does not have noticeable 

repeating areas of pattern. In this example, that is OK as I do not intend 

to eliminate the outside light reflection entirely, only soften the effect and 

make it appear like some of the wood is still showing through. If you do not 

like how the effect is turning out at any time, just drag the layer to the trash 

can icon in the Layers panel and then create a new layer and start again. 

Refer to Figure 3-63.
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Figure 3-63.  In the Layers panel, use the Delete Layer button if a 
layer is not healing as it should and then create a new layer

Your healing will not look exactly like mine, but that is OK. Once you 

are done, the next step would be to then select your new layer and lower 

the opacity slightly to about 68%. Refer to Figure 3-64.
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Figure 3-64.  The new layer with its opacity lowered makes the glare 
of the reflection less intense, and the focus is more on the room than 
just the floor

You can still see some of the reflection from the window, but now it 

does not overwhelm the image, and the room overall becomes the focus 

rather than just the floor.
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In your own projects, try this technique on images where you want to 

soften the glare in an image. Make sure to save (File ➤ Save) as you work 

and compare to the file big_room_healing_brush_final.psd.

We will look at some alternative and similar options in Volume 2 when 

we explore pattern fill layers and then camera raw filter.

�Patch Tool (J)
The Patch tool can be used to patch up a section of an image with another 

area of the image or a pattern. This kind of tool does not use brushes but 

rather selections. Similar to the healing brush, it tries to match the pixels, 

texture, lighting, and shading from the source. Some settings for the Patch 

tool rely on the current layer, so working on a duplicate of that layer is best 

when working with this tool. To create a duplicate of the layer, try dragging 

your background layer over the Create new layer button in the Layers 

panel. Refer to Figure 3-65.

Figure 3-65.  Use the Layers panel to create a duplicate layer of the 
background layer
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Let’s work with the file sky_patch_tool.psd. Make a duplicate file 

(Image ➤ Duplicate) to work with. And then make a duplicate of your 

background layer right away. Refer to Figure 3-66.

Figure 3-66.  A scene of harbor life

Then select the Patch tool. You can review its option in the Options bar 

panel from left to right, which can vary depending on the Patch options 

chosen. Refer to Figure 3-67.

Figure 3-67.  Options bar panel Patch tool options
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After the tool’s preset picker, you can work with small selections 

over select area of an image to cover things such as time stamps or 

imperfections or even a bird in the sky.

Use your tool to drag and draw out a selection with the setting of new 

selection. Refer to Figure 3-68.

Figure 3-68.  Patch tool dragging out a new selection

If you need to add to the selection while active, select the next button 

“Add to selection” and then draw over the current selection, or while the 

current selection is active, you can choose another button like subtract or 

intersect by choosing one of those options. Refer to Figure 3-69.
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Figure 3-69.  Options bar panel Patch tool options for adding, 
subtracting, and intersecting a selection

Use Edit ➤ Undo or Ctrl/CMD+Z if you need to go back a step in your 

selections. Set the button back to new selection when you are done. Refer 

to Figure 3-67.

While the selection is active, there are two methods of patching:

Normal: This uses either the Source or Destination to patch. You can 

also enable transparency when blending the patch in the sky or gradient 

background with transparent areas or leave disabled to keep the full 

sampled selection. Refer to Figure 3-70.

Figure 3-70.  Options bar panel Patch tool options set to Normal
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Or alternatively, use a pattern that you select from the drop-down list 

for filling the selected area. In this example, do not use this option.

While the selection is set to the option of “Source,” drag the selection 

around the bird to another area of the image you want to use as the new 

source. This will cause the bird to disappear and the original area to be 

filled with sky that has no pattern. Refer to Figure 3-71.

Figure 3-71.  Patch tool options set to Normal and Source and 
selection dragged

Or while the selection is active, use the option of Destination and drag 

the selection; in this case, you create a copy of the bird and place it in a 

new location. All selections can be made prior to your patch choice. Refer 

to Figure 3-72.
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Figure 3-72.  Patch tool options set to Normal and Destination and 
selection dragged

As with the Healing Brush, there is a diffusion option (1–7) set to a 

default of 5. This causes the blend to occur based on the surrounding 

background and the values that you choose.

The other patch option is Content-Aware. This patch option controls 

the structure of the selected pixels and adjusts how strictly the source 

structure is preserved (1–7); the default is 4. The color (0–10) adjusts how 

much the source color can be modified or blended; the default is 0, but 

10 is the highest setting. With this patch option, rather than creating a 

duplicate layer, you can work on a separate new blank layer (Layer 1) when 

you choose the option Sample all layers. Refer to Figure 3-73.
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Figure 3-73.  Options bar panel Patch tool options set to a patch of 
Content-Aware and set to a new layer

In this case, the bird is again covered when the selection is dragged but 

now on its own layer, which you can turn the visibility eye on and off. Refer 

to Figure 3-74.

Figure 3-74.  Options bar panel Patch tool options with  
Content-Aware setting; the selection is dragged to hide the bird

Select Edit ➤ Undo if you need to revert a step as you work.

Use Select ➤ Deselect (Ctrl/CMD+D) when you need to remove your 

selection area.
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Note for the cap appearing in the lower right-hand corner, you could 

try the Content-Aware patch after you create a selection, or I think in this 

case use the Remove tool you looked at earlier. Create another new layer if 

you want to test this. Refer to Figure 3-75.

Figure 3-75.  Removing the man’s cap from the scene on another new 
layer using the Remove tool
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Then save the document (File ➤ Save). You can review my  

sky_patch_tool_final.psd document if you want to compare.

�Content-Aware Move Tool (J)
Similar to the Patch tool, the Content-Aware Move tool also allows you to 

move content via a selection from one location to another, which might 

include a tree or part of a person or in this case a canoe with people in it.

Let’s look at the two files snow_content-aware_tool.psd and  

canoe_content-aware_tool.psd. Refer to Figure 3-76.

Figure 3-76.  Images of people playing in the snow and canoeing on 
the lake
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Make a duplicate (Image ➤ Duplicate) of both files.

In this case, you can work on a blank layer when using this tool. Refer 

to Figure 3-77.

Figure 3-77.  Work on a new blank layer in the Layers panel

You can review its option in the Options bar panel from left to right. 

Refer to Figure 3-78.

Figure 3-78.  Options bar panel Content-Aware Move Tool options
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After the tool’s preset picker are the same selection options as the 

Patch Tool. These can be used when you have created a new selection 

where you can then drag and add another selection, subtract, or intersect.

By default, the remix mode is set to “Move” so that you can move that 

selection. Refer to Figure 3-79.

Figure 3-79.  Options bar panel Content-Aware Move Tool options set 
to mode of move 

You can also use the bounding box handles surrounding the selection 

to scale and rotate the selection. Refer to Figure 3-80.
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Figure 3-80.  Use the Content-Aware Move tool bounding box 
handles to adjust your selection and click the check to confirm

You can click the cancel button if you need to revert back or click the 

commit check. Refer to Figure 3-80.

Once the commit check is clicked, the selection of the image will be 

on the new layer, and it will cover the original with filler pixels. However, 

in some instance, the blending may not be accurate depending on the 

complexity of the file. Refer to Figure 3-81.
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Figure 3-81.  The original person is covered and moved to a new 
location on the new layer

However, if it is set to Extend, it still can move, scale, or rotate and 

then commit the moved copy of the selection to a new location. Refer to 

Figure 3-82.

Figure 3-82.  Options bar panel Content-Aware Move Tool options set 
to Extend to create a copy of the person and not cover the original
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You might find these options for this tool to do a more accurate 

blending on the new layer than the Patch tool. But make sure to 

experiment between the two modes of Move and Extend to determine 

which works best for your project. In this case, I used Move. Refer to 

Figure 3-79.

Like the Patch tool, you can set the range for the Structure (1–7); I 

used a setting of 4. Set the color (0–10); I left it on 0. Choose “Sample 

all layers” when the checkbox is enabled and work on a new layer. The 

last setting “Transform on drop,” when enabled, allows for the scaling, 

rotation, and transformation of the selection when moved. If disabled, the 

transformation is committed directly after the selection is moved, and you 

cannot scale or rotate. Refer to Figure 3-82.

Use Select ➤ Deselect or Ctrl/CMD+D when you want to remove the 

selection border. 

While it may be easy to move a single individual in a group on a layer, 

moving a canoe in the water can be more difficult as you are dealing with 

ripples and reflections in the water that need to accurately blend as well.

Here, you can see after I created my selection, I used the mode of Move 

as well and commited the change using the check. Refer to Figure 3-83.
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Figure 3-83.  People on the lake are moved over using the  
Content-Aware Move tool

Use Select ➤ Deselect or Ctrl/CMD+D when you want to remove the 

selection marquee.

Note while using this tool for more accurate cleanup, as you will 

discover when you advance in the book, you can afterward use the 

Remove tool and layer mask on a separate layer. Notice that I turned off the 

visibility of Layer 1 as I worked so that I did not sample pixels from Layer 1 

by mistake. Refer to Figure 3-84.
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Figure 3-84.  To make the picture look more accurate and for the 
Content-Aware selection to blend, you may need to use the Remove 
tool on a new layer to cover the original canoe and its occupants
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As well as on Layer 1, use the Eraser tool on a layer mask to remove 

areas of the Content-Aware selection as required. Refer to Figure 3-85.

Figure 3-85.  Using the Layers panel to create other layers for the use 
of the Clone Stamp Tool or use the Eraser tool to remove extra details 
the Content-Aware Tool and Remove Tool created or alternatively use 
layer masks for a more accurate blend of added pixels

You may be left with patchy or ragged edges as this is a more complex 

selection that may also require a bit of feathering with the Clone Stamp 

tool as well. Here, you can see that as the patching and healing become 

complex, more than one tool is required.
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Tip: If while working with your selection you want to scale or feather 

it, try using the contextual task bar to reach these options quickly. We will 

look at selections as well as layer masks more in Chapters 6–8. Refer to 

Figure 3-86.

Figure 3-86.  Refer to your contextual task bar when you need 
additional selection options

Make sure to save your document (File ➤ Save) at this point, and you 

can refer to my files snow_content-aware_tool_final.psd and  

canoe_content-aware_tool_final.psd if you need to compare, and we  

will refer to them again in Chapter 8.

We will look at another related workspace called Content-Aware Fill 

in Chapter 8. For tips on how to organize and rename layers, refer to 

Chapter 5.

�Red Eye Tool (J)
The Red Eye tool only has one purpose: to remove red eye from photos. 

This was quite common before digital cameras added this reduction 

option to their software as there were a lot of red pupils due to the 

reflection of the flash in dark rooms when the iris is extended. Thankfully, 
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there are digital cameras now that operate in low-light conditions. Red 

Eye will work for correcting images where a human or pet has red pupils. 

Some cats with blue eyes have red eye reflection and others don’t. Refer to 

Figure 3-87.

Figure 3-87.  Example of cats with red and golden eyes

A lot of cats and dogs also have golden, green, or blue eye shine which 

this tool cannot correct. In that case, you would have to look to the Camera 

Raw filter, which we will look at in Volume 2, to correct pet eye. 

Luckily, here is a cat that exhibits red eye that you can practice with the 

file cat_red_eye.psd and make a duplicate copy (Image ➤ Duplicate) of 

the file. Refer to Figure 3-88.
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Figure 3-88.  Cat with red eye; in the Layers panel, a duplicate of the 
layer was created

In this case, you would want to work on a duplicate layer of the 

background or a selection of the background layer on a new layer.

Be careful to only click once in the red eye area or you will give your 

subject a black eye. You can also try dragging a marquee around the eye. 

Use Edit ➤ Undo or Ctrl/CMD+Z or the History panel if you need to undo 

your last step. Refer to Figure 3-89.
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Figure 3-89.  Cat eyes with the Red Eye Tool applied

You can review its option in the Options bar panel from left to right. 

Refer to Figure 3-90.

Figure 3-90.  Options bar panel Red Eye Tool options

After the tool’s preset picker, you can set the pupil size, which is at a 

default of 50%, and the darken amount, which is at a default of 50%. This 

can remove the red quite a bit.

In the case of pets, the pupil area, however, may not be as dark as 

you want as they have quite a bit of reflection in the eye, which you can 

vary with the Red Eye Tool settings. Or try painting on a new layer using 

the Brush Tool (see the “Brush Tool (B)” section in Chapter 4) with a 

foreground of black and then lowering that layer’s opacity to about 87%. 

Refer to Figure 3-91.
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Figure 3-91.  Use the Brush Tool and a lower opacity when you need 
to make the pet’s eyes darker

More details on these mentioned tools can be found on the 

following pages:

https://helpx.adobe.com/photoshop/using/retouching-

repairing-images.html

https://helpx.adobe.com/photoshop/using/content-aware-patch-

move.html

Save (File ➤ Save) any open projects you have so far and review the file 

labeled with cat_red_eye_final.psd if you need to compare.
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�Summary
In this chapter, we looked at a number of tools from the Tools panel that 

can be used to improve your digital images and heal areas. Some are better 

for one kind of restoration task than another. Working on separate layers 

also helps you to heal your images in a nondestructive way. In the next 

chapter, we will be looking at more tools for digital repair that you may 

want to use in conjunction with the tools in this chapter.
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