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Introduction

Welcome to A Beginner’s Guide to Digital Image Repair in Photoshop: 

Volume 1.

In today’s digital world, with smart phones and cameras, we can easily 

transfer our photos from phone to computer. Then, with Photoshop, we 

do a few basic corrections using various healing tools in conjunction with 

adjustment layers and filters and then print out the picture with our inkjet 

printer or post it on our social media page. However, occasionally we are 

left with the old or damaged photos and slides from a loved one who lived 

before the age of digital cameras. Now we need to decide what to do with 

these old family treasures, whether they be a family portrait or a trip to 

a historical location, that we have been keeping in a shoe box for many 

years. Some are in good condition, and others are very damaged. What can 

we do to restore them? Refer to Figure 1.

Figure 1.  Collection of photos, film slides, and negatives in a shoe box
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In Volumes 1 and 2, we will explore how you can work with your old 

historical photos in Photoshop and digitally restore them so that you can 

print them out for family as well as use them online as still photos or to 

animate select images. As we progress through the chapters in this book, 

you will look at some of the many tools and filters that Photoshop has to 

offer, both old and new, that can assist you in your restoration project.

For example:

•	 Chapter 1’s focus will be on preparation for working 

with old historical photos; you will review scanner 

basics for your photo print, new information on how to 

work with film slides and negatives, some guidelines 

on what type of scanner and dialog box settings to use 

for them, and initial file formats that are created after 

the scan.

•	 Chapter 2 will review how to set up your Photoshop 

workspace, an overview of some of the tools and 

panels, and the basic file formats to save the files you 

are working on in.

•	 Chapters 3–5 will look at the basic Photoshop tools that 

you would use for very basic photo restoration as well 

as a few other additional tools that you may want to 

incorporate for small touch-ups, color corrections, or 

cropping your artwork while working with the Layers 

panel on a personal project.

•	 Chapters 6–8 will explore some more advanced 

features, such as working with masks, selections, and 

other related commands and workspaces (old and new) 

that Photoshop has to offer. You will see how, when 

there are gaps and details are not present in a photo, 

you can be creative and fill in the missing details.
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Then Volume 2 will continue to explore the following:

•	 Explore various masks and how we can use them to 

color correct the entire scene or selected areas using 

the Adjustments panel and its new features. You 

will also review what the smart object layer is and 

how to apply smart filter adjustments to it that are 

nondestructive. Blending modes and other advanced 

color adjustment options will be looked at as well.

•	 Review some of the main basic filters that are mostly 

used for blurring, sharpening, or removing noise from 

an image. These filters will be applied to various layers, 

but we will also look at situations where they could be 

applied to layer masks or channels.

•	 Explore some advanced filters as well as some new 

filters that you may not be aware of that can help you 

with your photo restoration project. We will also take a 

brief look at how you can go about acquiring additional 

filters from the Adobe Creative Cloud console if you 

have a subscription.

•	 Focus on two possible ways that you can bring your 

images to life in Photoshop using the Timeline panel. 

One way is to create a basic slideshow GIF animation, 

and the second is to create a parallax animation from 

components of a single or multiple images. The latter 

has in recent years become popular when no historical 

video footage is available. We will look at what kinds of 

photos do and do not lend themselves to a parallax and 

then how to render the animation.

Introduction
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•	 Conclude our discussion on Photoshop and digital 

image repair with some final color touch-ups you can 

do should you plan to print your images or save them 

for online use. I will also mention a few additional 

Adobe Creative Cloud and Microsoft apps that you may 

want to consider should you want to continue to work 

with your images for other multimedia projects.

At this point, I will just mention that though most photos we will be 

working with in this book will be historical or vintage, if you have modern 

digital photos, you can use them as well.

Note that in this book some of the images where people are present 
have had their faces altered (with blurs or mannequin faces) to 
protect their original identities, so that you can use them for practice. 
However, if you have similar photos of friends or family, then feel free 
to use the same techniques mentioned in this book and practice on 
them instead of mine.

�Installing Photoshop and Other Adobe Apps
This book assumes that you are using the Adobe Creative Cloud 

subscription. Currently, I am using an individual license, but you may have 

Business or a student license.

www.adobe.com/creativecloud.html

Make sure to install a copy of the Creative Cloud Desktop console on 

your computer.

Since the focus of this book is on Adobe Photoshop, if you have not 

already done so make sure to download a copy of Photoshop from your 

Creative Cloud Desktop.

Introduction
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Go to Apps ➤ All Apps, then choose the Desktop option from the list. 

Under Essential in your plan, locate Photoshop and click Install. Refer to 

Figure 2.

If you are not sure of your system requirements, you can check 

them here:

https://helpx.adobe.com/creative-cloud/system-

requirements.html

https://helpx.adobe.com/photoshop/system-requirements.html

I am currently using Version 2024 (25.11).

Figure 2.  Creative Cloud Desktop settings for installing Photoshop

Introduction
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It may take several minutes for the download to complete, and you 

may be prompted to restart your computer. Once complete, you will find 

the application in your Installed section with other applications, if you 

installed them earlier. Adobe will occasionally send you updates which you 

can download to keep the software up to date. Refer to Figure 3.

Note that Adobe Bridge, to keep your photos organized, may also be 
downloaded. Though not used in this book, it will be briefly mentioned 
in Volume 2 as it relates to the Camera Raw filter. Camera Raw may 
also be installed with your Photoshop application. You may also want 
to download a copy of Media Encoder at the same time, but we will 
not require the application until Volume 2. Refer to Figure 4.

Figure 3.  Photoshop settings in the Creative Cloud Desktop to 
indicate it is installed and you can open the application

Figure 4.  Other Adobe applications that you may install: Bridge, 
Media Encoder, and Camera Raw
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Now that Photoshop is installed, click the Open button in the Creative 

Cloud Desktop, and then, after a minute, it will load and open. Refer to 

Figure 5.

You can leave Photoshop open for now if you are planning to read 

Chapter 1 next, or you can from the main menu choose File ➤ Exit (Ctrl/

CMD+Q) if you need to exit the application.

Note that this book does not discuss the separate application 

Photoshop Express or Beta features unless they are installed in the current 

application.

�Resources
Throughout this book, I will be supplying a reference for more details on 

various tools using the following link:

https://helpx.adobe.com/

You can also access more information on various Photoshop-related 

topics from the Photoshop Help menu, Discover panel (magnifying 

glass icon), as well as the Creative Cloud console’s Discover tab. Refer to 

Figures 6 and 7.

Figure 5.  Use the Creative Cloud Desktop to open the Photoshop 
application
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Figure 6.  Photoshop’s Help menu
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Figure 7.  Access to the Photoshop Discover panel along with the 
Creative Cloud Desktop giving access to Photoshop tutorials
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After you have finished this book, if you are interested in other 

Photoshop projects and working in combination with Adobe Illustrator, 

you can review some of my other Photoshop-related books should the 

topics be of interest to you:

•	 Graphics and Multimedia for the Web with Adobe 

Creative Cloud

•	 Accurate Layer Selections Using Photoshop’s 

Selection Tools

•	 Perspective Warps and Distorts with Adobe Tools: 

Volumes 1 and 2

•	 Creating Infographics with Adobe Illustrator: Volumes 

1, 2, and 3: These books briefly discuss Photoshop as it 

relates to infographic development.

Projects for this book can be found here: Link from Apress.

So let’s begin our journey into how to work with your box of historical 

photo treasures.

Introduction
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CHAPTER 1

Preparation for  
Working with Old 
Historical Photos
This chapter will discuss how to prepare your photos for scanning as well 

as what kind of scanner may be best for your project and then how to 

proceed with the scanning and saving of the scan file.

Note this chapter does contain projects found in the Volume 1 
Chapter 1 folder. Note that in my previous books, such as Accurate 
Layer Selections Using Photoshop’s Selection Tools and Creating 
Infographics with Adobe Illustrator: Volume 1, the focus was on 
scanning sketches which did not necessarily require a high degree of 
quality in regard to color and resolution, and so a scanner that could 
scan slides was not required. In this chapter, we will be assuming 
that, besides photo prints, you will also be scanning slides and 
negatives, so some new topics not discussed in those books will be 
discussed here.

https://doi.org/10.1007/979-8-8688-0450-2_1
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�Brief Photo History and Reason 
for Photographic Damage
As mentioned in the introduction, most photos in recent years are taken 

with your digital camera, which may be a separate piece of hardware 

(physical digital camera) or an application that is part of your smartphone 

which has a built-in camera. What we understand as photography has 

been around since the 1700s – the process of trying to capture and retain 

images on light-sensitive materials; the use of dyes to preserve that image 

on a substrate whether a film or a paper. Over the centuries, the camera 

evolved from using glass plates and paper to film starting around 1888 and 

then on to digital in 1975. However, up until the early 2000s, when digital 

cameras improved and became more affordable, it was still common for 

people to use film cameras and to store their prints in an album, negatives 

in sleeves, or slides in a reel or box to keep them dust-free and away from 

the light. Refer to Figure 1-1.
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Figure 1-1.  Collection of storage options used to store print photos as 
well as film slides and negatives

While this book’s purpose is not to go into the history of photography, 

negatives, and slides, it’s still important to know a bit about why the items 

you are reviewing may appear damaged.

In the case of prints and film (negatives and slides), oftentimes the dye 

on the paper or in the film emulsion in combination with dye couplers 

does age and fade when exposed to the light or due to other environmental 

issues, such as temperature, moisture, and humidity. In the case of 

damage to slides this can often leave us with many instances, depending 

on the film brand, in which normal colors of red, green, and blue sensitive 

layers have begun to fade and become solidly red, green or blue, this 
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is often dependent on the dye that used in the manufacturing process. 

Over time, for example, when a slide becomes red, it means that the cyan 

dye has become unstable and chemically broke down, leaving only the 

red (magenta) and maybe yellow dyes. Note that for film, the dull side is 

considered the side with the emulsion. Refer to Figure 1-2.

Figure 1-2.  Aged film turning red, a purple-blue color, and normal 
colorizing

Likewise in other media like the paper displaying the printed image, 

these dyes can also break down and fade when exposed to the light. Also, 

if exposed to certain glues for mounting the image in place, the adhesive 

chemicals soak into the paper; they are acidic, this yellows the paper. You 

may recall seeing albums with the clear plastic that seals the photographs 

onto the glued white cardboard. Refer to Figure 1-3.
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Figure 1-3.  Pages from an album with the images mounted with glue 
and covered with plastic seals

This is one of the worst things you can do to a photo, so care must be 

taken to remove the image without ripping the photo. If you have any of 

these, transferring them for now into an album with just plastic sleeves 

and no glue or tape is a better option. The plastic sleeves should be ones 

that are for photo protection and do not contain PVC or PVA plastics. Also, 

researching archive storage boxes is another option.

The film of the slides and negatives can turn yellow over time and 

become brittle. Also, if the film is handled incorrectly and touched with 

ungloved fingers, the natural oils in our skin can erode the emulsion, and 

our fingernails can scratch it and the shiny film side as well. Having clean 

hands and a pair of white lint-free cotton or nitrile gloves is good for this 

kind of work. Avoid gloves that have been pre-dusted with chalk. On the 

shiny film side (not the dull emulsion side), if you do need to clean any 

fingerprints off, you can try a microfiber cloth or a cotton swab and a 
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small amount of 91–99% Isopropyl Alcohol and rub the spot very gently 

to remove the fingerprints. Do not use water which may soften the film 

gel. Practice on a piece of film first which you are not concerned about 

damaging. Your local photo lab or museum may have some suggestions as 

well. Refer to Figure 1-4.

Figure 1-4.  Carefully cleaning the shiny side of a black and white 
negative with gloves and a cotton swab dipped in Isopropyl Alcohol

Note that Isopropyl Alcohol is both poisonous and flammable. Read 

instructions on how to use small amounts correctly and also store and 

keep out of reach of animals and children.

Some prints, if stored correctly under the right conditions like in a 

museum or archival vault that is regularly monitored, can last hundreds 

of years. This is not the case in our own homes where our main focus is 

not continuously on historical preservation. This is why in your collection, 

there may be a few pristine images, but more than likely many will have a 

torn edge, rips, and creases.
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One final “damage” factor that I will mention before we look at 

scanning is the fact of whether the photo was taken professionally or not. 

Whether it is recent or not, there is still the possibility of dust being on the 

lens, parts of the image being out of focus, and over- or underexposed and 

unintended objects, animals, or people appearing in the shot. These too 

can be things that we may want to “correct” as well, and much of this can 

be done with Photoshop as you will see in the following chapters. These 

are all factors to consider when deciding what level of authenticity your 

historical images should retain.

�Organization of Your Photos
Before you begin scanning or if you don’t have a scanner yet and need to 

purchase one, take some time to organize your prints, slides, and negatives 

into piles on the table or in boxes. Note how some negatives and slides are 

larger than others, and this will be important, as I will explain why shortly.

Some tools that may be helpful during your organization will be a 

magnifying glass, gloves to avoid touching the film (as mentioned in the 

previous section), and a small light table, and if the slides you have been 

given had an original projector, that can be helpful as well and save some 

time. Refer to Figures 1-5 and 1-6.
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Figure 1-5.  Some of the tools that you may need to review your 
film slides and negatives while cleaning with Isopropyl Alcohol, 
magnifying glasses, cotton gloves, and a light table

Figure 1-6.  Review your slides with the original slide projector if 
possible
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At this point, culling through what you do not intend to scan is all part 

of the organization process.

The main piles that you want to create are

•	 Prints larger than 8.5x11: This could be, for example, 

large family portraits in black and white or sepia, but 

color prints as well.

•	 Prints smaller than 8.5x11: This could include very old 

sepia or black and white image that are mounted on a 

thick card stock. Some of these may be over a hundred 

years old. Others will be the more modern color prints. 

Refer to Figure 1-7.	

Figure 1-7.  Organize your prints into piles as you work on them
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•	 Negative film: You may want to separate color negatives 

and black and white into piles as well as thinner 

and wider sizes. Leave the film in its plastic sleeves 

as you sort. Examples of most common sizes would 

be 135 (24mmx36mm), 126 (28x28mm), and 110 

(13mmx17mm). However, do expect a few that do not 

fit these ratios, depending on the camera that was used, 

such as the larger 120/122 medium format film. Refer 

to Figure 1-8.	

Figure 1-8.  Organize your film negatives into piles of color and black 
and white of various sizes
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•	 Slides (positives): Like slides, negatives come in a 

variety of sizes too, but the most common is 50x50mm 

or 135; however, they can vary in thickness of the paper 

or plastic that surrounds them. It’s important to keep 

common thicknesses and sizes together, during your 

organization. Refer to Figure 1-9.	

Figure 1-9.  Organize your slides into various categories and observe 
the thickness of the paper and plastic slide holders
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Also, while working on the slides, note if any are falling out of their 

holder and set aside; do not run these through the projector as they may be 

damaged further. Instead, view them on a light table with your magnifying 

glass. These, however, should be OK to scan later on a flatbed scanner.

�Scanner Purchase
In this chapter, we will now begin with looking at the kind of scanner 

that you can use to start digitizing your photos as well as when to use 

Photoshop’s dialog box to do the scanning, when to rely on the scanner’s 

dialog box, and finally how to complete the scanned process in Photoshop, 

view the scanned image, and review it. As you will see, there are various 

options to digitize your prints and slides based on their physical format.

To begin, it is important to determine what kind of scanner you 

require. Most flatbed scanners can be acquired at an office supply store 

or online. For basic photo, artwork, and document scans, they are quite 

affordable, and many brands are compatible with Photoshop. Refer to 

Figure 1-10.
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Figure 1-10.  An illustration of a flatbed scanner connected to the 
tower of a computer and wall power supply

If you are only working with a photographic print or already have a 

scanner that does not scan film, you can begin your process of scanning 

these images with your flatbed scanner. In most cases, the size of the print 

will be under 8.5x11.7 inches, which is slightly larger than a letter size. 

However, for those that are over 8.5x11, if higher quality is important you 

may need to research online for a photo or archival service that can scan 

large format artwork. Or you could try using your digital camera and taking 

a picture of the image yourself while the digital camera is mounted on a 
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stable tripod to avoid camera shake. I’ll mention this option at the end 

of the chapter. Alternately, you can scan your large photo in sections or 

separate images, but this will require you to “stitch” the image together 

again in Photoshop. If you plan to do that, just make sure you have enough 

of an area to move your image around the scanner to accommodate the 

paper size so that nothing collides or bends the paper, causing further 

damage. Refer to Figure 1-11.

Figure 1-11.  An illustration of a photo print that is too large for the 
scanner: it needs to be moved to scan twice, but there is a coffee cup in 
the way that should not be there, as they may collide

However, if the flatbed scanner that you have does not specifically 

mention that it can scan negatives and slides, you will have to consider 

purchasing one or looking into other services that can do that. Though not 

a topic of this book, it should be noted that some of these services, which 

would be available through your local photo lab, print house, library, 
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or museum, may even be able to offer services to digitize movie films 

and audio tapes or reels. However, while I will not discourage you from 

researching these services, if you want to give your slides and negatives the 

attention they deserve, I recommend looking at two scanner options.

�Types of Scanners for Film Slides and Negatives
For a scanner to scan any kind of transparent film and prints, it needs to 

have two light sources, one from above (backlight transmissive) for film 

and one from below for prints (reflective). A scanner that only scans prints 

has one light source from below which is reflective. Refer to Figure 1-12.

Figure 1-12.  An illustration of a scanner with two light sources 
showing the location of the lights

While it is not impossible to add a backlight source above your flatbed 

surface, I have done this using the following:

•	 A handheld LED white/RGB light wand set to white 

lighting.

•	 Covered the light and the film with aluminum foil to 

increase the light.

•	 Placed a thin white tissue paper in between the film 

and light wand to diffuse any light glare. Refer to 

Figure 1-13.	
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Figure 1-13.  An illustration of how I worked with my scanner when 
it would not allow me to scan the film

I had to do this when the light above my older film flatbed scanner 

stopped working due to a software upgrade and I had a deadline. While 

this work-around may be OK for a few slides or negatives, this is not an 

ideal solution as you will want to be scanning for a print quality. What 

is considered a good resolution (300–600dpi [dots per inch]) for paper 

scans is not ideal for tiny negatives and slides as they need a much higher 

resolution such as 1200–12,800dpi to be blown up accurately later for a 

print. I’ll discuss more about resolution options shortly. Also, in most 

cases, when scanning film only, the backlight is active while it moves with 

the scanner head, and the front light is inactive.

Here are two scanner solutions that I would suggest.

Portable stand-alone digital film scanner with a large LCD screen: 

This is a good option if you already have a flatbed scanner or need to 

work in various locations in your house or a house not near your personal 

computer. You only need to plug the scanner into your wall, and it does 

not need to be connected to your computer while you work. The images 

are transferred onto your SanDisk Ultra PLUS SDHCTM UHS-I Card which 

is 32GB (gigabytes); this is the same kind of card that you would use in a 

digital camera. The film images are loaded and viewed one at a time, and 

the scans are completed with a click of a button, which is quite fast. You 

can then take out the card and insert it into your laptop or home computer 
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and copy them off the card to work in Photoshop. Refer to Figure 1-14. I 

like that these types of scanners can scan 50x50mm slides and can handle 

several slide thicknesses, color negatives, as well as black and white 

negatives in various common sizes:

•	 135: 24mmx36mm

•	 126: 28mmx28mm

•	 110: 13mmx17mm

Figure 1-14.  An illustration of a portable stand-alone digital film 
scanner, plugged into the wall with a holder and an SDHC card

Note some portable scanners will also come with the option to scan 
120/122 medium format film. In my case, I was experimenting with 
the Hammacher Schlemmer model, which does not have the option of 
medium format film. For each type of slide or film, there are separate 
holders, and the highest resolution is around 3200dpi.

This kind of scanner comes with built-in software that can correct for 

dust and scratches as well as basic brightness and color adjustments, which 

you can always choose to do later in Photoshop yourself. However, there are 

a few drawbacks with this option. If your slides or negatives are oversized 

and not the common sizes, parts of the images will be chopped off during the 

scan. You may be able to compensate slightly by turning the film around to 
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do a second scan or try to insert the film without the adaptor/holder in place, 

but you would later have to stich the two images together in Photoshop; the 

point of the adaptor is to keep the film level straight, which is not easy to do 

without the adaptor. Also, while the stand-alone scanner is fast, if you want 

to scan several slides or negatives in one scan this is not possible.

Flatbed photo scanner with the option of slides and negatives: This 

is best if you do not have a scanner yet or need to upgrade your current 

flatbed scanner. With this type of scanner, it will have a direct connection 

to the computer so that you can work on your photos right away in 

Photoshop, which I will talk about in more detail shortly. This type of 

scanner is ideal if you need to scan your reflective prints up to 8.5x11 with 

a single light. The back or inner lid of the scanner is covered with a white 

document mat. Refer to Figure 1-15.

Figure 1-15.  A flatbed scanner with and without the mat cover and 
one of its holders for scanning film
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For film slides and negatives, these scanners have two lights; the 

document mat is removed to reveal the second light, and now the above 

backlight (transmissive), which is meant to illuminate the slide, is visible, 

while in this case the lower light that was used to scan the print is off, but 

the lower scanner cartridge inside the document table still moves with the 

backlight to capture the scan. Like the portable scanner for film, it can scan 

a variety of common sizes mentioned earlier. However, you can not only 

scan several in one scan, you can also easily move the larger film negatives 

or slides around to get a more accurate scan. As mentioned, for scans of 

prints larger than 8.5x11, you may need to consider contacting a photo 

lab or local library to see what options they would recommend. Flatbed 

scanners often come with additional adjustment options before entering 

Photoshop, which I will discuss later. For my testing, I was using the Epson 

Perfection V600 Photo model.

As with any electronic purchase, make sure you do some online 

research of the product first and check out the reviews of the product 

before you buy.

�Scanner Basics Review (Maintenance)
Whether you are scanning slides or prints, it is important to keep your 

scanner, holder, and film clean and dust-free. If you have a portable 

stand-alone digital film scanner, make sure to read the user manual 

and use the recommended cleaning tools regularly before and after you 

finish scanning your projects so that dust and dirt do not build up on the 

glass, and keep your device away from extreme temperatures and high 

humidity. The same is true of the flatbed scanner, clean it regularly with 

the recommended cleaning cloth to remove fingerprints and smudges. 

Refer to Figure 1-16.
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Figure 1-16.  An illustration of a person cleaning the flatbed scanner 
glass and removing smudges and dust before use

Note you can use an eyeglass lens cloth to clean the surface of the 
glass and, if required, a mild glass cleaner if recommended by the 
manufacturer. Be careful not to scratch the glass as this can happen 
if you press down on the scanner lid and scan a booklet’s coil that 
has any rough metal edges. Also, you should not have your scanner in 
an area of high humidity as the glass surface inside the scanner can 
fog up, leaving streaks which are difficult to clean.

For the flatbed scanner, make sure that your software drivers remain 

up to date so that the hardware can connect to the computer. Also, as with 

any printer, monitor, or scanner over five to ten years, the light gradually 

fades and loses its ability to calibrate colors accurately. The older scanner 
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hardware may be operational, but very likely is not the best for color 

photo scans where color is crucial for print or the Web. So you will want to 

monitor this over time and upgrade your hardware as required. Note this 

is not the same as the color correction you will be doing on your prints in 

Photoshop. However, it’s important, if required, once you have finished a 

corrected photo, to print out a copy and compare with how it appears on 

the screen. We’ll discuss that more in Volume 2.

As noted, if you have been using a portable stand-alone digital film 

scanner, consult the user manual to determine how to scan each slide or 

negative. If using the holders, make sure to place your film negative or 

slide in the correct orientation, keeping the dull emulsion surface facing 

towards the light source. Then, using a combination of the LCD screen to 

preview, built-in software, and scan buttons, each scan will be added onto 

the SDHC card, and then you can later remove it and insert it into your 

computer slot and preview on your computer. Note that if your computer 

does not have this slot, you can purchase a USB card reader adapter, 

which can accept a variety of card sizes. The file format will be an RGB 

color mode (.jpg), which you can open in Photoshop and get ready to start 

working on in Chapter 2.

However, for now let’s discuss the assumption that you are working 

with your flatbed scanner and personal computer. Refer to Figure 1-17.
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Figure 1-17.  An illustration of a flatbed scanner connected to a 
personal computer

Make sure to take time to install the software and consult the online 

user manual if any of your settings are slightly different than mine. Once 

your scanner is set up and turned on, you can directly connect to it via 

Photoshop using the Wizard Assists (WIA). For photo prints, this is a quick 

way to scan. I have delved into this in more detail for scanning sketches in 

the past, in the books I mentioned in this chapter. However, in this book, I 

will just delve into it very briefly, because using this method does not work 

well for slides and negatives, and you must use the scanner’s own dialog 

box to accomplish this.
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�Flatbed Scanner Option 1: Quick Scans of Photo 
Prints Directly into Photoshop
A flatbed scanner allows you to acquire the scan of a flat sheet of paper 

without the presence of outside light which could cause color distortions 

to your images. Some flatbed scanners will allow you to adjust the top 

lid so that it sits better on a large scan that has a higher raised surface. 

Other scanners have just a hinged lid so the bed might be exposed to 

outside light.

Ultimately, if you’re dealing with a photo that is either raised on a 

card or in an album that has binding that does not bend well, I would 

recommend placing a dark cloth sheet over your scanner to prevent any 

outside light from coming into the scanner as well. Refer to Figure 1-18.

Figure 1-18.  An illustration of a flatbed scanner covered with a black 
cloth to prevent shadows and gutter shadow on an album, near the spine
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You may get a gutter or side shadow between the pages during the 

scan; if at all possible, try to get the scan as flat as possible by taking it out 

of the photo cover or album. Refer to Figure 1-19.

Figure 1-19.  An illustration of a flatbed scanner covered with a single 
image laid on the scanner bed face down for scanning

Or if the prints cannot be removed from the album without damaging 

them further, you may have to use the lid of the scanner and with your 

hand gently press down to press the image a bit flatter.

Some scanners have software that can correct this gradient 

discoloration. However, you can use Photoshop and its adjustment 

layers afterward to clean this up and other issues, using a combination 

of selections and masks, as we will see in subsequent chapters 

and later in Volume 2.

In most cases, you will place your print face down on the glass in the 

upper right-hand corner next to the arrows or guides. If you are scanning 

multiple smaller images, place them as close together as possible using the 

right edge of your scanner as the guide, but try to avoid overlap.
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Take a moment to review your scanner’s manual or online specs as 

every one is built slightly differently, depending on the manufacturer. 

Your scanner should be able to scan at least 300–600dpi (dots per inch) or 

higher up to 2400dpi for a good quality.

In Photoshop, to connect to your scanner, you would make sure your 

scanner is plugged in and that it is turned on and connected to a USB port 

and that your computer is recognizing the device and the drivers are up to 

date. Most scanners have their own quick menu as well that you can access 

if you’re not able to connect to Photoshop at first, but we will look at that 

more closely in the next section.

Adobe gives some helpful information on this topic of connecting 

to Photoshop. Depending on whether you are using a MAC or Windows 

computer, go to

https://helpx.adobe.com/photoshop/using/acquiring-images-

cameras-scanners.html

Refer to Figure 1-20.

Figure 1-20.  Photoshop icon

However, let me demonstrate how the typical procedure of image 

acquisition might go, though there may be slight differences depending 

on your computer or scanner version. I demonstrate the steps I use for 

my scanner in Photoshop CC 2024 on the Windows 10 computer. Refer to 

Figure 1-21.

�Scanning the Photo

	 1.	 Once you open Photoshop, go to File ➤ Import ➤ 

WIA Support. Refer to Figure 1-21.
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Figure 1-21.  WIA Support dialog box

You will be presented with a dialog box where 

you will use the Wizard Assists or Windows Image 

Acquisition (WIA) to help you decide where you 

will place your scans. You can also use this area for 

compatible digital cameras should you be using a 

USB cable to connect. You would then browse for a 

Destination folder where the images will be stored 

and then choose to enable or disable options such as

	 a.	 Should the acquired images appear and open in Photoshop 

and when acquired by the scanner.

	 b.	 Should each image be stored in a unique, created subfolder 

using today’s date so that you can review them later. Refer to 

Figure 1-22.

Figure 1-22.  Subfolders containing individual scans
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	 2.	 When you have made your selections, click the Start 

button to move to the next dialog box or click the 

Cancel button to exit and not save your changes.

	 3.	 When you click the Start button, you will then 

be presented with the Select Device dialog box; 

in this case, it lists the scanner which is selected 

and its properties which will vary depending on 

the manufacturer and driver setup as per setup 

instructions. As mentioned earlier for the scanner, 

always make sure your drivers and software are 

up to date, so the scanner will be recognized and 

appear here. Refer to Figure 1-23.

Figure 1-23.  Select Device dialog box where you can choose a digital 
camera or scanner that you want to acquire images from

Chapter 1  Preparation for Working with Old Historical Photos 



28

	 4.	 While it is selected, click OK. This should then 

take you to the scanner dialog box, and you will 

be presented with various options on how to scan. 

Refer to Figure 1-24.

Figure 1-24.  Scan using WIA (scanner name) dialog box with its 
various options

In my case for this scanner, I can scan a

•	 Color picture

•	 Grayscale picture

•	 Black and white picture or text
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In most cases, when scanning a document, the 

default quick selections of color picture or grayscale 

are adequate, but I will choose those via the Custom 

Settings radio button and then click the lower 

link that says Adjust the quality of the scanned 

picture. This is best practice when working with 

print photos.

	 5.	 This brings up the Advanced properties dialog box, 

which gives me more options so that I can adjust 

the resolution to 300dpi (dots per inch) up to 600dpi 

or higher for other scanners. As well, I can adjust 

the brightness and contrast of the image. This can 

be reset as well. I generally leave those settings at 

zero and do that type of appearance correction in 

Photoshop, but depending on your scanner after 

some experimentation, you may want to move these 

sliders or whatever other settings are available for 

you. Refer to Figure 1-25.
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Figure 1-25.  Advanced Properties dialog box and various options

Later in Option 2, I will look at how you can get 

additional setting from your scanner’s dialog box.

	 6.	 I will then choose the Picture type from the drop- 

down menu, which is the same as the earlier 

choices, and click OK to confirm.

	 7.	 I would then place the image I want to scan on the 

scanner bed face down – in this example, in the 

upper right hand near the edge – close the lid, and 

in the Scanner WIA dialog box, click the Preview 

button. Refer to Figure 1-26.
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Figure 1-26.  Print is placed on the scanner face down, and then 
the Preview button in the dialog box is clicked to get a preview of 
the photo

In this case, the preview does not create a copy of the image yet; it 

is just stored in memory until you are ready to click Scan. If you notice 

that your image is a bit slanted or rotated, you can always open the lid, 

move the print a bit from the center to the left or right so it’s up against 

an edge, close the lid, and click the Preview button again. Some scanners 

will recognize the area of how large your artwork is and then will use their 

bounding box handles to crop or marquee to fit around that area, so you 

don’t have to scan the whole bed. You should have the option of being able 

to drag the handles to the area you want to scan. However, some scanners, 

via their dialog boxes, will allow you to scan more than one area on the 

page into separate files, if required, by letting you draw more than one 

bounding box and then scan all at the same time. Refer to Figure 1-27.
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Figure 1-27.  Preview of the print appears, and I can use the 
bounding box to crop how much of the sketch I want to scan

�Scanner Color Modes

Now, depending on the setting you choose, different file color modes 

will be generated via the basic or Advanced properties. For my 

scanner here are some examples:

A color picture will produce a .bmp 8-bit bitmap file in RGB color 

mode. The file is generally larger than a camera .jpg file, but it is as good 

as a .tif file, and it will not lose quality as a .jpg would and can be stored for 

archival purposes. Refer to Figure 1-28.
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Figure 1-28.  Scanner results top to bottom for a color picture 
on white paper, grayscale, and black and white picture or text 
(bottom image)

A grayscale picture produces a .bmp file; however, in this case, the 

color mode is Index and 8 bits. You can always convert it afterward in 

Photoshop, choosing from the menu Image ➤ Mode ➤ RGB color.

The black and white picture or text produces a .bmp file, but this time 

the color mode is Bitmap. I find this option to be the worst setting as the 

image is very grainy and broken. In most cases, even if the image is in 
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black and white, I will generally choose the Advanced properties of color 

picture as this produces artwork with the same or better detail than a 

digital camera.

	 1.	 Once you have made your setting choices, click 

the Scan button (see Figure 1-27), and the file will 

be transferred and appear in Photoshop and be 

saved in the destination subfolder that you set up 

earlier. You can check that it is 300dpi under the 

Image ➤ Image Size dialog box, and it will show the 

resolution to be 300 (pixels/inch), which is the same 

as the dpi setting. Click Cancel to exit that dialog box 

as you are not making any size adjustments. Refer to 

Figure 1-29.

Figure 1-29.  Checking the resolution of the document using the 
Image Size dialog box showing 300 Pixels/Inch resolution
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Note that for some scanners, though you scanned at 300dpi using 
this method, they may come in expanded with a resolution of 72dpi. 
Instead, in that case, you can use your Image Size dialog box to 
correct this, but we will review this in Chapter 2. Refer to Figure 1-30.

Figure 1-30.  Checking the resolution of the document using the 
Image Size dialog showing 72 Pixels/Inch resolution but a larger 
width and height

�Flatbed Scanner Option 2: Using Your Scanner 
Dialog Box for Prints, Slides, and Negatives
As noted earlier, while this is a fast way to scan your photos so that they 

directly appear in Photoshop, this is not the best way to scan your slides 

and negatives using the flatbed scanner as film settings are not recognized 

in the Photoshop dialog box.
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In this next example, I will just point out that for prints you can leave 

the document mat cover of the scanner on and scan using the scanner’s 

dialog box. However, when you need to scan your slides and negatives, you 

will need to remove the scanner document mat cover to expose the light 

in the transparency unit window so that the scanner will recognize you are 

scanning film. Refer to the illustration in Figure 1-15 and to your scanner’s 

user guide on how to do this correctly.

In this example, you would then select the holder that is right for your 

set of slides and negatives and then proceed to the scanner’s dialog box. 

Make sure that you review which side of the film should face the scanner 

glass (generally shiny side down or words if present are reversed). The 

scanner I am using has more features in the dialog box, and while I will 

not go into detail about all of them as your scanner may be different than 

mine, I will just point out a few that you should consider. In this case, the 

scanner has multiple user modes, and I am using the professional mode 

as it is most similar to the layout mentioned earlier in Option 1 when 

importing into Photoshop. Refer to Figure 1-31.
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Figure 1-31.  Various settings may be available through your flatbed 
scanner that are not available through Photoshop as seen for the 
Epson Scan in professional mode
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In this case, I use the current default settings, and I select what kind 

of original document type I am working with. If I had not removed the 

document mat cover, I would continue using reflective mode for my print 

and then adjust my next settings in the dialog box, such as document 

source “Document Table,” which is the glass surface, and Auto Exposure 

type, in this case, a photo and not a document. Refer to Figure 1-32.

Figure 1-32.  Choosing to scan a photo (reflective) print using the 
scanner’s dialog box

When scanning film, after you have removed the document mat, you 

would then switch your document type to Film and then choose a film 

type (Positive Film, Color Negative Film, or B&W Negative Film) and then 

select the correct holder as described in the user manual and lay it on the 

scanner glass and insert the film or slides as directed. For example scan 

with the dull emulsion towards the upper light source which will appear as 

a reversed image to you, this can insure the correct orientation of image or 

text in the preview and later for the scanned image. Refer to Figure 1-33.
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Figure 1-33.  Choosing to scan film slides using the scanner’s dialog 
box and placing the film slides in the holder for scanning on the right; 
the left side of the holder would be for negative film strips

Next, whether you are scanning prints or film, you would select from 

the options presented in the image type or color mode: some options 

in this example are 48-bit color, 24-bit color, color smoothing, 16-bit 

grayscale, 8-bit grayscale, and black and white. In most cases, I would 

suggest experimenting with the color settings even if the print is black and 

white. In this case, by default, it is set to 24-bit color which produces an 

8-bit RGB file (each color channel has 8 bits (8x3)). However, some slides 

may benefit from the 48-bit color setting, but it will still appear as an 8-bit 

RGB file when opened in Photoshop. I left the speed priority scanning 

unchecked. Refer to Figure 1-34.
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Figure 1-34.  Choosing a color mode from the scanner dialog box for 
a color print

Note that the image smoothing for my scanner will produce a type of 
posterized effect, and I would not recommend this setting or black 
and white for archival photos. Refer to Figure 1-35.

Figure 1-35.  Choosing a color mode of color smoothing for this 
print from the scanner dialog box is not the best choice; in this case, it 
would be better to use 24-bit color
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Next, set the resolution as this will affect the size of the file. For prints, 

setting it at 300–600dpi is generally best, but you may want to make it a 

higher number if you plan to make a larger print, though be aware that the 

graininess of the photo will likely determine how much you can enlarge 

the image without losing quality. Refer to Figure 1-36.

Figure 1-36.  Choosing the correct resolution for your prints or film

For film and negatives, experiment and use a much higher setting 

between 1200 and 12,800dpi. Note that if you are using a portable scanner 

that can scan at either 2400dpi or 3200dpi, this may be a good number to 

set on the flatbed as well if you want to compare scanning between the two 

products.

Then you will want to compare your document size and set a target 

size as required, based on either manually setting it in mm, inches, or 

pixels or a set ratio scale. Trimming may be on or off depending on other 

settings. Notice that if you wanted to have the image to be twice the 

size of the original at 200%, the target size will now be different than the 

document size. Refer to Figure 1-37.
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Figure 1-37.  Changing your scale from the original to the new 
target size

In the case of film, once the resolution is set and you have clicked the 

Preview, as you will see shortly, you may need to adjust the target size to 

one of the presets, so the file size is not too large. In this case, you would 

adjust the resolution down to match the higher scaling size that you want. 

Refer to Figure 1-38.
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Figure 1-38.  Altering your target size through scale and trimming 
and resolution for film after you have run a preview and compare 
possible file size

You will also notice that the scanner has some additional adjustment 

correction software that comes with it. I will leave these on the default 

setting as I make most adjustments in Photoshop. Depending on the 

scanner, using dialog boxes that appear when you click the various 

buttons, you could correct such things as autoexposure, histogram 

adjustment, tone correction, image adjustment, and color palette. These 

have slightly different names in Photoshop, and we will look at that more 

in Volume 2. Refer to Figure 1-39.
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Figure 1-39.  Various adjustment settings that may be offered in the 
scanner’s dialog box

Additionally, you also have some filter-like adjustments that affect 

blurriness, grain, color, backlight, and dust removal; you will learn about 

similar filters in Volume 2. Reading Volume 2 will give you a better idea of 

how to use them with a scanner, and you can then compare whether to use 

your scanner settings or the ones in Photoshop. For now, I will leave them 

at the default with Unsharp Mask on set to a level of Medium, but consult 

your scanner’s help menu if you need more details on these settings. Refer 

to Figure 1-40.

Figure 1-40.  Additional filter-like adjustment settings that may be 
offered in the scanner’s dialog box
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Note that in the case of color and black and white film negatives, your 

scanner may have the software to automatically invert them into positives. 

If not, I will show you in Volume 2 how you could do this.

Before you click the Preview or Scan button as you did in Option 1,  

locate the File Save Settings so that you know in what folder you are 

scanning the digital images to and, if required, adjust to a new location 

other than the Pictures folder. Refer to Figure 1-41.

Figure 1-41.  Checking the File Save Settings destination from the 
scanner’s dialog box

This scanner also allows me to adjust the file format choice. For now, 

I will leave it on the default of JPEG, though in other situations you may 

want to use a TIFF (.tif ) or BITMAP (.bmp) file as you saw in Option 1 if 

you are concerned about file compression. For a document, you can scan 

to a PDF, but make sure to consult the dialog box’s help menu if you need 

more information on what setting to use.

Other settings may be present as well for what to do for the next scan 

and whether the folder that contains the image should open automatically.

Click OK if you make changes or Cancel without making changes to 

exit. Refer to Figure 1-42.
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Figure 1-42.  Scanner’s File Save Settings dialog box and some 
possible image format options

Chapter 1  Preparation for Working with Old Historical Photos 



47

To begin the scan now, click the Preview button. This dialog box will 

have more options to zoom in and allow for single or multiple cropped 

scans when you marquee areas as well as rotation of the preview. Once 

you have the settings you need for the scanner, leave the preview open and 

click the Scan button, and again the File Save Settings dialog box may open 

just to confirm where you want to scan to. After clicking OK to confirm the 

File Save Settings, the images will transfer to the location you assigned. In 

this example, the files will not open automatically in Photoshop but will 

appear in the chosen Location folder. Refer to Figures 1-43 and 1-44 for 

some examples with prints and slides in the Preview dialog box.

Figure 1-43.  Previewing a print in the scanner’s Preview dialog box 
before scanning
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Figure 1-44.  Previewing a single slide in the scanner’s Preview dialog 
box before scanning, then clicking the Scan button to create the image
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Note that in the case of some larger film (medium format), such as 
older black and white negatives, you may need to use the Normal 
tab setting rather than an automatic Thumbnail to acquire the correct 
preview of the scan. The Normal tab in this example, as shown in 
Figure 1-43, would allow me to marquee the custom area I want to 
scan, while Thumbnail might break the single negative into two or 
more parts, which is what I don’t want. In Normal mode, I would also 
be able to scan several marquee photos at the same time.

So, as we can see, acquiring an image of your sketch via a flatbed 

scanner is very easy. You would then repeat these steps if you had any 

additional images to scan, and you could leave the Preview open as 

you work, as mentioned earlier, with the slides so that the file size and 

resolution are what you desire.

Remember, when you are finished with your scans, close each dialog 

box, clean the scanner, always put the document mat on again, and turn 

off your scanner.

You can then review your image in Photoshop by choosing File>Open 

and locating the file in your folder. Look at the color options of RGB and 

review the file formats you choose, in this case, a JPEG (.jpg), TIFF (.tif ), or 

BITMAP (.bmp). This will help you get a better understanding of how your 

scanner works, and you can learn to make better use of the software. Refer 

to Figure 1-45.

Figure 1-45.  Labels of scanned files in two formats and various color 
modes opened in Photoshop
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At this point, if you did make any Photoshop adjustments, which we 

will start to look at in Chapter 2, you may want to save (File ➤ Save [Ctrl+S 

or CMD+S]) your files that you scanned to your desktop, a USB flash drive 

stick, or external drive as a backup. Otherwise, close your scans for now 

(File ➤ Close).

�A Digital Camera (for Large Format Files)
As mentioned before, for larger prints such as family photos or scenery 

that cannot fit in your scanner that you may want to incorporate into your 

project, you can use a digital camera. You may have to experiment with a 

few shots until you get the best quality. Refer to Figure 1-46.
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Figure 1-46.  Capture your artwork with a digital camera

For example, if the camera needs to be close or the surface is shiny, do 

not use a flash as it will cause a reflection and the image will disappear. Use 

a tripod to avoid shaky images even if your camera has auto stabilizer. Set 

up the image in a vertical or horizontal position. Also, check if your tripod 

has an option where the camera can point straight down on the table 

without tipping over when taking the picture. Refer to Figure 1-47.
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Figure 1-47.  Photo example of how you could use a tripod and a 
digital camera like a scanner for larger sketches
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Your camera should be at least 12 megapixels or higher. You can 

also experiment on a macro setting as this may produce a better-quality 

resolution. The image will likely be .jpg (JPEG) in RGB color mode and 8 

bits. To then acquire the image, you can then use the method that Adobe 

describes using a USB port drive connected to the camera:

https://helpx.adobe.com/photoshop/using/acquiring-images-

cameras-scanners.html

Or just take out the camera’s memory card, insert it into your 

computer’s drive, and copy the images that you want into a folder on your 

computer, as was mentioned with the portable flatbed scanner.

Either way, I have presented you with a variety of options for acquiring 

a digital image of your photos, and the choice is up to you.

If you need to refer to an example of a final scanned image in 

Photoshop, use File ➤ Open. If you want to practice, use the car_image.
jpg that I scanned from a slide.

You can at this point close any files you have open in Photoshop and 

then exit (File>Exit) the application as well.

�Summary
In this chapter, we discussed how to scan some of your photos, whether 

they be prints, film negatives, or slides. We looked at various scanning 

options, and we also looked at how to review the digital scans afterward 

in Photoshop. In the next chapter, you will review our tools and panels 

that you will find in the Photoshop workspace and begin your work on the 

digitized photo.
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CHAPTER 2

Setting Up Your 
Photoshop 
Workspace
Once you have digitized your photos, if you have not worked in Photoshop 

before or need a review, you should read this chapter. Before you start any 

project, it’s important to begin setting up your Photoshop workspace and 

then opening and saving files in the correct format while you work. Let’s 

review those steps now.

Note this chapter does contain projects found in the Volume 1 
Chapter 2 folder.

�Creating a New File and Workspace Setup
If you do not already have Photoshop open, begin by doing that now and 

look at the current home page.

https://doi.org/10.1007/979-8-8688-0450-2_2
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�Setting Up the Workspace and Review 
of the Main Panels and Tools
To get started and set up your workspace, from the main menu choose File 

➤ New. The New Document dialog box will open.

For now, to practice, click the Print tab and use the preset blank 

document of Letter 8.5x11in @300ppi. Later, in the project section of this 

chapter, we will open some digital images which will vary in size and save 

them as .psd files. Refer to Figure 2-1.

Figure 2-1.  New Document dialog box with a preset of print and letter

In the dialog box, you will notice in the preset details on the right, the 

name will be currently Untitled-1.

The width is 8.5 and the height is 11, and these are in inches, but with 

the drop-down menu, I can choose other measurement settings. Leave on 

Inches as you work. Refer to Figure 2-2.
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Figure 2-2.  New Document presets allow you to set other 
measurement settings besides inches, such as pixels or centimeters

The orientation is portrait, but it can be switched to landscape by 

clicking the button icon next to it. I can add additional artboards, but I will 

leave that option unchecked. The resolution is 300 pixels/inch, which is a 

good resolution for working with photos that will be repaired. With lower-

resolution images of 72 pixels/inches, certain details might be lost as you 

later make various adjustments. The color mode is set to RGB (red, green, 

blue) color, which is the setting to work with for most digital photos. Refer 

to Figure 2-3.
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Figure 2-3.  Set your resolution to 300 pixels/inch and color mode to 
RGB color

If you were planning to print, you could set it to CMYK (cyan, magenta, 

yellow, black), lab, or even grayscale. However, some of these color modes 

do not allow access to all the Filters and Adjustment Layers that we will 

later be working with in the book and later in Volume 2. We’ll discuss 

this more later in the chapters that follow, including Volume 2. Refer to 

Figures 2-4 and 2-5 for a preview.
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Figure 2-4.  On the left, filter selection with RGB color mode; on 
the right, filter selection with CMYK color mode; some options are 
grayed out
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Figure 2-5.  On the left, adjustment layer selection with RGB color 
mode; on the right, adjustment layer selection with CMYK color 
mode; some options are grayed out

I don’t always know which direction the project is going to take 

artistically, so I like to keep all my options open; hence, I will stay with 

RGB color mode. I will keep the bit setting at 8 bits/channels as higher 

channels, like 16 or 32 bits, can also affect what filter I can use and can also 

increase file size. Refer to Figure 2-6.
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Figure 2-6.  Image bit size options from the drop-down menu

For info on bit settings, you can refer to these pages:

https://helpx.adobe.com/photoshop/using/bit-depth.html

https://helpx.adobe.com/photoshop/using/color-modes.html

And another setting that I will leave at default is Background Contents, 

which will be white. You could change this either via the drop-down menu 

or the custom color picker on the right. Refer to Figure 2-7.

Figure 2-7.  Background Contents and Advanced Options in the New 
Document dialog box
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The advanced options set the Color Profile at Working RGB: sRGB. For 

your own projects, you may prefer to use a different profile such as Adobe 

RGB (1998) as this is preferred by some graphic designers for print and 

professional photography with a higher range of colors. Refer to Figure 2-8.

Figure 2-8.  Alternate Color Profile settings in the New Document 
dialog box

Adobe states, “sRGB is recommended when you prepare images 

for the web, because it defines the color space of the standard monitor 

used to view images on the web. sRGB is also a good choice when you 

work with images from consumer-level digital cameras, because most 

of these cameras use sRGB as their default color space.” Now Adobe 

also recommends Adobe RGB (1998) for working with documents for 

conversion between high-end digital cameras and print. However, having 

said that, a lot of my work has been with my Canon inkjet printers and 

laser printers, and I have for this basic type of print work had good success 

with just the sRGB profile for portfolio and my client’s work. However, I 

leave that decision up to you and your print company when it comes to 

offset print work and what is the ideal Color Profile.

For more details on Color Profile settings, refer to

https://helpx.adobe.com/photoshop/using/color-settings.html

I will leave the pixel aspect ratio at square pixels and then click the 

Create button. Refer to Figure 2-7.
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Photoshop will then open the new blank document and the workspace 

which we will adjust next. Refer to Figure 2-9.

Figure 2-9.  New blank document appears in the Photoshop workspace

You can then begin to set up your workspace either using the main 

menu Window ➤ Workspace or from the Workspace button found on the 

far right of the Options panel bar. Refer to Figure 2-10.
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Figure 2-10.  Workspace options in the Window menu and from the 
right of the Options bar panel

For my work, I generally like to choose Essentials (Default) as this gives 

me all the tools that I need in the Tools panel as well as other essential 

panels. For additional reading, I discussed many of these panels in my 

book Accurate Layer Selections Using Photoshop’s Selection Tools. If you are 

working with a lot of photos, you may prefer to work with the photography 

workspace; however, for this book, work with the Essentials.
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Panels can be opened, collapsed, and undocked or docked by dragging 

them by the tab name to a new location in your Photoshop application. 

For example, as you work on your project, with the Layers panel, it might 

be helpful to separate it from the other panels it’s grouped with and drag it 

closer to your canvas. Refer to Figure 2-11.

Figure 2-11.  Drag to undock and move your Layers panel or any 
panel closer to your canvas as you work
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Most panels often have their own menu on the right of the panel which 

give you other options while working with the panel. You can find these 

panels, again, as well as additional panels, in the Window drop-down menu.

Tools, Panels, and Contextual Task Bar 
Overview Review
For now, I will just do a basic overview of the key panels that are useful 

from this workspace. In later chapters and in Volume 2, some of these 

tools in panels will be discussed in detail. If you find your workspace has 

become cluttered, if required, you can reset your Essentials workspace by 

choosing Reset Essentials from the Workspace menu. Refer to Figure 2-10.

�Tools

The Tools panel contains all the tools that you need to work on your 

Photoshop projects. As you can see in this figure, they are many, including 

a few recently added, such as the Remove Tool and the Adjustment Brush 

Tool. Refer to Figure 2-12.
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Figure 2-12.  Many tools are available in the Tools panel in Photoshop

However, for the moment, the main tools that you need to know about 

are the Move (V), Zoom (Z), and Hand (H) tools. Refer to Figure 2-13.

Figure 2-13.  Photoshop’s Move, Zoom, and Hand Tools
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We will explore some of the others in regard to digital photo restoration 

in Chapters 3–8, and later in Volume 2 they will be mentioned as well.

The Move Tool (V) allows you to move objects around on Layers with 

your mouse, and you can drag the contents of a Normal Layer around. It 

works with the Layers panel. Try dragging across the locked Background 

layer with the Move tool. An alert message pops up; in it you can click the 

Convert to Normal Layer button. This will make it Layer 0 so that you can 

move it around or off the canvas entirely. It is now a normal or regular 

layer. Refer to Figure 2-14.

Figure 2-14.  Use the Move Tool to convert your locked background 
layer to a normal Layer
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Alternatively, you can double-click that Background Layer first. 

Then click OK to the name Layer 0 in the New Layer dialog box. Refer to 

Figure 2-15.

Figure 2-15.  Double-click your background layer and use the New 
Layer dialog box to convert it to Layer 0

As Layer 0 or any unlocked layer, you can move it around the canvas.

The Zoom Tool (Z) allows you to zoom in and out of an image. To zoom 

in, click once with the tool; to zoom out, hold down the Alt/Option key 

+ click with the tool, or you can use your key commands of Ctrl/CMD++ 

(plus key) or Ctrl/CMD+- (minus key) or fit on screen Ctrl/CMD+0 to 

zoom in or out without using the mouse. Note that as you progress through 

the books, knowing how to use these key commands will be very helpful as 

we cannot always rely on accessing the tool from the Tools panel when in 

certain workspaces. Refer to Figure 2-16.

Figure 2-16.  Zoom Tool

Likewise, the Hand Tool (H) is great to use when you are zoomed in 

close to your artwork. Then you can drag and navigate about the Canvas 

without moving or disrupting the layers. If you hold down the spacebar 

while using the Move Tool, you can access this Hand tool and drag to move 
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the entire area. This is a helpful key command to know when you are not 

able to directly access it from the Tools panel in certain workspaces as you 

will see in the following chapters. Refer to Figure 2-17.

Figure 2-17.  Hand Tool

If you find that a tool is missing, it’s possible that it might be hidden 

under the Edit Toolbar button. Refer to Figures 2-12 and 2-18.

Figure 2-18.  Edit Toolbar button

To check, click the tool and the Customize Toolbar dialog box will 

open. Check on the right-hand side for your tool (Extra tools), and if 

present, you may need to drag and add it back to the left Toolbar side and 

then click Done to exit. Refer to Figure 2-19.
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Figure 2-19.  Customize Toolbar dialog box

However, with the Essentials (Default) Workspace, all the tools should 

be in the Tools panel. Click Cancel to exit the dialog box.

�Options Bar and Tool Presets Panels

The Options bar panel (also known as the Tool options bar) works with the 

Tools panel and the Window ➤ Tools Presets panel when you need to store 

tool settings or access other tool options, as you can see when you click the 

Move, Zoom, or Hand Tool. Each Options panel–based tool has separate, 

but sometimes similar, options. Refer to Figure 2-20.
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Figure 2-20.  The Options bar panel changes based on what tools are 
used. The Tool Presets panel can store that tool’s newly created presets

�Contextual Task Bar

Having similarities to the Options bar panel, this new Task bar, which has 

been recently added to Photoshop, acts as a type of repository for quick 

actions that you may want to perform on a specific layer. It can act as a 

suggestion for alternative options you may want to perform or for access to 

the Properties panel, which we will look at in a moment. In this case, you 

can move it around in your workspace by dragging on the left edge if you 

find it blocking part of your image; you can use the Window menu if you 

need to hide or reveal it. For more details, refer to Figure 2-21 and to the 

following link:

https://helpx.adobe.com/photoshop/using/using-tools.

html#contextual-task-bars.
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Figure 2-21.  View of the contextual task bar with its menu options

�History

The History panel records various steps as you perform them on your 

image. If you make a mistake as you work, you can click back or up a 

previous step in the History panel to remove that step and try again. You 

can also use Edit ➤ Undo from the menu, which has the key command of 

Ctrl/CMD+Z. Knowing this key command will be useful in Chapters 3–8 as 

well as Volume 2 as you may not have access to that sub-change step in the 

History panel while working in various workspaces. Refer to Figure 2-22.

Figure 2-22.  Use the History panel to move back to a previous state 
in your work
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�Comments

Though it appears as one of the Essentials, the Comments panel is 

not relevant to this book. However, it may be useful if you are sharing 

comments with other collaborators on your current project. They can be 

saved as you work in the Creative Cloud for others in your group to view. In 

this book, we are working alone, so you do not need to work with this panel 

in any chapter. Refer to Figure 2-23.

Figure 2-23.  The Comments panel is part of the available panels in 
the Essentials workspace and is used for collaboration with others on 
the Creative Cloud
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�Color

The Color panel allows you to click-select colors using its pallet without 

having to click the color picker in the Tools panel. This new color is added 

to the Foreground color in the Tools panel. Refer to Figure 2-24.

Figure 2-24.  The Color panel can be used to change the current 
Foreground color in the Tools panel
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Note that if you need to reset the Tools panel default to black and 
white, press the D key, and to switch foreground and background 
colors, press the X key on your keyboard. Refer to Figure 2-25.

Figure 2-25.  Set the current foreground and background colors back 
to black and white in the Tools panel

The Color panel menu also allows various ways to view the color and 

alter color. For now, we’ll just keep it on the Hue Cube setting, but in other 

situations, I recommend using RGB Sliders. Refer to Figure 2-26.

Chapter 2  Setting Up Your Photoshop Workspace



77

Figure 2-26.  The Color panel menu lets you set the way color is 
viewed to create a new swatch. Currently, in the menu, it is set to 
Hue Cube

�Swatches

The Swatches panel allows you to store the color swatches in a folder 

you create after they are acquired from the Tools panel’s Color Picker 

(Foreground or Background Color). Double-click on either the foreground 

or background swatch to access that dialog box. Back in the Swatches 

panel, these folders can be saved or exported and later shared with others. 

Individual swatches can also be added to the Libraries panel for further 

collaboration. Swatches can be accessed from the Options panel for Fill 

or Stroke of Vector Shapes as well as for various color adjustments with a 

solid fill. Refer to Figure 2-27.
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Figure 2-27.  Swatches that are added to the Swatches panel can be 
created using the Color Picker dialog box and then added to folders

Chapter 2  Setting Up Your Photoshop Workspace



79

�Gradients

The Gradients panel stores gradients (color transitions) that can be 

accessed either from the panel or when you are using the Gradient Tool. 

You can easily create your own gradients which can later be applied to 

a selected area on a layer, a Fill Layer, Adjustment layer, or Layer Style. 

Gradients have recently gone through some improvements, which we will 

look at in Volume 2. Refer to Figure 2-28.

Figure 2-28.  Gradients are stored in the Gradients panel in folders 
and can be viewed in various ways using the panel’s menu and can be 
accessed using the Gradient Tool’s Options bar
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�Patterns

The Patterns panel stores patterns. These patterns can later be filled into a 

selected area on a layer, a Fill Adjustment layer or even in a Layer Style. We 

will look at this option briefly in Volume 2 and how it could be relevant to 

your photographic work. Refer to Figure 2-29.

Figure 2-29.  The Patterns panel stores patterns in folder groups, and 
its menu allows you to view, import, or export patterns
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�Properties

The Properties panel is in some ways very similar to the Options bar panel 

in that it can help you while you are working with a tool as well as with 

transforming the scale and size of the object on a Layer. The Properties 

panel can also help you with quick actions rather than having to remember 

where in the main menu that command is located and can be used in 

conjunction with the Contextual Task bar. This panel will be used in this 

book and Volume 2. Refer to Figure 2-30.

Figure 2-30.  The Properties panel allows you to transform and 
align layers and work with other Photoshop tools using suggested 
quick actions
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�Adjustments

The Adjustments panel allows you quick access to many of the adjustment 

layers found in the Layers panel under the Create New Fill and Adjustment 

Layer button. Adjustment layers are great for specialized color corrections 

and hue adjustments, which you can modify using the Brush or Eraser 

Tool on the Layers panel masks (Layer and Vector), as well as use the 

Properties panel to move sliders that effect the adjustments and mask. 

However, other than if you chose to alter the mask, adjustment layers will 

not create a distortion to the image itself, only alter the color. This panel 

recently has had an upgrade and a new tools has been recently added call 

the Adjustment Brush Tool, which we will explore in more detail in Volume 

2. Refer to Figures 2-31 and 2-32.

Figure 2-31.  The Adjustments panel allows you to access Adjustment 
layers as you would from the button in the Layers panel
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Figure 2-32.  Use the Brush Tool or Eraser Tool or Adjustment Brush 
Tool paint on an adjustment layer mask or the Properties panel to 
adjust the slider settings for the adjustment and its mask

�Libraries

The Libraries panel can be used to share your Colors, Text, Patterns, and 

Graphics between Photoshop and Illustrator. In this book, we are not going 

into any detail of working with the Libraries panel, though if this is a topic 

of interest, you can refer to the books I mentioned in the introduction 
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as well as the following link for reference to working with your graphics: 

https://helpx.adobe.com/photoshop/using/cc-libraries-in-

photoshop.html. Refer to Figure 2-33.

Figure 2-33.  The Libraries panel can be used to store patterns 
and other assets that were created in Photoshop or another Adobe 
application like Illustrator
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�Layers

The Layers panel, along with the Tools and Options bar panel, is probably 

the most important panel in Photoshop. The Layers panel stores the 

Background, Normal Layers, Smart Object, Text, Vector Shape, Fill, and 

Adjustment Layers along with Layer Styles on separate Layers as well as 

Masks and Smart Filters. We will see how layers work in the Layers panel in 

Chapters 3–8 and in Volume 2. There are also various options available in 

its menu for altering specific layers, and the order and options may change 

based on the type of layer selected. Refer to Figure 2-34.

Chapter 2  Setting Up Your Photoshop Workspace



86

Figure 2-34.  The Layers panel can store a variety of layers, and they 
can be adjusted using its menu
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�Channels

The Channels panel is a great place to save and store your current 

selections and later incorporate them into your layer masks; we’ll see that 

briefly in Chapters 6–8 and then later in Volume 2. For additional reading, 

I go into greater detail with this in my book Accurate Layer Selections Using 

Photoshop’s Selection Tools, though this book is not required to complete 

the projects within these chapters. However, individual channels can be 

viewed and adjusted during photo restoration, which will be discussed in 

more detail in Volume 2. Refer to Figure 2-35.

Figure 2-35.  Channels panel with the menu and active channel 
mask hidden
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�Paths

The Paths panel is great for working with vector shapes, the pen tools, 

and selections. Paths can be stored in the Paths panel for later use. For 

additional reading, I go into greater detail with this topic in my book 

Accurate Layer Selections Using Photoshop’s Selection Tools, though this 

book is not required to complete the projects within these chapters. The 

Pen Tool and Paths panel will be briefly mentioned in Volume 2 in regard 

to vector mask creation. Refer to Figure 2-36.

Figure 2-36.  Paths panel and menu with newly created work path 
using the Pen tool
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Later, in other chapters in this book and in Volume 2, we will look at 

additional panels found in the Window menu such as

•	 Brushes (refer to Chapters 3–5)

•	 Brush Settings (refer to Chapters 3–5)

•	 Clone Source (refer to Chapters 3–5)

•	 Content Credentials (Beta) (refer to Chapter 8)

•	 Histogram (refer to Volume 2)

•	 Info (refer to Volume 2)

•	 Materials and Parametric Properties Panels (refer to 

Volume 2)

•	 Styles (Layer Styles) (refer to Volume 2)

•	 Timeline for Animated GIF and Video (refer to 

Volume 2)

If you like, you can open these panels and create your own custom 

workspace, but for now we will keep them closed (Window ➤ Workspace 

➤ New Workspace). Refer to Figure 2-37.
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Figure 2-37.  Create a New Workspace with your new panels that you 
frequently work with

In Volume 2, we will also be looking at filters and smart filters 

specifically for photos for restoration.
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�Rulers and Guides

One other thing you can do, while setting up your workspace, is to make 

sure, from the View menu, to choose View ➤ Rulers (Ctrl/CMD+R) in 

case you need to drag out some guides later when lining up objects on 

various layers. As well, choose View ➤ Show ➤ Smart Guides for smarter 

alignments while moving layers. Refer to Figure 2-38.

Figure 2-38.  Add rulers to your view so that you can add guides or 
use smart guides for alignment
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�Opening Your Scanned File
From the menu, select File ➤ Open (Ctrl/CMD+O). If you are working with 

one of my project files or one of your scanned images, locate the file using 

the resulting dialog box to open in Photoshop.

�Creating Image Duplicates
From the main menu, make sure to create a duplicate (Image ➤ Duplicate) 

so that you can work on a copy without changing the original. In this and 

all examples in the book, make sure to leave “Duplicate Merged Layers 

Only” checkbox disabled. Then click OK and the duplicate is created. Refer 

to Figure 2-39.

Figure 2-39.  Make a duplicate (Image ➤ Duplicate) of your file when 
you want to work on a copy without altering the original file

�Adjusting Scanned Image
Here are some suggestions if you need to make some initial or basic 

adjustments to a scanned image. Use the car_practice.jpg image and make 

a duplicate (Image ➤ Duplicate) if you need to practice later in the photo 

project section at the end of the chapter.
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If your scan is sideways, you can always choose, in Photoshop,  

Image ➤ Image Rotation and rotate the image in Photoshop 90° clockwise 

or counterclockwise or if it needs to be flipped 180°. Or use Flip Canvas 

Horizontal or Vertical if you notice that when you scanned for example, a film 

slide, the text appears reversed, so that it reads correctly. Refer to Figure 2-40.

Figure 2-40.  Location in the Image drop-down menu of Image 
rotation options
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Or, if you need to straighten the image slightly, you can double-click the 

Background layer in your Layers panel to make it Layer 0 and, from the main 

menu, use various Edit ➤ Transform options such as Rotate. As well, you 

can then use your Move Tool’s “Show Transform Controls” checkbox in the 

Options panel bar found under the gear icon and then use the bounding box, 

surrounding the image, to manually rotate it from a corner without changing 

the image size’s current orientation. Refer to Figures 2-41 and 2-42.

Figure 2-41.  Use the Photoshop Layers panel to change your 
background layer into Layer 0 in the New Layer dialog box and the 
result in the Layers panel
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Figure 2-42.  Photoshop options panel bar with settings and 
bounding box around the picture using the Move tool

Once done, you would then check the commit check in the Options 

panel bar and disable the “Show transform controls” option, if not 

required. Refer to Figure 2-42 and Figure 2-43. Then use the Layers 

panel menu to flatten your image back to a background layer. Refer to 

Figure 2-44.
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Figure 2-43.  Photoshop rotated image; click the check in the Options 
panel bar to confirm
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Figure 2-44.  Use the Layers menu to Flatten the image back to a 
Background layer
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Note that what was done here was just a very basic starting point 
to image repair. Other things that would need to be done here might 
include, while scaling or rotating, dragging out guides to make sure 
you know what you are straightening in the layer and cropping or 
adding more information to missing parts of the image.  This picture 
probably needs some slight color correction. Finally, if you zoom 
in, there is dust that will need to be removed as well. Starting in 
Chapter 3 and later in Volume 2, we’ll start looking into photos like 
this in more detail.

�Adjusting Image Size

One other basic adjustment we will consider is using the Image > Image 

Size dialog box when you want to make sure that your document is a 

certain resolution or size (dimensions for the width and height). You can 

scale by other increments including percent, if required, as well as pixels. 

Refer to Figures 2-45 and 2-46.
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Figure 2-45.  Adjusting the image size with various settings in the 
Image Size dialog box
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Figure 2-46.  Adjusting the image size with various settings in the 
Image Size dialog box and changing the resolution which will affect 
the width and height of the image

Before enabling the Resample checkbox, note that if you change the 

resolution to another number such as 300–600 pixels/inch, the width 

and height will also go up or down. This is good to know after a scan was 

created; as we saw in Chapter 1, it could be scanned at 300dpi/ppi, but 

when imported into Photoshop, it appeared to be 72ppi with a very large 

width and height. The option would then be to set it back to 300ppi so that 

it would return to the correct size. Make sure that the Resample checkbox 

is disabled when you do this for an accurate conversion.

However, in other cases, you may want to fit your photos to the original 

size or another preset from the Fit To drop-down list. During the process of 

resizing with the Resample check box enabled and then choosing a preset 

from the (Fit To:) list this will alter the width and height, optionally you 

can unlink the aspect ratio, and you have the option to alter the resolution 

independently when the Resample check box is enabled. Refer to Figure 2-47.
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Figure 2-47.  Setting a new preset size for Fit To so that the resample 
settings are now available, you can change the resample settings and 
adjust whether the width and height are linked
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Note that in most cases, I would recommend that you keep the 
aspect ratio linked to avoid unnecessary distortion while you work. 
Using Edit ➤ Transform ➤ Scale will give you more control over the 
scale correction, and we will look at that in Chapter 8.

While you cannot add any more authentic detail to an image that is 

already missing, you can use the various resample options to reduce or 

enlarge the image even if it is low resolution. To make an image appear less 

jagged with fewer artifacts or noise during scaling, the application uses 

a type of interpolation by using known data points or pixels to estimate 

values at unknown points. When enabled, you can, from the resample 

options, choose one from the drop-down list. While Adobe does give some 

hints with the names, you will have to use your preview window to zoom in 

to see if the result is what you intended. Refer to Figure 2-48.

Figure 2-48.  Choosing different resample options from the  
drop-down list in the Image Size dialog box
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•	 Automatic: For basic default interpolation.

•	 Preserve Details (enlargement): Try this option if you 

want to create enlarged prints. This option also has a 

Reduce Noise slider (0–100%) for further smoothing.

•	 Preserve Details 2.0: If you have set your Edit ➤ 

Preferences (Technology previews), this may be the 

current default option rather than Bicubic or automatic 

found in the General tab. Refer to Figure 2-49.	

Figure 2-49.  Photoshop Preference Options for General and 
Technology previews

According to Adobe, this option features artificial intelligence–assisted 

upscaling to preserve important details and textures while resizing images 

without introducing distortions. In addition to skin tones and hair textures, 

this feature preserves harder-edged details like text and logos. They 

recommend trying it on soups, salads, pizza, and any other subjects that 

need that extra dash of texture preservation. This option also has a Reduce 

Noise slider (0–100%) for further smoothing. Refer to Figure 2-48.
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•	 Bicubic Smoother (enlargement): This is good for 

enlarging images based on Bicubic interpolation 

but designed to produce smoother results during 

enlargement. Use the Reduce Noise slider (0–100%) for 

further smoothing.

•	 Bicubic Sharper (reduction): This is good for reducing 

the size of an image based on Bicubic interpolation 

with enhanced sharpening. This option maintains the 

detail in a resampled image. However, if you observe 

that it over-sharpens some areas of an image, try 

switching to Bicubic.

•	 Bicubic (smooth gradient): This is a slower and more 

precise method based on an examination of the values 

of the surrounding pixels. This option uses complex 

calculations and should produce smoother tonal 

gradations than Nearest Neighbor or Bilinear.

•	 Nearest Neighbor (hard edges): It is fast but not precise 

in that it replicates pixels next to each other. This option 

is best used for illustrations containing edges that are 

not anti-aliased where you want hard edges that are not 

blurry when you produce a smaller file. The edges can 

appear jagged, and this will be apparent later if you do 

further scaling outside of this dialog box.

•	 Bilinear: This adds more pixels by averaging the color 

values of surrounding pixels. According to Adobe, it 

produces medium-quality results.
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Note that the software, when resampling or interpolating, can 
ultimately only “guess” pixel-wise what the next pixel might be if you 
do an enlargement (upsampling). The enlarged image may be slightly 
blurry. That is why when scanning, especially with slides or film, if 
you plan to create a larger image, always scan at higher resolutions 
and save a backup of the file for later use when you need to do a 
reduction or a downsampling.

Try any one of these options on your image and zoom in to preview 

and then click OK to confirm and exit the dialog box. Use Edit > Undo or 

the History panel if you want to return and try another option.

More details on this topic can be found at the following links:

https://helpx.adobe.com/photoshop/using/image-size-

resolution.html#resampling-content

https://helpx.adobe.com/photoshop/using/technology-

previews.html

Having said that, later in other chapters we will look at some Content-

Aware workspaces that we can use to fill in some missing blanks within 

the photo.

�Saving Changes to Your Scanned Files 
Single Layer
If you intend to save a copy of your flattened single layer file for later use, 

you can save it as a .tif file or .jpg file.

Using the menu option of File ➤ Save (Ctrl/CMD+S), you will see the 

File ➤ Save As dialog box, and then you will browse and locate where you 

want to save your file.
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Note  When you click File ➤ Save before reaching that dialog box, 
you may be presented with some options as to whether to save to 
your computer or the Creative Cloud. I usually save to my computer 
and click the “On your computer” button. Later, you can still save a 
copy to the Creative Cloud, or as in this case, you want to save the 
file to a drive on your computer for backup. Refer to Figure 2-50.

Figure 2-50.  Save on your computer or on the Creative Cloud 
dialog box

Click Save to continue to the next dialog box.

Tiff files are often larger in file size, but they will not lose quality if 

another copy of the file is saved as a .tif again (lossless). In this example, 

the image compression is set to none, Save Image Pyramid is disabled, 

Pixel Order is Interleaved (RGBRGB), and the Byte Order is IBM PC 

because I am working on my Windows computer; in your case, you may 

be working on Mac OS, so it would be set to Macintosh. Choose a Layer 

Compression if required; in this case, it is disabled. Click OK. Refer to 

Figure 2-51.
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Figure 2-51.  Save As settings and TIFF options dialog box

For File ➤ Save, when you reach the Save As dialog box, you would 

browse for a location to save your file of the graphic as a .jpg. Bear in mind 

that each time you save a copy of a jpg, if you keep setting it to a low quality 

there is always the chance you are losing details that were once in the 

original. Jpegs are lossy and generally ideal for emailing or posting on a 

website since they are a smaller file size, but you should still always keep a 

backup of your original file, if you plan to use it for print and other projects.

Click Save and set your JPEG Options at Maximum image quality 12 

and a Format Option of Baseline (“Standard”), then click OK. Refer to 

Figure 2-52.
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Figure 2-52.  Save As settings and JPEG Options dialog box

However, while working on the projects in this book, you will want to 

save your copy as .psd file, so you can work with multiple layers and filters 

during your digital restoration. For practice, we will do that next.
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�Project: Open and Save a File 
in a PSD Format
For practice, click File ➤ Open, then select car_practice.jpg or a scan 

of a file that you plan to work on, and then make a duplicate (Image ➤ 

Duplicate) as you saw in Figure 2-39 using the dialog box. Click OK.

Try one of the following adjustment options that were mentioned in 

this chapter to make image adjustments, such as straightening the file or 

adjusting its image size.

After you complete some steps or while working on each project in this 

book, make sure to save (File ➤ Save [Ctrl/CMD+S]) your document. This 

time, you will save the file as a .psd somewhere on your computer. Then 

you can continue to modify and add more layers to your file later. Click 

Save and then OK to the Photoshop Format Options dialog box that may 

appear if you have multiple layers. Refer to Figure 2-53.
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Figure 2-53.  After you save your document for the first time, click 
OK to the dialog message on Maximize Compatibility to complete the 
saving of the .psd file

Later, while the file is open, you could then use Photoshop 

adjustment layers to do any color correction and clean up the file 

with your eraser or selection tools or cropping tools. We will do that 

to various images in the upcoming chapters and later in Volume 2. 

For now you can review my file car_practice_final.psd.
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�Summary
In this chapter, we reviewed how to create a new Photoshop file in the 

Photoshop workspace. Then we practiced opening a file, duplicating it, 

and making some basic adjustments. Lastly, we looked at some options 

for how to save the file in other formats, including .psd for a multilayer 

project. In the next chapter, we will look at multiple tools that can be used 

for photo restoration.
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CHAPTER 3

Tools for Photo 
Restoration: Part 1
Photoshop, as we have seen, has quite a few tools in the Tools panel, and 

to a beginner user, this can be quite overwhelming. I know for myself this 

was the case when I started using Photoshop. I often did not know where 

to begin or what tool to use. Over time, you will discover that some tools 

are ideal for photo restoration, while others are better for more artistic and 

abstract projects. Nevertheless, many tools can be used in combination, 

and you need to identify what the issue or damage actually is in the image 

before you use one particular tool. In other situations, different tools can 

fix the same damage, but you may prefer how one corrects over the other.

In this chapter, I will explain to you some of the main tools in the Tools 

panel I like to use for photo restoration or “healing” the damage, as well 

as some that can enhance your work or correct minor spot damage. Note, 

you may not use all these for every project. In this chapter as well as the 

following chapters, we will be using the Layers panel and try to work in 

the least destructive way possible so that you can go back at any time and 

correct your errors. You will be able to do that if you make sure that, as you 

saw in Chapter 2, you save a duplicate of your scan as a .psd document.

https://doi.org/10.1007/979-8-8688-0450-2_3
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Note this chapter does contain projects found in the Volume 1 
Chapter 3 folder. Some tools mentioned in this chapter have also 
been mentioned in my previous books, Accurate Layer Selections 
Using Photoshop’s Selection Tools and Perspective Warps and Distorts 
with Adobe Tools: Volume 1, but with new information presented as 
it relates to photographic images. As you work on each project in 
this chapter, make sure to create a duplicate (Image ➤ Duplicate), 
as mentioned in Chapter 2, so that you do not override the original 
artwork, and click OK to the message in the dialog box. Refer to 
Figure 3-1.

Figure 3-1.  Duplicate Image dialog box

Remember, as you work, to use the Move, Zoom, and Hand tools as 

well as the related key commands that were mentioned in Chapter 2. As 

well, use your History panel or Edit ➤ Undo (Ctrl/CMD+Z) if you make a 

mistake and need to revert a few steps. Refer to Figure 3-2.
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Figure 3-2.  Move, Zoom, and Hand Tools and History panel

Tip  When you save (File ➤ Save) your files later as a suggestion, 
you can also add your initials to the name so that you do not override 
the original file, for example, practice_file_JH.psd.

�Identifying Photo Damage/Issues 
and Working with the Healing Tools
In Photoshop, there are currently a collection of seven tools thought of as 

the “Healing Tools.” These tools can be used to digitally cover or fix such 

things as patching rips, creases, and stains as well as cover white spots, 

dust, and reflections where details are missing. This would be considered 

repairing an image to bring it back to its original state. However, if you are 

not as concerned about the authenticity and would just like a nice photo 

to display, you can also go a step further and fix cosmetic issues such as 

blemishes or add missing parts to a person that would be beyond the 

original borders of the canvas. You could also add copies of trees to fill in 

gaps or remove unnecessary details in the picture, such as powerlines, a 
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person, animals, or an object that is blocking part of an otherwise good 

photo. You may feel the removal of this item from the image is necessary so 

that you can enjoy the image without distraction. Refer to Figure 3-3.

Figure 3-3.  Before photo of a woman at the beach and after photo 
with the woman removed from the scene

We will see here a few before and afters of how this could appear or 

look while using each tool. However, the suggestions I present here are not 

an exhaustive list, and each damaged photo will have its own challenges. 

As mentioned in Chapter 2, sometimes more than one issue needs 
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correction. So, before you start working with just any tool, look at the photo 

and decide what kind of repair this photo needs to look its best. Then you 

need to identify the correct tool to use for that job. Let’s look at a few of 

these one at a time.

The main tools that I consider to be part of this “healing” collection are

•	 Clone Stamp Tool and Clone Source Panel

•	 Spot Healing Brush Tool

•	 Remove Tool

•	 Healing Brush Tool

•	 Patch Tool

•	 Content-Aware Move Tool

•	 Red Eye Tool

Refer to Figure 3-4.
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Figure 3-4.  Tools panel: The Clone Stamp Tool with various healing 
brushes and tools and Clone Source panel with menu options

Because this is a beginner guidebook, I will not go into all the details, 

but at least this will get you started on working with the tools. I will also 

provide links for reference. Remember to use Edit ➤ Undo (Ctrl/CMD+Z) 

or your History panel if you need to undo a step as you work.
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�Clone Stamp Tool (S) and Clone Source Panel
The Clone Stamp Tool can be selected from the Tools panel and used by 

itself with the Options bar panel, or it can be used in conjunction with the 

Clone Source panel. Refer to Figures 3-4 and 3-5.

Figure 3-5.  The Clone Stamp Tool Options bar panel

This is often the default tool to gravitate to when you need to correct or 

cover basic damage.

Let’s start to practice with the file army_practice_healing_clone.psd. 

Open it in Photoshop and make a duplicate of the file (Image ➤ Duplicate) 

as mentioned in Chapter 2. Refer to Figure 3-6.

Figure 3-6.  Damaged black and white photo of army men practicing 
moving injured soldiers

To give some background on this particular photo, this is a landscape 

picture that was longer than 11 inches, and so it needed to be scanned in 

two sections before I could start to work on it. The second half of the image 
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was then copied into the first file, and the crop tool was expanded so that 

both halves on separate layers could be placed side by side. (See cropping 

later in Chapter 5.) The two layers were then moved separately with the 

Move tool and rotated slightly so that they were level and could be merged 

as one image using the menu command of Layer ➤ Flatten image.

In this case, I have supplied it to you as a single flattened image and 

have blurred the faces of the people in the photo. In your own projects, 

you would not blur faces if working on a personal historical project unless 

specifically asked to do so by a client, as you would generally want to keep 

the faces clear so that you could research and identify if these were known 

people in your ancestry. I will discuss basic blurring later in Chapter 4 and 

again how to create an overall blur with a mask in Volume 2.

Coming back to the image and examining it more closely with the 

Zoom and Hand tools (Spacebar), you can see that there are several 

identifiable rips and creases; some of the rips also appear to have a slight 

reddish color to them. Refer to Figure 3-7.
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Figure 3-7.  Inspecting crease lines and cracks in the photo print 
using the Zoom and Hand tools

This was due to the image remaining slightly bent under the weight of 

the scanner lid when the scanner scanned the area due to the fact that the 

whole image could not sit on the scanner glass flat. I could have scanned 

this image as a grayscale; however, I wanted to retain the original yellow 

tone of the paper for now.
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Spend a moment identifying the areas of damage as well as any 

scratches or white dots that probably do not fit with the original scene.

The Clone Stamp tool is an ideal candidate, for this image, to start with. 

Select that tool now. Refer to Figure 3-8.

Figure 3-8.  Tools panel, Clone Stamp Tool

To practice with the tool, Alt/Option-click a location next to the rip. 

This is to get a source of pixels for repairing that are not damaged, and 

then just click another location once or twice over the crease or rip that 

you want to cover. Refer to Figure 3-9.
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Figure 3-9.  Finding a clone source and then repairing some of the 
damages with the clone source tool on the grass

For the moment, use Edit ➤ Undo, the History panel, or  

Ctrl/CMD+Z. Currently, what was done could be considered destructive, 

and you may want to make alternations as you cover the rip. Refer to 

Figure 3-10.
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Figure 3-10.  Moving back a few steps using the History panel

After you have undone the last cloning step, go to your Layers panel 

and click the Create a new layer button, and a new layer will appear 

where you will continue to use the Clone Stamp Tool moving forward, in a 

moment. Refer to Figure 3-11.
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Figure 3-11.  Use the Layers panel to create a new Layer and then 
work on the new Layer

Before you do that, let’s review our options in the Options bar panel 

from left to right. Refer to Figure 3-12.

Figure 3-12.  The Clone Stamp Tool Options bar panel
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The first option is the tool presets picker, which is used to store the 

custom setting you may create after you have used this tool for a while so 

that you can reuse them again in other projects. Note that tool presets can 

also be accessed from the Window ➤ Tool Preset panel as mentioned in 

Chapter 2. Refer to Figure 3-13.

Figure 3-13.  Options bar panel Clone Stamp tool presets and related 
tool presets menu settings

You would then see the Brush preset picker. This drop-down menu 

allows you to adjust the brush’s size (1–5000px), hardness (0–100%), and 

angle/roundness. The angle is controlled by moving the preview arrow; 

when horizontal and pointing right, it is at 0°. The angle can be adjusted 

by rotating the arrow around the brush (–180,0,180°). Roundness is 

whether the brush is fully round or elliptical. Use the round handles on 

the preview to move the brush roundness in or out (0–100%). The angle is 
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more apparent when you alter roundness giving a narrow angled brush. By 

default, you should in most cases leave the angle at 0° and the roundness at 

100%. Using the brush preview and search, look for a recently used brush 

or one actually stored in your Brushes panel. Refer to Figure 3-14.

Figure 3-14.  Options bar panel Clone Stamp tool Brush preset 
picker options

Note that you can search through the brushes found in the various 
folders. These brushes are used by other brush tools and are all 
located in the Brushes panel. Refer to Figure 3-15.
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Figure 3-15.  Brushes panel options

Use the lower slider in the Brush preset picker menu when you need 

to enlarge the preview of the brushes. In the Options bar panel, the next 

button, resembling a paint brush on a folder, will allow you to access more 

brush settings in the Brush Settings panel. Refer to Figure 3-16.
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Figure 3-16.  Options bar panel Clone Stamp tool options and toggle 
to Brush Settings panel and menu options

While our focus in this book is not on using all the brush settings, I will 

just point out that you can add more specialized settings to your brush 

via this panel, which includes adjusting shaped dynamics and textures. 

However, in most cases, if you want to alter just the default settings, you 

would be using the main tab “Brush Tip Shape,” which includes the same 

settings as the Brush preset picker of size diameter (1–5000px), angle 

(–180,0,180°), roundness (0–100%), and hardness (0–100%).

However, there are other options to flip the brush on the X (horizontal) 

and Y (vertical). By default, they are left unchecked. You can also alter the 

spacing (1–1000%) which is at a default of 25%. Move the sliders to alter the 

settings and look at the preview. Refer to Figure 3-16.
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If you are interested in settings beyond this book, you may want to 

check out my book Perspective Warps and Distorts with Adobe Tools: 

Volume 1 as well as the following link: https://helpx.adobe.com/

photoshop/using/creating-modifying-brushes.html.

The next button in the Options bar panel resembling a stamp allows 

you to toggle to the Clone Source panel. Refer to Figure 3-17.

Figure 3-17.  Options bar panel Clone Stamp tool option to access the 
Clone Source panel and menu options
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The Clone Source panel allows you to have up to five clone source 

points, each with their own settings. By default, it is set to Source 1, which 

is somewhere in the document, when you Alt/Option-click a location. 

Refer to Figure 3-18.

Figure 3-18.  Clone Source panel options for two sources

However, a clone source can be from other open documents as well 

if you Alt/Option-click in them first. You could set this as Source 2 if 

you select that icon in the panel first. In this example, we are only using 

Source 1.

Some of the options in this panel are for buttons for flipping the clone 

horizontally and vertically. Scale the clone source with linkage to the ratio 

by percentage for width (W) and height (H) (1.0–400.0%). Offsetting the 

clone are (X, Y), in this case, pixels. You can change the angle of the clone 

(–360, 0, 360°); by default, it is set to 0. Reset using the counterclockwise 

arrow button. This is not the same as the angle of brush; in this case, you 

are altering the angle of the inner clone source. Refer to Figure 3-17.
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You can change the Frame Offset and lock the frame. However, leave 

this setting at 0 and unlocked as this is used more for frames as you would 

find in an animation or video file. Refer to Figure 3-17.

You can also show and hide the various overlay settings, such as set its 

opacity (0–100%); by default, it is set to show overlay as Normal, but you 

can set other overlay modes so that you can see the underlying setting as 

you paint. By default, the show overlay checkbox is enabled and is set to 

100% Opacity Normal blending mode, so you can see your cloned source 

pixels accurately as you paint. The Clipped setting is enabled, Auto Hide 

disabled, and Invert disabled. Refer to Figure 3-17.

Returning to the Options bar panel, if you don’t like painting an exact 

clone source and want to blend pixel colors as you stamp, you can also try 

other brush options like changing from Mode: Normal to Multiply. These 

are blend settings also called Effect mode. How these overlaying Blending 

Modes affect the overall blend of the underlying colors of a layer will be 

delved into in Volume 2. However, in this book, keep the tool setting on 

Normal for now so that you can use the clone stamp at the default setting 

without altering from the original colors as you clone. Refer to Figure 3-19.
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Figure 3-19.  Options bar panel Clone Stamp tool blend modes

Next, for Opacity the range is 1–100%; if you want to fade the clone as 

you paint, use the slider to adjust Opacity. Generally, when I need to cover 

an area, I will leave the Opacity at 100%, but feather the edges of my brush 

by setting the hardness down to a lower percentage such as 0% using the 

earlier described setting in the Brush preset picker. However, there will 

be times where you will find, when working with the tool, a lower Opacity 

percentage may create a better blend. Refer to Figure 3-20.
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Figure 3-20.  Options bar panel Clone Stamp tool brush preset, 
Opacity options, Flow options, Angle and Align options

Next to Opacity is the round icon with a pen that can be toggled on or 

off. It is called “Always use Pressure for Opacity; when off, the brush preset 

controls the pressure” by default. I usually leave this setting disabled.

Next is the flow setting which controls the Flow rate (1–100%), which 

you can adjust with its slider. I leave this at the default of 100%.

Next to it is the icon button resembling a spray paint gun called 

“Enable airbrush-style build-up effects.” I leave this button by 

default toggled off. However, experiment with it as it may give a more 

blended effect.

Next, you can set the Brush angle (–180,0,180°) of the brush. This 

option is also found in the Brush preset picker and Brush Settings panel; by 

default, this should be set to 0°. When you set it in one location, it changes 

in the other locations to the same setting. Refer to Figure 3-20.

When Aligned is enabled, you use the same offset for each stroke. 

This is more apparent when you click and Shift-click in different locations 

to create a clone in a straight line or click and then Shift-drag. Refer to 

Figure 3-21.
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Figure 3-21.  Options bar panel Clone Stamp tool Align option and 
aligning the brush

�Working on More Than One Layer in a  
Nondestructive Way

At this point, as we saw earlier, you could start to stamp on your 

background layer with the Clone Stamp and use the options in the Options 

bar panel I have presented so far. However, this can be destructive as you 

are working on the background, and once pixels are altered, they are set, 

unless you use the History panel or Ctrl/CMD+Z right away. To avoid 

this, that is why you created a clear blank layer in the Layers panel. Make 

sure that it is currently selected; in this example, it is Layer 1. Refer to 

Figure 3-22.
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Figure 3-22.  Layers panel working on the new layer with the Clone 
Stamp Tool

While working with the Clone Stamp Tool, you can now focus on the 

Options bar panel and choose to sample using Current & Below. Other 

options would be Current Layer, which is best with single layers but again 

is destructive, or All Layers if you are trying to clone some information 

from a layer above. Refer to Figure 3-23.

Figure 3-23.  Options bar panel Clone Stamp Tool sample and 
pressure options

This would sample from all current visible layers but may sample 

from layers you did not intend to. You can, however, select the next option 

that looks like a black and white circle with a slash “turn on to ignore 

adjustment layers when cloning”; this option by default is off. We will 

look at adjustment layers in more detail in Volume 2. For now, use the 

Sample option of Current & Below as you sample this will prevent you from 

sampling from any additional layers you add above later.
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The final setting that looks like a pen in a target icon is “Always use 

Pressure for Size. When off, Brush Preset controls pressure”; this option 

is by default off and is generally used when working with a stylus. Refer to 

Figure 3-23.

�Putting Your Knowledge into Practice

Now that you know your options for the Clone Stamp Tool, on the selected 

blank layer with your Clone Stamp, select a clone source, Alt/Option-click 

and then begin clicking to cover that affected area with surrounding pixels 

to make the crease or rip disappear.

Learning how to work with this tool is very important as you will 

discover some cloning appears better when you adjust the size and 

hardness of the brush using the sliders in the Brush preset picker as 

you work.

For example, areas of wood or stone may be best with a medium-sized 

brush with a hard edge, but the sky, grass, or areas of the skin or cloth 

may be better with a smaller-sized brush or a hardness of 0% for better 

blending. Refer to Figure 3-24.
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Figure 3-24.  Adjusting the Clone Stamp brush size and covering 
the damage

You also need to spend time and experiment with the Brush Settings 

(Figure 3-16) and Clone Source panels (Figure 3-17) to get the best blend.

Slowly work on one rip at a time; remember to zoom in with the Zoom 

tool or use your Hand tool (Spacebar) as you work to moving about the 

canvas from one rip to the next.

Avoid using the Move tool as you do not want to move your cloned 

areas on the new layer by mistake.

As you work, frequently Alt/Option-click in a new location near the 

rip to get a similar source clone. Use sources from both sides of the rip for 

a better blend. And use your Clone Stamp Tool’s source overlay preview 

as a guide especially when dealing with straight edges that need to line up 

like bricks or edges of buildings so that the joins do not appear wavy or 

crooked.
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As you cover the rip, try not to incorporate another part of a 

different rip.

Rather than dragging the Clone Stamp Tool, try a combination of 

clicking and then frequently changing the clone source location until you 

have covered the rip you want and then move on to the next location.

You can use Edit ➤ Undo or the History panel at any time as you work. 

Refer to Figure 3-25.

Figure 3-25.  Use your History panel when you need to go back a 
few steps

Note, if there is less detail around the rip, such as areas in the grass, a 

large brush might be OK. However, when working on areas of high detail, 

such as on clothing, try a smaller-sized brush as you work on the above 

Layer 1. Refer to Figure 3-26.
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Figure 3-26.  Options bar panel Clone Stamp tool options, adjusting 
the brush size

Once you have completed covering a rip, try turning the new layer in the 

Layers panel off and back on using the visibility eye. Refer to Figure 3-27.

Figure 3-27.  Repairing the long rip in the photo and then using the 
Layer’s visibility to review the correction so far
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In my case, I was able to clone and cover the rip; however, there is 

still some redness I was not able to remove around the boot, and that will 

require a color correction with an Adjustment layer and possibly a layer 

mask to isolate the area. Color adjustments with masks will be looked at in 

more detail in Volume 2. Refer to Figure 3-27.

Also, try lowering and then raising the selected layer’s opacity to 0% 

and then back to 100% using the Layers panel Opacity slider if you need to 

see how you are progressing at this point. Refer to Figure 3-28.

Figure 3-28.  Lower the Layer’s opacity if you need to see the damage 
to review the correction
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Rather than using Edit ➤ Undo all the time as you learn more about 

the healing tools in this chapter, you may want to use the Clone Stamp in 

combination with the Eraser Tool to remove your pixel mistakes, which I 

will discuss in more detail in the section “Other Tools for Restoration” in 

Chapter 4. Refer to Figure 3-29.

Figure 3-29.  Tools panel’s Clone Stamp Tool and Eraser tool

Tip  While working with any brush, you can quickly decrease or 
increase the brush’s size by using the left bracket [ or right bracket ]  
on your keyboard. This makes it easier to change sizes rather than 
having to access the Options bar panel’s Brush preset picker. Refer to 
Figure 3-30.

Figure 3-30.  Decrease or increase your brush size using the 
bracket keys
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You can continue to work on this army image on your own, fixing other 

rips and imperfections with the Clone Stamp tool. Or you can return to 

the file again later in the chapter once you have learned a bit more about 

the other related healing tools, such as the Spot Healing Brush tool, which 

we will look at next, and later the Healing Brush tool. Then see the “Photo 

Project” section at the end of Chapter 5 for more information.

Save (File ➤ Save) your work so far. Refer to file army_practice_
healing_clone_p1_final.psd if you need to see my progress.

At this point, try this Clone Stamp tool on a more colorful image, such 

as a copy of the file garden_clone_stamp.psd or one of your own images 

that you scanned. In this example, while working on a new layer, try 

removing some of the thin wires that appear to block the sky, or try adding 

more flowers to another location in the garden. Refer to Figure 3-31.
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Figure 3-31.  Use the Clone Stamp Tool to remove powerlines or add 
flowers on a new layer

Make sure to save (File ➤ Save) each of your files as you work on them. 

Refer to file garden_clone_stamp_final.psd for reference.
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Note that the Pattern Stamp Tool (S) found with the Clone Stamp is 
not discussed in this book as this is more for adding artistic effects 
to an image. If you are interested in this tool, you can refer to my 
Perspective Warps and Distorts with Adobe Tools: Volume 1 book 
mentioned earlier in this chapter or the following link as it is also 
used by the application Photoshop Elements and has similar options. 
Refer to Figure 3-32: https://helpx.adobe.com/ 
photoshop-elements/using/patterns.html.

Figure 3-32.  The Pattern Stamp Tool is found with the Clone 
Stamp Tool

The next set of tools share some similarities and differences to the 

Clone Stamp; let’s look at them next. Refer to Figure 3-33.

Figure 3-33.  Various healing brush tools
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�Spot Healing Brush Tool (J)
The Spot Healing Brush Tool is often a tool used for cosmetic touch-ups on 

a face or skin, such as various imperfections like acne or scars. However, 

this tool does not have to be used just for the face; it can be for small spots 

of missing information, such as reflections and stains on a damaged image, 

or for removing a time stamp. You can try that out on the file  

deer_spot_healing.psd. Refer to Figure 3-34.

Figure 3-34.  Photo of some deer in the winter woods

In this case, part of the time stamp is in the lower right covering the 

silhouette of a deer in the forest. The time stamp is distracting, and you 

may not even notice that deer in the image. As you did with the Clone 

Stamp Tool, make a duplicate file (Image ➤ Duplicate) to work with.

As with the Clone Stamp Tool, working on a new layer is best, so you do 

not destroy the original artwork. Refer to that tool for more details. Refer to 

Figure 3-35.
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Figure 3-35.  Use the Layers panel to create a new layer

After you select the tool, you can review its options in the Options bar 

panel from left to right. Refer to Figure 3-36.

Figure 3-36.  Options bar panel Spot Healing Brush Tool options

Beside the tool’s preset picker, you will find the Brush option’s drop- 

down menu, which includes, for only round or elliptical brushes, a setting 

for size, hardness, spacing, angle, and roundness, and you can use the 

preview to adjust for angle and roundness manually. Optionally, you can 

also work with a stylus for this tool and set the size based on pen pressure 

or stylus wheel or turn it off. Note that you will only be able to use round or 

elliptical brush heads. Refer to Figure 3-37.
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Figure 3-37.  Options bar panel Spot Healing Brush tool options 
for brushes

When working with this brush, Adobe recommends making the brush 

a bit bigger than the imperfection so that it will cover it when you click. 

For skin or blurry regions of the photo as in the army image, reducing the 

hardness of the brush may be a good idea for better blending and then 

clicking once or twice on several areas. Refer to Figure 3-38.
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Figure 3-38.  Using the brush to heal spots on the army man’s arm. 
Options bar panel Spot Healing Brush tool options

However, for the deer picture, around the time stamp, I will use a brush 

with a hardness of 100%.

The painting mode also allows for various types of color blending as 

you paint over an area, but as a beginner, start with the default mode of 

Normal to test. However, using an option like Replace may preserve some 

details from the original photo, such as film grain and texture. In this 

example, you want to cover and blend parts of the time stamp, so a Normal 

mode setting is best. Refer to Figure 3-39.
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Figure 3-39.  Options bar panel Spot Healing Brush Tool options for 
painting mode

The next area called Type refers to how the brush will handle the 

blend. The options are as follows:

Content-Aware: This is the default setting. Unlike the Clone Stamp 

where you have to Alt/Option-click to get a source to start the Spot Heal 

Brush tool, this setting compares the image content nearby to fill the 

selection with realistic details as well as accounting for shadow and object 

edges. Refer to Figure 3-40.

Figure 3-40.  Options bar panel Spot Healing Brush tool options 
for Type

Create Texture: This allows you to create a texture with the pixels from 

pixels within the selection, but may not be best for restoration and leave a 

grainy effect.
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Proximity Match: This is another good option to test as it uses pixels 

that surround the selection to patch the area. It comes with an extra setting 

called diffusion (1–7) that is set to a default of 5 and appears at the end of 

the Options bar panel. Diffusion creates a pattern-like blur which can vary 

in strength based on the settings you choose. It controls how quickly the 

pasted region adapts to the surrounding image. Select a lower value for 

images with grain or fine details or a higher value for smooth/blurry areas. 

Refer to Figure 3-41.

Figure 3-41.  Options bar panel Spot Healing Brush tool options set 
to Type of Proximity Match

In this case, I left it on the Type option of Content-Aware as this created 

the closest blend to cover the numbers.

When working with this tool, as you did with the Clone Stamp, work on 

a new layer by adding it using the Layers panel. Refer to Figure 3-42.
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Figure 3-42.  Options bar panel Spot Healing Brush tool options and 
working on a New Layer in the Layers panel

Then in the tool’s Options bar panel, enable the Sample All layers to 

get details from your background layer and other visible layers if present. 

In the Options bar, the Brush angle is the same angle set when you set 

the brush options from its menu. The last or second to last icon, which 

looks like a target, is “Always use Pressure for Size. When off, Brush Preset 

controls pressure”; this option is by default off and is generally used when 

working with a stylus. Refer to Figure 3-42.

In this example, rather than clicking a single spot to heal, try dragging 

with your brush over a larger area that you want to heal. When you release 

the brush, that number in the time stamp should be hidden and appear 

with the darker color of the deer’s body. Refer to Figure 3-43.
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Figure 3-43.  Removing the time stamp that is covering the deer

Try this on other areas of the time stamp until all the numbers are 

removed. Sometimes, dragging in smaller sections is best rather than 

around the whole number. Use Edit ➤ Undo or Ctrl/CMD+Z if your first 

attempt does not work as you expected. Turn the eye on Layer 1 in the 

Layers panel off and on to review your results. Then save your file.

You can compare the results to my deer_spot_healing_final.psd.

�Remove Tool (J)
The Remove tool is a relatively new tool to the healing tool collection, and, 

as its name says, it is meant to remove a selection from the image. This 

could be anything, such as an unwanted object, plant, or even an animal 

or person, and it is replaced with other surrounding details to make it 
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appear that the object was never there. We will use the file person_on_
the_beach_remove.psd. Make sure to create a duplicate of the file (Image 

➤ Duplicate). Refer to Figure 3-44.

Figure 3-44.  Woman looking for rocks at the beach

As with the Clone Stamp Tool, working on a new layer in the Layers 

panel is best, so you do not destroy the original artwork. Refer to 

Figure 3-45.
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Figure 3-45.  Working on a new Layer in the Layers panel

Make sure to zoom in to the object you want to remove. Use the key 

commands of Ctrl/CMD++ and Ctrl/CMD+- as you work, so you do not 

lose your overlay while painting it.

Before you use the tool, review its options in the Options bar panel 

from left to right. Refer to Figure 3-46.

Figure 3-46.  Options bar panel Remove Tool options

Beside the tool’s preset picker is the add to brushed area (+) and 

subtract from brushed area (-) icons. These are used for painting a 

selection overlay when you have the option “Remove after each stroke” 

disabled. Add to brush area is by default on. Refer to Figure 3-47.

Chapter 3  Tools for Photo Restoration: Part 1



156

Figure 3-47.  Painting a magenta overlay and removing parts of the 
overlay with the Remove tool

After making a brush stroke, the (-) button can be used to erase part 

of the magenta overlay selection. Now brush again to remove some of the 

overlay. As you work, switch between the (+) and (-) buttons to refine the 

overlay. However, leaving a bit of overlay into the water is a good idea, and 

with this tool you do not have to be exact with your edge, but you should 

fill in your entire overlay area, not leaving any gaps on the body. You can 

also adjust the size of the brush by typing in the number (1–5000) or using 

the slider. Refer to Figure 3-48.
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Figure 3-48.  Options bar panel Remove tool brush tool options

Next is the button “Always use Pressure for Size”; this option is by 

default off and is generally used when working with a stylus.

The gear icon has a pop-up menu that allows you to change the overlay 

setting of color (magenta) and opacity (25%). The overlay helps you to 

refine your selection area. Refer to Figure 3-49.

Figure 3-49.  Options bar panel Remove tool options for overlay and 
stroke settings

As mentioned, because you are working on a new blank layer above 

the background, make sure to enable the “Sample all layers” checkbox. 

Rather than build up an overlay area, you can enable “Remove after each 

stroke” when you want to remove the area overlay after a single stroke. 

However, for this example, leave that checkbox disabled. Lastly, on the far 

right, you can reset your settings using the counterclockwise arrow icon to 

reset all strokes or commit your overlay settings using the check (Commit) 

button. Refer to Figure 3-49 and Figure 3-50.
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Figure 3-50.  Completed overlay and removal of the woman on 
the beach
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This example was fairly easy to work with, and the selection blended in 

very nicely to the surrounding landscape, and the person is gone. In your 

file, turn the eye on Layer 1 off and on to see the difference and then make 

sure to save your work (File ➤ Save). Refer to file person_on_the_beach_
remove_final.psd for reference.

You can see how easy it is to remove the person from the surrounding 

content. However, keep in mind that for more complicated backgrounds, you 

may need to do some additional clone stamping or use the Remove tool again 

if the new area does not quite turn out as you envisioned, as in practicing 

with the file example person_2_remove.psd. Remember as you remove the 

person, remove parts of the man’s shadow as well. Refer to Figure 3-51.
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Figure 3-51.  Removal, using the Remove tool, of the man from the 
historical site
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Try this out as well on an object in the tulip_remove.psd, but again, 

once complete, observe what is replicated during the overlay and decide if 

you need to use another healing tool to complete the transformation such 

as aligning the rows of flowers. Refer to Figure 3-52.

Figure 3-52.  Removal of the unwanted structure from the Tulip field 
after creating an overlay

Save your work (File ➤ Save) at this point, and you can review the 

mentioned files person_2_remove_final.psd and tulip_remove_
final.psd.

In Chapter 8, you can try similar results with the Content-Aware Fill 

workspace.
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�Healing Brush Tool (J)
The Healing Brush Tool shares similarities with the Spot Healing Brush 

Tool and the Clone Stamp Tool and can also access the Clone Source 

panel. You can refer to those tools for certain details. The Healing Brush 

generally works in a larger area like the Clone Stamp and requires an Alt/

Option-click on a sample spot.

While you can use the Healing Brush Tool on the skin or clothing as in the 

army image, it can also be used to heal other materials. Refer to Figure 3-53.

Figure 3-53.  Working with the Healing Brush Tool to remove crease 
lines from the army man’s stocking and the grass
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As with the Clone Stamp Tool, working on a new layer is best, so you 

do not destroy the original artwork. Its purpose is to blend and match the 

texture, lighting, shading, and transparency of surrounding sampled pixels 

so that they will blend with the area you are trying to repair.

Let’s try this tool with the big_room_healing_brush.psd file and make 

a duplicate (Image ➤ Duplicate) of the file to work on. In this example, we 

want to fix the glare on the floor so that it is not quite so visible. Refer to 

Figure 3-54.

Figure 3-54.  Use the Healing Brush tool to lessen reflections on 
the floor
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Once you select the tool, you can review its options in the Options bar 

panel from left to right. Refer to Figure 3-55.

Figure 3-55.  Options bar panel Healing Brush tool options

Next to the tool’s preset picker is the Brush Options menu where you 

can set the brush’s size, hardness, spacing, angle, and roundness using 

either the text boxes, sliders, or brush preview; refer to the Spot Healing 

Brush tool for more information, but note that it can only be used for 

round or elliptical brushes. Refer to Figure 3-56.

Figure 3-56.  Options bar panel Healing Brush Tool options for brush 
presets and the Clone Source panel

Beside the menu is the Clone Source panel toggle button; refer to the 

Clone Source panel for more information on how to use this.
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Painting mode by default should be set to Normal or Replace, but you 

can choose other options for more artistic effects. Refer to the Spot Healing 

Brush tool for more information. For this project, keep the Mode: Normal 

option. Refer to Figure 3-57.

Figure 3-57.  Options bar panel Healing Brush tool painting 
mode options

When doing a photo restoration project, I recommend working with 

the Source set to Sampled and review the options and continue to set the 

additional options on the right. Refer to Figure 3-58.

Figure 3-58.  Options bar panel Healing Brush tool Source options of 
Sampled or Pattern
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Note  If the Source is Pattern, then you will be working with patterns 
that are found originally from the Patterns panel, which we will not be 
going into much detail in this book. I will mention Patterns in regard 
to Fill layers in Volume 2. Keep the Source on Sampled as you work in 
this chapter. Refer to Figure 3-58.

Aligned as with the Clone Stamp tool is good to be enabled when you 

sample the same offset for each stroke. In this example, I kept Aligned 

disabled. If you have used older versions of this tool from 2014 or earlier 

and prefer those settings, you can enable the “Use Legacy” checkbox, but 

this will disable the diffusion settings on the far right which you do not 

want to do in this example. Refer to Figure 3-59.

Figure 3-59.  Options bar panel Healing Brush tool options for 
alignment, legacy, sample options, angle, pressure, and diffusion

As with the Clone Stamp tool, work on a new layer above the 

background and change the sample setting to “Current & Below”; the other 

settings of Current Layer and All Layers are also available in the list. Beside 

the list, you can click the button “Turn on to ignore adjustment layers 

when healing” if required and if they are present. We will look at these 

kinds of layers in Volume 2. Refer to Figure 3-60.
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Figure 3-60.  Options bar panel Healing Brush tool options setting 
when working on a New Layer in the Layers panel

The Brush angle (–180,0, 180°) is the same angle set when you set the 

brush options. The second to last icon, “Always use Pressure for Size. When 

off, Brush Preset controls pressure,” is by default off and is generally used 

when working with a stylus. The diffusion option (1–7) is set to a default of 

5 and is the same as the Spot Healing Brush. Refer to Figure 3-60.

One tip to remember if working on a spot or reflection is to use a  

brush larger than the area you want to heal. However, this is a narrow 

room, so you can stamp or drag the brush along as required. In this case, 

I Alt/Option-clicked a source area on the floor. I started with a brush size 

of 51px and a hardness of 100% and then clicked and dragged around the 

edges of the reflection, gradually moving inward. Refer to Figure 3-61.
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Figure 3-61.  Using the Healing Brush tool will create a blurred heal 
covering

What you may notice with this brush, even though it has a hard edge, 

is that it blurs the edges of the stamp, and you need to Alt/Option-click to 

create a new clone source as you work on your next click. To keep the wood 

grain, I moved in an up or down direction to keep an accurate source. 

The floor in this example appears rather blurry and not crisp. Refer to 

Figure 3-62.
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Figure 3-62.  Move in an up or down motion to create a more 
accurate blur healing with the brush

Also, you do want to make sure the wood does not have noticeable 

repeating areas of pattern. In this example, that is OK as I do not intend 

to eliminate the outside light reflection entirely, only soften the effect and 

make it appear like some of the wood is still showing through. If you do not 

like how the effect is turning out at any time, just drag the layer to the trash 

can icon in the Layers panel and then create a new layer and start again. 

Refer to Figure 3-63.
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Figure 3-63.  In the Layers panel, use the Delete Layer button if a 
layer is not healing as it should and then create a new layer

Your healing will not look exactly like mine, but that is OK. Once you 

are done, the next step would be to then select your new layer and lower 

the opacity slightly to about 68%. Refer to Figure 3-64.
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Figure 3-64.  The new layer with its opacity lowered makes the glare 
of the reflection less intense, and the focus is more on the room than 
just the floor

You can still see some of the reflection from the window, but now it 

does not overwhelm the image, and the room overall becomes the focus 

rather than just the floor.
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In your own projects, try this technique on images where you want to 

soften the glare in an image. Make sure to save (File ➤ Save) as you work 

and compare to the file big_room_healing_brush_final.psd.

We will look at some alternative and similar options in Volume 2 when 

we explore pattern fill layers and then camera raw filter.

�Patch Tool (J)
The Patch tool can be used to patch up a section of an image with another 

area of the image or a pattern. This kind of tool does not use brushes but 

rather selections. Similar to the healing brush, it tries to match the pixels, 

texture, lighting, and shading from the source. Some settings for the Patch 

tool rely on the current layer, so working on a duplicate of that layer is best 

when working with this tool. To create a duplicate of the layer, try dragging 

your background layer over the Create new layer button in the Layers 

panel. Refer to Figure 3-65.

Figure 3-65.  Use the Layers panel to create a duplicate layer of the 
background layer
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Let’s work with the file sky_patch_tool.psd. Make a duplicate file 

(Image ➤ Duplicate) to work with. And then make a duplicate of your 

background layer right away. Refer to Figure 3-66.

Figure 3-66.  A scene of harbor life

Then select the Patch tool. You can review its option in the Options bar 

panel from left to right, which can vary depending on the Patch options 

chosen. Refer to Figure 3-67.

Figure 3-67.  Options bar panel Patch tool options
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After the tool’s preset picker, you can work with small selections 

over select area of an image to cover things such as time stamps or 

imperfections or even a bird in the sky.

Use your tool to drag and draw out a selection with the setting of new 

selection. Refer to Figure 3-68.

Figure 3-68.  Patch tool dragging out a new selection

If you need to add to the selection while active, select the next button 

“Add to selection” and then draw over the current selection, or while the 

current selection is active, you can choose another button like subtract or 

intersect by choosing one of those options. Refer to Figure 3-69.
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Figure 3-69.  Options bar panel Patch tool options for adding, 
subtracting, and intersecting a selection

Use Edit ➤ Undo or Ctrl/CMD+Z if you need to go back a step in your 

selections. Set the button back to new selection when you are done. Refer 

to Figure 3-67.

While the selection is active, there are two methods of patching:

Normal: This uses either the Source or Destination to patch. You can 

also enable transparency when blending the patch in the sky or gradient 

background with transparent areas or leave disabled to keep the full 

sampled selection. Refer to Figure 3-70.

Figure 3-70.  Options bar panel Patch tool options set to Normal
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Or alternatively, use a pattern that you select from the drop-down list 

for filling the selected area. In this example, do not use this option.

While the selection is set to the option of “Source,” drag the selection 

around the bird to another area of the image you want to use as the new 

source. This will cause the bird to disappear and the original area to be 

filled with sky that has no pattern. Refer to Figure 3-71.

Figure 3-71.  Patch tool options set to Normal and Source and 
selection dragged

Or while the selection is active, use the option of Destination and drag 

the selection; in this case, you create a copy of the bird and place it in a 

new location. All selections can be made prior to your patch choice. Refer 

to Figure 3-72.
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Figure 3-72.  Patch tool options set to Normal and Destination and 
selection dragged

As with the Healing Brush, there is a diffusion option (1–7) set to a 

default of 5. This causes the blend to occur based on the surrounding 

background and the values that you choose.

The other patch option is Content-Aware. This patch option controls 

the structure of the selected pixels and adjusts how strictly the source 

structure is preserved (1–7); the default is 4. The color (0–10) adjusts how 

much the source color can be modified or blended; the default is 0, but 

10 is the highest setting. With this patch option, rather than creating a 

duplicate layer, you can work on a separate new blank layer (Layer 1) when 

you choose the option Sample all layers. Refer to Figure 3-73.
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Figure 3-73.  Options bar panel Patch tool options set to a patch of 
Content-Aware and set to a new layer

In this case, the bird is again covered when the selection is dragged but 

now on its own layer, which you can turn the visibility eye on and off. Refer 

to Figure 3-74.

Figure 3-74.  Options bar panel Patch tool options with  
Content-Aware setting; the selection is dragged to hide the bird

Select Edit ➤ Undo if you need to revert a step as you work.

Use Select ➤ Deselect (Ctrl/CMD+D) when you need to remove your 

selection area.
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Note for the cap appearing in the lower right-hand corner, you could 

try the Content-Aware patch after you create a selection, or I think in this 

case use the Remove tool you looked at earlier. Create another new layer if 

you want to test this. Refer to Figure 3-75.

Figure 3-75.  Removing the man’s cap from the scene on another new 
layer using the Remove tool
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Then save the document (File ➤ Save). You can review my  

sky_patch_tool_final.psd document if you want to compare.

�Content-Aware Move Tool (J)
Similar to the Patch tool, the Content-Aware Move tool also allows you to 

move content via a selection from one location to another, which might 

include a tree or part of a person or in this case a canoe with people in it.

Let’s look at the two files snow_content-aware_tool.psd and  

canoe_content-aware_tool.psd. Refer to Figure 3-76.

Figure 3-76.  Images of people playing in the snow and canoeing on 
the lake
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Make a duplicate (Image ➤ Duplicate) of both files.

In this case, you can work on a blank layer when using this tool. Refer 

to Figure 3-77.

Figure 3-77.  Work on a new blank layer in the Layers panel

You can review its option in the Options bar panel from left to right. 

Refer to Figure 3-78.

Figure 3-78.  Options bar panel Content-Aware Move Tool options
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After the tool’s preset picker are the same selection options as the 

Patch Tool. These can be used when you have created a new selection 

where you can then drag and add another selection, subtract, or intersect.

By default, the remix mode is set to “Move” so that you can move that 

selection. Refer to Figure 3-79.

Figure 3-79.  Options bar panel Content-Aware Move Tool options set 
to mode of move 

You can also use the bounding box handles surrounding the selection 

to scale and rotate the selection. Refer to Figure 3-80.
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Figure 3-80.  Use the Content-Aware Move tool bounding box 
handles to adjust your selection and click the check to confirm

You can click the cancel button if you need to revert back or click the 

commit check. Refer to Figure 3-80.

Once the commit check is clicked, the selection of the image will be 

on the new layer, and it will cover the original with filler pixels. However, 

in some instance, the blending may not be accurate depending on the 

complexity of the file. Refer to Figure 3-81.
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Figure 3-81.  The original person is covered and moved to a new 
location on the new layer

However, if it is set to Extend, it still can move, scale, or rotate and 

then commit the moved copy of the selection to a new location. Refer to 

Figure 3-82.

Figure 3-82.  Options bar panel Content-Aware Move Tool options set 
to Extend to create a copy of the person and not cover the original
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You might find these options for this tool to do a more accurate 

blending on the new layer than the Patch tool. But make sure to 

experiment between the two modes of Move and Extend to determine 

which works best for your project. In this case, I used Move. Refer to 

Figure 3-79.

Like the Patch tool, you can set the range for the Structure (1–7); I 

used a setting of 4. Set the color (0–10); I left it on 0. Choose “Sample 

all layers” when the checkbox is enabled and work on a new layer. The 

last setting “Transform on drop,” when enabled, allows for the scaling, 

rotation, and transformation of the selection when moved. If disabled, the 

transformation is committed directly after the selection is moved, and you 

cannot scale or rotate. Refer to Figure 3-82.

Use Select ➤ Deselect or Ctrl/CMD+D when you want to remove the 

selection border. 

While it may be easy to move a single individual in a group on a layer, 

moving a canoe in the water can be more difficult as you are dealing with 

ripples and reflections in the water that need to accurately blend as well.

Here, you can see after I created my selection, I used the mode of Move 

as well and commited the change using the check. Refer to Figure 3-83.
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Figure 3-83.  People on the lake are moved over using the  
Content-Aware Move tool

Use Select ➤ Deselect or Ctrl/CMD+D when you want to remove the 

selection marquee.

Note while using this tool for more accurate cleanup, as you will 

discover when you advance in the book, you can afterward use the 

Remove tool and layer mask on a separate layer. Notice that I turned off the 

visibility of Layer 1 as I worked so that I did not sample pixels from Layer 1 

by mistake. Refer to Figure 3-84.

Chapter 3  Tools for Photo Restoration: Part 1



187

Figure 3-84.  To make the picture look more accurate and for the 
Content-Aware selection to blend, you may need to use the Remove 
tool on a new layer to cover the original canoe and its occupants
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As well as on Layer 1, use the Eraser tool on a layer mask to remove 

areas of the Content-Aware selection as required. Refer to Figure 3-85.

Figure 3-85.  Using the Layers panel to create other layers for the use 
of the Clone Stamp Tool or use the Eraser tool to remove extra details 
the Content-Aware Tool and Remove Tool created or alternatively use 
layer masks for a more accurate blend of added pixels

You may be left with patchy or ragged edges as this is a more complex 

selection that may also require a bit of feathering with the Clone Stamp 

tool as well. Here, you can see that as the patching and healing become 

complex, more than one tool is required.
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Tip: If while working with your selection you want to scale or feather 

it, try using the contextual task bar to reach these options quickly. We will 

look at selections as well as layer masks more in Chapters 6–8. Refer to 

Figure 3-86.

Figure 3-86.  Refer to your contextual task bar when you need 
additional selection options

Make sure to save your document (File ➤ Save) at this point, and you 

can refer to my files snow_content-aware_tool_final.psd and  

canoe_content-aware_tool_final.psd if you need to compare, and we  

will refer to them again in Chapter 8.

We will look at another related workspace called Content-Aware Fill 

in Chapter 8. For tips on how to organize and rename layers, refer to 

Chapter 5.

�Red Eye Tool (J)
The Red Eye tool only has one purpose: to remove red eye from photos. 

This was quite common before digital cameras added this reduction 

option to their software as there were a lot of red pupils due to the 

reflection of the flash in dark rooms when the iris is extended. Thankfully, 
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there are digital cameras now that operate in low-light conditions. Red 

Eye will work for correcting images where a human or pet has red pupils. 

Some cats with blue eyes have red eye reflection and others don’t. Refer to 

Figure 3-87.

Figure 3-87.  Example of cats with red and golden eyes

A lot of cats and dogs also have golden, green, or blue eye shine which 

this tool cannot correct. In that case, you would have to look to the Camera 

Raw filter, which we will look at in Volume 2, to correct pet eye. 

Luckily, here is a cat that exhibits red eye that you can practice with the 

file cat_red_eye.psd and make a duplicate copy (Image ➤ Duplicate) of 

the file. Refer to Figure 3-88.
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Figure 3-88.  Cat with red eye; in the Layers panel, a duplicate of the 
layer was created

In this case, you would want to work on a duplicate layer of the 

background or a selection of the background layer on a new layer.

Be careful to only click once in the red eye area or you will give your 

subject a black eye. You can also try dragging a marquee around the eye. 

Use Edit ➤ Undo or Ctrl/CMD+Z or the History panel if you need to undo 

your last step. Refer to Figure 3-89.

Chapter 3  Tools for Photo Restoration: Part 1



192

Figure 3-89.  Cat eyes with the Red Eye Tool applied

You can review its option in the Options bar panel from left to right. 

Refer to Figure 3-90.

Figure 3-90.  Options bar panel Red Eye Tool options

After the tool’s preset picker, you can set the pupil size, which is at a 

default of 50%, and the darken amount, which is at a default of 50%. This 

can remove the red quite a bit.

In the case of pets, the pupil area, however, may not be as dark as 

you want as they have quite a bit of reflection in the eye, which you can 

vary with the Red Eye Tool settings. Or try painting on a new layer using 

the Brush Tool (see the “Brush Tool (B)” section in Chapter 4) with a 

foreground of black and then lowering that layer’s opacity to about 87%. 

Refer to Figure 3-91.
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Figure 3-91.  Use the Brush Tool and a lower opacity when you need 
to make the pet’s eyes darker

More details on these mentioned tools can be found on the 

following pages:

https://helpx.adobe.com/photoshop/using/retouching-

repairing-images.html

https://helpx.adobe.com/photoshop/using/content-aware-patch-

move.html

Save (File ➤ Save) any open projects you have so far and review the file 

labeled with cat_red_eye_final.psd if you need to compare.
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�Summary
In this chapter, we looked at a number of tools from the Tools panel that 

can be used to improve your digital images and heal areas. Some are better 

for one kind of restoration task than another. Working on separate layers 

also helps you to heal your images in a nondestructive way. In the next 

chapter, we will be looking at more tools for digital repair that you may 

want to use in conjunction with the tools in this chapter.
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CHAPTER 4

Tools for Photo 
Restoration: Part 2
Continuing from the previous chapter, I will explain to you some of the 

other commonly used tools in the Tools panel I like to use for photo 

restoration or “healing” the damage as well as some that can enhance your 

work or correct minor spot damage. You may not use all these for every 

project. In this chapter as well as the following chapter, we will be using the 

Layers panel and try to work in the least destructive way possible so that 

you can go back at any time and correct your errors. You will be able to do 

that if you make sure that, as you saw in Chapter 2, you save a duplicate of 

your scan as a .psd document.

Note this chapter does contain projects found in the Volume 1 
Chapter 4 folder. Some tools mentioned in this chapter have also 
been mentioned in my previous books, Accurate Layer Selections 
Using Photoshop’s Selection Tools and Perspective Warps and Distorts 
with Adobe Tools: Volume 1, but with new information presented as 
it relates to photographic images. As you work on each project in 
this chapter, make sure to create a duplicate (Image ➤ Duplicate), 
as mentioned in Chapter 2, so that you do not override the original 
artwork, and click OK to the message in the dialog box. Refer to 
Figure 4-1.

https://doi.org/10.1007/979-8-8688-0450-2_4
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Figure 4-1.  Duplicate Image dialog box

Remember, as you work, to use the Move, Zoom, and Hand tools as 

well as the related key commands that were mentioned in Chapter 2. As 

well, use your History panel or Edit ➤ Undo (Ctrl/CMD+Z) if you make a 

mistake and need to revert a few steps. Refer to Figure 4-2.

Figure 4-2.  Move, Zoom, and Hand Tools and History panel

Tip  When you save (File ➤ Save) your files later as a suggestion, 
you can also add your initials to the name so that you do not override 
the original file, for example, practice_file_JH.psd.
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�Other Tools for Restoration
So far, we have seen the importance of working on multiple layers while 

working on a project so as not to destroy the original artwork when using 

the healing tools. However, there are a few other tools you may want to 

consider when working on your image in combination.

Tip  If you need to quickly return to the default setting of a tool as 
you work, you can right-click the tool preset and choose Reset Tool. 
Refer to Figure 4-3.

Figure 4-3.  Any tool options can be reset if you right-click the tool’s 
preset in the Options bar panel

�Eraser Tool (E)
The Eraser tool is one of the most essential and useful tools that you will 

use, when working on your restoration project on separate layers, to 

remove the pixels and patches you created to cover an area. Sometimes, 

too much healing is done, as you saw with the Patch and Content-Aware 

tools, and so you need to be able to remove some of the pixels covering the 

layer to return partially to the original state.

As well, you can match your brush size and hardness if you need to 

have a similar reduction to an area after you have painted with one of the 

healing brushes. Many of the settings you will find similar to the Clone 

Stamp Tool, but I will just point out the basic differences.
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Select that tool now and open one of the previous files, from Chapter 3, 

where you think you may want to erase some of the healing. For example, 

the area surrounding the girl in the snow that you worked on earlier with 

the Content-Aware Move Tool and moved over to the right. There is too 

much of the original image around her so she did not blend into the area 

as well as she should have. Open the file snow_content-aware_tool_erase.
psd in this chapter’s folder to practice. Refer to Figure 4-4.

Figure 4-4.  Working with the Eraser Tool to remove areas 
surrounding the person
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Let’s look at the tool’s Options bar panel from left to right. Refer to 

Figure 4-5.

Figure 4-5.  Options bar panel Eraser Tool options

After the tool’s preset picker, as with the Clone Stamp Tool, you will 

find the Brush preset picker pop-up menu. Here, you can access the 

brush size (1–5000px) and hardness (0–100%) and adjust the angle and 

roundness with the preview as well as search for an ideal brush that you 

recently used or a new brush from the Brushes panel. Refer to Figure 4-6.

Chapter 4  Tools for Photo Restoration: Part 2



200

Figure 4-6.  Options bar panel Eraser Tool options Brush preset 
picker drop-down menu
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While in the Brush preset picker, use the lower slider to increase or 

decrease the preview size of a particular brush. The next icon button lets 

you access the Brush Settings panel. Refer to Figure 4-7.

Figure 4-7.  Brush Settings panel
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This is a common panel to the Clone Stamp Tool and most brush tools 

including the Eraser. Here, you can create some more custom brushes. 

This is more of an advanced topic which I will not go into detail in this 

book. I mentioned the link earlier in the Clone Stamp Tool (S) and Clone 

Source Panel section of Chapter 3. Generally, as a beginner, while doing 

your photo restoration, you will be using either a hard round or soft round 

brush on a new separate layer (Layer 1) as you work over the background 

to erase parts of the healing. However, you can use the Brush Tip Shape tab 

in the Brush Settings panel if you need to have the same settings as with 

the Clone Stamp Tool.

Returning to the tool’s Options bar panel, the next option is Eraser’s 

Erasing Mode; there are three options: Brush, Pencil, and Block. Refer to 

Figure 4-8.

Figure 4-8.  Options bar panel Eraser Tool options for mode

Brush is the default setting that is used most often for erasing, if you 

want to match your setting to another brush tool while erasing. The edge 

can have varying degrees of hardness. Refer to Figure 4-9.
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Figure 4-9.  Working with the Eraser Tool mode brush with a soft or 
hard brush

Pencil creates a thin or wide erase line with very hard pixilated edges. 

You cannot reduce the level of hardness. You could use this in conjunction 

with the Pencil tool; see that section for more details later in the chapter. 

Refer to Figure 4-10.
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Figure 4-10.  Working with Eraser Tool mode of Pencil and Block

Block allows you to erase with a square block shape; this is good when 

you need to create a straight edge erase around photos. You can zoom 

in Ctrl/CMD++ (plus key) and then use the block erase mode and then 

Shift-drag along a border to create a straight edge at 90° degrees vertical or 

horizontal edge. Refer to Figure 4-10.

For now, return to Brush mode as I find this the best setting to use in 

most situations for erasing and blending.

Another setting for the Eraser tool is Opacity (1–100%), which you can 

change with the pop-up slider; the default is 100% or full erase. The next 

option in the Options bar panel is the same as the Clone Stamp Tool, you 

have the option to set the next icon which resembles a circle and pen that 

can be toggled on or off is “Always use Pressure for Opacity, when off the 

brush preset controls the pressure”; by default, I usually leave this setting 

disabled. Refer to Figure 4-11.

Chapter 4  Tools for Photo Restoration: Part 2



205

Figure 4-11.  Options bar panel Eraser Tool options for setting 
opacity and pressure, flow, and airbrush style

Next is the flow setting which controls the flow rate (1–100%) for the 

stroke. I leave this on the default of 100%. Another setting icon (spray 

paint gun) is “Enable airbrush-style build-up effects”; I leave this button 

disabled. Refer to Figure 4-11.

Then set the Smoothing rate (0–100%) for stroke; by default, it is 0% but 

you can use higher values to reduce the shakiness of the brush stroke. Note 

that if you find your smoothing options to be disabled, check your Brush 

Settings panel to make sure that it is enabled. Refer to Figure 4-12.
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Figure 4-12.  Options bar panel Eraser Tool options for setting 
smoothing and angle and smoothing option found in the Brush 
Settings panel

When smoothing is higher than 0%, other smoothing options can be 

located under the gear icon, such as Pulled String Mode, Stroke Catch-up, 

Catch-up on Stroke End, and Adjust for Zoom. Refer to Figure 4-13 to see 

which should be currently enabled.
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Figure 4-13.  Options bar panel Eraser Tool smoothing options are 
accessible for setting smoothing when over 0%

The Brush angle setting (–180,0,180°) is the same setting as the one 

found in the Brush preset picker or Brush Settings panel; by default, this 

should be set to 0°. Refer to Figure 4-13.

The Erase to History checkbox, when enabled, works with the History 

panel and will erase areas from a designated history state; by default, it is 

disabled. Refer to Figure 4-14.

Chapter 4  Tools for Photo Restoration: Part 2



208

Figure 4-14.  Options bar panel Eraser Tool options for setting Erase 
to History with the History panel

Like the Clone Stamp tool, you can toggle the icon button “Always use 

Pressure for Size. When off, Brush Preset controls pressure.” This option is 

by default off and is generally used when working with a stylus.

The last icon button, which looks like a butterfly and is not relevant to 

this book, is Symmetry Paint, which is more for art purposes rather than 

repair. If this topic is of interest to you, you can later check that out in my 

books that I mentioned in this chapter. Refer to Figure 4-14.

Besides being able to erase on Layers, you can also erase on Layer 

Masks, for hiding and revealing areas of a layer, and we’ll see examples of 

this in Chapter 8. Refer to Figure 4-15.
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Figure 4-15.  You can use the Eraser tool with a Layer mask in the 
Layers panel to control what you erase

As additional practice, this time work with your copy of the file  

canoe_content-aware tool_erase.psd or your own file as seen from 

Chapter 3. With the Eraser tool, try to remove any areas that were created 

using the Content-Aware tool that you do not need. Since you are not 

working with Layer masks until Chapter 8, remember to use Ctrl/CMD+Z 

or use the History panel as you work with the eraser if you need to return 

back a step. You can look at my files snow_content-aware_tool_erase_
final.psd and canoe_content-aware tool_erase_final.psd for reference. 

Refer to Figure 3-85.
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Note that there are two other Eraser tools found with our main 

Eraser Tool. They are the Background Eraser Tool and Magic Eraser 

Tool. They can also be used to remove areas, but in a destructive way 

from a background or selected areas. For this book, I consider these 

more advanced tools which would not be regularly used for most photo 

restoration projects. However, if you would like to explore these further 

later on your own, you can check out my book Accurate Layer Selections 

Using Photoshop’s Selection tools or the following link for more details on if 

you should use them in a project. Refer to Figure 4-16.

Figure 4-16.  The Eraser Tool comes with two other erasers, 
Background Eraser and Magic Eraser tool

https://helpx.adobe.com/photoshop/using/erasing-parts-

image.html

Should you use these tools, remember to work with them on a 

duplicate layer.

�Brush Tool (B)
While I do not use this tool directly on background layers while doing 

photo restoration, you can use a small brush for filling small areas with 

solid color and optionally reduce the opacity of the overlaying layer. You 

saw earlier in Chapter 3, with the Red Eye tool, how you could make 

the eyes black and dark. However, using a very small brush is also great 

for filling in tiny broken gaps; this might include where the edge of a 
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person or building has disappeared in a black and white or color image 

due to overexposure. You can see an example of that if you return to the 

garden_clone_stamp_final.psd example from Chapter 3 as well as in this 

black and white picture of a castle (castle.psd) in this chapter. Refer to 

Figure 4-17.

Figure 4-17.  The roofs and parts of building disappear into the 
almost white sky

Another similar tool you can use in this case is the Pencil tool which 

will give you a thin crisp edge, which we will look at later. For now, let’s 

look at the Brush tool’s Options bar panel from left to right. Refer to 

Figure 4-18.
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Figure 4-18.  Options bar panel Brush Tool options for setting

After the tool’s preset picker, you will find many of the options similar 

to either the Clone Stamp Tool or Eraser Tool, and you can refer to those 

tools if you want more details on the Brush preset picker for adjusting such 

things as size and hardness. Refer to Figure 4-19.

Figure 4-19.  Options bar panel Brush Tool options for setting Brush 
preset picker
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Next, you would click the brush folder icon to access the Brush Settings 

Panel as with the other brushes just focus on the Brush Tip Shape tab and 

keep the Option of smoothing enabled. Refer to Figure 4-20.

Figure 4-20.  Options bar panel Brush Tool options’ access to the 
Brush Settings panel
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Painting mode should by default set to Normal. Using other options 

will allow different color blend effects, depending on the type of 

foreground color you enter in the Tools panel color picker and then paint 

over your various brush strokes. In this case, the D key was pressed to use 

the default color of black. Remain in the Blending mode of Normal. Refer 

to Figure 4-21.
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Figure 4-21.  Options bar panel Brush Tool options for painting 
mode; the current foreground color is previewed in the Tools panel 
and accessed when you double-click to enter the color picker
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In the Options bar panel, Opacity (1–100%) by default is 100%. The 

next icon is “Always use Pressure for Opacity; when off, the brush preset 

controls the pressure”; in this example, it is disabled. Flow rate (1–100%) is 

set to 100%. The next icon is “Enable airbrush-style build-up effects”; it is 

disabled in this example. Refer to Figure 4-22.

Figure 4-22.  Options bar panel Brush Tool options for setting 
Opacity and Flow

Smoothing is set to a default of 10%. The gear icon, like the Eraser tool, 

has additional smoothing option. See Eraser tool and its link for more 

details. The Brush Angle setting (–180,0,180°) is the same setting as the one 

found in the Brush preset picker or Brush Settings panel; by default, this 

should be set to 0°. Refer to Figure 4-23.

Figure 4-23.  Options bar panel Brush Tool options for setting 
Smoothing options, angle, pressure, and symmetry paint

Like the Clone Stamp tool, you can click the icon “Always use Pressure 

for Size. When off, Brush Preset controls pressure.” This option is by default 

off and is generally used when working with a stylus.

The last icon button which looks like a butterfly (symmetry paint) is 

not relevant to this book and is more for art purposes rather than repair. 

If this topic is of interest to you, you can check this out in my earlier 

mentioned books; see Eraser tool for more details. Refer to Figure 4-23.
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For practice, now use the file garden_clone_stamp_brush.psd 

example. On a new Layer 2, use a thin black line of the brush size of 2px 

and a hardness of 100% so that the edge of barn is easier to see in the 

image against the pale blue sky. Zoom in with the Zoom tool if you need 

to see the area up close. Clicking at one point with the brush tool and 

then Shift-clicking at the end point allows for a straight line. Refer to 

Figures 4-24 and 4-25.

Figure 4-24.  Options bar panel Brush Tool options for setting Brush 
preset picker and then clicking to create a line
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Figure 4-25.  Working on a new layer allows you to lower the opacity 
so that you can edit the new line separately from the other layers

The line in this case may appear too dark, so lower the layer’s opacity 

to about 23% so that the line is still visible but blends in with the picture. 

Refer to Figure 4-25.

Save (File ➤ Save) your work, and you can refer to 

garden_clone_stamp_brush_final.psd.

In the castle.psd example, by doing similar steps now, the edges of the 

building are not disappearing in the black and white print photo. Refer to 

Figure 4-26.
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Figure 4-26.  Adding a line to the edges of the building, so they do not 
disappear into the sky

Note that in both cases, the sky is very dull and uninteresting. We will 

consider in Chapter 8 what could be done in color photos to improve this.

Likewise, as an idea, consider other black and white photos where 

part of the head is not complete due to overexposure by adding a thin line 

where you think the rest of the head should be, would prevent his head 

from completely disappearing into the white background. You could work 

in combination with the Eraser tool and again lower the opacity of the 

layer to make a better blend. Refer to Figure 4-27.
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Figure 4-27.  Adding to the top of a man’s head and collar when 
details are missing

Note that in this more complex example, if you apply it to your own 

projects, you may not have access to alternate photos to compare. So, 

there may be a limited amount of information that you can repair, and, in 

some cases, you may need to guess at how the head or another body part 

is formed based on human anatomy. Take your time with these kinds of 

projects to get the form correct. Refer to Figure 4-27.

In another situation, you may want to use your Brush Tool on a layer 

mask instead of the Eraser tool as we will see in Chapter 8 and later with 

Color in Volume 2.

�History Brush Tool (Y)
One other brush-related tool that you may want to use for some projects 

is the History Brush. You can use this in combination with the Brush Tool, 

Eraser Tool, and the History panel. Use this tool to paint back some of the 

details that are lost while working on your project. Let’s look at the tool’s 

Options bar panel from left to right. Refer to Figure 4-28.
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Figure 4-28.  Options bar panel History Brush Tool options

After the History Brush’s preset picker option, most options are similar to 

the ones found for either the Clone Stamp, Eraser, or Brush Tool; you can 

refer to those tools for more details. The options that follow are the

•	 Brush preset picker menu for setting brush size, 

hardness, angle, roundness, and brush options.

•	 Toggle to Brush Settings panel.

•	 Painting mode menu: Set to a default of Normal.

•	 Opacity (1–100%): The default is 100%.

•	 “Always use Pressure for Opacity. When off, the Brush 

Preset controls the pressure”: Disabled by default.

•	 Flow rate (1–100%): The default is 100%.

•	 “Enable airbrush-style build-up effects”: Disabled by 

default.

•	 The angle setting (–180,0,180°) is the same setting 

as the one found in the Brush preset picker or Brush 

Settings panel; by default, this should be set to 0°.

•	 Like the Clone Stamp Tool, you can use “Always use 

Pressure for Size. When off, Brush Preset controls 

pressure.” This option is by default off and is 

generally used when working with a stylus. Refer to 

Figure 4-28.	

Chapter 4  Tools for Photo Restoration: Part 2



222

Here, you can see how the History Brush works with the History panel. 

Some lines were painted with the Brush tool and then erased with the 

Eraser tool. However, a history source was set for the brush in the History 

panel, and now with the History brush, I can paint some detail of my erase 

area back. If you do not want to continue using this setting anymore you 

can disable it in the History panel. Refer to Figure 4-29.

Figure 4-29.  Use the History panel to set a History state after an area 
has been erased, and you want to paint it back

For artistic painting, this can be useful and could be used with the Art 

History Brush Tool as well. Refer to the following link for more details and 

to my books mentioned in the chapter as well if this is a topic you want to 

look at in more detail on your own. Refer to Figure 4-30.

Figure 4-30.  The Art History Brush Tool is found with the History 
Brush Tool

https://helpx.adobe.com/photoshop/using/painting-stylized-

strokes-art-history.html
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However, the layer mask, as we will see in Chapter 8, is a better option 

when you need to paint back actual photographic details.

�Pencil Tool (B)
Like the Brush tool, you can use the Pencil tool to fill in gaps and breaks, 

though the line will be more crisp and not fuzzy, and the hardness setting 

will have little effect, as you saw with the Eraser Tool when it was set to 

pencil mode earlier in this chapter. Let’s look at the tool’s Options bar 

panel from left to right. Refer to Figure 4-31.

Figure 4-31.  Options bar panel Pencil Tool options

After the tool’s preset picker options, many of the settings are the same 

as the Clone Stamp, Eraser, and Brush Tools (you can refer to those tools 

for more details). These include the Brush preset picker menu and toggle 

button to the Brush Settings panel.

Make sure that painting mode is normal, and opacity is 100%. “Always 

use Pressure for Opacity. When off, the Brush Preset controls the pressure,” 

in this case, is disabled. Refer to Figure 4-32.
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Figure 4-32.  Options bar panel Pencil Tool options for setting 
painting mode and opacity

Next is the smoothing rate (0–100%); the default is 10%. Additional 

smoothing options are found in the gear pop-up menu. The Brush angle 

setting (–180,0,180°) is the same setting as the one found in the Brush 

preset picker or Brush Settings panel; by default, this should be set to 0°. 

Auto Erase is disabled by default, but when enabled can be used to draw 

background colors over foreground colors. Refer to the following link if you 

need more details of when to use Auto Erase. Refer to Figure 4-33.

Figure 4-33.  Options bar panel History Brush Tool options for 
smoothing options, angle, auto erase, pressure, and symmetry paint

https://helpx.adobe.com/photoshop/using/erasing-parts-

image.html

Like the Clone Stamp and Eraser tools, you can use “Always use 

Pressure for Size. When off, Brush Preset controls pressure”; this option is 

by default off and is generally used when working with a stylus.

The last icon button which looks like a butterfly (symmetry paint) is 

not relevant to this book and is more for art purposes rather than repair. If 

this topic is of interest to you, you can check it out in my earlier mentioned 

books. Refer to Figure 4-33.

In this example, we can compare how the Brush tool (Layer 1) and the 

Pencil tool (Layer 2) were used to fill in the broken line next to the castle_
final.psd in the black and white photo.
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While it might be OK for very thin lines, the pencil line appears more 

jagged, so I personally prefer the Brush tool for better blending. Lowering 

the opacity of the pencil layer to about 23% can improve its look slightly. 

Refer to Figure 4-34.

Figure 4-34.  Creating a line using the Brush tool, the Pencil tool, and 
the Pencil tool with its Layer Opacity reduced

�Color Replacement Tool (B)
This is a more advanced tool which can be used for basic color 

replacement on edges or quick edits. Examples are those colors that are 

considered contiguous or share a common border or even blending into 

one another. You can choose a foreground color from the Tools panel color 

picker when you double-click it to replace the unwanted color. I used R:51, 

G:102, B: 153. Refer to Figure 4-35.
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Figure 4-35.  Use the Tools panel swatch for the foreground color 
created using the color picker for the Color Replacement tool

Then decide which color you want to replace in the image and drag 

inside that area to replace the targeted color.

You can see in the bird.psd image that you can change the bird from 

yellow to blue. Make sure to create a duplicate (Image ➤ Duplicate) of the 

file to work on and zoom in with the Zoom tool to get closer to the bird. 

Refer to Figure 4-36.
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Figure 4-36.  Changing the bird’s color from yellow to blue using the 
Color Replacement Tool

Note, however, that this can be destructive, and you will need to 

work on a duplicate copy of the background layer. Remember to drag the 

Background in the Layers panel over the New Layer button to make the 

duplicate layer. Refer to Figure 4-37.
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Figure 4-37.  Create a duplicate layer of the background in the Layers 
panel when you want to work with the Color Replacement tool

However, a better option to use on a larger area, in a less destructive 

way, is the adjustment layers, which we will review in Volume 2. For now, 

should you want to experiment with the Color Replacement tool, I’ll just 

mention the tool’s Options bar panel from left to right. Refer to Figure 4-38.

Figure 4-38.  Options bar panel Color Replacement Tool options
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After the tool’s preset picker options, you can use the Brush preset 

picker to change the size, hardness, spacing, angle, and roundness, as 

well as when using a stylus, such things as dynamic control for size and 

tolerance. Refer to Figure 4-39.

Figure 4-39.  Options bar panel Color Replacement Tool options for 
Brush presets
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There are several painting modes – hue, saturation, color, and 

luminosity – but by default, it is set to color which is recommend by Adobe. 

Refer to Figure 4-40.

Figure 4-40.  Options bar panel Color Replacement Tool options for 
painting mode

The Sampling options are three icons that resemble eyedroppers. Refer 

to Figure 4-41.

Figure 4-41.  Options bar panel Color Replacement Tool options for 
sampling: limits, tolerance, anti-alias, angle, and pressure

•	 Continuous: Samples the colors continuously as you 

drag the mouse over them.

•	 Once: Replaces the targeted color only in areas 

containing the color that you must first select.
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•	 Background Swatch: Replaces only areas containing the 

current selected background color. Refer to Figure 4-41.	

Limits can then be set to determine the spread of the replaced color:

•	 Discontiguous: Use when you need to replace the 

sampled color wherever it occurs under the pointer.

•	 Contiguous: Will replace colors that are contiguous 

with the color immediately under the pointer.

•	 Find Edges: Will replace connected areas containing 

the sampled color while still preserving the sharpness 

of the shape’s edges. Refer to Figure 4-41.	

Tolerance by default is set to 30%. Adobe recommends that you choose 

a low percentage to replace colors very similar to the pixel you select 

or increase the percentage to replace a broader range of colors. If you 

discover the range of replaced colors is too small, you can increase the 

Tolerance setting in the Options bar panel. Refer to Figure 4-41.

Keep the Anti-alias checkbox enabled to produce a smooth edge in the 

corrected areas.

The Brush angle setting (–180,0,180°) is the same setting as the one 

found in the Brush preset picker; by default, this should be set to 0°.

Like the Clone Stamp tool, you can use “Always use Pressure for Size. 

When off, Brush Preset controls pressure.” This option is by default off and 

is generally used when working with a stylus. Refer to Figure 4-41.

Note that this brush does not have access to the Brush Settings panel, 

and you can only use round or elliptical brushes.

On the background layer copy of the bird.psd image, test the tool with 

the settings of Mode: Color, Sampling: Continuous, and Limits of Find Edges 

(Figure 4-41); while you paint on the copy layer over the bird, make sure to 

zoom in and change the brush size and paint over the areas of the bird. As an 

area turns blue, move on to another yellow or brown area and click in that area 

and then continue to paint until the bird is a blue color, as seen in Figure 4-36.
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Press the D key when you need to return to the default colors in the 

color picker. Refer to Figure 4-42.

Figure 4-42.  Tools panel foreground and background color swatch 
set back to default

The other tool in this set is the Mixer Brush Tool (B), and it is used more 

for artistic painting and is not a topic of this book. Refer to Figure 4-43.

Figure 4-43.  Tools bar Mixer Brush Tool

Save (File ➤ Save) your document. Refer to the following link if you 

need more details on the Mixer brush:

https://helpx.adobe.com/photoshop/using/painting-mixer-

brush.html

The next six tools can affect the position as well as the color of the 

pixels overall.

Chapter 4  Tools for Photo Restoration: Part 2

https://helpx.adobe.com/photoshop/using/painting-mixer-brush.html
https://helpx.adobe.com/photoshop/using/painting-mixer-brush.html


233

�Blur Tool
The Blur Tool is similar to various Healing Brush tools in that it can be 

used to make areas of an image appear blurry, but you can over-blur an 

image as well or vary the blur in a variety of locations. When you want to 

blur part of an image, I would recommend using it on a blank layer.

Continue to use the copy of the bird.psd file and practice blurring the 

area surrounding the bird so that the bird in the image appears sharp and 

in focus. Refer to Figure 4-44.

Figure 4-44.  Work on a new Layer when you want to work with the 
Blur tool and preview the now blurry leaves surrounding the bird
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Let’s look at the tool’s Options bar panel from left to right. Refer to 

Figure 4-45.

Figure 4-45.  Options bar panel Blur Tool options

After the tool’s preset picker, you can set the Brush preset picker (size, 

hardness, angle, roundness, and type of brush). In most cases, I work with 

a soft or hard round brush. Refer to Figure 4-46.
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Figure 4-46.  Options bar panel Blur Tool options for the Brush 
preset picker

These are found in the Brushes panel. Soft is better for a blur because 

the hardness is reduced to 0%.
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As with other brush tools, you have access to the Brush Settings panel. 

However, some additional options beyond the Brush Tip Shape tab may 

not be available for this kind of brush. Refer to Figure 4-47.

Figure 4-47.  Brush Settings panel

Varying the size of the brush from large to small can make a better blur.

Like the Healing Brush tool, you will have access to a limited number 

of painting mode options. Refer to Figure 4-48.
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Figure 4-48.  Options bar panel Blur Tool options for mode, strength, 
angle, Sample All Layers, and pressure

To test, always start with the default mode of normal and keep the 

strength of the stroke at 50%. The Brush angle setting (–180,0,180°) is the 

same setting as the one found in the Brush preset picker or Brush Settings 

panel (Brush Tip Shape); by default, this should be set to 0°. When you are 

working on a new layer above your background layer, enable the Sample 

All Layers option and the blurred pixels will be added to that layer, and in 

the Layers panel, you can turn the layer’s visibility eye off and on as you 

work. Refer to Figure 4-49.
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Figure 4-49.  Continue to work on your new Layer 1 as you build up 
the blur

The last icon is “Always use Pressure for Size. When off, Brush Preset 

controls pressure.” This option is by default off and is generally used when 

working with a stylus. Refer to Figure 4-48.

Practice using the Blur Tool varying the brush sizes, and, if you find 

that you have added too much blur in one area, you can always use the 

Eraser Tool to remove part of the Blur or the History panel to undo a step. 

Remember, while zoomed in, to use your Hand Tool (Spacebar) and Zoom 

Tool to navigate on the page.
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In this example, I only blurred a small portion on the image 

surrounding the bird. However, in Volume 2, we will look at how to create 

an overall blur effect with various filters and masks.

Save (File ➤ Save) your work. We will return to this file later in the 

chapter.

�Sharpen Tool
The Sharpen Tool is similar to the Healing Brush, Clone Stamp, and Blur 

tools. However, it can be used to make areas of an image appear less 

blurry, but you can also over-sharpen part of an image.

In this example, practice with the plant.psd image. Refer to 

Figure 4-50.

Figure 4-50.  The head of the echeveria pot appears a bit out of focus 
and needs a sharpening
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Try using this tool to make the head of the plant pot less blurry and 

more in focus. Refer to Figure 4-51.

Figure 4-51.  Work on a new layer in the Layers panel to sharpen the 
pot’s bull head

When you want to sharpen part of an image, I would recommend that 

you work on a new layer.
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Let’s look at the tool’s Options bar panel from left to right. Refer to 

Figure 4-52.

Figure 4-52.  Options bar panel Sharpen Tool options

After the tool’s preset picker, as with the Blur tool, the Sharpen tool will 

allow you to alter your settings in the Brush preset picker (size, hardness, 

angle, roundness, and type of brush). As with other brush tools, you have 

access to the Brush Settings panel, but some of the advanced settings like 

the Blur tool will be unavailable. Like the Healing Brush tool, you will have 

access to the various limited painting mode options. Refer to Figure 4-52.

To test, always start with the default mode of normal and keep the 

strength of the stroke at 50%. The Brush angle setting (–180,0,180°) is the 

same setting as the one found in the Brush preset picker or Brush Settings 

panel (Brush Tip Shape); by default, this should be set to 0°. Refer to 

Figure 4-53.

Figure 4-53.  Options bar panel Sharpen Tool options for Painting 
mode, Strength, angle, Sample All Layers, Protect Detail, and pressure

When you are working on a blank layer above your background layer, 

enable the “Sample All Layers” option, and the sharpened pixels will be 

added to that layer. In the Layers panel, you can turn the layer’s visibility 

off and on as you work. Protect Detail is enabled to minimalize pixilation 

in the fine details as you work. The last icon is “Always use Pressure for 

Size. When off, Brush Preset controls pressure”; this option is by default off 

and is generally used when working with a stylus. Refer to Figure 4-53.
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On your blank layer, paint, with the Sharpen Tool, over the head of 

the pot (Figure 4-51). Use your Eraser Tool if you need to remove some 

of the areas that you may have over-sharpened or the History panel to 

undo a step. Remember to use your Hand Tool (Spacebar) and Zoom 

Tool to navigate on the page. I found that using a large brush of about 60 

pixels with a hardness of 0% worked best, as I could gradually build up the 

sharpened areas, but these settings may vary for your own projects as they 

would be different than mine.

Save (File ➤ Save) your document. You can use the file plant_final.psd 

as a reference.

Later, in Volume 2, we will look at how to create an overall sharpen 

effect with various filters.

�Smudge Tool
The Smudge Tool is similar to a Brush and the Blur tool in that it can be 

used to make areas of an image appear blurry or smudged, but you can 

over-smudge an image as well. Smudging could be used to smooth a rip 

or crease or just blur a small area. When you want to smudge part of an 

image, I would recommend using it on a blank layer. Refer to Figure 4-54.
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Figure 4-54.  Create another new layer for Smudge tool practices

In this case, continue to use the bird.psd file, try smudging some of the 

leaves in a new layer around the bird, and see how this compares to a blur 

you created earlier. Refer to Figure 4-55.
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Figure 4-55.  Use the Smudge tool on the leaves to see a different 
effect of blur

Let’s look at the tool’s Options bar panel from left to right. Refer to 

Figure 4-56.

Figure 4-56.  Options bar panel Smudge Tool options
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After the tool’s preset picker, as with the Blur tool, you can alter your 

settings in the Brush preset picker (size, hardness, angle, roundness, and 

type of brush). As with other brush tools, you have access to the Brush 

Settings panel, but like the Blur Tool some of the advanced settings will be 

unavailable. Refer to Figure 4-56.

Like the Healing Brush tool, you will have access to the various 

painting mode options.

To test, always start with the default mode of normal and keep the 

strength of the stroke at 50%. The brush angle setting (–180,0,180°) is the 

same setting as the one found in the Brush preset picker or Brush Settings 

panel (Brush Tip Shape); by default, this should be set to 0°. Refer to 

Figure 4-57.

Figure 4-57.  Options bar panel Smudge Tool options Painting mode, 
Strength, angle, Sample All Layers, Finger painting, and pressure

When you are working on a blank layer above your background layer, 

enable the Sample All Layers option and the smudged pixels will be added 

to that layer, and in the Layers panel, you can turn the layer’s visibility off 

and on as you work. Refer to Figure 4-57.

Use finger painting for an artistic effect; otherwise, keep this setting 

disabled by default. Refer to Figure 4-58.
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Figure 4-58.  Working with the Smudge tool finger painting mode on 
and then turning it off

The last icon is “Always use Pressure for Size. When off, Brush Preset 

controls pressure.” This option is by default off and is generally used when 

working with a stylus. Refer to Figure 4-58.

Continue to experiment with the Smudge tool, painting on the leaves. 

Use your Eraser Tool if you need to remove some of the areas that you may 

have over-smudged or the History panel to undo a step. To see a more 

dramatic smudge, use a large brush size like 94 pixels and a hardness 

of 0%. Remember to use your Hand Tool (Spacebar) and Zoom Tool to 

navigate on the page.

When complete, save (File ➤ Save) your document. You can use my file 

bird_final.psd as a reference.

As mentioned, overall sharpening, blurring, and smudging can also be 

performed with a variety of filters, as you will see in Volume 2. These filters 

if turned into smart filters can also be used in a nondestructive way for 

easy editing, along with masks.
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�Dodge Tool
The Dodge Tool is similar to a brush tool; however, rather than shift pixels 

around, it is used to alter the color of those pixels as you paint over an 

area. The Dodge tool is meant to lighten those pixels. However, keep in 

mind that this can become destructive if you are working on the original 

background layer. If you are not used to working with the Dodge tool, I 

would recommend making a copy of the background layer by dragging it 

over the New Layer button in the Layers panel and start with a small area 

and a small brush to see how it works. Refer to Figure 4-59.
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Figure 4-59.  Use the Layers panel to create a duplicate of the 
background layer

To practice, use the geese.psd image and make a duplicate (Image ➤ 

Duplicate) of the file and then a duplicate layer.

Remember to use your History panel if you need to revert a few steps. 

Let’s look at the tool’s Options bar panel from left to right. Refer to 

Figure 4-60.
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Figure 4-60.  Options bar panel Dodge Tool options

After the tool’s preset picker, as with the Blur tool, you can alter your 

settings in the Brush preset picker (size, hardness, angle, roundness, and 

type of brush).

As with other brush tools, you have access to the Brush Settings panel, 

but some advanced settings may not be available. Refer to Figure 4-61.
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Figure 4-61.  Brush Settings panel

Choose a range that you want to affect; this could be shadows, 

midtones, or highlights. Refer to Figure 4-62.
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Figure 4-62.  Options bar panel for Dodge Tool options for range 
exposure and airbrush

Then set your exposure level (1–100%); in this case, I am working with 

72%. The next setting “Use airbrush-style build-up effects” currently is 

disabled. Refer to Figure 4-62.

The Brush angle setting (–180,0,180°) is the same setting as the one 

found in the Brush preset picker or Brush Settings (Brush Tip Shape) 

panel; by default, this should be set to 0°. Protect tones is enabled when 

you want to minimize clipping in shadows and highlights and keep the 

colors from shifting in hue. The last icon is “Always use Pressure for Size. 

When off, Brush Preset controls pressure”; this option is by default off and 

is generally used when working with a stylus. Refer to Figure 4-63.

Figure 4-63.  Options bar panel Dodge Tool options for angle, protect 
tones, and pressure

The Dodge tool can be helpful when doing minor touch-ups. In this 

image, try to lighten some of the areas in shadow which are affected by the 

Range: Shadows. Refer to Figure 4-64.
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Figure 4-64.  Options bar panel Dodge Tool options, setting the brush 
size and before and after with the tool

In this case, one sweep or drag over a lower shadow with a 65px brush 

is probably enough, as too much makes the shadows start to appear 

washed out. Working in a small section might be best, and remember to 

use your History panel if you start to notice that the colors are becoming 

washed out. The pavement or green areas of the grass appear to benefit 

more from this tool.

However, when you want to be able to control the overall lighting of an 

image or work in a nondestructive way, working with Adjustment Layers 

and masks, as will be seen in Volume 2, may be a better option.

�Burn Tool
The Burn Tool is similar to a brush tool; however, rather than shift pixels 

around, it is used to alter the color of those pixels as you paint over an area. 

The Burn tool is meant to darken those pixels. However, keep in mind that 

this can become destructive if you are working on the original background 

layer and switching between Dodge and Burn. If you are not used to 

working with the Burn tool, I would recommend making a copy of the layer 
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by dragging the background layer over the New Layer icon in the Layers 

panel and start with a small area and a small brush to see how it works.

In this example, continue to practice with the background copy layer 

created in the geese.psd image but in a different area such as the grass, 

which is washed out. Refer to Figure 4-65.

Figure 4-65.  Keep working on your background copy layer in the 
Layers panel
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Use your History panel if you need to revert a few steps.

Let’s look at the tool’s Options bar panel from left to right. Refer to 

Figure 4-66.

Figure 4-66.  Options bar panel Burn Tool options

After the tool’s preset picker, as with the Blur tool, you can alter your 

settings in the Brush preset picker (size, hardness, angle, roundness, and 

type of brush). As with other brush tools, you have access to the Brush 

Settings panel, but like the Dodge Tool, some advanced options are not 

available.

Just like with the Dodge tool, choose a range that you want to affect; 

it could be shadows, midtones, or highlights. Then set your exposure 

level (1–100%); in this case, I am working with 50%. The next setting “Use 

airbrush-style build-up effects” currently is disabled. Refer to Figure 4-66.

The Brush angle setting (–180,0,180°) is the same setting as the one 

found in the Brush preset picker or Brush Settings panel (Brush Tip 

Shape); by default, this should be set to 0°. Protect tones is enabled when 

you want to minimize clipping in shadows and highlights and keep the 

colors from shifting in hue. Refer to Figure 4-67.

Figure 4-67.  Options bar panel Dodge Tool options for angle, protect 
tones, and pressure
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The last icon is “Always use Pressure for Size. When off, Brush Preset 

controls pressure”; this option is by default off and is generally used when 

working with a stylus. Refer to Figure 4-67.

The Burn tool can be helpful for doing minor touch-ups. This time, use 

the Burn Tool in the geese image on an area of the grass, using the range 

of midtones, and notice how the grass becomes darker as you hold down 

the brush and drag around the area. Do not hold the brush down in any 

one area for too long or go over an area too many times, or rather than 

darkening the lawn, you might give it a burnt appearance. I used a large 

brush from about 90px to 130px and a hardness of 0%. Refer to Figure 4-68.

Figure 4-68.  Use the Burn tool in an area where you want the grass 
to be a bit darker

However, when you want to be able to control the overall lighting of an 

image or work in a nondestructive way, working with Adjustment Layers 

and masks, as will be seen in Volume 2, may be a better option.
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For additional information on the Dodge and Burn tools, you can 

review this page:

https://helpx.adobe.com/photoshop/using/dodge-burn-image-

areas.html

�Sponge Tool
The Sponge Tool is similar to a brush tool however, rather than shift pixels 

around, it is used to alter the color of those pixels as you paint over an 

area. The Sponge tool is meant to saturate or desaturate those pixels. It 

can be used with both color and black and white images. However, keep in 

mind that this can become destructive if you are working on the original 

background layer and switching between modes. If you are not used to 

working with the Sponge tool, I would recommend making a copy of the 

layer, as you did with the Dodge and Burn Tools, and start with a small area 

and a small brush to see how it works.

Continue to practice with the copy of the geese.psd image on the same 

background copy layer but a different area. Refer to Figure 4-69.
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Figure 4-69.  Keep using a background copy layer as you work with 
the Sponge tool

Use your History panel if you need to revert a few steps.

Let’s look at the tool’s Options bar panel from left to right. Refer to 

Figure 4-70.

Figure 4-70.  Options bar panel Sponge Tool options
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After the tool’s preset picker, as with the Blur tool, with the Sponge Tool 

you can alter your settings in the Brush preset picker (size, hardness, angle, 

roundness, and type of brush). As with other brush tools, you have access 

to the Brush Settings panel, but like the Dodge tool, not all advanced 

options will be available. In this case, the tool has two painting modes, 

“saturate” to intensify the color and “desaturate” to dilute the color. Then 

set your flow rate (1–100%); in this case, I am working with 50%. The next 

setting, “Use airbrush-style build-up effects,” currently is disabled. Refer to 

Figure 4-71.

Figure 4-71.  Options bar panel Sponge Tool options for mode, flow, 
and airbrush

The Brush angle setting (–180,0,180°) is the same setting as the one 

found in the Brush preset picker or Brush Settings panel (Brush Tip 

Shape); by default, this should be set to 0°. Vibrance is enabled when 

you want to minimize clipping for fully saturated or desaturated areas of 

color. The last icon is “Always use Pressure for Size. When off, Brush Preset 

controls pressure.” This option is by default off and is generally used when 

working with a stylus. Refer to Figure 4-72.

Figure 4-72.  Options bar panel Sponge Tool options for angle, 
vibrance, and pressure
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The Sponge tool can be helpful for doing minor touch-ups. In the 

geese image, in the mode of saturate, try another area and notice how the 

wood on the trash can becomes brighter. Refer to Figure 4-73.

Figure 4-73.  For the Sponge tool, a mode of saturate can make 
the wood more visible, and a mode of desaturate can lighten the 
pavement and make it gray

Or with desaturate, you can lighten areas of the road and make it more 

gray rather than it having a pinkish hue.

You would vary your brush size, depending on the area you want to 

affect, in this case, between 30px and 100px, and keep the hardness at 0%.

Sponge will also add or remove the color of the lawn and, in this case, 

does not make the lawn greener. We can see for this picture that using the 

Sponge tool to saturate is not an ideal way to control the midtones where 

this image needs some overall help. Refer to Figure 4-74.

Figure 4-74.  Mode of saturate for the lawn turns it yellow rather 
than a nice green grass
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However, for a black and white image (home.psd) removing a yellow 

stain with the sponge on Mode: Desaturate would be good as seen in the 

lower left of this photo. However, in doing so, we lose some of the toning of 

the original image. Refer to Figure 4-75.

Figure 4-75.  Use the Sponge tool to remove small stains from black 
and white images

Save (File ➤ Save) the current documents you have open and refer to 

the files with the geese_final.psd if you need to compare.
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When you want to be able to control the overall lighting of an image or 

work in a nondestructive way with color, working with Adjustment Layers 

and masks, as will be seen in Volume 2, may be a better option.

For additional information on how to use the Sponge tool, refer to 

this page:

https://helpx.adobe.com/photoshop/using/change-color-

saturation-sponge-tool.html

Remember to save (File ➤ Save) any images that you have worked 

on so far.

�Summary
In this chapter, we looked at a number of tools from the Tools panel that 

can be used to improve your digital image and heal areas. Some are better 

for one kind of restoration task than another. Working on separate layers 

also helps you to heal your images in a nondestructive way. In the next 

chapter, we will be looking at a few more tools for cropping your artwork.
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CHAPTER 5

Tools for Photo 
Restoration: Part 3
Continuing from the previous chapter, I will explain to you some of the 

cropping tools in the Tools panel I like to use for photo restoration that 

can enhance your work or correct minor distortion. Note you may not 

use these tools for every project. In this chapter as well as the following 

chapters, we will be using the Layers panel and try to work in the least 

destructive way possible so that you can go back at any time and correct 

your errors. You will be able to do that if you make sure that, as you saw in 

Chapter 2, you save a duplicate of your scan as a .psd document. We will 

then end this chapter with a photo project that will review some of the 

tools you have learned from the previous two chapters.

Note this chapter does contain projects found in the Volume 1 
Chapter 5 folder. Some tools mentioned in this chapter have also 
been mentioned in my previous books, Accurate Layer Selections 
Using Photoshop’s Selection Tools and Perspective Warps and Distorts 
with Adobe Tools: Volume 1, but with new information presented as 
it relates to photographic images. As you work on each project in 
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this chapter, make sure to create a duplicate (Image ➤ Duplicate), 
as mentioned in Chapter 2, so that you do not override the original 
artwork and click OK to the message in the dialog box. Refer to 
Figure 5-1.

Figure 5-1.  Duplicate Image dialog box

Remember, as you work, to use the Move, Zoom, and Hand tools as 

well as the related key commands that were mentioned in Chapter 2. As 

well, use your History panel or Edit ➤ Undo (Ctrl/CMD+Z) if you make a 

mistake and need to revert a few steps. Refer to Figure 5-2.

Figure 5-2.  Move, Zoom, and Hand Tools and History panel
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Tip  When you save (File ➤ Save) your files later as a suggestion, 
you can also add your initials to the name so that you do not override 
the original file, for example, practice_file_JH.psd.

�Cropping Images with Crop and Perspective 
Crop Tools
When working with scanned images, there are situations where, when you 

make a marquee selection, you scan too much on one or more sides of 

your image. Sometimes, this is intentional if perhaps you plan to add more 

detail around the edge of the photo and need a larger canvas as you work. 

However, in other situations, you want to remove some of the image for a 

nice clean edge. When doing this, always work on a duplicate (Image ➤ 

Duplicate) of the scan.

The two tools I like to use are the Crop Tool and the Perspective 

Crop Tool.

Most times, before I make any correction to my image, I like to do the 

cropping right away. But sometimes, with damaged photos, it is best to do 

the cropping after making minor touch-ups to your rips and creases. In 

other situations, the print or slide has become slightly distorted, or maybe 

you took a photo of the scene at a height that was not exactly straight 

on and so a perspective crop might need to be used instead. Refer to 

Figure 5-3.

Figure 5-3.  Tools panel Crop Tool and Perspective Crop Tool
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�Crop Tool (C)
The Crop Tool has recently had a few improvements added as I will 

point out.

Use a duplicate (Image ➤ Duplicate) of the tower.psd example to 

practice. Refer to Figure 5-4.

Figure 5-4.  A tower at a slight angle in a photo that could be cropped

Let’s review the Options bar panel from left to right. Refer to Figure 5-5.
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Figure 5-5.  Options bar panel Crop Tool options

After the tool’s preset picker, you can choose from a number of preset 

aspect ratio options or crop sizes. Refer to Figure 5-6.

Figure 5-6.  Options bar panel Crop Tool options for crop presets
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When you want to work with a ratio, choose the ratio option and swap 

the ratio. Refer to Figure 5-7.

Figure 5-7.  Options bar panel Crop Tool options of ratio

Or click the Clear button (Figure 5-7) and then you can drag the 

bounding boxes, manually creating a custom crop. Refer to Figure 5-8.
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Figure 5-8.  Create a manual crop with the bounding boxes

But if in inches, you can alternatively select W (width) × H (height) × 

Resolution.

From the Options bar panel, set an aspect ratio for the crop box, swap 

width and height using the arrows, and set the resolution in px/in or px/

cm. You can move the image while in this crop preview if you need to 

center it. Click the Clear button to reset the settings back to no values and 

continue with your custom sizing. Refer to Figure 5-9.
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Figure 5-9.  Options bar panel Crop Tool options for width, height, 
and resolution
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You can click the Straighten option to straighten the image by dragging 

out a line on the canvas and release and then preview the result. Refer to 

Figure 5-10.

Figure 5-10.  Use the Crop tool’s straighten options when you want to 
align the tower
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To adjust the grid preview, click the grid icon to reveal and set the 

overlay options. Refer to Figure 5-11.

Figure 5-11.  Options bar panel Crop Tool options Grid 
Overlay Options

These overlays can be useful for various projects to assist you in 

creating a more accurate crop; by default, I like to use the Rule of Thirds. 

Use the gear icon and set additional crop options so that you can see more 

accurately the area that is being cropped vs. the area that will remain. In 

this case, make sure to enable Show Cropped Area, Auto Center Preview, 

as well as Enable Crop Shield. The Crop Shield currently has a color that 

matches the canvas with an Opacity of 75% and Auto Adjust Opacity 

enabled. Use Classic Mode is disabled. Refer to Figure 5-11.
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Rather than removing the surrounding pixels after cropping, you can 

choose to enable or disable Delete Cropped Pixels. Generally, I choose 

to keep this button enabled as I am working on a copy of my file and can 

always return to the original. However, if working with various overlaying 

layers, you may want to keep this option unchecked so that you can still 

move the layers around within the set area, should an area on one layer be 

cropped by mistake. Refer to Figure 5-12.

Figure 5-12.  Options bar panel Crop Tool options, Delete Cropped 
Pixels and Fill with Background (default) color from the Tools panel 
or Fill with Transparent (default)

When you extend the crop, rather than making the canvas smaller, we 

can rely on some new settings that have recently been combined in the Fill 

drop-down menu. Refer to Figure 5-13.
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Figure 5-13.  Crop extended

In the past, when we would expand the crop area, the new area 

would fill with either the Tools panel background color if there was just 

a background layer or transparent pixels when Delete Cropped Pixels is 

disabled. Refer to Figures 5-12, 5-14, and 5-15.

Figure 5-14.  Crop extended with white background or 
transparent pixels

Later, the option of Content-Aware Fill was added where the sample 

content from part of the image is used to fill the area. In the sky area, it 

would look OK, but on the ground, if not set up correctly or pre-cropped 
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to remove unwanted pixels, this might cause the image to repeat with 

those pixels included. As you can see, repeat on the right side. Refer to 

Figure 5-15.

However, recently a new fill setting has been added, called Generative 

Expand. This is a recent AI option that has been added to generate 

high-quality new content to fill the extended space that you can access 

from Adobe with or without a text prompt if you agree to the licencing 

conditions. I will talk about this option more in Chapter 8. Note that the 

info button gives the user a few details about when to use each setting. 

Refer to Figure 5-15.

Figure 5-15.  Crop extended using the Option fill of Content-Aware 
Fill for the sky and the ground on the right
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In the Options bar panel, if you need to reset your options at any time, 

click the counterclockwise arrow reset button, Cancel to exit without 

cropping, or the Commit setting check to confirm the crop. Refer to 

Figure 5-16.

Figure 5-16.  Options bar panel Crop Tool options for revert, cancel 
and commit

In this tower example, try to straighten the image and crop off the dark 

lines on the right and bottom of the image. To crop any gaps in the process, 

enable Delete Cropped Pixels and set the Fill to Background (default).

Before you click the Check (Commit), preview the result. Use Ctrl/

CMD++ and Ctrl/CMD+- if you need to zoom in or out and the Spacebar to 

access the Hand Tool. Refer to Figure 5-17.
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Figure 5-17.  Crop with straighten rotation and use guides

Once committed, then save (File ➤ Save) your image. You can review 

my file tower_final.psd as a reference.
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Tip  While working with the Crop tool, you can also drag out guides 
from your rulers and then use the bounding box handles to rotate the 
crop if you prefer this method of straightening. Refer to Figure 5-17. 
To remove the guides, choose View ➤ Guides ➤ Clear Guides.

�Perspective Crop Tool (C)
As mentioned, sometimes a picture, such as a print or slide, can appear to 

be slightly distorted due to how it was stored in the album or in the holder 

or even the angle the image was taken at. Using a perspective crop can 

partially correct the distortion.

Open the file glass_window.psd; in this example, you can see that 

the upper area of the stained glass is a bit wider than the bottom. Refer to 

Figure 5-18.

Figure 5-18.  A picture of a window, with a slight distortion

Chapter 5  Tools for Photo Restoration: Part 3



279

With this tool selected, click out the four points that you want for the 

crop. This creates a grid. As with the Crop tool, use your key commands of 

Ctrl/CMD++ or Ctrl/CMD+- when you need to zoom in and out. Refer to 

Figure 5-19.

Figure 5-19.  Use the Perspective Crop tool and grid to correct the 
distortion
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Review the Options bar panel from left to right. Refer to Figure 5-20.

Figure 5-20.  Options bar panel Perspective Crop Tool options

After the tool’s preset picker, optionally you set your width (W) and 

height (H), or you can swap width and height with the arrows, then set the 

resolution for cropped images, either pixels/in or pixels/cm. Generally, 

you will want to keep the resolution the same as the original. The Front 

Image button values, in this case, may be the current size and resolution of 

the document when working on multiple layers. Choose the Clear button 

to reset your current setting and enable the Show Grid checkbox, so you 

can see the preview grid as you work.

In this case, I just used the grid and did not enter any values into the 

Options bar panel.

Once you’re done, you can click the Cancel button to exit without 

making changes or the Commit check icon to commit your perspective 

crop. Refer to Figures 5-20 and 5-21.
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Figure 5-21.  Window straighten

Use Edit ➤ Undo or the History panel if you do not like the result of the 

crop and then try again. Save (File ➤ Save) your work, and you can refer to 

my file glass_window_final.psd.

�Organizing Your Layers Panel: Moving 
and Copying Layers
Let’s review some of the layer options when working with the Layers 

panel. You can apply this knowledge to any .psd file you have open. Use 

the file garden_clone_stamp_brush_final.psd to practice.

Once you have created a few new Layers over the top of your 

background layer, it is important to keep them organized. Note that the 
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top layer is the most visible (Layer 2), and it overlaps Layer 1 and the 

Background layer. Refer to Figure 5-22.

Figure 5-22.  Working with multiple layers in the Layers panel

You can select and drag layers up and down in the panel to change the 

order. The selected layer is the one you are working on, which will become 

a different color, in this case a darker gray, when you click it with your 

mouse. Refer to Figure 5-23.
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Figure 5-23.  Changing the order of a layer in the Layers panel
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Note that if a layer is locked, such as the Background layer, it cannot 

be moved; it must be first unlocked. In that case, you would double-click it 

and make it Layer 0, as you saw in Chapter 2, in the section about adjusting 

your scanned image.

�Create New and Duplicate Layers
Remember, as you saw in Chapter 3, that new blank layers can be created 

when you click the new layer button in the Layers panel. Duplicates of a 

layer, such as the background or any new layer, can be created when you 

drag the layer over the New Layer button. Refer to Figure 5-24.

Figure 5-24.  Create a New Layer in the Layers panel

You can also drag several new layers over the New Layer button to 

make copies if you first Shift-click each layer to select them. Refer to 

Figure 5-25.
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Figure 5-25.  Layers panel makes duplicate copies of more than 
one layer
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�Delete Layers
A layer or several layers can be deleted when you drag it over the trash can, 

or while it is selected, click the trash can, or choose that option from the 

panel’s menu. Then click yes to the message. Refer to Figure 5-26.

Figure 5-26.  Delete a Layer using the Layers panel and its menu
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�Copying Layers
Copying Layers from one document to the next is also possible. When both 

document files are dragged side by side, you can drag one layer, such as the 

background or another layer once selected into the other document. Refer 

to Figure 5-27.

Figure 5-27.  Use the Layers panel to drag a layer from one document 
to another when they are side by side

Keep in mind that when you drag the file’s layer into another file, which 

has a different color mode, resolution, or width and height, the image layer 

may display differently than you expect. In the case of a different resolution, 

the image may be larger or smaller than expected from the file you dragged 

from. Note, also check how close you are zoomed in on both documents as 

this can affect how you are viewing them. Refer to Figure 5-28.
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Figure 5-28.  Check your viewing size and resolution if your image 
appears at a size you did not expect

If you want to drag several layers that include the adjustments, once 

they are complete, you can Shift-click and drag those selected layers over 

or consider using the Layer menu’s Flatten Image option on a copy of the 

file, back to a background layer. Refer to Figure 5-29.

Figure 5-29.  After working in several completed layers, you can 
flatten them
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However, if for some reason you need to keep those layers separate 

as you work in the new document, keeping some of them together in a 

group folder to drag over as one unit with your background selected may 

be a better option. When layers are selected, you can click the new group 

button, and they are added to the group. Refer to Figure 5-30.

Figure 5-30.  Organize your layers in a group folder

Whether you copy over the layers or not, keeping layers in group 

folders is a good way to keep them organized.

�Colorizing Group Folders
If you have a lot of layers and cannot find a specific type of layer, you can 

use the filter options to assist you from the list; choose options such as 

Kind, Name, Effect, and Group or use the icons next to the list. You can 

hover over them to review those options. When you right-click a folder, you 

can give each folder a different color from the menu. Refer to Figure 5-31.
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Figure 5-31.  To keep organized in the Layers panel, you can filter 
your layers to find them or give each group a color
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�Renaming Layers and Folders
To give a layer or a group folder a new name, double-click the name of it 

and type in a new name and then click another layer or folder to commit 

the name. Refer to Figure 5-32.

Figure 5-32.  Rename a layer if you need to remember what kind of 
repair it is for

We will discuss more about Layers and copying selections as we 

progress through the book, but if you would like to know more about layer 

basics now, you can consult the following link:

https://helpx.adobe.com/photoshop/using/layer-basics.html

�Photo Project (Army Image)
For this project, we will review a few of the things you learned about from 

the tools discussed. In this case, continue with your copy of the army 

image (army_practice_healing_clone.psd) that you started with at the 

beginning of Chapter 3, which I have put in this chapter’s folder as well. 

See file army_practice_healing_clone_p2.psd as a starting point.

Continue to work on separate layers so that you can continue to work 

in a nondestructive way over the background. Refer to Figure 5-33.
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Figure 5-33.  Army image with some details and damage removed

First, continue to use the Clone Stamp Tool to clean up the rips, 

creases, white spots, reflections, and noticeable stains. However, try using 

some of the other healing tools that were mentioned in Chapters 3 and 4.  

What about trying the Remove tool on spots or using the Spot Healing 

Brush and Healing Brush tools? Could the Blur tool assist if set to a small 

brush? I used Layer 1 for this work. Or what about areas where it is too 

white, like around the man’s helmet where it meets the backpack or 

another man’s arm? You could use a thin black 1px Brush Tool and Opacity 

reduced to 12% on a separate layer, new Layer 2, which I renamed brush. 

Refer to Figure 5-34.
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Figure 5-34.  Adding a line of detail to the hat so that it can be 
distinguished from other items

After you have corrected as many “blemishes” as possible on Layer 1, 

look at the edge of the page and fill in areas where part of the edge of the 

page is missing and needs a more even edge where a crack or rip might 

be. At this point, the edge does not have to be perfect as you use the Clone 

Stamp Tool, but you can drag out a guide if you need some help to check 

your progress. Refer to Figure 5-35.

Figure 5-35.  Dragging out a guide to check the edge of the image
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What I’m trying to show here is that the healing tools by themselves 

can correct many issues, but they cannot correct them all, such as 

completely straightening bowed edges, removing color like on the boot 

without destroying the toning, or when we notice that there are numerous 

dust and scratches. In some situations, there can be too many small 

imperfections to stamp at once without making more blemishes. And in 

later chapters as well as Volume 2, we will tackle these issues. You can 

review my final file army_practice_healing_clone_finalp2.psd in this 

chapter’s folder to see how far we have progressed. Refer to Figure 5-36.

Figure 5-36.  Color damage and multiple dust spots and scratches

For now, try working on your own project, identify what needs to 

be improved, and, with the same steps as discussed here, incorporate 

other tools discussed in Chapters 3, 4 and this chapter. With the tools, 

experiment with adding missing information to the image, for example, on 

people or other items, using the healing tools. After that, review your work 

and consider if there are other parts of your restoration project that would 

benefit from an overall color correction, or are you having trouble selecting 

specific areas of the image? Then save (File ➤ Save) your work and put it 

aside until you have read other chapters.
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�Summary
In this chapter, we looked at a number of tools from the Tools panel that 

can be used to improve your digital image and crop areas. Some are better 

for one kind of restoration task than another. Working on separate layers 

also helps you to work on your images in a nondestructive way. In the next 

chapter, we will be looking at more tools for creating selections, which will 

eventually be used with layer masks for covering or when you need to fill in 

the missing details of an image.
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CHAPTER 6

Masks, Selections, 
and Filling in the 
Gaps: Part 1
When dealing with historical or family photos that are 20, 50, or even 100 

years old, it would sometimes be nice to be able to fill in missing details 

when we don’t know how the entire scene looked back then.

Sometimes, one or two images of the same scene were taken, and we 

can copy details from one photo to the other, or we might be able to find 

an image on the Internet or another image collection that will give us some 

clue as to what the missing detail is, but more often than not, we have to 

guess. Photoshop certainly has a number of tools that can assist us to do 

that using AI to create content-aware fills for small areas.

In other situations, you may want to even out the edge of an image that 

may not be completely straight as part of the digital repair.

https://doi.org/10.1007/979-8-8688-0450-2_6
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In this chapter as well as in Chapters 7 and 8, we will look at how to use 

selection tools and layer masks to cover or hide areas of a photo as well as 

use various tools and workspaces to fill in missing gaps in an image. We 

will also look at transforming and scaling to correct basic distortions and 

then look at ways to add more information.

In this chapter, the focus will be on tools for selection and working in 

Quick Mask Mode.

Note this chapter does contain projects found in the Volume 1 
Chapter 6 folder.

Note some of the tools I discuss in this chapter can also be found in 
my book Accurate Layer Selections Using Photoshop’s Selection Tools.  
In that book, the focus was on working with illustrations; however, in 
this book, the focus will be on photos that are digitally repaired.

�Photoshop’s Selection Tools
Photoshop has a number of tools that can be used for basic and complex 

selections, depending on what you want to select in your photo in a 

selected layer such as the background. Refer to Figure 6-1.
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Figure 6-1.  At least ten or more selection tools can be used with the 
Layers panel to create selections on a background image

In this chapter, we will look at seven of these selection tools and then 

the other three in Chapter 7. However, while not required for this book, I 

will briefly in this chapter mention a new tool recently added called the 

Selection Brush Tool (L) and provide a link for more details. See section 

“Lasso Tools for custom selections”. Refer to Figure 6-1.

These selections can then be refined using various options from the 

contextual task bar or the Select menu. Refer to Figure 6-2.
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Figure 6-2.  Use Photoshop’s Select menu or contextual task bar to 
access various selection options

Once a selection has been made, you can use Quick Mask Options and 

Select and Mask workspace to refine the selection.

You then have the option to copy that selection of pixels onto a new 

layer, save the selection to a channel, or apply the selection as a Layer mask 

to the current layer or a duplicate layer to save and refine the selection. 

Refer to Figure 6-3.
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Figure 6-3.  The Channels panel displays a saved selection and a 
Layer mask in the Layers panel

Chapter 6  Masks, Selections, and Filling in the Gaps: Part 1



302

For the moment, let’s look at the basic Layer selection tools and how 

they work on several images, and then later in Chapter 8, we will explore 

how these selections can be saved within the current image document and 

applied to Layers as a layer mask. In this chapter’s examples, the setting in 

the panel menu’s Layer Properties for showing layer mask badges has been 

disabled in the dialog box so that you can see the contents of the mask 

clearly (refer to Figure 6-3).

�Rectangular Marquee Tool (M)
The Rectangular Marquee tool can be used to make rectangular or square 

selections. Generally, when you want to make this kind of selection, it can 

be useful for defining a border around an image so that you can work with 

one of the healing tools without going beyond the bounds of the selection. 

Examples of such tools that you would work within a selection could 

include the Clone Stamp, Brush, or Eraser Tool, which were reviewed in 

Chapters 3 and 4. Refer to Figure 6-4.

Figure 6-4.  Use the Rectangular Marquee Tool with other tools like 
Clone Stamp, Brush, and Eraser
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To practice, let’s use and open the tower image tower_selection.psd, 

like the image that you saw in Chapter 5.

As a note, this image was first cropped using the Crop tool to remove 

the extra black borders that appeared along the right and bottom sides 

with settings “Delete Cropped Pixels” enabled and clicked the check to 

confirm. Refer to Figure 6-5.

After that, I did a second cropping with the setting “Delete Cropped 

Pixels” disabled and this time using guides dragged from the ruler on 

the left and the bounding box overlay I rotated using a corner handle to 

straighten the image along the tower’s right side. Alternatively, I could have 

used the Straighten options as seen in Chapter 5. I made sure to extend the 

crop dragging outward. In the Options bar panel, I made sure to disable 

“Delete Cropped Pixels” checkbox with a Fill option of Transparent. 

Once the crop was confirmed by clicking the check, I then from the 

main menu choose View ➤ Guides ➤ Clear Guides as the guides in the 

image were no longer required. Refer to Figures 6-5 and 6-6.
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Figure 6-5.  Some images require two croppings. Use your rulers to 
drag guides to help you straighten an image as you crop and rotate it 
using overlay and the Options bar panel
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Figure 6-6.  Resulting crop extended and rotated with transparent 
gaps present
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Make sure to create a duplicate of the image (Image ➤ Duplicate) 

to progress through the next set of selection tools. It’s OK if we have 

blank transparent areas on Layer 0 as we will deal with those later. I have 

supplied for you the tower_selection_image.psd from this point. Refer to 

Figure 6-7.

Once the Rectangular tool is selected, to create a rectangular selection, 

drag out a marquee. For a square selection add and hold down the Shift 

key while dragging. You can also Alt/Option-drag from a center point. 

Upon releasing the mouse, the selection is created. Refer to Figure 6-7.
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Figure 6-7.  Use the Rectangular Marquee Tool to create rectangular 
and square selections
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On a new layer, try painting with the Clone Stamp Tool or Brush Tool 

within the selection and note how the new pixels will not go beyond the 

borders of the selection. In this instance, I used the Brush Tool so that you 

can visualize the effect clearly, but when blending, clearly the Clone Stamp 

tool is the better choice. You can then use the Eraser tool and remove 

those pixels, but again it will not paint or erase beyond the boundary of the 

selection. Refer to Figure 6-8.

Figure 6-8.  Use the Brush and Clone Stamp tools on a new Layer 
1, and while the selection is active, paint on that layer to reveal the 
painting boundary and erase the painted area with the Eraser Tool
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You can then invert the selection by choosing, from the menu, Select 

➤ Inverse (Shift+Ctrl/CMD+I). Now you can paint with the Brush tool on 

the opposite side of the marquee without crossing over to the area that you 

earlier added the pixels to. Use this command again if you need to return 

to the original setting. Refer to Figure 6-9.

Figure 6-9.  Paint or clone stamp on the inverse side of the selection

To remove the selection quickly, use Select ➤ Deselect (Ctrl/CMD+D). 

This selection is now gone, and you can paint on the entire layer. Refer to 

Figure 6-10.

Figure 6-10.  Deselect the selection and view the results
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A useful key command in the Select menu is Select ➤ All (Ctrl/CMD+A) 

when you want to select the whole layer. Another is Select ➤ Reselect 

(Shift+Ctrl/CMD+D) when you reselect the most recent deselection, and 

you don’t want to use your History panel. However, if you have done several 

steps after your deselection, you may not be able to recover your selections 

using this option. We will look at saving selections later in Chapter 7.

For now, continue to work on Layer 1 as you can always erase any of 

the pixels you paint on this layer for practice or use the Layers panel to 

delete the Layer and then create a new Layer 1 and start again.

To refine the kind of selection you want, use the Options bar panel. 

Let’s look at the panel from left to right. Refer to Figure 6-11.

Figure 6-11.  Rectangular Marquee tool Options bar panel

After the tool’s preset picker are various selection options. Refer to 

Figure 6-12.

Figure 6-12.  Rectangular Marquee tool Options bar panel, tool 
preset picker
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You have already seen these options in Chapter 3 when you worked 

with the Patch and Content-Aware Move Tools. You can drag out a new 

selection if you need to practice.

The first button allows you to create a new selection; next, you can add 

to the selection (Shift-drag), then you can subtract from the selection (Alt/

Option-drag), and lastly you can intersect with another selection (Alt/

Option+Shift-drag). Refer to Figure 6-13.

Figure 6-13.  Four selection options from the Options bar panel
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The next section allows you to feather or soften the edges of the 

selection. By default, it is set to 0px, but the range can go as high as 1000px. 

Before you create a new selection with a feather of 10px, you would set 

this first. Enter the value and then click in another area of the Options bar 

panel to commit the value or drag over the word feather left and right to 

decrease and increase the value. Then drag out the selection on the canvas 

and note that the selection becomes rounded, and the painting is blurrier 

and extends slightly beyond the visual selection. If you set the feathering 

too high, you may receive a warning. After working with the tool, it is 

always best to reset it back to 0px for your next project, if you want a crisp 

selection edge. Refer to Figure 6-14.

Figure 6-14.  Feather settings can be set before a selection is created, 
and if set too high, a warning may appear
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The next option, Anti-alias (to smooth the edge of the transition), is 

grayed out and not available to this tool. Refer to Figure 6-14.

The next section is for the type of marquee style. There are three kinds 

of styles:

Normal: Use this option if you want to create a manual marquee when 

you drag out the selection. Refer to Figure 6-15.

Figure 6-15.  Rectangular Marquee Tool Options bar panel settings 
for Style: Normal

Fixed Ratio: This allows you to set a ratio for the width and height like 

1:1 or 1:2; you would then drag out the selection. You can also swap the 

settings using the arrows button. Refer to Figure 6-16.

Figure 6-16.  Rectangular Marquee Tool Options bar panel settings 
for Style: Fixed Ratio

Fixed Size: This allows you to set a very specific width and height in 

(pixels) px or other increments when you right-click the text fields. Like the 

fixed ratio, you can also swap your settings using the arrows button. Click 

the canvas to add the selection. You can then drag the selection to the 

location you need it to be. Refer to Figure 6-17.
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Figure 6-17.  Rectangular Marquee Tool Options bar panel settings 
for Style: Fixed Size and changes to increment settings

Note that when you want to return to manually creating a marquee, 
set your style back to Normal.
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The last button, “Select and Mask…,” is a more complex workspace 

used to create or refine a selection. We will look at that button in more 

detail later in Chapter 7. Refer to Figure 6-18.

Figure 6-18.  Rectangular Marquee Tool Options bar panel Select 
and Mask button

�Copying Parts of a Layer

Once you create a selection, you can copy that selection of pixels onto 

a new layer. The information presented here can be used with this 

selection tool or any mentioned selection tool within this chapter and 

Chapters 7 and 8.

While the background layer or Layer 0 is selected, use Edit ➤ Copy 

(Ctrl/CMD+C) and then Edit ➤ Paste (Ctrl/CMD+V); this pastes the pixels 

onto a new layer which you can edit without affecting the background. 

The pixels are pasted directly on top of the original but sometimes slightly 

offset, the new layer. The selection border is then removed or deselected. 

Refer to Figure 6-19.
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Figure 6-19.  Copying a selection from the background or Layer 0 to a 
new layer
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Tip A  faster way to copy the selection from the background is to 
try the key command Ctrl/CMD+J, also known as Layer Via Copy. 
You can also right-click the selection and choose this option. This will 
also paste the selection on a new layer directly above the original 
background pixels in this case there will be no offset. Refer to 
Figure 6-20.

Figure 6-20.  Copying a selection from the background or Layer 0 to a 
new layer using the pop-up menu option of Layer Via Copy
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Note that to avoid destroying the original pixels on the background 
or Layer 0, I would avoid using Edit ➤ Cut or Layer Via Cut as you 
can see the result of the visibility turned off on the cut pixels. Refer to 
Figure 6-21.

Figure 6-21.  Cutting a selection from the background or Layer 0 to a 
new layer after using the pop-up menu option of Layer Via Cut

After you create any selection on a new layer, you can select it and 

move it with the Move tool. While the Move Tool is selected, you can also 

use your arrow keys on your keyboard to nudge your selection. Refer to 

Figure 6-22. Remember to use the Options bar panels gear icon to locate 

the “show transform controls” and disable if you do not want to scale or 

see the bounding box while you move the content on the layer.
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Figure 6-22.  Use the Move tool to move the selection on the board 
and view in the Layers panel
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You can also use Edit ➤ Undo or your History panel if you copied or 

removed the wrong pixels by mistake. Refer to Figure 6-23.

Figure 6-23.  Use the History panel to undo your last steps

Note that if there are no pixels on all or part of a layer when you placed 

the selection and you try to Edit ➤ Copy, you will receive a warning 

message. Click OK. You need to make sure to observe, as you work, which 

layer you are currently on when you copy pixels. In this case, you should be 

on Layer 0 to avoid the warning. Refer to Figure 6-24.
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Figure 6-24.  If you try to copy an area on a layer that is transparent, 
you will receive a warning that the selection is empty

If you need to move just the active selection, then don’t select it with 

the Move tool. Remain on the marquee tool and move (mouse-drag or 

nudge with arrow keys) only the selection while the new selection option is 

chosen. This will move all active selection areas at the same time. Refer to 

Figure 6-25.
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Figure 6-25.  Use the current Rectangular Marquee tool set to new 
selection to move the current selection on the canvas

Chapter 6  Masks, Selections, and Filling in the Gaps: Part 1



323

If you need to scale the current selection, then use Select ➤ Transform 

Selection, and this will scale only the selection and not the pixels. Use the 

bounding box handles to manually scale and rotate. Hold down the Shift 

key if you need to scale disproportionately. Refer to Figure 6-26.

Figure 6-26.  You can transform a selection and scale and rotate it
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Click the check in the Options bar panel to commit your new selection 

size. Later in Chapter 8, we will review how to do basic transformations, 

such as scale and rotation, using these transform options. Refer to 

Figure 6-27.

Figure 6-27.  Use the Options bar panel to assist with the 
transformation

Tip  If you create a selection with the Rectangular Marquee tool, you 
can then select the Crop tool, and it will automatically be turned into 
a crop selection. Click back the Rectangular Marquee right away if 
you do not want to turn it into a crop. Refer to Figure 6-28.
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Figure 6-28.  A rectangular selection can be cropped with the 
Crop tool or, before doing that, returned to a selection using the 
Rectangular selection tool

Note that for very thin 1px-sided rectangular selections, I recommend 
using the Single Row Marquee Tool or the Single Column Marquee 
Tool. These tools will allow you to create a new selection, add, 
subtract, or intersect with the current selection with basic feathering 
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(0–1000px), but you cannot set any additional style sizing options 
as it is fixed to 1 pixel and whatever the length or height of the 
document is when you click the canvas. Refer to Figure 6-29.

Figure 6-29.  Single Row and Single Column Marquee Tools with 
Options bar panel settings

However, I do find these tools ideal for when an image has been 

scanned and you have a small 1 pixel border on one or more sides that 

you want to cover with white brush or a clone stamp from source material 

outside of the selection to begin blending and matching the edge of the 

photo. Refer to Figure 6-30.
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Figure 6-30.  Use the Clone Stamp tool in small selections to clean up 
edges and then move the selection and continue to clone stamp

By default, I leave the feather at 0px. Like all selections, they can be 

moved while that selection tool is selected and set to a new area to blend 

other pixels next to it in that column or row. Zoom in using the Zoom tool 

as you work with this kind of selection to get a closer look and then Select 

➤ Deselect to review your work.
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�Elliptical Marquee Tool (M)
The other basic selection tool that I often use in this set is the Elliptical 

Marquee tool for creating elliptical and circular selections. Refer to 

Figure 6-31.

Figure 6-31.  Elliptical Marquee Tool from the Tools panel

Most of the information that you have learned about the Rectangular 

Marquee tool you can apply to the Elliptical Marquee, and you can refer to 

that section for more details.

However, I will point out that to create an elliptical selection, once the 

selection tool is selected, drag out a marquee. For a circular selection, add 

and hold down the Shift key while dragging. You can also Alt/Option-drag 

from a center point. Upon releasing the mouse, the elliptical selection is 

created. Refer to Figure 6-32.
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Figure 6-32.  Creating Elliptical and Circular selections with the 
Elliptical Marquee tool
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The tool’s Options bar panel after the tool’s preset picker is also mostly 

the same as the Rectangular Marquee tool, and you can review that section 

for more information regarding selection options of new, add, subtract, 

and intersect. Look from left to right at the Options bar panel. Refer to 

Figure 6-33.

Figure 6-33.  Elliptical Marquee tool Options bar panel set to new 
selection

I will just point out that after the Feather option (0–1000px), you 

will now have the option of choosing to enable or disable the Anti-alias 

checkbox for smooth edges of the transition; by default, it is enabled. 

If disabled, the edges are very jagged, which is not good for a curved 

transition. Refer to Figure 6-34.
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Figure 6-34.  Elliptical Marquee tool Options bar panel with and 
without Anti-alias selected before a selection is made and then 
brushed within the selection

Style options (Normal, Fixed Ratio, and Fixed Size) are also available 

to scale the ellipse selection, like the Rectangular Marquee. Refer to 

Figure 6-35.
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Figure 6-35.  Elliptical Marquee tool Options bar panel, Style settings 
and Select and Mask button

Note that we will review the Select and Mask button later in Chapter 7.

As with the other selections, you can move the selection when the tool 

is selected, and the option is set to New Selection; use Select ➤ Transform 

Selection when you want to scale.

I often use this selection option with Layer Masks and Adjustment or 

Fill layers to create a type of rounded faded halo or oval vignette around an 

image, which we will look at more in Volume 2. However, Chapter 8 in this 

volume will give you some clues as to how to apply the selection to a layer 

mask. Refer to Figure 6-36.
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Figure 6-36.  Creating a masked vignette around an image

�Modifying the Selection via the Menu

The selection menu has several other options that you can explore to 

modify your selection further. I will demo with an Elliptical Marquee 

selection in a File ➤ New document for practice. In the menu, go to Select 

➤ Modify and choose one of the submenu options. In their dialog boxes, 

you can enter settings and click OK to alter the selection. Let’s review them 

now. Refer to Figure 6-37.
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Figure 6-37.  Select menu Modify options

Border (1–200px): This allows you to create a border around the 

current selection. Refer to Figure 6-38.

Figure 6-38.  Border Selection dialog box with filled selection example

Smooth (1–500px): This will create a smoother selection based on the 

sample radius of pixels with more rounded corners. Smooth on an already 

curved selection may have little effect. You can also apply the effect to the 

canvas bounds. Refer to Figure 6-39.
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Figure 6-39.  Smooth Selection dialog box with filled selection 
examples without and with smoothing

Expand (1–500px): This will cause the selection to get larger by a set 

number of pixels. You can also apply the effect to the canvas bounds. Refer 

to Figure 6-40.

Figure 6-40.  Expand Selection dialog box with filled 
selection example
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Contract (1–500px): This will cause the selection to get smaller by a set 

number of pixels. You can also apply the effect to the canvas bounds. Refer 

to Figure 6-41.

Figure 6-41.  Contract Selection dialog box with filled 
selection example

Feather (0.1–1000px): This is similar to the feathering found in the 

Options bar panel. However, it is applied after the selection has been 

created. You can set the feather radius by a set number of pixels. You can 

also apply the effect to the canvas bounds. Refer to Figure 6-42.
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Figure 6-42.  Feather Selection dialog box with filled selection 
examples without and with feather

The two other options found in the Select menu are Grow and Similar. 

Grow can expand around a current selection, and Similar can be used to 

select similar colored pixels. However, neither of these have dialog boxes to 

control the settings.

After you have tried each of these selection modify options, you can 

see when painting with the Brush Tool or Clone Stamp Tool or erasing with 

the Eraser Tool how the placement of the selection border is altered and 

sets a new boundary for where the pixels can be placed.

As you move forward in the chapter, apply what you have learned so far 

to other selection tools.
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�Lasso Tools for Custom Selections
The next set of selection tools are for more complex selections; they 

are the Lasso Tool, Polygonal Lasso Tool, and Magnetic Lasso Tool. 

Additionally, a new Tool has been added to this section called the 

Selection Brush Tool (L). While we will not be going into any detail in 

this book, it will allow you to paint a selection (add or subtract) with the 

brush adjusting the opacity, size, and hardness on the layer using an 

overlay color (see gear icon). Afterwards, you can activate this selection by 

selecting one of the other selection tools from the Tools panel. For more 

details refer to this link: https://helpx.adobe.com/photoshop/using/

selecting-lasso-tools.html#selection-brush. Refer to Figure 6-43.

Figure 6-43.  Tools panel’s various Lasso Tools

�Lasso Tool (L)
When you need to make a quick and loose selection around some pixels, 

the Lasso Tool is ideal for making selections that are neither rectangular 

nor elliptical. Refer to the information about the Rectangular Marquee 

Tool and Elliptical Marquee tool for more information on your options. For 

this tool, drag and draw out a selection. Even if you don’t join the selection, 

when you release the mouse, it will automatically close, joining the 

selection. Continue, in this example, to use the copy of tower_selection_
image.psd to practice. Refer to Figure 6-44.
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Figure 6-44.  Using the Lasso tool to create a loose selection

Look from left to right at the Options bar panel. Refer to Figure 6-45.

Figure 6-45.  Lasso Tool Options bar panel options

After the tool’s preset picker area are the same selection options for 

working with the Rectangular Marquee Tool. However, you would loop 

to create New Selection, Add To selection, Subtract from selection, and 

Intersect with selection. Next, you can feather (0–1000px) the selection; 

by default, it is set to 0px, and like the Elliptical Marquee tool, you will 

have access to enable or disable the Anti-alias setting to smooth edge 

transitions; by default, it is enabled.
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The other option, “Select and Mask” button, is a more advanced 

workspace; see that section later in Chapter 7.

Remember to set your setting in the Options bar panel back to new 

selection when you want to start a new selection or move the current 

selection using this tool.

�Polygonal Lasso Tool (L)
This tool is very similar to the Lasso Tool. However, it is used to create 

more angular selections. By clicking out points, you could use it to create 

triangular or multisided selections. You close the selection when you hover 

over the original starting point and a zero appears. You can Shift-click out 

selection lines for 45° and 90° angles. Use the Backspace/Delete key when 

you need to revert back a step. Refer to the Rectangular Marquee tool for 

more details. Refer to Figure 6-46.
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Figure 6-46.  Creating a tighter selection with the Polygonal Lasso
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Look from left to right at the Options bar panel. Refer to Figure 6-47.

Figure 6-47.  Polygonal Lasso Tool Options bar panel options

After the tool’s preset picker area are the same selection options for 

working with the Rectangular Marquee Tool. However, you would click out 

to create a New Selection, Add To selection, Subtract from selection, and 

Intersect with selection. Next, you can feather the selection; by default, 

it is set to 0px, and like the Elliptical Marquee tool, you will have access 

to enable or disable the Anti-alias setting to smooth edge transitions; 

by default, it is enabled. The other option, “Select and Mask,” is a more 

advanced workspace; see that section later in Chapter 7.

�Magnetic Lasso Tool (L)
This tool shares similarities with the Lasso and Polygonal Lasso tools. 

However, it has the ability of sticking to certain pixels to make a very close 

and accurate selection based on the setting chosen in the Options bar 

panel. Just click and then drag or hover and click, and the anchor points 

and segments of the selection will attach themselves. Like the Polygonal 

Lasso Tool, you can close the selection when you return to the final 

point, and the cursor will show an O. Then click to complete or you can 

double-click, and the selection will close itself. While you hover, use the 

Backspace/Delete key when you need to revert back a step, while using 

the Magnetic Lasso, if you find the points are getting tangled. Refer to 

Figure 6-48.
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Figure 6-48.  Creating a very close selection with the Magnetic 
Lasso Tool

Refer to the Rectangular Marquee Tool for more details. Look from left 

to right at the Options bar panel. Refer to Figure 6-49.

Figure 6-49.  Magnetic Lasso Tool Options bar panel options

After the tool’s preset picker are the same selection options as 

when working with the Rectangular Marquee Tool. Drag to create a 

New Selection, Add To selection, Subtract from selection, and Intersect 
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selection. Next, you can feather (0–1000px) the selection; by default, it 

is set to 0px, and like the Elliptical Marquee tool, you will have access to 

enable or disable the Anti-alias setting to smooth edge transitions; by 

default, it is enabled.

The next section controls how the Magnetic Lasso responds.

Width: Set the distance from the edge to consider for path (1–256px); 

by default, it is set to 10px.

Contrast: Set the contrast of edge to consider for path (1–100%); by 

default, it is set to 10%.

Frequency: Set the frequency at which the points are added to the path 

(0–100); by default, it is set to 57.

“Use tablet pressure to change pen width” is enabled, and you can use 

this option if you are working with a stylus. Refer to Figure 6-50.

Figure 6-50.  Magnetic Lasso Tool Options bar panel options to 
control width, contrast, frequency, pressure, and Select and Mask

The other option, “Select and Mask” button, is a more advanced 

workspace; see that section later in Chapter 7.

The Magnetic Lasso Tool is ideal for selecting those tricky selections 

quickly, for example, around the statue of this unicorn. Try this tool on an 

open duplicate of the file unicorn.psd. Refer to Figure 6-51.
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Figure 6-51.  Use the Magnetic Lasso tool around the unicorn for a 
fairly accurate selection
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As you go around with the Magnetic Lasso, you can use the Zoom 

key command of Ctrl/CMD++ to get closer and then use your Hand tool 

(Spacebar) to navigate without deselecting by mistake when you reach 

your original point. Or double-click with your mouse to complete the 

selection.

Adjusting these options in the panel bar may improve your ability to 

select as the current settings may not select it all accurately. However, 

every project is different, and you will likely want to refine your selection 

afterward, which we will begin to explore next.

Note T he Pen tool, which will be mentioned in Volume 2, can also 
help create a selection using anchor points. Refer to Figure 6-52.

Figure 6-52.  Tools bar panel’s Pen tool is another tool that can be 
used to create a selection

�Refining the Selection with Quick Mask Mode (Q)
No matter what kind of selection tool you choose, often you will either 

select not enough or too much. You can see this when I tried to select the 

horn on the unicorn with the Magnetic Lasso tool or the roof on the tower. 

Some of the selection goes slightly into the sky, while other areas did not 

cover the roof adequately. Refer to Figure 6-53.
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Figure 6-53.  You need to refine a selection when not all the pixels are 
selected as accurately as possible

In these situations, the trick, while the current selection is active, is 

to use the Tools panel Quick Mask Mode, which you can easily access by 

pressing the letter Q on your keyboard. You will know you are in that mode 

when the layer you are on turns red and the red mask on the image will 

appear, in this case, surrounding the tower. Refer to Figure 6-54.
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Figure 6-54.  Edit in Quick Mask Mode when you need to refine your 
selection

While in Quick Mask Mode, you can either use your Brush tool or 

Eraser tool to refine your selections without erasing pixels. Refer to 

Figure 6-55.
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Figure 6-55.  Use the Brush or Eraser Tool when you want to paint a 
selection in Quick Mask Mode

I personally prefer to use my Easer tool because I have the modes of 

Brush and Block as you saw in Chapter 4. Refer to Figure 6-56.

Figure 6-56.  The Eraser tool has three different modes for refining 
and painting in a selection
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For this example, you can vary the brush size using a soft (0% 

hardness) or hard brush (100% hardness) and then press the D key on your 

keyboard to set the Tools panel back to the default swatches of black and 

white. Refer to Figure 6-57.

Figure 6-57.  Toggle in the Tools panel between showing and hiding 
areas while painting in Quick Mask Mode

For the Eraser tool, when you want to remove part of a selection, paint 

with white in the foreground, and to reveal, press X, with black in the 

foreground. Toggle (X) between black to reveal (adding to selection) and 

white to hide (subtracting from selection). Note that the Brush tool uses 

opposite settings for black (hide/subtract) and white (reveal/add), but 

you can still use the X key to toggle. Regardless of which tool you choose 

the red area by default is considered in here the masked area. Refer to 

Figure 6-58.
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Figure 6-58.  Paint with the Eraser tool to show and hide area with 
the mask in Quick Mask Mode
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While zoomed in, you can use your Hand Tool (Spacebar) to navigate. 

Also, try, with your Brush or Eraser, to click one point and then Shift-click 

at another point if you want to create a straight selection from one point to 

the next. Refer to Figure 6-59.

Figure 6-59.  Paint quickly on straight edges using the click and Shift- 
click method

In my example, I used a small soft brush preset to make the selection.

Use Shift-drag for straight vertical and horizontal lines.

Continue to clean up your selection as you work with the Eraser or 

Brush Tool. You may also want to paint some of the mask into the door 

opening if you do not want this to be part of your selection. Refer to 

Figure 6-60.
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Figure 6-60.  While in Quick Mask Mode and outside of Quick Mask 
Mode with the selection active

When you want to exit Quick Mask Mode, press Q again. You will then 

be returned to the “Marching Ants” selection. Toggling between mask on 

and off can be helpful as you refine your selection.

Note that if you do not like the red mask due to the fact that your image 

has a lot of red areas, you can change the options by double-clicking the 

icon in the Tools panel. I leave it at the default of red, and I make sure 

that the color indicates Masked Areas and not Selected Areas. Refer to 

Figure 6-61.
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Figure 6-61.  Exit Quick Mask Mode using the Tools panel or now set 
Quick Mask Options in the dialog box

Many complex selections use a mask or overlay, and you will see that as 

you progress through this chapter and Chapters 7 and 8. Note that you can 

use the new Selection Brush Tool as an alternative to the Quick Mask Mode, 

refer to the link mentioned earlier if you need more details on that topic.

If you would like to save your selection at this point you can do that 

using the option (Select ➤ Save Selection) and after entering the details 

and name of the selection in the dialog box it will be saved in the Channels 

panel. You can refer to that section later in Chapter 7 for more details 

or continue with the next set of selection tools. In my tower_selection_
image_final.psd file, I have saved the selection for you to compare. This 

selection can later be used to create a Layer mask in Chapter 8. Refer to 

Figure 6-62.
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Figure 6-62.  Tower selection has been saved in the Channels panel

Save (File ➤ Save) any open documents you have at this point.

�Summary
In this chapter, we reviewed several selection tools and looked at how to 

enter, edit, and exit from Quick Mask Mode using tools from Chapters 3–5. 

In the next chapter, we will continue to look at a few more selection tools, 

the Select and Mask workspace, and how to save and load selections.
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CHAPTER 7

Masks, Selections, 
and Filling in the 
Gaps: Part 2
In this chapter, we will be continuing the discussion on selection 

tools from Chapter 6. Then we will be working in the Select and Mask 

workspace. We will look at additional selection options for color range, 

focus area, and sky and finally discover how to save and load selections.

Note this chapter does contain projects found in the Volume 1 
Chapter 7 folder.

Note some of the tools I discuss in this chapter can also be found 
in my book Accurate Layer Selections Using Photoshop’s Selection 
Tools.  In that book, the focus was on working with illustrations; 
however, in this book, the focus will be on photos that are digitally 
repaired.

https://doi.org/10.1007/979-8-8688-0450-2_7
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�Complex Selection Tools
As selections become more complex, you need to rely on other selection 

tools. The three that are used here are the Magic Wand Tool, Object 

Selection Tool, and Quick Selection Tool. Refer to Figure 7-1.

Figure 7-1.  Tools panel has three complex selection tools

Let’s look at those tools next. You can use a duplicate (Image ➤ 

Duplicate) of the tower_selection_image_final.psd file to practice.

�Magic Wand Tool (W)
When you need to select areas of similar colors, the Magic Wand tool 

can help you do that. Many of the selection options are similar to the 

Rectangular Marquee tool, so you can refer to that section for more details 

in Chapter 6. Click an area of color, such as the sky, if you want to select it 

and then use the Shift key when you want to add to the selection. You can 

use Edit ➤ Undo (Ctrl/CMD+Z) if you want to go back a step in what you 

have selected. Refer to Figure 7-2.
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Figure 7-2.  Use the Magic Wand tool to select various clouds 
in the sky

Look from left to right at the Options bar panel. Refer to Figure 7-3.

Figure 7-3.  Magic Wand Tool Options bar panel

After the tool’s preset picker, you will find the same selection options 

as the Rectangular Marquee tool in Chapter 6: New Selection, Add To 

selection, Subtract from selection, and Intersect with selection.

The next option is the sample size, which refers to the number of pixels 

sampled by the tool. Refer to Figure 7-4.
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Figure 7-4.  Magic Wand tool Options bar panel with the list of 
sample size options

This is similar to the Eyedropper Tool (I) which samples color pixels as 

well for the purpose of creating a swatch as seen in the Tools panel. Refer 

to Figure 7-5.

Figure 7-5.  Eyedropper Tool Options bar panel can add a new 
swatch to the Tools foreground

However, when the Magic Wand Tool samples, upon click it creates a 

selection. The sample size by default is set to point sample, but there are 

other presets you can access from the drop-down list, such as 3x3 Average, 

which will sample a larger area. Refer to Figure 7-4.

The next setting is tolerance (0–225), which sets the range when 

sampling colors. Generally, when sampling colors, I will leave it at the 

default of 32, but sometimes a lower setting will give you a more precise 
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selection. In the case of the sky, to select more of it faster, I may want to 

raise the setting to about 100, which would get most of the sky-blue area 

selected in one click. Refer to Figure 7-6.

Figure 7-6.  Magic Wand tool Options bar panel with the tolerances 
changed from 32 to 100, resulting in a faster selection in the image
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However, this tolerance choice can vary from project to project. So, 32 

is a good starting point.

By default, anti-alias is enabled to smooth the edge transition. 

Contiguous is also enabled when you want to sample bordering pixels to 

make a larger selection, as I have done here.

Sample All Layers by default is disabled and is fine when you are 

selecting from the background layer (Layer 0), but you should enable 

this setting, for example, if you are working on the above (Layer 1) when 

you want to sample colors from that layer or multiple layers to get a more 

accurate selection. Refer to Figure 7-7.

Figure 7-7.  Layers panel working with the Magic Wand Tool options 
on Layer 1 with Sample All Layers active
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The next settings, Select Subject and Select and Mask, are more 

complex settings and workspaces, which we will review after discussing 

the next two selection tools. Refer to Figure 7-8.

Figure 7-8.  Magic Wand tool Options bar panel with Select Subject 
and Select and Mask buttons

As you click and Shift-click to add to your selection, for example, you 

may want to add the blue sky that is inside of the tower to your selection. 

Note that, as you work, you can enter and exit the Quick Mask Mode (Q) 

at any time and refine your selection. In this case, I may want to clean 

up the selection around the top of the tower, as when I selected a higher 

tolerance, it selected this area as well. Refer to Figure 7-9.
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Figure 7-9.  Viewing the selection of the sky in Quick Mask Mode 
reveals that some of the tower was selected as well because it had a 
similar color contrast threshold or tolerance with the sky

So, I would likely spend some time zoomed in with my Brush or Eraser 

Tool masking that area of the selection, then exit Quick Mask Mode to 

review the selection again. Refer to Figure 7-10.
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Figure 7-10.  Use the Eraser tool in Quick Mask Mode to clean up the 
sky selection and then exit Quick Mask Mode to review

�Object Selection Tool (W)
The Object Selection Tool is used to quickly select objects that it recognizes 

and creates a surrounding selection. It has some similar selection features 

like the Rectangular Marquee tool, but many differences as well. How you 

select depends on what mode and settings are enabled in the Options bar 

panel. Let’s continue with the unicorn.psd example used in Chapter 6. 

Refer to Figure 7-11.
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Figure 7-11.  Use the Object Selection tool for a quick selection of 
the unicorn

Look from left to right at the Options bar panel. Refer to Figure 7-12.

Figure 7-12.  Object Selection Tool Options bar panel

After the tool’s preset picker, you will find the same selection options as 

the Rectangular Marquee tool: New Selection, Add, Subtract, and Intersect 

with selection. In this example, we want to create a New Selection, but we 

are going to let the Object Finder do the work for us.
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When using this tool, make sure that the Object Finder checkbox is 

enabled. This will then allow you access to the next set of buttons. The 

refresh button (rotating arrows) allows you to refresh the selection setting 

for the Object Finder. Refer to Figure 7-13.

Figure 7-13.  Object Selection Tool Options bar panel with various 
Object Finder settings that can be accessed from the gear menu

The next button (square with three inner shapes) allows you to show 

all objects (hold down the N key if you need to toggle the preview mode). 

Even some bushes have the potential of being selected if that was your 

intent. Refer to Figures 7-13 and 7-14.
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Figure 7-14.  Multiple objects could be selected using the Object 
Selection tool

The gear icon (see Figure 7-13) has additional options that control the 

overlay, such as Object Subtract which finds and automatically subtracts 

an object within a defined region. This could be the area between the 

unicorn’s front legs. Object Finder mode is by default set to auto refresh 

radio button, but you can change the setting to manual refresh by selecting 

that option. The other Overlay Options are for Color (Magenta), Outline 

(1.5px), Opacity (100%), and whether to show the overlay (auto, always, or 

never). Leave at the Auto radio button setting.

The next setting is the mode of selection. You can either use a 

Rectangular Marquee called Rectangle to create your selection or the 

option of Lasso. Refer to Figure 7-15.

Figure 7-15.  Object Selection Tool Options bar panel’s mode options
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As you saw earlier with the Lasso tool, the mode of Lasso may get you a 

closer accurate selection. Refer to Figure 7-16.

Figure 7-16.  Use the mode of Rectangle or Lasso to get Object Finder 
to detect what you want to select

However, rather than dragging over or around the object because 

Object Finder is already set to detect the unicorn, simply clicking with your 

tool is enough regardless of the mode. Refer to Figure 7-17.
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Figure 7-17.  An accurate selection was created of the unicorn using 
the Object Selection Tool

The next option, Sample All Layers, by default is disabled, but when 

you want to sample colors from multiple layers to get a more accurate 

selection, enable this setting. Refer to Figure 7-18.
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Figure 7-18.  Object Selection Tool Options bar panel with Hard Edge 
settings enabled and the current selection

The next option is Hard Edge, which when enabled enforces a hard 

edge on the selection. The next button is an alert that allows you to provide 

feedback on the selection results. Refer to Figure 7-19.
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Figure 7-19.  Object Selection Tool Options bar panel 
feedback button

In this example, I thought this tool did a much better job and was faster 

than the Magnetic Lasso tool.

The next options, Select Subject and Select and Mask, are more 

complex settings and workspaces, which we will review after discussing 

the next selection tool. Refer to Figure 7-20.

Figure 7-20.  Object Selection Tool Options bar panel with the Select 
Subject and Select and Mask buttons

As with other selection tools, you can enter and exit the Quick Mask 

Mode (Q) at any time and refine your selection as you work, for example, 

the area around the hoofs or horn which may need some refinement. Refer 

to Figure 7-21.
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Figure 7-21.  The selection around the horn of the unicorn may need 
some refinement in Quick Mask Mode

You can review this selection that I saved in the unicorn_final.psd 

file. Likewise, try this tool on the tower_selection_image_final.psd and 

compare the results.
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�Quick Selection Tool (W)
The Quick Selection tool in some ways operates similarly to a brush 

to create a wide range selection when you drag over an area. Use a 

duplicate (Image ➤ Duplicate) of the file squirrel_selection.psd. Refer to 

Figure 7-22.

Figure 7-22.  Use the Quick Selection Tool when you want to create a 
selection around a furry creature
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Note that you may prefer to use the Object Selection Tool for this 

example. However, sometimes, when you add to or subtract from a 

selection quickly around the fur or hair, this can be a better option, as there 

may be situations where the Object Selection Tool fails to recognize the 

object, or you don’t want to enter Quick Mask Mode right away.

For the Quick Selection Tool, look from left to right at the Options bar 

panel. Refer to Figure 7-23.

Figure 7-23.  Quick Selection Tool Options bar panel

After the tool’s preset picker, you can use the brush buttons to create 

a new selection, add to the selection, or subtract from the selection. The 

default setting is add, since you want the selection to increase. If you want 

to remove some of the selection, switch to that option and paint out some 

areas. Refer to Figure 7-24.

Figure 7-24.  Quick Selection Tool Options bar panel for creating 
new, adding to, or subtracting from the selection
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The brush options drop-down list allows you to set the selection 

brush’s size, hardness, spacing, angle, roundness, and dynamic control size 

(off, pen pressure, or stylus wheel). As you switch between brush options, 

the settings will remain the same. Refer to Figure 7-25.

Figure 7-25.  Quick Selection Tool Options bar panel for 
brush options

The next option again is the brush angle that is the same as the one 

displayed in the brush options. Refer to Figure 7-26.

Figure 7-26.  Quick Selection Tool Options bar panel for Angle, 
Sample All Layers, Enhance Edge, Select Subject, and Select and 
Mask buttons
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Sample All Layers by default is disabled, but when you want to sample 

colors from multiple layers to get a more accurate selection, enable this 

setting. The next setting is Enhanced Edge; when enabled, it allows for the 

selection’s edge to automatically reduce the roughness or jaggedness of the 

selection boundary. Areas around the squirrel’s tail might be best for this 

setting. Refer to Figure 7-27.

Figure 7-27.  Quick Selection Tool Options bar panel with Enhance 
Edge enabled

The selection flows closer to the subject’s boundaries applying the 

edge refinement.

This can be done manually in the Select and Mask workspace as you 

will see shortly.

The next button is Select Subject, which we will explore in more 

detail now.

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



378

�Understanding the Select Subject Button
The Select Subject button, as you have noticed, is included with the Magic 

Wand, Object Selection, and Quick Selection tools. This option can also be 

accessed via the Select menu. Refer to Figure 7-28.

Figure 7-28.  Quick Selection Tool Options bar panel with Select 
Subject button options

The purpose of this button is to create a selection from the most 

prominent objects in the image; by default, it is set to Device for quicker 

results, but you can also set it to Cloud for detailed results. Leave on Device 

for now. When you click this button and you already have a selection, click 

OK to the message, and a new selection will be created around the object. 

Refer to Figure 7-29.

Figure 7-29.  Warning message that appears when the Select Subject 
button is clicked and a selection is already active

In this example, you will notice that the squirrel’s feet were removed from 

the selection because they are a close color match with the brown wood. In 

this case, you could return to the Quick Selection tool and paint back (Add to 

Selection) that part of the selection now missing. Refer to Figure 7-30.
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Figure 7-30.  Select Subject may not select all parts of the squirrel, 
and you may need to use the Quick Selection tool to paint back parts 
of the selection

As with other selection tools, you can enter and exit the Quick Mask 

Mode (Q) at any time and refine your selection as you work with the Brush 

or Eraser tools, such as the fur on the squirrel’s tail, or you can use the next 

button called Select and Mask.
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�Working with the Select and Mask Workspace
The Select and Mask button, which is available to all the selection tools, 

which we have discussed so far in this chapter and the marquee and lasso 

tools in Chapter 6, after you have created your selection allows you to work 

in a complex workspace for further editing and refinement of the selection. 

This workspace can also be accessed via the Select menu (Select ➤ Select 

and Mask).

In my book that I mentioned at the beginning of this chapter, I have 

used this workspace to refine a selection on an illustration. However, Select 

and Mask is ideal for photos where you have a lot of fine details that need 

selection, such as hair and fur. We will continue to work on the squirrel 

selection on the background layer. Refer to Figure 7-31.

Figure 7-31.  In the Layers panel, I am on the Background Layer 
when the Select and Mask button is clicked
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Let’s explore that area now by clicking that button to enter the 

workspace.

This workspace has several tools, an Options bar, and a Properties 

panel for creating your mask selection. Refer to Figure 7-32.

Figure 7-32.  Working in the Select and Mask workspace

The tools that you can use in this section are described here and can be 

found on the left-hand side of the workspace, while the Properties panel is 

found on the right. Refer to Figure 7-33.
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Figure 7-33.  Select and Mask workspace tools and Properties panel 
in View Mode

Note I will explain the Properties panel in a moment, but for now, your 

view is set to Onion Skin (O) which shows a semitransparent area around 

your selection. However, as you work you may preview to set your view to 

Marching Ants (M) as you have seen with other selections. For now, leave 

on Onion Skin mode. First, we will review the tools and then look at those 

viewing properties later.

�Quick Selection Tool (W)

Similar to the Quick Selection Tool outside of the workspace, this tool 

allows you to paint by clicking and dragging a selection mask based on 

color and texture similarities. Refer to the Options bar panel and look from 

left to right. Refer to Figure 7-34.
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Figure 7-34.  Select and Mask workspace tools Quick Selection Tool 
Options bar panel

As you paint, the options let you add to the selection or subtract from 

the selection and change the brush size (1–5000). Here, I added a bit more 

selection around the squirrel’s tail. Refer to Figure 7-35.

Figure 7-35.  Paint with the Quick Selection Tool to add more of the 
squirrel fur on the tail to the selection
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If there is more than one layer, you can choose to Sample All Layers; 

however, if you are working on the current layer to create a selection, then 

leave this option unchecked. Refer to Figure 7-34.

Within the workspace, you can also use the same settings of Select 

Subject when you want to create a selection from the most prominent 

objects in the image. By default, it is set to Device. Refer to Figure 7-36.

Figure 7-36.  Select and Mask workspace tools Quick Selection Tool 
Options bar panel, Select Subject and Refine Hair buttons

However, there is a new button in this area called Refine Hair which is 

available to all the selection tools in this workspace.

Refine Hair is used when you want to find and refine hair around the 

selection. Adobe recommends that you use it when you have set the Refine 

Mode of Object Aware in the Properties panel. We will look at that area 

after reviewing the rest of the workspace’s tools. However, you can click 

that button now to see the results as it appears to feather that area around 

the furry tail a bit more. Refer to Figure 7-37.
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Figure 7-37.  Try the Refine Hair button on the squirrel and preview 
the results

�Refine Edge Brush Tool (R)

This tool is also for selections and is very similar to the Brush tool in this 

workspace, but it is used for refining the edge or border areas of your 

selection. You can brush over an area like hair and fur to get finer selection 

details. Try brushing around some of the furry edges of the squirrel’s body 

to practice.

Refer to the Options bar panel, and looking from left to right, you will 

notice that it shares many of the same options as the Quick Selection Tool. 

Refer to Figure 7-38.
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Figure 7-38.  Select and Mask workspace tools Refine Edge Brush 
Tool Options bar panel

However, unlike the Quick Selection Tool, while you add (expand 

detection area) and subtract (restore orignal edge) from your selection, 

you have more options to change the brush’s size, hardness, spacing, angle, 

roundness, as well as dynamic control size options if using a stylus. Refer 

to Figure 7-39.

Figure 7-39.  Select and Mask workspace tools Quick Selection Tool 
Options bar panel Brush options
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The angle of the brush can also be set outside the drop-down list. Refer 

to the Quick Selection tool if you need more details on the setting of the 

Sample All Layers checkbox, Select Subject button, and Refine Hair button. 

Refer to Figure 7-38.

�Brush Tool (B)

After using the Quick Selection Tool and Refine Edge Brush tool, you 

can use the Brush tool to clean up remaining details by adding to or 

subtracting from the selection. The options for this tool, found in the 

Options bar panel, are similar to the previously mentioned tools, Quick 

Selection and Refine Edge Brush. Refer to those tools if you need more 

details on Brush options list, angle, Sample All Layers, and the Select 

Subject and Refine Hair buttons. Refer to Figure 7-40.

Figure 7-40.  Select and Mask workspace tools Brush Tool Options 
bar panel set to add to selection

Here, I tried painting a bit with the subtract from selection option 

outside the squirrel as I noticed that some areas outside of its fuzzy tail on 

the right were also being picked up. Refer to Figure 7-41.
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Figure 7-41.  Select and Mask workspace tools Brush Tool Options 
bar panel set to subtract from selection and painting out areas on the 
right of the squirrel’s tail
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�Object Selection Tool (W)

The Object Selection tool is basically identical to the same tool outside of 

the workspace. Drag out a Rectangular Marquee or Lasso loop around the 

object you want to select. Refer to Figure 7-42.

Figure 7-42.  A quicker selection of most of the squirrel could be done 
in the Select and Mask workspace with the Object Selection tool

Or in this case, just click. The Object Finder uses the application to 

identify and detect select objects within an image and then creates and refines 

the current selections. You can refer to the section on Object Selection tool 

earlier in the chapter. However, I will just mention that this tool in the Select 

and Mask workspace assumes that a selection is already present, and so no 

new selection button is available; you either add, subtract, or intersect with 

the selection. Be aware of this difference should other selections you made 

surrounding the squirrel be added to this selection as well. You may need to 

then subtract those unrequired objects.
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For reference, view the Options bar panel from left to right. Refer to 

Figure 7-43.

Figure 7-43.  Select and Mask workspace tools Object Selection Tool 
Options bar panel

The other settings which are the same are Enable the Object Finder 

checkbox, refresh icon, and show all objects option button. Set any addition 

options using the gear icon drop-down menu. Refer to Figure 7-43.

Then choose the selection mode of either rectangle or lasso. You 

can choose to enable the settings of “Sample All Layers” and Hard Edge 

checkboxes. Next to the feedback button is the Select Subject and Refine 

Hair buttons; refer to the Quick Selection Tool if you need more details on 

those settings. Refer to Figure 7-44.

Figure 7-44.  Select and Mask workspace tools Object Selection Tool 
Options bar panel set to Rectangle or Lasso mode

After using this tool, you can return to the other previously mentioned 

tools at any time to clean up your selection.

�Lasso Tool (L) and Polygonal Lasso Tool (L)

These last two selection tools are found together and are basically the same 

as the tools found outside the workspace and mentioned in Chapter 6.  

Use the Lasso when you want to loop around and create a selection in a 

free hand style or use the Polygonal Lasso when you want to quickly create 
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straight edge segments for a selection. Remember, with the Polygonal 

Lasso, to close your selection when you click the starting point and the O 

symbol appears or double-click. Use the Delete/Backspace key if you need 

to go back a step as you create the selection. Refer to Figure 7-45.

Figure 7-45.  Select and Mask workspace tools Lasso and 
Polygonal Lasso

Unlike the tools outside the workspace, here there is no New selection 

button; you can either add, subtract, or intersect with the selection. Refer 

to the Options bar panel from left to right. Refer to Figure 7-46.

Figure 7-46.  Select and Mask workspace tools Lasso Tool Options 
bar panel

Refer to the Quick Selection tool if you need more details on the 

Sample All Layers checkbox, the Select Subject button, and the Refine 

Hair button.

In this example, neither of these tools are required, but be sure to test 

them on your own projects.

�Hand Tool (H)

As you have seen from Chapter 2 and onward, make sure to use your Hand 

tool when you need to navigate around an image, especially if you are 

zoomed in. The Hand tool Options bar also allows you to scroll all opened 

document windows, if more than one document is open, as well as zoom 

in to 100%, Fit Screen, or Fill Screen when you click that button. Refer to 

Figure 7-47.
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Figure 7-47.  Select and Mask workspace tools Hand Tool Options 
bar panel

While in the workspace, you can still use the Spacebar key to access 

the tool.

�Zoom Tool (Z)

Use the Zoom Tool and its options to zoom in and magnify or zoom out. 

In the Options panel bar, there are some similar settings to the Hand tool. 

However, you can also enable the settings of Resize Windows to Fit, Zoom 

All Windows, and Scrubby Zoom. Refer to Figure 7-48.

Figure 7-48.  Select and Mask workspace tools Zoom Tool Options 
bar panel

While in the workspace, you can also use the commands of Ctrl/

CMD++, Ctrl/CMD+-, and Ctrl/CMD+0.

Note  In this workspace, you do not have access to the History 
panel; use Ctrl/CMD+Z if you need to undo a step.

�Properties Panel

The panel on the right is the Properties panel, which can also help you 

view and refine the selection. Its settings change based on which view you 

choose in View Mode. Refer to Figure 7-49.
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Figure 7-49.  Select and Mask workspace tools Properties panel with 
view options
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View Mode

This mode allows you to set how you want to view your selection, and 

you can use the drop-down menu to choose different modes such as the 

following:

Onion Skin (O): View against a semitransparent background. This 

transparency can be adjusted with the slider (0–100%). I left this setting at 

20% transparency in the examples shown earlier. Refer to Figure 7-49.

Marching Ants (M): Like the selections outside the workspace, this 

makes it appear like moving dashed lines, known as marching ants. It 

can also reveal some areas that you may still not have selected or masked 

enough. Refer to Figure 7-50.

Figure 7-50.  Properties panel View Mode Marching Ants
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Overlay (V): Similar to a Quick Mask Mode, you can set a red overlay to 

work with your tools. You can also control the overlay’s opacity (0–100%), 

color using the color picker, and “Indicates” in that overlay for Masked 

Areas or Selected Areas using the list. Leave on Masked Areas. I set my 

opacity at 48% as 100% is a bit too intense to look at while masking. Refer 

to Figure 7-51.

Figure 7-51.  Properties panel View Mode overlay and options

On Black (A): This places the selection on a black background area; 

you can set the Opacity level slider (0–100%). The default is 50%. However, 

for dark animals like the squirrel, this may not be an ideal color. Refer to 

Figure 7-52.
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Figure 7-52.  Properties panel View Mode On Black and Opacity slider

On White (T): This places the selection on a white background area; 

you can set the Opacity level slider (0–100%). The default is 50%. The 

mask in this case is a bit difficult to see as there are a lot of bright areas 

surrounding the squirrel. Refer to Figure 7-53.

Figure 7-53.  Properties panel View Mode On White and Opacity slider
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Black and White (K): This visualizes the selection as black and white. 

This is similar to how it will appear as a layer mask or saved channel 

selection as you will see later in the chapter and Chapter 8. It can give you 

a good idea of whether the mask is fading correctly or not. But in this case, 

you cannot see the actual squirrel. Refer to Figure 7-54.

Figure 7-54.  Properties panel View Mode Black and White

On Layers (Y): The selection is surrounded by an area of transparency. 

This can help us visualize what would actually be selected and could be 

copied to a new layer outside of this workspace. Refer to Figure 7-55.
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Figure 7-55.  Properties panel View Mode On Layers

Pressing the F key will allow you to cycle through the views, while 

pressing the X key to toggle temporarily disables all views.

Depending on the view that you are using, you can set other options. 

Refer to Figure 7-56.
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Figure 7-56.  Properties panel View Mode options outside of the 
View menu

Show Edge (J): This displays the area of refinement created by the 

Refine Edge Brush Tool. By default, this option is disabled, but here is how 

it might appear in Onion Skin View Mode. Refer to Figure 7-57.

Figure 7-57.  Properties panel with Show Edge (J) enabled

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



400

Show Original (P): View the original selection when you started. By 

default, this setting is disabled. Refer to Figure 7-56.

Real-time refinement: This will render an accurate preview of the 

changes. However, while brushing, the update preview may slow down.

High Quality Preview: If enabled, a high-quality preview is displayed; 

when unchecked, a low-quality preview is displayed. Keep unchecked 

while brushing as this may affect performance.

Preset: Once you create your ideal viewing presets, you can save, load, 

and delete them, when you choose that option from the list. The current 

preset is set to default, but you can create your own custom settings as you 

work. They are saved as .SLM files. Refer to Figure 7-56.

Remember settings: When enabled, it remembers the current settings 

should you exit the workspace while working on your selection. Currently, 

I have that setting disabled. Refer to Figure 7-56.

Pause here for a moment to find your ideal View settings and then, 

before continuing with the next settings in your Properties panel, use your 

brush tools to clean up the selection, adding or subtracting as you work. 

I use the Overlay view mode and Brush to clean up my selection. Then I 

switch between the Quick Selection Tool and Refine Edge Brush Tool to get 

a better selection. Adjust your brush size as required; a smaller size may 

give you a better selection. Refer to Figure 7-58.

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



401

Figure 7-58.  Use the Overlay view mode and various brush tools in 
the Select and Mask workspace to continue to refine the selection

View in other view modes to compare, and when happy with your 

selection results, continue on to the next section in the Properties panel.

Refine Mode

When working with the current brushes such as the Refine Edge Brush 

tool, you can choose one of two options. Currently, you have been working 

in Color Aware mode. Refer to Figure 7-59.

Figure 7-59.  Properties panel Refine Mode settings
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Color Aware: Recommended for simple or contrasting backgrounds.

Object Aware: Recommended for hair, fur, or complex background 

when using the Refine Hair button or Edge Detection.

When you switch modes, you will get the following alert message. Click 

OK to proceed or cancel. Refer to Figure 7-60.

Figure 7-60.  Alert that appears when you switch between modes

I’ll click OK and proceed to the next section of the Properties panel 

while in Object Aware mode. At this point, your current selection should 

be unchanged.

Edge Detection

There are two settings in this section. Refer to Figure 7-61.

Figure 7-61.  Properties panel Edge Detection settings
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Radius: This determines the size (0–250px) of the edge of the selection 

of the refinement area. A small radius gives a sharper edge, while a large 

one will give a softer edge. Currently, it has been set to 0 pixels. However, if 

increasing the size of the radius to 80px, you can see that the edge area in 

some areas around the feet increases and blurs. Refer to Figure 7-62.

Figure 7-62.  Altering the radius may change selection around the 
edge of the squirrel

Smart Radius: Enable this option when you want to automatically adapt 

the radius to the image edges. This can allow for variable widths, such as 

when dealing with hair that is near shoulders in portrait images. The hair 

would likely need a greater refinement than the shoulders, the shoulders 

being a more consistent area. This can also reduce some of the fuzziness of 

the refined edge around the feet area for this example. Refer to Figure 7-63.
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Figure 7-63.  Adding the setting of Smart Radius can also alter the 
selection around the squirrel

Remember, you can view this radius when in your view mode you have 

enabled the Show Edge option. Refer to Figure 7-64.

Figure 7-64.  Enabling Show Edge in the Properties panel View 
Mode setting
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Knowing this, I’ll reduce the Edge Detection radius down to 0px, but 

I can leave my Smart Radius on, and I may want to use my Brush tool 

to clean up some of those gaps inside the body in the overlay except for 

around the tail. Refer to Figure 7-65.

Figure 7-65.  Adjust the Radius setting and paint areas around the 
squirrel to clean the selection up

Turn the Show Edge settings off and continue to use your brush, as 

required, after you disabled the setting. Then continue on to the next 

section in the Properties panel. Refer to Figure 7-66.
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Figure 7-66.  Turn off Show Edge after making adjustments on 
the overlay

Global Refinements

Further refinements to the edge of a selection can then be made using the 

sliders and buttons. These changes affect the overall selection. Refer to 

Figure 7-67.
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Figure 7-67.  Properties panel Global Refinements options

Smooth (0–100): This smooths the jagged selection edges. In this case, 

I left the settings at zero, but a higher setting did cause the selection to alter 

near the squirrel’s ears, and I want the selection, instead, to be tight. Refer 

to Figure 7-68.

Figure 7-68.  Move the smooth slider to view how the mask changes
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Feather (0–1000px): This softens and blurs the selection edge. Too high 

a setting can cause overall blurring, making your selection disappear. In 

this case, I left the selection on 0px. Refer to Figure 7-69.

Figure 7-69.  Feather slider set to 1000px (preview) and then set 
back to 0px

Contrast (0–100%): Increase or decrease the contrast or transition of the 

selection edge. As a suggestion you may prefer to use this slider and the Edge 

Detection and Smart Radius option in combination with the Refine Edge 

Brush Tool you looked at earlier. Too high a setting may make the transition 

too abrupt and jagged. In this case, I left it at 0%. Refer to Figure 7-70.

Figure 7-70.  Contrast slider set to 100% (preview) and then set 
back to 0%

Shift Edge (–100%,0, +100%): Contract or expand the selection edge. 

Negative values move the soft-edged borders inward or use positive values 

to move the borders outward. Adobe says shifting these borders inward 
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can help remove unwanted background colors from selection edges. 

Here, you can see an inward shift of –52%, an outward shift of +52%, and 

the default settings of 0% on the back of the head of the squirrel. Refer to 

Figure 7-71.

Figure 7-71.  Move the Shift Edge slider to see how it affects 
the overlay

Clear Selection: This removes the current selection in the preview area. 

Use Ctrl/CMD+Z right away if that was not your intent.

Invert: This inverts the current selection. Click Invert again to return 

the selection back to its earlier state. Refer to Figure 7-72.
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Figure 7-72.  Properties panel Clear Selection and Invert selection 
and then click Invert again to get it back to the original selection 
setting displayed as a black & white overlay

Once you are happy with the results, you will want to output your 

selection. The viewing option of black on white can certainly show you 

how far you have come with your selection. Refer to Figure 7-72.

Output Settings

The following Output settings to consider are seen next in Figure 7-73.
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Figure 7-73.  Properties panel Output settings

Decontaminate Colors: This removes the color fringe from the image, 

replacing it with the color of the nearby pixels. It is disabled by default.

When enabled, the strength of color replacement is proportionate to 

the softness of selection edges. Adjust the Amount slider to change the 

decontamination amount. The Amount of 100% (maximum strength) 

is the highest value. Because this option changes pixel color, it requires 

output to a new layer, with or without a layer mask or a document, but not 

as a selection. In this case, you want to retain the original layer, so you can 

revert to it if needed.

In this example, I find that it does make the squirrel tail bushier, but 

then some of the highlights on the edge of the fur are lost and covered by 

the new color. So, in this situation, I will keep the options disabled. Refer to 

Figure 7-74.
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Figure 7-74.  Decontaminate Colors makes the squirrel’s tail appear 
bushier but may add colors I don’t want to the selection

Output to: Depending upon the options chosen, you can choose one 

of the following output types: Selection, Layer Mask, New Layer, and New 

Document. Some options can also be combined with a Layer Mask. Layer 

masks will be looked at shortly in Chapter 8. For now, use the option of 

Selection. Refer to Figure 7-75.

Figure 7-75.  Properties panel Output settings Output To options list

The last option buttons in the Properties panel are reset, OK to commit 

changes, and Cancel to exit. Refer to Figure 7-76.

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



413

Figure 7-76.  Properties panel Output settings: reset, OK, and 
Cancel buttons

In this case, I chose the Output of Selection and clicked OK.

This selection will then be active on the canvas.

We will discuss saving a selection in a moment (Select ➤ Save 

Selection), as this is important if you ever want to refine the selection 

further at a later date using Select and Mask. Refer to Figure 7-77.

Figure 7-77.  Final squirrel selection made

However, I just want to point out a few other selection options you may 

want to consider as well.

Chapter 7  Masks, Selections, and Filling in the Gaps: Part 2



414

Refer to the following link if you need more information on Select 

and Mask:

https://helpx.adobe.com/photoshop/using/select-mask.html

Make sure to save (File ➤ Save) any of your open files at this point.

�Other Selection Options You May Want 
to Explore from the Select Menu
Three other selection options that are found in the Select menu, which you 

may want to consider, are

•	 Color Range

•	 Focus Area

•	 Sky

I will give you a brief overview of what each of these is used for should 

you have similar projects.

�Color Range
Color Range is a good option when you need to select specific colors 

within a photo that may be scattered throughout, such as selecting the 

blue areas of the sky which is broken up by trees and their branches, in the 

earlier winter snow image from Chapter 3. Use the file Snow_Content_
color_range.psd to practice.

This kind of selection would take a lot of time using the Magic Wand 

Tool from this chapter, so using this Select ➤ Color Range dialog box can 

speed up the process. Refer to Figure 7-78.
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Figure 7-78.  Sampling the sky using the Color Range dialog box
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Click a color area in the sky to begin setting your color range.

The settings found in this dialog box are as follows:

Select: This drop-down list lets you select a specific color using 

sampled colors, a range such as reds, greens, shadow, highlights, skin 

tones, or out of gamut colors that may not print accurately. Out of gamut 

will be explored in Volume 2. Color ranges that are not present cannot be 

selected. Refer to Figure 7-79.

Figure 7-79.  Color Range dialog box with select color settings list

Detect Faces: When enabled, it allows for more accurate skin tone 

selection if faces are present.

Localized Color Clusters: This is enabled by default to make 

contiguous selection.

Fuzziness (0–200): The slider is used to adjust the falloff beyond the 

selection boundaries or how wide a range of colors is in the selection.

Range (0–100%): Use the slider to adjust the range of the selection 

or how far or near the color is from the localize color clusters. Refer to 

Figure 7-80.
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Figure 7-80.  Color Range dialog box settings

As the settings are changed, the preview area lets you view by selection 

or image. By default, it is set to selection. Then use the selection preview 

options list to preview as a selection mask on the canvas (grayscale, black 

matte, white matte); by default, it is set to none, and your actual image 

will not have an overlay. However, choosing a setting of Quick Mask will 

show you what areas will be part of the selection or masked in red. Refer to 

Figure 7-81.
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Figure 7-81.  Color Range dialog box settings for various 
preview modes
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The other eyedropper buttons on the right allows you to make a 

selection on the canvas, add to the selection, or subtract from the selection 

sample. You can also invert the selection if the checkbox is enabled. Refer 

to Figure 7-82.

Figure 7-82.  Color Range dialog box eyedropper tools, Invert 
checkbox, and buttons

Presets that you create can be loaded and saved. The file is saved 

as .AXT.

Click OK to confirm the settings or Cancel to exit.

Tip H old down the Alt/Option key if you need to turn the Cancel 
button into a Reset button and click to undo current settings.

You can find more details on color range at the following link:

https://helpx.adobe.com/photoshop/using/selecting-color-

range-image.html
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I will just mention that once your selection is active, you can use 

the Quick Mask Mode or Select and Mask to refine the selection further 

as some of the snow, which is blue in the lower area, would have been 

selected as well.

�Focus Area
Focus Area, as you will notice, has some similarities to Select and Mask. 

It also has access to the Select and Mask workspace should you need to 

access it for fine-tuning. Use this option when you want to select areas in 

an image that are in focus. In this case, we could use it to make a selection 

of the area of the garden outside that is framed by the pillars. The area 

inside is rather dark, but you may want a selection of the garden for 

another project.

Open the focus_garden.psd file and while on Layer 0, then use the 

Select ➤ Focus Area dialog box to preview what happens next. Refer to 

Figure 7-83.
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Figure 7-83.  Select the inner area of the framed door using the Focus 
Area dialog box
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The settings in this dialog box include the following:

View Mode: Like the Select and Mask workspace, you can set various 

view modes. Refer to that section earlier in the chapter if you need more 

details. By default, it is set to On White (T). Refer to Figure 7-84.

Figure 7-84.  Focus Area dialog box View Mode and the result of the 
preview selection On White

Toggle the Preview checkbox to see the original image. Note that this 

area does not have an Onion Skin option but has different modes called On 

Layers (Y) to reveal the layer masked by the selection and Reveal Layer (R) 

to view the entire layer without masking.

Parameters: In-Focus Range (0–7.5) is used to adjust the fine-tuning 

of the focus area to broaden or narrow the selection; by default, it is set to 

3.0 when the auto calculation setting is enabled. If you move the slider, the 

auto setting becomes disabled. Refer to Figure 7-85.
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Figure 7-85.  Focus Area dialog box Parameters options

Advanced: Image Noise Level (0.002–0.100) can be increased if too 

much background is selected in a noisy image. In this example, by default, 

it is set to 0.029 when the auto calculation setting is enabled. If you move 

the slider, the auto setting becomes disabled.

Output: Like the Select and Mask workspace, you can set an output 

option such as a selection, layer mask, new layer, or document. Refer to 

that section earlier in the chapter if you need more details. For now, leave 

at Selection. Refer to Figure 7-86.

Figure 7-86.  Focus Area dialog box Output options
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•	 Soften Edge: When enabled, it runs additional 

processing to soften or feather the edges.

	 The tools on the left include

•	 Zoom tool (Z): For zooming in (Alt/Option-click) or 

zooming out.

•	 Hand tool (H): For moving about the canvas.

•	 Focus area add tool (E): Adds to selection. Use the 

brush to add back to the selection.

•	 Focus area subtract tool (E): Subtracts from selection. 

Use the brush to remove parts of the selection. Refer to 

Figure 7-87.	
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Figure 7-87.  Focus Area dialog box tools
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Click OK to commit or Cancel to exit. Upon Clicking OK, you will have 

an active selection. Refer to Figures 7-86 and 7-87.

Tip H old down the Alt/Option key if you need to turn the Cancel 
button into a Reset button.

For more information on this tool, refer to the following link:

https://helpx.adobe.com/photoshop/using/select-area-

focus.html

�Sky Selection
Select ➤ Sky is a very quick selection option and allows you to select areas 

of the sky while on the background layer if you want to edit your otherwise 

dull sky. You can see that here in the garden image (garden_clone_stamp_
final.psd) from Chapter 3. Refer to Figure 7-88.

Figure 7-88.  Use sky selection when you need to select the sky area of 
an image quickly
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Note that some skies are quite complex to select, so using Color Range 

may be a better option, and you still may need to refine this selection 

using Quick Mask Mode (Q) or Select and Mask. However, we will look at 

another sky selection workspace in Chapter 8 (see Sky Replacement).

�Saving Selections in the Channels Panel
Once you have created a complex selection using any or a combination 

of tools, it can be frustrating to then click another selection tool by 

mistake and lose the entire selection that you carefully crafted. Or in other 

situations, you may want to return to that selection later in the project to 

edit further, another day. As you saw earlier in the chapter, the Select and 

Mask has a wide variety of options for output, including layer mask, but 

when you just want to save a selection upon exiting the workspace, while it 

is active, choose Select ➤ Save Selection. In this case, the selection around 

the squirrel was active in the copy of the squirrel_selection.psd file. Refer 

to Figure 7-89.
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Figure 7-89.  Use the Save Selection dialog box to save an active 
selection

When the dialog box opens, you can save the destination in the current 

document, a new document and then as a new channel, or as a layer mask 

on a current layer. Next, you can give it a name. In this case, the operation 
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is to create a new channel, but if it is an already saved channel, you can 

select it from the list, you can add, subtract, or intersect with it. If you 

have other channels already saved, you will have the additional option of 

replacing that channel.

Click OK to save the selection in the Channels panel. You can now 

safely Select ➤ Deselect the selection. Refer to Figure 7-90.

Figure 7-90.  Selections are saved in the Channels panel under the 
main color channels

�Load a Selection
If you need to load a saved selection from the Channels panel, choose 

Select ➤ Load selection. In my case, I already have saved my squirrel 

selection, so if you need to practice, you can look at the file squirrel_
selection_final.psd. Refer to Figure 7-91.
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Figure 7-91.  Load a selection using the Load Selection dialog box

Select the source document and the channel name. Alternatively, 

you can enable invert to reverse the loaded selection. In this case, the 

operation is a new selection. However, if you have a selection already 

active, you can add to selection, subtract from selection, or intersect with 

the selection. Click OK to exit and the selection is loaded on the canvas as 

seen in Figure 7-89.

�Creating Separate Channel Selections 
from an RGB Photo
Besides adding selections to your Channels panel, you will notice that this 

panel holds the three RGB channels (Red, Green, Blue) and a composite of 

those channels called RGB. Refer to Figure 7-92.
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Figure 7-92.  All channels or selections can be loaded to create an 
active selection

These should not be confused with layers even though the layout looks 

similar, and you can turn the visibility eyes on and off to see a grayscale 

image of each channel. You can load individual channels to create 

selections, and this could later assist you with your work in Volume 2. 

Whether a channel or a selection, you can load it by Ctrl/CMD-clicking the 

thumbnail image in the panel to load the selection.

Note  In Volume 2, we will see how to adjust the RGB channels to 
affect color using adjustment layers. For now, while working with the 
Channels panel to have your RGB channels’ (separate and composite) 
visibility eyes on and selected, the selection channel’s visibility eye 
is off and deselected to avoid entering a masked state. Refer to 
Figure 7-92.

Save (File ➤ Save) any of your open files at this point.
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�Summary
In this chapter, we used three selection tools, the Select and Mask 

workspace, and several selection options found in the Select menu that 

can assist when we want to save and load a selection to eventually fill in 

the gaps and missing details using the tools from Chapters 3–5. In the next 

chapter, we will look at how to add layer masks as well as work with various 

workspaces to fill in gaps with selected and generated content.
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CHAPTER 8

Masks, Selections, 
and Filling in the 
Gaps: Part 3
In this chapter, we will be completing our discussion on selections and 

learn how to create Layer masks and then review two different workspaces 

for filling in gaps as well as options for doing a basic blend of panorama 

photo. I will also mention some of the features of Generative Fill. Lastly, 

we will continue to work on a photo project based on what was learned in 

Chapters 6 and 7.

Note this chapter does contain projects found in the Volume 1 
Chapter 8 folder.

Note some of the tools I discuss in this chapter can also be found 
in my book Accurate Layer Selections Using Photoshop’s Selection 
Tools.  In that book, the focus was on working with illustrations; 
however, in this book, the focus will be on photos that are digitally 
repaired.

https://doi.org/10.1007/979-8-8688-0450-2_8
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�Creating Layer Masks
Once a selection is created, besides saving the selection, you can then 

apply it to a Layer as a Layer mask using the Layers panel. Layer masks 

are ideal for hiding and revealing parts of an image in a nondestructive 

way. For example, let’s say that I wanted to reduce the opacity of the 

background layer, but I wanted just the squirrel to remain at 100%.

I could make a duplicate of the background layer (drag over the new 

Layer icon) and then load the selection from the Channels panel by Ctrl/

CMD-clicking the thumbnail. Here, I used my file squirrel_selection_
mask.psd. Refer to Figure 8-1.
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Figure 8-1.  Use the Channels panel to load a selection over a 
duplicate layer

Then apply that selection as a Layer mask to my background copy of 

the Layer in the Layers panel by clicking the add Layer Mask button. Refer 

to Figure 8-2.
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Figure 8-2.  On the duplicate background copy layer, apply a Layer 
Mask using the Layers panel
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At first, you would not notice any change to the image as the 

background opacity has not yet been altered or reduced. However, rather 

than alter the background layer, just select it and then you could apply 

a solid color of white using the Fill Adjustment Layer option. Use R:255 

G:255 B:255 and click OK to exit. Refer to Figure 8-3.

Figure 8-3.  Use one of the Fill Adjustment options to create a solid 
color fill of white with the Color Picker dialog box

Now the squirrel with the Layer mask is over a white background fill, 

and we will explore various color fills (solid, gradient, and pattern) more in 

Volume 2. Refer to Figure 8-4.
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Figure 8-4.  The solid fill color appears below the background copy of 
the layer

Then reduce the Color Fill Layer’s opacity to 25%. Now you can see 

some of the background, but it is faded due to the color overlay above the 

background layer. Refer to Figure 8-5.
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Figure 8-5.  Reduce the opacity of the Color Fill Layer so that the 
background appears slightly faded

On the background layer copy, when you select the Layer Mask, you 

can use your Brush or Eraser tool to paint on a layer mask and touch up 

any areas around the tail without erasing the actual image underneath the 

mask. You know the mask is selected because it has a border around it. 

Refer to Figure 8-6.
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Figure 8-6.  Use your Brush or Eraser tool on the selected layer mask 
to refine the selection further

As I mentioned earlier in Chapter 6 while working in Quick Mask 

Mode (Q), I prefer to use the Eraser Tool while working on the mask. While 

working with the Eraser tool, set the Tools panel to the default colors of 

black foreground and white background and paint on the layer mask. Use 

the X key to toggle between showing and hiding parts of the mask while 

working with the tool. Refer to Figure 8-7.
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Figure 8-7.  Toggle (X) and view the Tools panel as you work on the 
mask with a tool to hide and reveal areas as you paint

Note  When working on the mask, the color swatch default settings 
in the Tools panel may appear slightly different as you are working on 
the mask and not the image.

Note that if you select the layer thumbnail by mistake, you will erase or 

paint parts of the layer which you do not want to. In this case, use Edit ➤ 

Undo right away or use your History panel to go back a few steps and select 

the Layer Mask again. Refer to Figure 8-8.
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Figure 8-8.  If you paint on the image, you will alter the image 
permanently, so always paint on the mask

Keep the layer and layer mask linked together when moving a layer 

with the Move tool. Otherwise, they will move separately when the 

mask or layer is selected. To prevent this, click the link icon on the layer 

between the image thumbnail and mask if you notice it is missing. Refer to 

Figure 8-9.

Figure 8-9.  Make sure the mask is linked when you use the Move tool
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�Enable/Disable Layer Mask
In some situations, you may want to disable the layer mask to compare 

settings.

To disable the Layer mask, right-click it and choose that option from 

the pop-up menu. Do the same if you need to enable it again. Refer to 

Figure 8-10.

Figure 8-10.  Right-click a Layer mask to enable and disable it

Tip  You can remove a Layer mask by right-clicking it and choosing 
Delete Layer Mask or dragging it to the trash can icon. However, in 
this case, keep the Layer mask. Refer to Figure 8-11.

Figure 8-11.  Right-click if you need to select the option to disable 
your Layer mask

Another way to edit or to hide or show a Layer mask while working is to 

use the Properties panel.

Chapter 8  Masks, Selections, and Filling in the Gaps: Part 3



444

�Adjusting a Layer Mask in the Properties Panel
In the Properties panel, Layer masks can be altered using the Density 

(0–100%) and Feather sliders (0–1000px). Density acts as a type of 

opacity for the entire mask. Feather blurs the edges of the mask. Refer to 

Figure 8-12.

Figure 8-12.  Properties panel with Layer Mask options

In the Properties panel adjust the Density to 49%, revealing more of 

what is under the mask arround the squirrel. Set the feather slider to 50px 

and observe the blur on the edges of the mask. Refer to Figure 8-13.
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Figure 8-13.  Properties panel setting Layer Mask density and 
feather options

This can look nice when trying to feather an elliptical selection on a 

white background as seen earlier in Chapter 6 with the tower image, but 

we will review this in more detail in Volume 2. Refer to the image_tower_
vignette.psd and select the mask if you need to review the settings in the 

Properties panel for this.

The Refine area of the Properties panel also allows access to the Select 

and Mask workspace, the Color Range dialog box, and the Invert mask 

option. The lower half allows you to load a selection from a mask, apply a 

mask to the layer, enable/disable a mask, and delete a mask while selected. 

Refer to Figure 8-14.
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Figure 8-14.  Properties panel set Refine options

You can use the Layer mask in a variety of ways, such as referring back 

to the canoe and snow images that both could contain masks in Chapter 3.  

See canoe_content-aware tool_erase_final.psd and snow_content-
aware_tool_erase_final.psd in this chapter’s folder for comparison. Also, 

a Layer mask can be used, for example, around the edge of the army image 

from Chapter 5 to create an even edge with a rectangular selection. I will 

discuss this more at the end of the chapter when we continue to work on 

the restoration project. Refer to Figure 8-15.
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Figure 8-15.  Use the Layers panel to create a Layer mask to cover 
uneven edges in the army image

Note that you can also use the Properties panel to apply a vector mask, 

but I will mention more on that in Volume 2. Refer to Figure 8-16.

Figure 8-16.  The Properties panel has an option to create a 
vector mask
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�Adding Smart Object Layers
Sometimes, when working on an image before I apply a Layer mask, I will 

convert my layer to a smart object layer using the Layers menu, as I am 

doing on a copy of the layer. Refer to Figure 8-17.

Figure 8-17.  Convert a Layer to a Smart Object Layer

Smart object layers are ideal for when you need to scale your selection 

of an image up or down multiple times if you are not sure what the correct 

size will be. This prevents the loss of quality in the image. I will review 

basic scaling in a moment. However, if you load and apply your layer mask 

to a Smart Object Layer, you can ensure that if you click the thumbnail by 

mistake, when you start using the Eraser tool, you will not edit the Smart 

Object Layer, and you will get a warning message. In this case, you would 

click Cancel and then select the Layer mask to continue to paint. Refer to 

Figures 8-18 and 8-19.
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Figure 8-18.  Add a Layer mask to the Smart Object Layer

Figure 8-19.  A warning message will appear if you try to paint on the 
Smart Object Layer; paint on the Layer mask so you do not rasterize 
the Layer by mistake

If you clicked OK, this would rasterize the layer, returning it to a 

Normal Layer, which is what you don’t want. In situation where you 

do want to rasterize a smart object layer, choose that option from the 

Layer’s menu.

Note that if you paint with a Brush tool, with the smart object 

thumbnail selected, a new layer will be added over the top.

For any kinds of image touch-ups, whether with Brush, Eraser, or 

Clone Stamp tool, I recommend, as you saw in Chapters 3 and 4, to always 

work on a new layer on top of the background images, whether they be 
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smart object layers or not, to prevent destroying your artwork. In this case, 

I covered up some dust in the squirrel’s fur using the Clone Stamp Tool on 

Layer 1. Refer to Figure 8-20.

Figure 8-20.  Use the Clone Stamp and other tools like the Brush or 
Eraser to edit your squirrel image on Layer 1

If for some reason you do want to edit a smart object, double-click the 

thumbnail to enter the encapsulated “.psb” file. Make your edits to that 

file. Select File ➤ Save and then close the .psb file, and the smart object is 

Chapter 8  Masks, Selections, and Filling in the Gaps: Part 3



451

updated in the .psd Photoshop file. You can then continue to work on your 

Smart Object Layer’s layer mask or other Layers within the current (.psd) 

document. Refer to Figure 8-21.

Figure 8-21.  Enter the Smart Object Layer if you do need to edit 
it further

Tip A lt/Option-click a Layer mask if you need to enter and exit it to 
see how refinement of just the mask is progressing.

Save (File ➤ Save) your work so far and refer to my file squirrel_
selection_mask_final.psd.

�Edit ➤ Transform Review (Scale and Rotate 
Smart Object Layers)
As mentioned, one of the benefits of using Smart Object Layers is that you 

can scale them down or back up to their original size numerous times 

without worrying about loss of quality, and the Layer mask will also scale.

In most cases, when doing digital image repair, you will need to do the 

two basic types of transformation: scaling and rotating. While there are 

quite a few transform options in the Edit menu, for this book, we will focus 

on these two options. In this case, let’s use the tower_two.psd file. In this 

example, there is a second smart object layer that has a layer mask applied. 

Refer to Figure 8-22.
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Figure 8-22.  Apply a Layer mask to a duplicate Smart Object Layer 
for scaling

Select the Move tool if you want to follow along and select the Layer 0 

copy which is the Smart Object layer with the Layer mask and has its layer 

mask selected. Refer to Figure 8-23.
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Figure 8-23.  Move your Smart Object Layer with the Move tool

Use Edit ➤ Free Transform if you want to scale and rotate at once, 

or separately choose the options Edit ➤ Transform ➤ Scale or Edit ➤ 

Transform ➤ Rotate. Each option will present the same Options bar panel 

but will constrain you to that specific operation. For this example, use Edit 

➤ Free Transform. Look at the Options bar panel from left to right. Refer to 

Figure 8-24.

Figure 8-24.  Free Transform scale and rotate using the Options 
bar panel

In this case, because this is not an actual tool, the preset picker options 

for this tool are unavailable. The next icon, depending on the layer type, 

allows you to set the reference location point, but it is not available in this 

operation unless you enable it first. In this case, I left it disabled and the 

reference point in the center location. Refer to Figure 8-25.

Figure 8-25.  Free Transform Options bar panel, setting the 
reference point
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While the bounding box handles are active, you can now move 

the layer by dragging from the center of the selected tower, and it will 

update in its horizontal X and vertical Y reference point position. Refer to 

Figure 8-26.

Figure 8-26.  Use the Transform Options bar panel or move by 
selecting inside the bounding box panels
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The triangle icon between the X and Y values, when enabled, allows 

you to use relative positioning for the reference point; by default, it is 

disabled. Refer to Figure 8-26. You can right-click the X or Y point if you 

want to change the increment setting from pixels to inches. I left it on 

pixels for now. Refer to Figure 8-27.

Figure 8-27.  Change the increment settings in the Transform Options 
bar panel when you right-click

For scaling, you can either use your bounding box handles to scale 

proportionately or the width (W) and height (H) options which are 

currently scaling by percentage and have the link icon for aspect ratio 

enabled. If you hold down the Shift key while you drag the handles, you 

can scale disproportionately, and the link will be disabled as you scale. 

Refer to Figure 8-28.
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Figure 8-28.  Use the Transform Options bar panel with the link 
enabled or disabled or bounding handles to scale the image

Note if you need to reset the scale, enter 100% in both width and height 

with the scaling locked. Click in another field if you need to confirm the 

number. Refer to Figure 8-29.
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Figure 8-29.  Use the Transform Options bar panel with the link 
enabled to set back to 100%

While working, you can also use your contextual task bar to flip on the 

horizontal or vertical, and this would change the width and height from 

positive to negative numbers in the Options bar panel or type the number 

value into the text box. Refer to Figure 8-30.

Figure 8-30.  Use the contextual task bar and Transform Options bar 
panel with the link enabled to flip the Smart Object Layer
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To alter the angle or rotate you can set a new degree setting or rotate 

using one of your bounding box corner handles. Refer to Figure 8-31.

Figure 8-31.  Use the Transform Options bar panel to rotate

The next two options H and V will let you set a horizontal or vertical 

skew. Generally, when doing digital repair, I will leave these at the 0° 

degree settings. Note that if your smart object layer has no layer mask, 

these settings will not appear. Refer to Figure 8-32.

Figure 8-32.  Transform Options bar panel skew settings
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For a smart object layer with a Layer mask in the Options bar panel, 

you will see the option of Interpolation, as seen in Chapter 2, with the 

Image ➤ Image Size dialog box. This option list can also be used to scale 

Smart Object Layers for a better scale, based on preview compression 

with the Layer mask. By default, I keep it on the Bicubic setting, but you 

can refer to that chapter if you need more details on other options, such 

as Nearest Neighbor, Bilinear, and the other Bicubic options of Smoother, 

Sharper, and Automatic. Refer to Figure 8-33.

Figure 8-33.  Transform Options bar panel Interpolation option list 
and warp option button

Note that alternatively for smart object layers without a Layer mask, 

you may also see the Anti-alias checkbox for smoother edge transition, but 

the setting will be unavailable in the Options bar panel.

The next option that appears like a warped mesh is when you want to 

warp the image. Click it when you want to scale, and you want to switch 

between the free transform and warp modes. In this case, do not click 

this button, but on your own you can learn more on this topic in my book 

Perspective Warps and Distort with Adobe Tools: Volume 1 or the link 

mentioned at the end of this section. Refer to Figure 8-33.
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Once you have completed your rotation and scale, click either the 

cancel button to exit without making a change or the check to commit the 

transformation, and the Layer mask will scale as well because it is linked 

with the image thumbnail. Refer to Figure 8-34.

Figure 8-34.  Transform Options bar panel cancel or commit settings. 
Smart Object Layer image scaled as well as the Layer mask
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This transformation of the Smart Object layer has been stored in the 

Properties panel if you need to reset the transformation. To do that, you 

can use the Properties panel and reset it using the counterclockwise arrow 

reset transforms. Refer to Figure 8-35.

Figure 8-35.  Use the Properties panel to reset the width, height, and 
angle of the embedded smart object layer

However, be aware that this will not always reset the Layer mask 

scaling if at least two scales or a rotation has been performed before 

clicking reset.
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Alternatively, you can also return to Edit ➤ Free Transform any time if 

you need to scale the smart object with the mask without losing the quality 

of your Smart Object Layer. But make sure to keep the smart object and 

Layer mask linked if you plan to alter the scaling or rotation.

We will look at smart objects again in the Volume 2, but if you want to 

know more on this topic on warping and transforming, you can refer to 

these links:

https://helpx.adobe.com/photoshop/using/transforming-

objects.html

https://helpx.adobe.com/photoshop/using/warp-images-shapes-

paths.html

Also, note that while working with Edit ➤ Free Transform, clicking 

another tool may deselect the transformation. Instead, use Edit ➤ Undo 

(Ctrl/CMD+Z) and use your Spacebar to access the Hand tool and use the 

Zoom options of Ctrl/CMD++ and Ctrl/CMD+- as you move around the 

canvas to avoid exiting a transformation.

�When to Use Content-Aware Scale
One other scaling tool that you may want to you use when doing digital 

image repair is the Edit ➤ Content-Aware Scale option. Note that this 

command does not allow you to work on a Smart Object Layer, so you 

must work on a duplicate layer instead. If you want to rasterize a copy of a 

smart object layer to practice on, right-click the copy and choose Rasterize 

Layer (Layer ➤ Rasterize ➤ Layer). This returns it back to a regular normal 

layer. However, the layer mask will still remain. Refer to Figure 8-36.

Figure 8-36.  Rasterization of a Smart Object Layer using the 
Layers menu
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Content-Aware scale is best to use on items like people or structures. 

With the layer selected, go to Edit ➤ Content-Aware Scale.

If you review the Options panel from left to right, you will notice that 

many of the settings are the same as Free Transform. These include the 

toggle settings for the reference point and location and the X (horizontal) 

and Y (vertical) reference point settings. The triangle button uses relative 

positioning for reference point. The next settings are for width (W) and 

height (H) scaling, which are currently in percents. Refer to Figure 8-37.

Figure 8-37.  Content-Aware Scale Options bar panel

However, there are a few differences in that you cannot rotate. The 

Amount (0-100%) sets the threshold for scaling to minimize the distortion. 

Protect is another option that can minimize distortion; by default, it is set 

to none. Refer to Figure 8-38.

Figure 8-38.  Content-Aware Scale Options bar panel Amount and 
Protect options

However, if you have saved a selection in the Channels panel, you can 

use this to specify which area to protect. The final button, which looks like 

a person when enabled, can be used to protect skin tones. Click the Cancel 

icon if you want to exit this area or the check if you want to commit the 

scaling you did with the bounding box handles. Refer to Figure 8-39.
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Figure 8-39.  Content-Aware Scale Options bar panel; click the check 
to commit the settings

Not all projects are ideal to use with Content-Aware scale; however, it 

can be used to produce some very interesting artistically warped effects, 

including to the tower.

Save (File ➤ Save) your work so far and use the file tower_two_final.psd 

as a reference.
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�Filling in the Gaps
In the previous chapters, we have been working with a copy of the tower 

file on normal Layer 0 because the file was cropped and the crop was then 

extended; there are a few gaps on the four sides that we would like to fill in 

to make the image more complete. There are a few advanced options you 

can try when you need to fill in blank areas. We will use one of them next. 

Make a duplicate (Image ➤ Duplicate) of the file tower_content_aware_
fill.psd.

�Content-Aware Fill Dialog Box and Workspace
To begin, I will use my Magic Wand Tool mentioned in Chapter 7 and 

click and then Shift-click in the four transparent corners of the image on 

Layer 0 so that I have a selection of the area that I would like to fill. Refer to 

Figure 8-40 and note the settings used.
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Figure 8-40.  Select the transparent areas of the image using the 
Magic Wand Tool
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From the menu, go to Edit ➤ Content-Aware Fill. Refer to Figure 8-41.

Figure 8-41.  Content-Aware Fill workspace

This workspace has many similar features to the Content-Aware Move 

tool and the Remove tool from Chapter 3. However, using the tools with 

a sampling area is great for when you need to preview and control how 

the content will display. In images like this with very small gaps, most of 

the work is done for you, and so this is an ideal workspace for those crop 

extending projects.

This workspace has several tools found on the left side: Sampling 

Brush Tool (B), Lasso Tool, Polygonal Lasso Tool (L), Hand Tool (H), and 

Zoom Tool (Z). Refer to Figure 8-42.
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Figure 8-42.  Content-Aware Fill workspace tools

We will now review the options for these tools when selected.

�Sampling Brush Tool (B)

In Options bar panel, the Sampling Brush tool allows you to add to the 

green overlay (+) or subtract from the overlay (-). You can also change the 

size of the brush (1–5000). You can also use your left [ and right ] keyboard 

square brackets to change the brush size as you work. Refer to Figure 8-43.

Figure 8-43.  Content-Aware Fill workspace Sampling Brush tool 
Options bar panel

Paint over the area of the green mask this sets the sampling area. In this 

example, a mask was automatically created, and it appears to be sampling 

correctly if we compare it to the preview. Refer to Figure 8-44.
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Figure 8-44.  Overlay and preview area of image

However, there may be situations where the mask may be sampling 

areas that would not give accurate fill in the gaps so you would want to 

paint out those areas using subtract from overlay brush (-). Removing that 

sampling may make the fill more accurate and update the preview. In your 

project, if you did paint out some of the overlay and you do not like the 

result, use Ctrl/CMD+Z right away. In this case, we want to keep the whole 

mask, but we will edit the selection slightly. Refer to Figure 8-45.
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Figure 8-45.  Painting with the Sampling Brush tool to remove or add 
to the sample area

�Lasso and Polygonal Lasso Tool (L)

The Lasso Tool and Polygonal Lasso Tool are very similar to the tools found 

outside this workspace and in the Select and Mask workspace. However, 

there are a few differences which I will point out. Lasso is for loose loop 
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selections, while Polygonal Lasso is for more angular selections. These are 

ideal if you realize at some point you need to add to the current selection 

to fill in your gaps better. Refer to Figure 8-46.

Figure 8-46.  Adding to the selection using the selection tools and 
small gaps that appear in the preview

Use Ctrl/CMD+Z if you did not want to edit the selection. However, 

we will need to expand our selections slightly as there is usually a slight 

gap between the selection and the mask, which we do not want to appear 

when we output the preview.

You can review the Options bar panel from left to right. Refer to 

Figure 8-47.

Figure 8-47.  Content-Aware Fill workspace Polygonal Lasso tool 
Options bar panel
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As with the tools outside the workspace, you have access to creating a 

selection that is new; you can also add, subtract, or intersect the selection. 

By default, it is set to add to the selection. You can feather (0–1000px) the 

selection to soften the edges and enable the Anti-alias checkbox to smooth 

the edges of the transition. Other options in this workspace include the 

Expand and Contract buttons which allow you to quickly expand and 

contract the green sampling area and selection area by a set number 

of pixels (1–30px) each time you click a button. If you want to reset the 

original selection, click the counterclockwise arrow. Refer to Figure 8-47.

In this case, we will click the expand button once to expand the 

selection by 3px. This will update in the preview and eliminate the gaps. 

Refer to Figure 8-48.

Figure 8-48.  The selection is expanded and the small gap is removed 
in the preview
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�Hand Tool (H)

The Hand Tool has the same zoom settings outside this workspace and 

in the Select and Mask workspace in Chapter 7. Besides being able to use 

your Spacebar key to navigate about the overlay area, you can zoom in 

100%, fit the screen, or fill the screen. Refer to Figure 8-49.

Figure 8-49.  Content-Aware Fill workspace Hand tool Options 
bar panel

�Zoom Tool (Z)

The Zoom Tool has the same zoom settings outside this workspace and in 

the Select and Mask workspace in Chapter 7. Besides being able to use the 

key commands of Ctrl/CMD++ and Ctrl/CMD+-, you can use the buttons 

in the Options bar panel to zoom in, zoom out, and scale a move while 

Scrubby Zoom is active, and like the Hand tool, you can zoom to 100%, fit 

the screen, or fill the screen. Refer to Figure 8-50.

Figure 8-50.  Content-Aware Fill workspace Zoom tool Options 
bar panel

�Overlay Area

Beside the tools is the selection overlay area which is where you paint and 

add or remove some of your green sampling overlay mask or add to the 

selection.
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�Preview Panel

Next to your overlay work area is the Preview panel area. This area will 

update as you make changes to the overlay area and the Content-Aware Fill 

panel. On the lower part of the panel is a slider that lets you expand and 

contract the preview for a better view. Refer to Figure 8-51.

Figure 8-51.  Preview panel settings

�Content-Aware Fill panel

The Content-Aware Fill panel allows you to control the overlay further, and 

it has several sections. Refer to Figure 8-52.
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Figure 8-52.  Content-Aware Fill panel and sampling options

Sampling area overlay: This area allows you to show/hide the green 

sampling area. Other settings are to set the Opacity slider which is 

currently at 50%. A different color can be set by clicking the swatch to 

access the color picker and click OK to exit. You may want to change 

the color if your image has a lot of green. The Indicates list allows you to 
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choose whether to show the overlay in the sampling area or the excluded 

area. By default, I usually leave it on the setting of sampling area. Refer to 

Figure 8-52.

Sampling area options have three settings: auto, rectangular, and 

custom. By default, it is set to a rectangular setting to use a rectangular 

region around the fill area. Auto allows you to use content similar to 

the surrounding fill area and may remove parts of the green sample 

area it thinks are not required to make a better blend. And the Custom 

option is used, for a manually defined sampling area, which you can use 

your Sampling Brush Tool to edit. If you switch between the sampling 

options, you may get a warning. You can reset the sample area using the 

counterclockwise arrow button while using an option and if more layers 

are available, sample all layers. In this example, remain on the rectangular 

setting with Sample All Layers disabled. Refer to Figure 8-53.

Figure 8-53.  Content-Aware Fill panel with sampling area options 
set to rectangular and a warning message that may appear when 
switching between some options

Fill Settings help you calculate what the area will be filled with in 

regard to the surrounding pixels and overlay options. Refer to Figure 8-54.
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Figure 8-55.  Content-Aware Fill panel testing rotation options that 
appear in the preview

Figure 8-54.  Content-Aware Fill panel Fill Settings options

Color Adaptation: This allows for contrast and brightness to adapt for 

a better match (good for content with gradual color or texture changes). 

Besides the default setting from the list, you can choose three other 

options: none, high, or very high. In this case, default is the best setting as I 

found the others to be either too blurry or repetitive. Though every project 

is different, use the preview to decide which you like best and examine all 

corners. Refer to Figure 8-55.

Rotation Adaptation: This allows for content rotation for a better 

match, such as content with rotated and curved patterns. The default 

setting is none, but other options from the list are low, medium, high, or 

full. I left it on none as I was just trying to expand the fill into the gaps, not 

create warping and distortion. Refer to Figures 8-54 and 8-55.
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Other transformation options include the checkboxes of Scale and 

Mirror, which by default are disabled. Scaling is for resizing content such 

as patterns of different sizes and perspectives. Mirror allows you to do a 

horizontal flipping when horizontal symmetry is required. In this case, I 

left these two settings unchecked. Refer to Figure 8-54.

You can reset the sample area using the counterclockwise button. Refer 

to Figure 8-54.

Output settings, as with the Select and Mask workspace, allow you 

to decide how you want to output your overlay. You can output to a New 

Layer, the Current Layer, or a Duplicate Layer. By default, it is set to New 

Layer, which is what I want. Refer to Figure 8-56.

Figure 8-56.  Content-Aware Fill panel output settings

Note that in this example with the tower, we are working with a normal 

layer and not a Smart Object Layer as described earlier in the chapter. This 

workspace will work with those kinds of layers as well if there are gaps to 

fill, but you will still have the same output options if you start with a blank 

layer above the Smart Object layer before you enter the workspace.

The last set of buttons allows you to reset for current settings. The 

Apply button allows you to commit your output settings but keep the 

workspace open and try other settings. Click OK to commit your output 

settings and close the workspace or cancel and exit without saving 

changes. Refer to Figure 8-57.

Chapter 8  Masks, Selections, and Filling in the Gaps: Part 3



479

Figure 8-57.  Content-Aware Fill panel buttons: reset, OK, Apply, 
and Cancel

In this case, click OK and review your results. The new layer was called 

Layer 0 copy with the new pixels. If you notice the selection is still active, 

use Select ➤ Deselect. Refer to Figure 8-58.

Figure 8-58.  After exiting the Content-Aware Fill workspace, the 
selection will remain, and you can deselect the selection and view the 
new layer in the Layers panel (Layer 0 copy)
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Keep in mind that even with the most excellent Content-Aware Fill of 

gaps, there may still be tiny little repetitive areas that can occur near the 

border of the gaps. That is why I will always inspect the edge afterward 

and on my blank new layer (Layer 1) use a small soft brush with the Clone 

Stamp tool, as seen in Chapter 3, to do a final cleanup if any lines or dust 

and scratches remain. You can also clone stamp areas inside the image. 

Remember in the Options bar panel to sample from Current and Below to 

get as much clone source as possible, including details from the new pixels 

created using Content-Aware Fill. Refer to Figure 8-59.

Figure 8-59.  Use the Clone Stamp tool on blank layer 1 to touch up 
any minor gaps and imperfections that may still be visible along the 
edges for a better blend

After you are done, save (File ➤ Save) your work, and you can view my 

tower_content_aware_fill_final.psd file for reference.

More details can be found at the following link:

https://helpx.adobe.com/photoshop/using/content-aware-fill.html
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�Sky Replacement
Edit ➤ Sky Replacement is a tool that is ideal for editing an otherwise dull 

sky, which can often appear in many photographic prints. This can be 

due to the fact that the image was taken on an overcast day or maybe due 

to the brightness of the sky and lack of a polarizing filter where the sky 

appears faded or white. Knowing this, you may want to consider using this 

workspace to edit your project and add interest.

�Could Sky Replacement Be Used on Vintage Photos?

The sky in the tower image was quite dramatic, and so that picture does 

not need a sky replacement in my opinion. However, let’s make a dull sky 

more exciting; the garden_sky.psd image like we saw in Chapter 3 is a 

good example of that. I am working in an Image ➤ Duplicate of the file. 

Refer to Figure 8-60.

Figure 8-60.  Garden image that requires a sky replacement

Chapter 8  Masks, Selections, and Filling in the Gaps: Part 3



482

In this case, I had three layers, the background (Layer 0) and two other 

layers that I did clone stamping on. To keep them together, I then Shift- 

clicked them all and turned them into one Smart Object Layer using the 

Layers panel menu. Refer to Figure 8-61.

Figure 8-61.  Layers panel; convert some of the layers to a single 
Smart Object Layer
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You do not need to start with an initial selection to begin as Photoshop 

will detect the sky area if it is present in the image. Go to Edit ➤ Sky 

Replacement and look at the dialog box workspace. A sky will be applied to 

where the sky should be in the image. Refer to Figure 8-62.

Figure 8-62.  Sky replacement workspace and preview on the image
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The four main tools found on the left of the dialog box are the Move 

Sky Tool (V), Sky Brush (B), Hand Tool (H), and Zoom Tool (Z).

�Move Sky Tool (V)

Use this tool to move and drag the sky layer as you work. Use caution when 

moving the sky that you do not show part of the border edge as you drag. 

Refer to Figure 8-63.

Figure 8-63.  Sky replacement workspace Move tool Options 
bar panel

�Sky Brush (B)

This brush tool, also known as the Sky Brush, is used to extend or reduce 

the sky area. Use the options Add to the selection (+), and Subtract from 

the selection (-) to alter the selection area. Next, you will find similar 

settings for the brush picker preset as in Chapter 3, for size, hardness, 

angle, roundness, and other brush options from the menu that you would 

find in the Brushes panel. Refer to Figure 8-64.

Figure 8-64.  Sky replacement workspace Sky Brush tool Options 
bar panel

Choose a color mode; by default, the Mode is set to overlay for blending, 

but there are many more options for blending the sky you can try from the 

list such as Multiply and Lighten. We will look at what blending modes and 

their options are more in Volume 2 in regard to color, but for now use the 

overlay mode. Then set an opacity (1–100%). By default, it is at 50%.
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In this case, paint around the edge of the barn’s roof with a small 14px 

brush with a hardness of 50% with the subtract from selection so that the 

sky does not spread into this area. The mask selection is currently seen in 

the Channels panel. Refer to Figure 8-65.

Figure 8-65.  Sky replacement workspace Sky Brush tool Options 
bar panel brush settings and painting to remove some of the sky 
touching the barn and then seeing the results of the selection in the 
Channels panel
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�Hand Tool (H)

Similar settings for the Hand Tool are found outside of this workspace 

using the same tool in the Tools panel. Use the Hand tool when you need 

to move around the image when zoomed in. Other options include Scroll 

All Windows, Zoom 100%, Fit Screen, or Fill Screen. Refer to Figure 8-66.

Figure 8-66.  Sky replacement workspace Hand tool Options 
bar panel

�Zoom Tool (Z)

Similar settings for the Zoom Tool are found outside of this workspace 

using the same tool in the Tools panel. They are Zoom in and Zoom out 

buttons and the checkboxes Resize Windows to Fit, Zoom All Windows, 

and Scrubby Zoom. Then use the buttons to zoom to 100%, Fit Screen, or 

Fill Screen. Refer to Figure 8-67.

Figure 8-67.  Sky replacement workspace Zoom tool Options 
bar panel

Use Ctrl/CMD+Z if you need to undo any steps as you work.

�Sky Options

On the middle/right of the dialog box, the Sky options menu allows you 

to select a new or recently added sky from the list. You can also add your 

own sky to a new sky group, import a sky, or delete one of your skies. Use 

the slider if you need to see a magnified view of the sky before you select it. 

The gear icon will also present more options, such as how to acquire more 

skies, export, or rename a sky. Refer to Figure 8-68.
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Figure 8-68.  Sky replacement workspace Sky options
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The sky you select will appear if the preview in the dialog box is active.

The current sky I have appears too moody, and I want a bright and sunny 

sky for the garden. The sky I chose now is BlueSky003 by Rick Mandia (6533 

by 4355 pixels), though you may prefer a different sky. Refer to Figure 8-69.

Figure 8-69.  Sky replacement workspace Sky option selections
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You can then use the various sliders, checkboxes, and lists to continue 

to edit the sky.

Shift Edge (–100,0,100): Expand or contract the sky and foreground 

image boundary.

Fade Edge (0–100): Soften the sky and foreground image boundary. 

Refer to Figure 8-70.

Figure 8-70.  Sky replacement workspace Sky options for the edges 
altered with sliders

Sky Adjustments can be controlled with the following options:

Brightness (–100,0,100): The slider controls the brightness of the 

replacement sky.

Temperature (–100,0,100): The slider controls how warm or cool the 

colors are in the replacement sky with blue to yellow tints.

Scale (50–400): Use the slider to adjust the size of the replacement sky 

so that it blends more naturally.

Flip the sky horizontally when the checkbox is enabled. Refer to 

Figure 8-71.
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Figure 8-71.  Sky replacement workspace Sky Adjustments sliders and 
flip sky option

Foreground Adjustments can be controlled with the following sliders:

Lighting Mode: Set a blending mode for the lighting. The two options 

are multiply and screen. Blending modes will be discussed in more detail 

in Volume 2. Use the default setting of multiply.

Foreground Lighting (0–100): Apply the lighting adjustment contrast 

to the foreground by controlling the opacity values. When set to zero, no 

effect will be displayed.

Edge Lighting (0–100): Preserve details along the edge of objects and 

reduce halos by controlling the opacity values. When set to zero, no effect 

will be displayed.

Color Adjustment (0–100): Apply color harmonizing to the foreground 

by controlling the opacity values. When set to zero, no effect will be 

displayed. Refer to Figure 8-72.
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Figure 8-72.  Sky replacement workspace Foreground Adjustments

In this example, the only settings I changed were in Sky Adjustments, 

that is, the Brightness to 18 and the Temperature to 9 (as I felt that the sky 

blended into the scene better). Refer to Figure 8-73.
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Figure 8-73.  Sky replacement workspace Sky Adjustments altered in 
the image

Output section should be set to Output To:  New Layers as a sky 

replacement group or alternatively from the list choose Duplicate Layer 

which is a single flattened layer. If you plan to edit your sky later on, I 

recommend the setting of New Layers. Then you can view the new Layer 

masks and Adjustment Layers that have been added to your Layers panel. 

We will explore Adjustment Layers in Volume 2. Refer to Figure 8-74.

Figure 8-74.  Sky replacement workspace Output options

Enable preview to view changes.

Click OK to commit or Cancel to exit without saving changes.
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After clicking OK, the Layers panel then displays the new adjustment 

layers and sky image in various group folders. Refer to Figure 8-75.

Figure 8-75.  Layers panel with the new Sky Replacement 
Layers added

Keep in mind that if you have not color corrected your background 

photo yet, the sky may not blend as accurately with the rest of the image as 

you intend. For example, the trees in the background may be a bit too pale, 

and there may be other areas that could be overall darkened or lightened. 

Digital image repair is much like renovating a house; once you fix one area, 

other areas for correction will reveal themselves as you work. You may 
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need to add or subtract layers as you work. Remember, you can always turn 

off a layer’s visibility if you need to compare. Also, consider if there is water 

in a lake or pond in the scene when you add a sky. You may need to color 

the lake a bit to match.

In Volume 2, we will look at color correction in more detail, and then 

you may wish to return to sky replacement and practice it again with new 

settings or even edit your smart object layer if you notice imperfections 

revealing themselves later as you color correct.

For more sky options and details, you can visit the following link:

https://helpx.adobe.com/photoshop/using/replace-sky.html

Make sure to save (File ➤ Save) your work at this point. View the 

garden_sky_final.psd for reference.

�Other Photo Stitching Options You May 
Want to Try
In the Layers panel, if you are working with two or more images that have 

been copied into a single file that you need to blend together, you can use 

the Move tools to align while several images are selected in the Layers 

panel. Refer to Figure 8-76.
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Figure 8-76.  Layers panel with several layers selected and choosing 
one of the Align options in the Move tool Options bar panel

However, if the images were not each taken at a straight angle with a 

tripod, oftentimes the image may be misaligned with missing gaps. This 

is often the case with photograph film prints where at that time one did 

not have the luxury of taking multiple shots of a scene and reviewing it on 

the screen and was limited by the amount of film each roll could hold. Not 

until the film was processed could you see how they developed and what 

may have been missing.

However, some other options you may want to consider when starting 

to blend scanned images together include the following.
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�Edit ➤ Auto-Align Layers
You can set various projections (auto, perspective, collage, cylindrical, 

spherical, and reposition) and lens correction to adjust distortion, such 

as vignette removal and geometric distortion. We will see more on these 

topics in Volume 2 when we look at advanced filters. Refer to Figure 8-77.

Figure 8-77.  Auto-Align Layers dialog box with three images aligned 
using the Auto setting
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For scanned photos from film, I would recommend trying 

experimenting with the options of either auto, perspective, collage, or 

reposition as some of the images may require a slight rotation. Ideally, 

there should be a bit of overlap from one image to the next for this option 

to work as it should, to detect detail for better alignment. As you choose 

each setting, look in the lower area of the dialog box for tips as to when to 

use these settings. Click OK and then, if you do not like the results, use the 

History panel to undo the steps and try again.

�Edit ➤ Auto-Blend Layers
This is another alternative, second blending mode step when trying 

to correct a panorama or stacked layers that are stacked on top of one 

another. There are options to blend seamless tones and colors as well as 

the option to Content-Aware Fill Transparent areas automatically. Refer to 

Figure 8-78.
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Figure 8-78.  Auto-Blend Layers dialog box with the Layers panel and 
new layer masks applied and the new composite merged layer
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Again, if you plan to blend your panorama image, make sure that the 

images you are using do have some overlap, or there may be gaps in the 

blend. Upon clicking OK, this will create a single merged image above the 

other layers and will then apply a mask to the non-merged layers.

For stacked images that are not similar, this could produce some odd 

color blending results. Use this setting if you have the same scene but one 

photo is overexposed, but the other is underexposed, and a new merged 

layer would be created.

�File ➤ Automate ➤ Photomerge
Photoshop has several automate options that can save you time when 

working with many similar looking photos that need to be formatted a 

certain way. People will use Actions from the Actions panel in combination 

with an Automate ➤ Batch or Create Droplet. While Actions is not the 

topic of this book, because each of the photos you are repairing is unique 

and different, one Automate command you may want to consider is 

Photomerge. Refer to Figure 8-79.

Figure 8-79.  File menu Automate sub-options
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Photomerge is very similar to the earlier Auto-Align Layers and Auto- 

Blend options. However, in this case, you can merge separate files or 

files within a folder when you browse or add open files into a single new 

document instead of them being copied into one document as several 

Layers. Refer to Figure 8-80.

Figure 8-80.  Photomerge dialog box

Keep in mind that if you are working with scanned photos, you have 

made copies with necessary area crop before you start this process.

Click OK, and again, based on your settings, a similar panorama 

layer structure will be generated in the Layers panel Untitled_Panorama 

document. Refer to Figure 8-81.
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Figure 8-81.  Layers panel with new Photomerge Layers added 

Save your project (File ➤ Save). You can see my finished example 

Panorama-1_final.psd which is found in the panorama_files folder along 

with the images I used to create the Photomerge.

Note R egardless of which of the three options you use, you may 
still have to do a final crop afterward or use your Content-Aware Fill 
workspace and Clone Stamp tool to fill in any small gaps.

You can learn more about this topic from the following links:

https://helpx.adobe.com/photoshop/using/aligning-layers.html

https://helpx.adobe.com/photoshop/using/combine-images-auto-

blend-layers.html
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https://helpx.adobe.com/photoshop/using/create-panoramic-

images-photomerge.html

Another helpful Automate option is the PDF presentation, which will 

be mentioned in Volume 2.

�The New Features of Generative Fill
Generative Fill is a new AI feature that has recently been added to 

Photoshop as well as Adobe Illustrator, which is powered by generative AI 

and Adobe Firefly. By using this feature, you agree to follow its guidelines, 

which are found in the following link. Refer to Figure 8-82.

Figure 8-82.  Photoshop and Illustrator app icons

www.adobe.com/legal/licenses-terms/adobe-gen-ai-user-

guidelines.html

I will just mention a few highlights about this product as it is optional 

to use and that the images that are generated are ethically sourced from 

Adobe Stock images.

To activate the product when a selection is active, in the menu go to 

Edit ➤ Generative Fill or your contextual task bar. Or use Edit ➤ Generate 

Image which can also be accessed from the lower area of the Tools panel. 

Refer to Figure 8-83.
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Figure 8-83.  Generative Fill and Generative Image options and new 
button in the contextual menu

Generative AI can be used to fill in missing gaps in your photos using 

text prompts to describe what you want to add to the scene if you do not 

feel that Content-Aware Fill has done an adequate job.

After creating a selection in a photo with one of the selection tools, you 

can then access the Generative Fill option to do such things as

•	 Generate objects.

•	 Generate backgrounds to create a new scene around a 

person or an object.
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•	 With the Crop Tool, expand your canvas and fill in 

empty regions with new content as mentioned in 

Chapter 5.

•	 Remove objects, similar to how you would with the 

Remove tool in Chapter 3.

If you do not want to use a text prompt, then Photoshop will fill that 

selection area based on the surroundings.

Once you have decided on your choice, use your contextual task bar 

to click generate and choose an option from a preview from the Properties 

panel before generating a new layer known as a Generative Layer that 

displays your choice in the Layers panel. This layer will remain editable 

should you change your mind and want to try another variation or 

generate more variations by either interacting with the Properties panel or 

creating a new text prompt. Alternatively, you can also use the new dialog 

box from the Tools panel “Generate an image using a text prompt”. Refer to 

Figure 8-83 and the link at the end of this section for more details.

You can also gain more knowledge about this tool from the following 

links or use your Creative Cloud Desktop console and go to Apps ➤  

Gen-Ai for more information on which applications use this feature 

look for information on either Adobe Firefly or Adobe Express. Refer to 

Figure 8-84.

Chapter 8  Masks, Selections, and Filling in the Gaps: Part 3



505

Figure 8-84.  Creative Cloud Desktop app allows you to try Adobe  
Firefly and Adobe Express features

https://www.adobe.com/products/photoshop/generative-fill.html

https://helpx.adobe.com/photoshop/using/generative-fill.html

One thing I have noticed in researching Generative Fill is that the 

examples of images that are used are mainly in full color and not in 

black and white. This is certainly something to consider and test as the 

lack of color may affect the context of the text prompts as well as what 

will generate in low color situations. Surrounding color or perspective 

placement of an object or person in a scene can certainly affect whether an 

item stands out or blends in. It will be interesting to see how this product 

continues to develop. In Volume 2, we’ll look at various alternative ways to 

colorize photos. More on how to generate an image with descriptive text 

prompts can be found at this link:

https://helpx.adobe.com/photoshop/using/generate-image.html
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�Content Credentials (Beta) Panel
While working with the Generative Fill options and saving your files, be 

aware that Photoshop will automatically append content credentials to 

images generated using Generative Fill and Generative Expand when 

they are exported as PNG, JPG, or “Save as” to let you and others know 

an image was created or edited in Photoshop using Firefly’s generative 

AI technology. These content credentials can be viewed in the Window 

➤ Content Credentials (Beta) panel. However, if you have created the 

images yourself and want the credit, then you can add your own content 

credentials as well. Refer to Figure 8-85.

Figure 8-85.  Content Credentials (Beta) panel
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You can learn more about this panel from the following link:

https://helpx.adobe.com/photoshop/using/content-

credentials.html

�Photo Project
On your own, now work on the following images, canoe and snow scene, 

that were mentioned in Chapter 3 that could use Layer masks to cover up 

extra pixels, and practice applying what you have learned in this chapter as 

well as in Chapters 6 and 7. You can refer to my files canoe_content-aware 
tool_erase_final.psd and snow_content-aware_tool_erase_final.psd in 

this chapter’s folder if you need a reference. Refer to Figure 8-86.
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Figure 8-86.  Practice adding Layer masks to past projects
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Also, as you did in Chapter 7, use the Select and Mask workspace to 

create selections, but this time try outputting that selection to a Layer Mask 

instead. Refer to Figure 8-87.

Figure 8-87.  Practice adding Layer masks using the Select and Mask 
workspace to past projects

Then return to the file called army_mask_edge.psd to straighten 

the edges using a Rectangular Marquee selection on a layer copy of the 

background to make the edge appear straighter and drag out a selection 

arround the image area you want to show. Refer to Figure 8-88.
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Figure 8-88.  Create a selection of the area you want to add the Layer  
mask to

With the selection active, then apply a Layer mask using the Layers 

panel. Refer to Figure 8-89.

Figure 8-89.  Add the Layer mask and edit it with the Eraser tool set 
to block mode
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With the Layer mask selected, paint with Eraser set to Mode: Block on 

the canvas for a clean edge. Do this if you did not cover all the bends and 

creases on the edge of the image as you wanted to with the rectangular 

selection. Zooming in and holding down the Shift key as you erase will 

help. Refer to Figure 8-90.

Figure 8-90.  Use the Eraser tool on a Layer mask to hide and cover 
edges for a straight line

Then you can apply a Solid color fill of white behind the Background 

copy layer. Refer to Figure 8-91.

Figure 8-91.  Add a Color Fill behind the Background copy layer, so a 
white edge will appear as a frame around the image

To cover up the extra edits made with the healing tools that may 

appear as pixels beyond the white boarder, while on Layer 1, you can 

make a copy of the Layer mask from the Background copy layer by 

Ctrl/CMD-clicking on that mask first on the mask in the Background 

copy layer. Refer to Figure 8-89. Then selecting Layer 1, click Add 

Layer Mask to apply the same mask to Layer 1. Refer to Figure 8-92 

to see what that looks like when applied.
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Figure 8-92.  Add a Layer Mask to Layer 1 in the Layers panel

Note that the brush layer does not need a Layer mask.

Next while on Layer 1, you could then select the image thumbnail area 

of Layer 1 and continue to use the Clone Stamp tool and Alt/Option-click 

and to continue to “heal” areas that would be partly covered by mask and 

those pixels below the mask would not appear visible on the canvas. This 

is good when you need to cover rips and imperfections close to the edge. 

Refer to Figure 8-93.
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Figure 8-93.  In the layer that contains the earlier clone stamps, 
you can continue to edit while keeping a clean straight edge in the 
final image

When done, then click on the Layer 1 layer mask as in Figure 8-92.

The edge is now clean and white and free of rips and creases. Refer to 

Figure 8-93.

Save (File ➤ Save) any open files and review the “army_mask_edge_
final.psd” file for reference.

In these examples, we were able to use selections to hide and reveal 

part of an image on a layer. However, in other situations, you may want to 

use selections to mask or reveal colors for the purpose of correction, which 

you will see in Volume 2, or maybe the addition of a filter effect in select 

areas as that will also be discussed in that volume as well.
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�Summary
In this chapter, we reviewed various selection tools and workspaces that 

can help us to fill in the gaps and missing details when we work with 

tools from Chapters 3–5. We also looked at adding Layer Masks and 

working with Smart Object Layers. In Volume 2, we will look at a few more 

types of masks as well as look at some of the main and specialized color 

correction options you can use when working with your Layers panel in 

a nondestructive way. Various types of filters will be discussed as well in 

regard to current and new projects.

Note that currently the file we have been working on will be saved as 

a .psd with multiple layers. You may want to keep the file like this until 

you have completed your final color corrections and filter adjustments. 

In Volume 2, once this is done you can then make a copy of the file and 

use your Layers panel menu to flatten the image (Layer ➤ Flatten Image). 

In Volume 2, we will then review changing color modes from RGB to 

CMYK and file formats for print (.tif ) and the Web (.jpg) and other formats 

depending on how you plan to use the final image. For now, until you 

read the next volume, if you need to review these file formats, refer back to 

Chapter 2 and keep working on your .psd file.

Looking forward to continuing our photo restoration journey in the 

next volume.
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opacity and flow setting, 216
painting mode, 214, 215
pencil tool option, 223–225
preset picker, 217
setting, 212
smoothing option, 216

C
Channels panel, 300
Color replacement tool

background layer, 231
brush angle setting, 231
brush presets, 229
duplicate layer, 226–228
foreground/background 

color, 232
foreground color, 225, 226
mixer brush tool, 232
options bar panel, 228
painting mode, 230
sampling options, 230

Complex selection tools
channels panel, 429–431
color range

details, 419, 420
dialog box, 414, 415
eyedropper tools/invert 

checkbox/buttons, 419
preview modes, 418
select color settings list, 416
settings process, 417

focus area
dialog box, 420, 421, 424, 425
output options, 423
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parameters options, 422, 423
view mode, 422

load selection
dialog box, 429, 430
RGB channels (Red, Green, 

Blue), 430, 431
magic wand tool

eraser tool, 364, 365
eyedropper tool, 360
layers panel, 362
options bar panel, 359
sample size options, 360
sampling colors, 360, 361
select and mask buttons, 363
selection options, 358, 359
viewing selection, 364

object selection tool
accurate selection, 370
adding/subtracting 

selection, 375
brush options, 376
enhanced edge option, 377
feedback button, 372
gear icon, 368
hard edge settings, 371
mode, 369
mode options, 368
multiple objects, 368
object Finder checkbox, 367
options bar panel, 366, 375
refinement, 373
select and mask buttons, 372
selection features, 365, 366

properties panel
black and opacity slider, 396
Black/White, 397
decontaminate colors, 412
different modes, 394
edge detection, 402–406
global refinements, 406–410
high-quality preview, 400
layers, 398
On White/Opacity slider, 396
output settings, 410–414
overlay and options, 395
overlay view mode, 401
radius setting, 405
refine mode settings, 

401, 402
Show Edge (J), 399
view mode, 393–400
workspace tools, 392, 393

quick selection tool, duplicate 
image, 374

selection options, 414
color range, 414–420
focus area, 420–426
sky selection, 426

Select/Mask button
background layer, 380
brush tool options, 387, 388
hand tool options, 392, 393
Lasso and Polygonal Lasso, 

390, 391
layers, 380
object selection tool, 

389, 390

Complex selection tools (cont.)
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properties panel, 
381, 392–414

quick selection tool, 382–385
rectangle/lasso mode, 390
refine edge brush 

tool, 386–388
refine hair button, 384, 385
view mode, 382
zoom tool, 392

select subject button options, 
378, 379

tools panel, 358
warning message, 378

Content-Aware Fill tool
auto-align layers, 496, 497
auto-blend layers, 498–500
automate sub-options, 499–502
auto, rectangular, and 

custom, 476
commit option, 478, 479
dialog box settings, 465–467
hand tool options, 473
Lasso Tool and Polygonal Lasso 

Tool, 470–472
minor gaps and 

imperfections, 480
output settings, 478
overlay area, 473
photomerge dialog box, 

500, 501
preview panel, 474
sampling brush tool, 468–470
sampling options, 474, 475
settings options, 476, 477

sky replacement, 481
adjustments, 489, 490
Brush tool options, 484
channels panel, 485
duplicate image, 481–484
edges, 489
foreground 

adjustments, 490–492
hand tool, 486
layers panel, 482, 493
move tool options, 484
option selections, 488
output option, 492
photo stitching options, 

494, 495
Sky options menu, 486, 487
workspace/preview, 483
zoom tool, 486

testing rotation options, 477
warning message, 476
workspace tools, 467, 479
zoom tool, 473

Content-aware move tool
bounding box handles, 182, 183
contextual task bar, 189
eraser tool, 188
extend option, 184
files, 180
layers panel, 181
move tool, 185, 186
remove tool, 186, 187
scaling/rotation/

transformation, 185
selection options, 182
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Cropping tools
background/transparent 

pixels, 274
content-aware fill, 274, 275
crop tool (C), 266
delete option, 273
duplicate image, 266
duplicate Image  

dialog box, 264
extend option, 273, 274
generative expand, 275
grid overlay options, 272
history panel, 264
layers panel

colorizing group folders, 
289, 290

copying layers, 287–289
delete layers, 286
duplicate layers, 284, 285
multiple layer, 281
renaming folders, 291
select/drag layers, 282, 283

manual crop creation, 269
marquee selection, 265
move/zoom/hand tools, 264
options bar panel, 267, 269, 270
perspective crop tool (C), 

265, 278–281
photo project (army 

image), 291–294
ratio options/crop sizes, 

267, 268
revert/cancel/commit, 276
straighten options, 271

straighten rotation/guides, 
276, 277

tools panel, 265

D
Dodge tool

brush size, 252
burn tool, 255
layers panel, 247, 248, 252, 253
options bar panel, 248, 249, 254
protect tones, 251, 254
range exposure and 

airbrush, 251
settings panel, 249, 250

E, F
Elliptical Marquee tool

Anti-alias checkbox, 330, 331
border selection dialog box, 334
contract selection dialog 

box, 336
elliptical and circular selections, 

328, 329
expand selection dialog 

box, 335
feather selection dialog box, 337
layer masks/adjustment layers, 

332, 333
modification options, 333–337
options bar panel, 330
smooth selection dialog 

box, 335
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style options, 331, 332
tools panel, 328

Eraser tool (E)
brushes panel, 199, 201
erasers/background/magic 

eraser tool, 210
eraser tool, 197, 198
flow/airbrush style, 205
history panel, 208
layers panel, 208, 209
mode brush, 202
opacity and pressure, 205
options bar panel, 199
Pencil/Block, 204
smoothing options, 206, 207

G
Generative Fill

AI feature, 502
app icons, 502
Cloud Desktop app, 504, 505
content credentials panel, 

506, 507
contextual menu, 502, 503
options, 503

H, I, J, K
Healing tools

clone stamp tool/clone 
source panel

adjustment layer, 141
align option, 135

blending Modes, 132
blend modes, 133
brush panel, 127–129
brush tool, 137, 138, 140, 145
clone source, 123
clone stamp tool, 122
colorful image, 143, 144
damaged black and white 

photo, 119
decrease/increase, 142
effect mode, 132
eraser tool, 142
flattened image, 120
history panel, 123, 124, 139
layers panel, 124, 125, 

135–137, 140
menu options, 118, 130
opacity percentage, 133
options bar panel, 119, 

125, 130
pattern stamp tool, 145
sources panel, 131
tool preset panel, 126
zoom and hand tools, 121

content-aware move tool
bounding box handles, 

182, 183
contextual task bar, 189
eraser tool, 188
extend option, 184
files, 180
layers panel, 181
move tool, 185, 186
remove tool, 186, 187
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scaling/rotation/
transformation, 185

selection options, 182
healing brush tool

accurate blur healing, 
168, 169

army image, 162
clone source panel, 164
delete layer button, 170
diffusion settings, 166
layers panel, 167
lessen reflections, 163
opacity layer, 171
options, 164
painting mode options, 165
round/elliptical brushes, 164
sampled/pattern, 165
spot/reflection, 167

patch tool
adding/subtracting/

intersecting selection, 175
background/duplicate 

layers, 172
content-aware 

option, 177–179
destination/normal 

selection, 177
dragging out, 174
duplicate/background 

layers, 172
duplicate file, 173
normal selection, 175
options, 173

source/normal 
selection, 176

photo damage/issues
cosmetic issues, 115
main tools, 117

red eye tool
details, 193
layers panel, 190, 191
options bar panel, 192
reduction option, 189
tool settings, 192, 193

remove tool (J)
brush tool options, 157
historical site, 160
layers panel, 155
magenta overlay/removing 

parts, 156
object/plant/even, 153
options, 155
overlay creation, 161
overlay/removal, 158
overlay/stroke  

settings, 157
spot brush tool (J)

brush tool options, 147, 148
Content-Aware, 150
diffusion, 151
heal spots image, 149
imperfections, 146
layers panel, 146, 147, 152
painting mode, 149, 150
proximity match, 151
texture, 150
time stamp, 153

Healing tools (cont.)
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winter woods/photo 
image, 146

Historical photos
albums, 5
environmental issues, 3
films, 5
Isopropyl Alcohol, 6
light-sensitive materials, 2
media, 4
museum/archival vault, 6
organization process

film slides/negatives, 8
negative film, 10
negatives/slides, 7
original slide projector, 8
piles, 9
slides, 11

plastic sleeves, 5
prints/film, 3
scanner (see Scanner process)
shiny film side, 6
storage options, 3

L
Lasso tools

complex selection tools, 
390, 391

loose selection, 339
Magnetic Lasso tool

close selection, 342, 343
options bar panel 

options, 343
pen tool, 346

select/mask button, 344
unicorn image, 344, 345

options bar panel options, 339
Polygonal Lasso tool, 

341–343, 470–472
quick mask mode (Q)

brush and block modes, 349
brush/eraser tool, 348, 349
click and shift-click 

method, 352
edit option, 347, 348
eraser tool, 350, 351
selection active, 353
selection mode, 347
showing/hiding areas, 350
tools panel, 353, 354
tower selection, 354, 355

tools panel, 338
Layer masks

add layer masks, 449
background copy, 435, 436
bounding box panels, 454
brush/eraser/clone stamp tool, 

449, 450
brush/eraser tool, 440
cancel/commit settings, 460
color fills, 437, 438
color picker dialog box, 437
content-aware scale 

option, 462–464
contextual task bar, 457
delete option, 443
duplicate layer, 434, 435
edit option, 450
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enable and disable options, 443
history panel, 441, 442
interpolation option, 459
link enable/disable option, 

456, 457
move tool, 442, 452
options bar panel, 453
photo project, 507–513
pixels setting, 455
properties panel, 444–447, 461
reference point, 453
skew settings, 458
smart object layer, convert 

layer, 448
tools panel, 441
transformation/scaling/

rotating, 451, 452
warning message, 449

M, N, O
Magnetic Lasso tool

close selection, 342, 343
options bar panel options, 343
pen tool, 346
select/mask button, 344
unicorn image, 344, 345

P, Q
Photo project

background copy layer, 511
block mode, 510

clone stamps, 513
eraser tool, 511
layers panel, 512
masks/past projects, 508
selection option, 510
select/mask workspace, 509

Photo restoration/healing
blur tool, 233

layers panel, 237, 238
options bar panel, 234
painting mode options, 

236, 237
preset picker, 235
preview mode, 233
settings panel, 236

brush tool(B)
black and white/color 

image, 211
brush preset picker, 212
brush settings panel, 213
castle.psd, 218, 219
eraser tool, 219
history panel, 220–223
opacity, 218
opacity and flow setting, 216
painting mode, 214, 215
pencil tool option, 223–225
preset picker, 217
setting, 212
smoothing option, 216

color replacement tool
background layer, 231
brush angle setting, 231
brush presets, 229

Layer masks (cont.)
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duplicate layer, 226–228
foreground/background 

color, 232
foreground color, 225, 226
mixer brush tool, 232
options bar panel, 228
painting mode, 230
sampling options, 230

cropping (see Cropping tools)
dodge tool

brush size, 252
burn tool, 255
layers panel, 247, 248, 

252, 253
options bar panel, 248, 

249, 254
protect tones, 251, 254
range exposure and 

airbrush, 251
settings panel, 249, 250

duplicate image dialog box, 
114, 196

eraser tool (E)
brushes panel, 199, 201
erasers/background/magic 

eraser tool, 210
eraser tool, 197, 198
flow/airbrush style, 205
history panel, 208
layers panel, 208, 209
mode brush, 202
opacity and pressure, 205
options bar panel, 199
Pencil/Block, 204

smoothing option, 206
smoothing options, 207

healing (see Healing tools)
history panel, 115
move/zoom/hand tools, 

115, 196
reset tool, 197
sharpen tool, 239–242
smudge tool

blur image, 243, 244
finger painting mode, 246
layers, 242, 243
options bar panel, 244
painting mode, 245

sponge tool
angle, vibrance, and 

pressure, 258
background copy layer, 

256, 257
black and white image, 260
geese.psd image, 256
mode, flow, and 

airbrush, 258
mode option, 259
options bar panel, 257
save option, 261

Photoshop workspace, 55
adjusting scanned image

layers panel, 94
move tool, 95
options panel bar, 95–97
rotation options, 92, 93

adjustment layers, 82, 83
brush/eraser tool, 83
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channels, 87
color panel menu, 75–77
comments panel, 74
contextual task bar, 72, 73
duplicate image, 92
Elliptical Marquee tool

Anti-alias checkbox, 330, 331
border selection dialog 

box, 334
contract selection dialog 

box, 336
elliptical and circular 

selections, 328, 329
expand selection dialog 

box, 335
feather selection dialog 

box, 337
layer masks/adjustment 

layers, 332, 333
modification 

options, 333–337
options bar panel, 330
smooth selection dialog 

box, 335
style options, 331, 332
tools panel, 328

file/workspace
background contents/

advanced options, 61
blank document, 63
CMYK color mode, 58–60
color profile, 62
document dialog box, 56

image bit size options, 61
layers panel, 65
options panel bar, 63, 64
preset details, 56
set up, 56
width/color mode, 57

gradients (color transitions), 79
history panel, 73
icon, 25
image size adjustment

artificial intelligence, 103
auto resolution options, 100
data points/pixels, 102
dialog box, 98–100
further smoothing, 103, 104
links, 105
preference options, 103
preset size, 101
resample options, 102

Lasso (see Lasso tools)
layers panel, 85, 86
libraries, 83, 84
options bar panel, 71, 72
paths, 88–90
patterns, 80
pen tool, 88
properties, 81
PSD file format, 109, 110
Rectangular Marquee tool

background layer, 315, 316
brush/clone stamp tools, 308
clone stamp, 326, 327
Clone Stamp/Brush/

Eraser, 302

Photoshop workspace (cont.)
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copying layer, 315–327
deselect selection, 309
feather settings, 312
fixed ratio, 313
fixed size, 314
history panel, 320
layers panel, 318, 319
Layer Via Copy, 317
normal option, 313
options bar panel, 310
overlay/options bar panel, 

303, 304
paint/clone stamp, 309
pop-up menu option, 

317, 318
rectangular/square 

selections, 306, 307
selection options, 311, 

321, 322
selection tool, 324, 325
select/mask button, 315
Single Row and Single 

Column tool, 326
square selection, 302
tool preset picker, 310
transform selection, 323, 324
transparent gaps, 305
warning message, 320, 321

rulers/guides, 91
save files

creative cloud dialog 
box, 106

JPEG options dialog box, 108
.tif file/.jpg file, 105

TIFF options dialog box, 107
scanned file, 92
selection tools

background image, 298
channels panel, 301
contextual task bar, 299, 300

swatches panel, 77, 78
tools panel

background layer, 69
customize toolbar dialog 

box, 70, 71
edit toolbar button, 70
hand tool, 69, 70
move/zoom/hand tools, 67
normal layer, 68
remove tool, 66, 67
zoom tool, 69

transform/align layers, 81

R
Rectangular Marquee tool

background layer, 315, 316
brush/clone stamp tools, 308
clone stamp, 326, 327
Clone Stamp/Brush/Eraser, 302
copying layer, 315–327
deselect selection, 309
feather settings, 312
fixed ratio, 313
fixed size, 314
history panel, 320
layers panel, 318, 319
Layer Via Copy, 317
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normal option, 313
options bar panel, 310
overlay/options bar panel, 

303, 304
paint/clone stamp, 309
pop-up menu option, 317, 318
rectangular/square selections, 

306, 307
selection options, 311, 321, 322
selection tool, 324, 325
select/mask button, 315
Single Row and Single Column 

tool, 326
square selection, 302
tool preset picker, 310
transform selection, 323, 324
transparent gaps, 305
warning message, 320, 321

S
Scanner process

collides/bends, 14
color modes, 32–35
digital camera, 50–53
film clean/dust-free, 19–22
film slides/negatives

backlight source, 15
flatbed photo scanner, 18, 19
light sources, 15
portable stand-alone digital 

film, 16–18
resolution options, 16

flatbed scanner
additional filter-like 

settings, 44
adjustment settings, 43, 44
color mode, 39, 40
dialog box, 35
document size, 41, 42
file save settings, 45
formats/color modes, 49
gutter/side shadow, 24
image format options, 46
negative film strips, 39
photo (reflective) print, 38
Photoshop icon, 25
prevent shadows/gutter 

shadow, 23
preview dialog box, 47, 48
professional mode, 36, 37
resolution, 41
scaling size, 42, 43
slides and negatives, 36

flatbed scanners, 12, 13
grayscale picture, 33
personal computer/flatbed 

scanner, 21
photo scanning

device dialog box, 27
enable/disable options, 26
preview button, 30–32
properties dialog  

box, 29, 30
subfolders, 26
WIA support dialog 

box, 26, 28

Rectangular Marquee tool (cont.)
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Photoshop (see Photoshop 
workspace)

portable stand-alone digital 
film, 21

services, 14
Smudge tool

blur image, 243, 244
finger painting mode, 246
layers, 242, 243
options bar panel, 244
painting mode, 245

Sponge tool
angle, vibrance, and pressure, 258
background copy layer, 256, 257
black and white image, 260

geese.psd image, 256
mode, flow, and airbrush, 258
mode option, 259
options bar panel, 257
save option, 261

T, U, V
Tools panel, see Photo 

restoration/healing

W, X, Y, Z
Wizard Assists/Windows Image 

Acquisition (WIA), 26
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