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Abstract Natural products from medicinal plants have been increasingly used in
modern medicine due to their safety, efficacy, and lesser toxicity. World over, a large
number of natural compounds are evaluated for the desired bioactivity. A wide range
of phytoconstituents such as alkaloids, terpenoids, tannins, steroids, etc. have been
recognized for their varying biological activities. However, obtaining the natural
products with the desired bioactivity is a time-consuming and commercially difficult
process. Molecular docking is used for screening known as well as novel drugs to
identify novel compounds by predicting their binding mode and affinity. Moreover,
in silico molecular docking can be performed to analyze their binding capabilities
into the 3D structure of proteins. AutoDock and AutoDockTools are open-source
techniques that have been extensively cited in the literature as essential tools in
structure-based drug design. These methods are fast enough to permit the virtual
screening of ligand libraries containing tens of thousands of compounds. This article
highlights the recent developments in the virtual screening of enzyme inhibitors
using various docking tools and their significant applications in designing potent
inhibitors for the management of various metabolic and infectious diseases.

Keywords Natural products · Virtual screening · Molecular docking · In silico ·
AutoDock and AutoDockTools

M. Patil · S. Patil · R. H. Patil (*)
Department of Microbiology and Biotechnology, R. C. Patel Arts, Commerce and Science
College, Shirpur, India

V. L. Maheshwari
School of Life Sciences, KBC North Maharashtra University, Jalgaon, Maharashtra, India

L. Zawar
Department of Pharmacognosy, H. R. Patel Institute of Pharmaceutical Education and Research,
Shirpur, MS, India

© The Author(s), under exclusive license to Springer Nature Singapore Pte Ltd. 2022
V. L. Maheshwari, R. H. Patil (eds.), Natural Products as Enzyme Inhibitors,
https://doi.org/10.1007/978-981-19-0932-0_4

105

http://crossmark.crossref.org/dialog/?doi=10.1007/978-981-19-0932-0_4&domain=pdf
https://doi.org/10.1007/978-981-19-0932-0_4#DOI


4.1 Introduction

Natural products have been a valuable source of new drugs. Secondary metabolites
are naturally derived substances and/or by-products from plants, animals, and
microorganisms (Baker et al. 2000). According to the World Health Organization
(WHO) estimates, 80% of the people of developing countries rely on traditional
medicines, mostly plant-derived drugs, for their primary health needs. Over 49% of
the new medicines registered by the United States Food and Drug Administration
(USFDA) are derived from natural products or their derivatives. The Indian subcon-
tinent has been one of the rich hotspots with over 2500 plant species being used in
indigenous medicines. The use of medicinal plant resources for health management
is an imperative part of tribal culture. It is evident that these people have vast
traditional knowledge about medicinal plants and use them for a wide range of
health-related applications. In the old traditions, local tribal communities have
discovered the medicinal uses of hundreds of plants and plant-based substances.
Medicinal plants contain a variety of bioactive constituents known as phytochemi-
cals that make them effective in the treatment of a wide range of diseases (Twilley
et al. 2017; Anigboro et al. 2020), and they are becoming more popular as thera-
peutic agents due to their high safety profile, low cost, and widespread availability
(Govindappa 2015; Limanaqi et al. 2020). Natural oxyprenylated ferulic,
umbelliferone derivatives and coumarins, flavonoids, glycosides make up a large
portion of these natural phytochemicals.

Enzyme inhibitors are mostly plant or microbial bioactive secondary metabolites
that bind to enzymes and inhibit/reduce their activity. The use of natural products as
enzyme inhibitors is well documented (Rauf and Jehan 2017). The binding of
inhibitors to the enzymes alters the conformation of the active site, thereby halting
the chemical process. Inhibition of enzymes can be both irreversible and reversible.
The inhibitory effects of plant extracts and the isolated compounds on the activity of
various enzymes, viz. α-amylase, α-glucosidase, and pancreatic lipase have been
studied to discover potential therapeutic candidates. Various reports have demon-
strated the in vitro, in vivo, and in silico enzyme inhibitory potential of natural
products of plant and microbial origin (Rauf and Jehan 2017).

The discovery of new, safe, and effective enzyme inhibitors is a long and costly
process. Conventionally, a trial-and-error method is used in screening vast libraries
of chemical constituents against a known enzyme in the hopes of finding some useful
lead drugs. Combinatorial chemistry approaches were found effective as they offered
rapid and high-throughput screening capabilities to quickly screen these enormous
chemical libraries for novel and potent inhibitors.

Molecular docking is important in silico technique normally used to predict the
interaction between the receptor and the ligand. This technique is employed in drug
discovery because it is inexpensive and time-saving (Miners et al. 2004). For these
reasons, the development of in vitro and in silico approaches is important to predict
drug interactions, to possibly identify the pharmacophore, to reduce time and costs
(FitzGerald et al. 2020). Using in silico docking approach, the most effective

106 M. Patil et al.



inhibitors of different enzymes can be screened for further investigation to under-
stand the structures of proteins and molecular interaction of ligands to exert their
inhibitory activity. Therefore, to understand such possible molecular interactions
between the enzyme and inhibitor, a combined in vitro and in silico method is
required to screen for bioactive molecules.

Several approaches are available for determining whether a bioactive compound
is interacting with a biological macromolecule; for example, kinetic investigations
and in silico molecular docking study (Mentes et al. 2018; Moreno et al. 2020).
Prediction of chemical compounds’ reactivity, chemical hardness, stability, nucleo-
philic or electrophilic nature, as well as drug-like properties (such as absorption,
distribution, metabolism, and excretion) with plausible precision using in silico
analytical methods such as semi-empirical quantum mechanics (frontier molecular
orbital (FMO) theory calculations) and pre-ADME or adsorption, distribution,
metabolism, and excretion cheminformatics tools have also been reported (Bondzic
et al. 2020; Siahaan et al. 2021). These methods have been used to investigate
molecular interactions between chemical substances or ligands and proteins, includ-
ing acetylcholinesterase (Bondzic et al. 2020), epoxide hydrolase (Jo et al. 2016),
3-hydroxysteroid dehydrogenase (Oyebamiji et al. 2020), and pancreatic lipase (Hou
et al. 2020). The use of molecular docking analysis, as one of the biophysical/bio-
computational techniques for probing ligand–protein binding interactions, has
gained more recognition and relevance over the years in the fields of biochemistry
and biophysics (Almasri 2020).

Molecular Docking for Screening of Enzyme Inhibitors
Molecular docking of protein–ligand interaction is an effective and competent tool
for in silico screening of natural products as inhibitors. It plays the most important
and ever-increasing role in rational drug design. Molecular docking is a computa-
tional program of virtual screening for an appropriate ligand (enzyme inhibitor) that
fits both energetically and geometrically the proteins’ binding pocket. Consensus
molecular docking is one of the approaches to increase detection of real actives
within virtual screening campaigns. With molecular docking, it is possible to find the
most favorable position, orientation, and conformation for the binding of a molecule
to, a protein target, assigning a score that is the estimate of the likelihood of binding
of each molecule and conformation (Cavasotto 2015). There are different open-
source molecular docking programs, Autodock Vina, Smina, LeDock, and rDock,
available for this purpose. Here we propose/present the protocol for Autodock Vina.
AutoDock and AutoDockTools are open-source techniques that have been used as
essential tools in structure-based drug design. Moreover, these methods are fast
enough to permit the virtual screening of ligand (inhibitors) libraries containing
thousands of natural compounds. The protocol can be implemented in any virtual
screening campaign where proteins (enzymes) are used as molecular targets. In
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addition, we introduce a scoring strategy based on the average RMSD value obtained
from comparing the different confirmations to predict the best fit.

4.2 Molecular Docking with AutoDock

AutoDock suite is molecular modeling simulation software that attempts to predict
the noncovalent binding of the macromolecule (receptor) and ligand (small mole-
cule). It is one of the most accurate and effective tools that is capable of predicting
the bound conformations and binding energies of the ligands with macromolecules
targets. Furthermore, it is open-source software, and it includes several complemen-
tary tools like AutoDock Vina, Autodock, Raccoon2, AutoDockTools, and
AutoLigand. AutoDockTool combines precision in identifying the binding pose of
a tiny molecule in corresponding to the receptor pocket for computational docking
researchers.

There are four basic steps in a typical docking process. First, prepare the ligand
and target protein (depending on the nature of the ligand and/or target, this may
necessitate more complex processes). Second, prepare to dock and scoring param-
eters (for Autodock to run, the following files should be created: grid parameter file,
map files, docking parameter files). Third, using a graphical interface or a command-
line interface terminal to launch the docking program (e.g., AutoDock). The fourth
step is to analyze and evaluate the docking data (by comparing docking poses to
crystalline ligand). Here we are providing easy step-by-step and practical docking
protocols using AutoDock and AutoDockTools. In nutshell, the AutoDock engine
uses a proprietary format known as PDBQT. For both ligand and protein, this file
contains all information on atom kinds and charges. This file is created when a PDB
file (http://www.wwpdb.org/documentation/file-format) is converted. It can be made
with AutoDockTools, the preferred graphical user interface for AutoDock. A Grid
calculating approach is used to evaluate the binding site’s energy (AutoGrid). The
ligand’s energetics is then compared to values calculated from the interaction terms
assigned by the affinity grids computations. In the last step, the ligand is docked
utilizing a variety of search techniques. The Lamarckian genetic algorithm (LGA),
which is implemented in AutoDock, is one of the most widely used and effective
approaches for determining optimal ligand binding conformation with predicted free
energies of association.

A landmark enzyme, Pancreatic Lipase (PL) was identified as a major target for
binding of inhibitors in the treatment of obesity. Human pancreatic lipase consists of
449 amino acids with a coated catalytic center of the N-terminal domain including
Ser-152, his-263, and Asp-176. The catalytic triad (S152–D176–H263) and the lid
(peptide stretch C237–C261) are found in the large N-terminal domain (residues
1–335) of 2OXE, which has the typical/-hydrolase fold of lipases and is dominated
by a central parallel sheet (Winkler et al. 1990; Van Tilbeurgh et al. 1993). In the
present review, PL will be used as a model for docking using AutoDock as it is a
promising target for binding of inhibitors in the treatment of obesity.
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4.2.1 Computational Tools Required for Docking

4.2.1.1 Starting with a Set of Preliminary and Important Requirements

This would require user-friendly tools such as protein data bank (https://www.rcsb.
org/) and Swiss-PdbViever (https://spdbv.vital-it.ch/) in order to understand and
deduce the structural alignment, finding the active site, amino acid mutations,
H-bond, angles, and distance between the atoms of the protein–ligand complexes.
These tools offer a great help that explains all you need to know about manipulating
protein–ligand complexes, removing the solvent, fixing structure, and more.

4.2.1.2 Download the PDB (Protein Data Bank) File

The X-ray diffraction crystallographic structure (3D) of human pancreatic lipase-
related protein (PDB ID, 2OXE) is downloaded from the Research Collaboratory for
Structural Bioinformatics (RCSB) Protein Data Bank (https://www.rcsb.org/
structure/2OXE). The current crystal structure has 466 amino acid residues and the
monomer has a resolution of 2.8 Å (Fig. 4.2). The 3D structure of the ligand can be
obtained from https://pubchem.ncbi.nlm.nih.gov/. The structure of both target pro-
tein and corresponding ligand were extracted separately from the original PDB files.
Users are encouraged to regenerate the target.pdb and ligand.pdb files using Swiss-
PDB viewer http://spdbv.vital-it.ch/.

4.2.1.3 Download the Computational Tools

AutoDock 4.2.6

The latest version of Autodock should be downloaded from http://autodock.scripps.
edu/downloads/autodock-registration/autodock-4-2-download-page/. This new ver-
sion of Autodock runs natively under Windows, see instructions for installation
(http://autodock.scripps.edu/downloads/autodock-4-2-x-installation-on-windows).
The main files, AutoDock4 and AutoGrid4 are necessary to run the pre-docking
(energy maps), docking, and scoring calculation.

MGL/AutoDockTools

AutoDockTools can be downloaded from http://mgltools.scripps.edu/downloads. It
is a Graphical User Interface for preparing input, running, and analyzing Autodock
dockings (adding atomic charges, fixing bonds, adding hydrogens, preparing the
ligand and target in Autodock-compatible PDBQT format, creating grids and
docking parameter files, and visualizing interactively docking results).
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Method-Docking Approach

The following steps are crucial since they specify how to execute AutoGrid and
AutoDock and offer accurate docking parameters. The coordinated files and associ-
ated information should be created in the PDBQT format, which includes atom/bond
types, partial atomic charges, and other information. These data types are prepared
typically using AutoDockTools (ADT). The steps in the docking method are
represented in Fig. 4.1.

4.2.2 Preparation of Protein for Autodock

The following steps represent the preparation of the crystal structure of PL protein
(2OXE Fig. 4.2) PDB file into the PDBQT file format.

• First, open AutoDockTools and MGL tools from desktop or program files. Before
preparing protein, make sure that protein.pdb and ligand.pdb files are in the same
folder, e.g., Desktop/autodock.

• Click on File > Preferences > Set: change the startup directory > set file path.
• From File menu > open > read molecule > select target protein.pdb from same

folder: Desktop/autodock.
• The crystal 3D structure of 2OXE will appear on screen, then Click on

Edit > Delete water > Hydrogen > Add (polar Hydrogen’s) > Click on Charges

•Preparation of Protein (PDBQT)

•Preparation of Ligand (PDBQT)

•Preparation of the Grid Parameter File (GPF)

•Preparation of the Docking Parameter File (DPF)

•Run Autogrid and autodock

•Analyse Docking Lof file (DLG ) for  Autodock results

Fig. 4.1 Step-wise docking approach for the molecular docking of protein–ligand interaction
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> Add Kollman charges > Compute Gasteiger charges. This will add partial
charges to protein.

• Click on Grid >Macromolecule > Open: Open and select target protein pdb file,
and ADT tool will prompt a new window to save our protein into pdbqt file> save
the PDBQT file in the same folder where we created target pdb. This will store the
partial charges and Autodock atom types that are compatible with autodock grid
computing.

4.2.3 Preparation of Ligand for Autodock

The process of creating ligand PDBQT from a PDB file from the crystal structure of
ligand.pdb consists of the following steps.

• Click on Ligand > Input > open: open ligand.pdb file from the same folder, the
crystal 3D structure will appear on the screen.

• Click on Edit > Delete water > Hydrogen> Add (polar Hydrogen’s) > Click on
Charges > Add Kollman charges > Compute Gasteiger charges.

• Click on Ligand > Torsion Tree > Detect Root > Ligand > Torsion
Tree > Choose Torsions: decide on the rotatable bonds to be considered and
set the number of torsions.

• Select Ligand > Output > Save as PDBQT: save the ligand file with “pdbqt”
extension (e.g., ligand.pdbqt). Type in the extension manually and save it in the
same folder.

Fig. 4.2 Three-dimensional
crystal structure of the
generated 2OXE model of
pancreatic lipase
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4.2.4 Docking Approach

4.2.4.1 Preparation of Grid Parameter File (GPF)

• For the preparation of the grid parameter file to run with Autogrid4.exe, open the
Grid menu in AutoDockTools to prepare the parameters for Autogrid calcula-
tions. Autogrid calculates grid maps of interaction energies for various atom
types. This is important to calibrate the docking procedure.

• Click on Grid > Set Map Types > Choose Ligand: select the ligand molecule
from the list or open the ligand. pdbqt saved previously. Select Grid > Grid Box:
Select the number of grid points in x, y, and z directions. Usually, the default 40 is
taken. However, we can increase or decrease that number in any direction. From
the “Center” menu, select “Center on ligand.” Leave other parameters on default.

• The number of grid points in each dimension: only give even numbers (from
2 � 2 � 2 to 126 � 126 � 126). Grid Maps depend on the orientation of the
macromolecule.

• Click on File > Close saving current: save the settings before closing. Otherwise,
settings will be lost if the program is closed. Select Grid > Output > Save GPF:
save our gpf file as docking.gpf. Type in the extension manually and save it in the
same directory. This will create one grid map for each atom type in the ligand plus
electrostatics and a desolvation map. Check out the content of Grid Parameter
File, docking.gpf (by Notepad).

4.2.4.2 Preparation of Docking Parameter File (DPF)

In AutoDockTools, open the docking menu to prepare the docking parameters for
Autodock.

• Click on Docking > Macromolecule > Set Rigid Filename: Select target macro-
molecule protein file (e.g., protein.pdbqt). Again select
Docking > Ligand > choose: select ligand in pdbqt format. Leave everything
on default and select Accept.

• Select again docking > Search Parameters > Genetic Algorithm: set the number
of GA Runs as 10. Leave other parameters on default and select Accept.

• Click on Docking > Docking Parameters: Leave on default parameters. Again
click on Docking>Output> Lamarckian GA: save dpf file (e.g., docking.dpf) in
the same directory. Type in the extension manually.

• Now we have all the required files for docking; target protein.pdbqt, ligand.pdbqt,
docking.gpf, docking.dpf files in the same folder.
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4.2.4.3 Running AutoGrid4 and AutoDock4

After downloading and installing AutoDock 4.2.6 from http://autodock.scripps.edu/
downloads/autodock-registration/autodock-4-2-download-page/, for Windows users,
Start > Run and type “cmd.exe,” then type the command: “C:\Program Files\
The Scripps Research Institute\ Autodock\autodock4.exe”.

For running Autogrid4, Start > Run and type “cmd.exe,” change the working
directory to ~Desktop\autodock (using the cd command). Type in the console:
autogrid4.exe -p docking.gpf -l docking.glg. For running autodock4, type in the
console: autodock4.exe -p docking.dpf -l docking.dlg & . This will take some time
depending on your CPU and memory capacity.

All information about the docking runs, the calculated binding energy in Kcal/
mol, as well as other data RMSD versus crystal binding pose is contained in the dlg
file. Figure 4.3 represents different conformations of protein–ligand interactions.

4.2.4.4 Analyzing Docking Results

Open the analyze menu in AutoDockTools to analyze the docking results. Docking
results can be found in the docking.dlg log file in the same directory.

Fig. 4.3 Predicted active sites for binding of compounds (ligands) in the pancreatic lipase enzyme
in the molecular docking
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• Select the Analyze>Docking> open>Docking.dlg. file> open analyze> select
Conformations> play. This will show the conformation from 1 to 10 of the ligand
bound to PL protein.

• The best conformation shows binding energy (G) of �10.59 kcal/mol and
inhibition constant (Ki) of 17.17 nM (nanomolar) and a RMSD (root-mean-square
deviation of atomic positions) from a reference structure of 1.22 Å.

• This demonstrates that Autodock’s results are accurate and dependable (in the
nanomolar range for a recognized inhibitor). Docking and virtual screening
would be extremely useful in the search for novel PL inhibitors.

4.3 Significance of Molecular Docking in Inhibitor
Screening for Biomedical Applications

Molecular docking is a widely used platform to understand drug biomolecular
interactions that have applications in rational drug design and discovery. It is also
used for mechanistic studies binding studies of ligand into the preferred binding site
of the target protein/DNA through the noncovalent interactions. The values of the
binding energy, free energy, and stability of complexes help predict the binding
affinity of the molecule under study. There are numerous examples where the
docking approach successfully identifies the target sites for several different recep-
tors/targets. For example, using docking technology, Schames et al. (2004) discov-
ered HIV 1 integrase as a new binding site for drugs treating AIDS. Using
AutoDock, this receptor was effectively used for the inhibition of HIV integrase.
The most striking discoveries involving docking approaches include the discovery of
novel type I TGF-beta receptor kinase inhibitor (Singh et al. 2003), aurora kinase A
inhibitor (Park et al. 2018), dopamine D3 receptor for anticancer molecules (Varady
et al. 2003), etc. Table 4.1 provides a detailed outlook of various target proteins/
receptors that are inhibited using a ligand with its PDB ID, binding sites, software
used in the study, and the biological significance of the study.

4.4 Limitations of Molecular Docking

The lack of confidence in scoring functions’ ability to provide correct binding
energies is a key constraint of molecular docking. This is because some
intermolecular interaction terms, such as solvation effect and entropy change, are
difficult to anticipate precisely. Furthermore, several intermolecular interactions that
have been proved to be significant are rarely taken into account in scoring methods.
For example, halogen bonding and guanidine–arginine interactions have been
shown to contribute to protein–ligand binding affinity, although they are not taken
into account. Secondly, the water molecules that are present in the binding pocket
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create lots of difficulties during the docking process. The major challenges faced in
the docking experiments are that of rigid receptors. Most importantly, molecular
docking does not provide insights into the spectrum of action against non-target
proteins/receptors. One has to depend on animal and human trials to get this
information.

References

Almasri IM (2020) Computational approaches for the discovery of natural pancreatic lipase
inhibitors as antiobesity agents. Future Med Chem 12:741–757

Anigboro AA, Avwioroko OJ, Cholu CO (2020) Phytochemical constituents, antimalarial efficacy,
and protective effect of Eucalyptus camaldulensis aqueous leaf extract in plasmodium berghei-
infected mice. Prev Nutr Food Sci 25:58

Avwioroko OJ, Anigboro AA, Atanu FO, Otuechere CA, Alfred MO, Abugo JN, Omorogie MO
(2020) Investigation of the binding interaction of α-amylase with Chrysophyllum albidum seed
extract and its silver nanoparticles: a multi-spectroscopic approach. Chem Data Collect 29:
100517

Baker D, Mocek U, Garr C (2000) Natural products vs. combinatorial: a case study. In: Wrigley SK,
Hayes MA, Thomas R, Chrystal EJT, Nicholson N (eds) Biodiversity: new leads for pharma-
ceutical and agrochemical industries. The Royal Society of Chemistry, Cambridge, pp 66–72

Bondzic AM, Sencanski MV, Nikezic AVV, Kirillova MV, Andre V, Kirillov AM, Bondzic BP
(2020) Aminoalcoholate-driven tetracopper (II) cores as dual acetyl and butyrylcholinesterase
inhibitors: experimental and theoretical elucidation of mechanism of action. J Inorg Biochem
205:110990

Cavasotto CN (2015) In silico drug discovery and design: theory, methods, challenges, and
applications. CRC Press, Boca Raton

Chen XZ, Yu XY, Dai C, Huang QY, Shen Y,Wang J, Hu Y, Lin ZH (2022) Identification of potent
CypD inhibitors via pharmacophore based virtual screening, docking and molecular dynamics
simulation. J Mol Struct 1247:131355

FitzGerald RJ, Cermeno M, Khalesi M, Kleekayai T, Amigo-Benavent M (2020) Application of in
silico approaches for the generation of milk protein-derived bioactive peptides. J Funct Foods
64:103636

Govindappa M (2015) A review on role of plant (s) extracts and its phytochemicals for the
management of diabetes. J Diabetes Metab 6(1):38

Gyebi GA, Elfiky AA, Ogunyemi OM, Ibrahim IM, Adegunloye AP, Adebayo JO, Olaiya CO,
Ocheje JO, Fabusiwa M (2021) Structure-based virtual screening suggests inhibitors of 3-chy-
motrypsin-like protease of SARS-CoV-2 from Vernonia amygdalina and Ocimum gratissimum.
Comput Biol Med 136:104671

Hou XD, Guan XQ, Cao YF, Weng ZM, Hu Q, Liu HB, Jia SN, Zang SZ, Zhou Q, Yang L (2020)
Inhibition of pancreatic lipase by the constituents in St. John’s Wort: in vitro and in silico
investigations. Int J Biol Macromol 145:620–633

Huang Y, Wang H, Wang H, Wen R, Geng X, Huang T, Shi J, Wang X, Wang J (2020) Structure-
based virtual screening of natural products as potential stearoyl-coenzyme a desaturase
1 (SCD1) inhibitors. Comput Biol Chem 86:107263

Ijaz M, Noor R, Nayab G, Niaz S, Basharat Z, Rastrelli L, Jayanthi S, Efferth T, Khan H (2021)
Screening of potent phytochemical inhibitors against SARS-CoV-2 protease and its two Asian
mutants. Comput Biol Med 133:104362

Jayaraman M, Lakshmanan L, Karthikeyan M, Krishna R (2021) Virtual screening assisted
discovery of novel natural products to inhibit the catalytic mechanism of mycobacterium
tuberculosis InhA. J Mol Liquids 335:116204

4 Recent Updates on In Silico Screening of Natural Products as Potential. . . 121



Jo AR, Kim JH, Yan XT, Yang SY, Kim YH (2016) Soluble epoxide hydrolase inhibitory
components from Rheum undulatum and in silico approach. J Enzyme Inhib Med Chem 31:
70–78

Li W, Cui X, Chen Z (2021) Screening of lactate dehydrogenase inhibitor from bioactive com-
pounds in natural products by electrophoretically mediated microanalysis. J Chromatogr A
1656:462554

Limanaqi F, Biagioni F, Mastroiacovo F, Polzella M, Lazzeri G, Fornai F (2020) Merging the multi-
target effects of phytochemicals in neurodegeneration: from oxidative stress to protein aggre-
gation and inflammation. Antioxidants 9:1022

Mayasah A, Anand G, Gabriel A (2018) Discovery of natural product inhibitors of phosphodies-
terase 10A as novel therapeutic drug for schizophrenia using a multistep virtual screening.
Comput Biol Chem 77:52–63

Mentes E, Yılmaz F, Emirik M, Ülker S, Kahveci B (2018) Synthesis, molecular docking and
biological evaluation of some benzimidazole derivatives as potent pancreatic lipase inhibitors.
Bioorg Chem 76:478–486

Miners JO, Smith PA, Sorich MJ, McKinnon RA, Mackenzie PI (2004) Predicting human drug
glucuronidation parameters: application of in vitro and in silico modeling approaches. Annu
Rev Pharmacol Toxicol 44:1–25

Moreno EN, Arvizu-Flores AA, Valenzuela-Soto EM, Garcia Orozco KD, Wall-Medrano A,
Alvarez-Parrilla E, Ayala-Zavala JF, Dominguez Avila JA, Gonzalez-Aguilar GA (2020)
Gallotannins are uncompetitive inhibitors of pancreatic lipase activity. Biophys Chem 264:
106409

Narendra G, Raju B, Verma H, Sapra B, Silakari O (2021) Multiple machine learning models
combined with virtual screening and molecular docking to identify selective human ALDH1A1
inhibitors. J Mol Graph Model 107:107950

Oyebamiji AK, Tolufashe GF, Oyawoye OM, Oyedepo TA, Semire B (2020) Biological activity of
selected compounds from Annona muricata seed as antibreast cancer agents: theoretical study. J
Chem 2020:6735232

Pablo AN, Rogerio AS, Diones CB, Lilian JL, Cristiane LD, Braga MM, Denis BR, Joao BTR
(2015) Virtual screening of acetylcholinesterase inhibitors using the lipinski’s rule of five and
zinc databank. BioMed Res Int 8:20

Padhi S, Masi M, Chourasia R, Rajashekar Y, Rai A, Evidente A (2021) ADMET profile and virtual
screening of plant and microbial natural metabolites as SARS-CoV-2 S1 glycoprotein receptor
binding domain and main protease inhibitors. Eur J Pharmacol 890:173648

Park H, Jung HY, Mah S, Hong S (2018) Systematic computational design and identification of low
picomolar inhibitors of aurora kinase A. J Chem Inf Model 58(3):700–709

Rajguru T, Dipshikha B, Mahendra KM (2022) Identification of promising inhibitors for Plasmo-
dium haemoglobinase Falcipain-2, using virtual screening, molecular docking, and MD simu-
lation. J Mol Struct 1248:131427

Rauf A, Jehan N (2017) Natural products as a potential enzyme ihnhibitors from medicinal plants,
enzyme inhibitors and activators, Murat Senturk. IntechOpen, London. https://www.intechopen.
com/chapters/54038

Rauf B, Rashid U, Khalil A, Khan S, Anwar S, Alafnan A, Alamri A, Rengasamy KRR (2021)
Docking-based virtual screening and identification of potential COVID-19 main protease
inhibitors from brown algae. S Afr J Bot 143:428–434

Schames JR, Henchman RH, Siegel JS, Sotriffer CA, Ni H, McCammon JA (2004) Discovery of a
novel binding trench in HIV integrase. J Med Chem 47(8):1879–1881

Siahaan P, Sasongko NA, Lusiana RA, Prasasty VD, Martoprawiro MA (2021) The validation of
molecular interaction among dimer chitosan with urea and creatinine using density functional
theory: in application for hemodyalisis membrane. Int J Biol Macromol 168:339–349

Singh J, Chuaqui CE, Boriack-Sjodin PA, Lee W-C, Pontz T, Corbley MJ (2003) Successful shape-
based virtual screening: the discovery of a potent inhibitor of the type I TGFβ receptor kinase
(TβRI). Bioorg Med Chem Lett 13(24):4355–4359

122 M. Patil et al.

https://www.intechopen.com/chapters/54038
https://www.intechopen.com/chapters/54038


Sofiene L, Chaker BS, Houssem H, Kamel B (2014) In silico screening and study of novel ERK2
inhibitors using 3D QSAR, docking and molecular dynamics. J Mol Graph Model 53:1–12

Teli DM, Shah MB, Chhabria MT (2021) In silico screening of natural compounds as potential
inhibitors of SARS-CoV-2 main protease and spike RBD: targets for COVID-19. Front Mol
Biosci 7:599079

Twilley D, Langhansova L, Palaniswamy D, Lall N (2017) Evaluation of traditionally used
medicinal plants for anticancer, antioxidant, anti-inflammatory and anti-viral (HPV-1) activity.
S Afr J Bot 112:494–500

Van Tilbeurgh H, Egloff MP, Martinez C, Rugani N, Verger R, Cambillau C (1993) Interfacial
activation of the lipase-procolipase complex by mixed micelles revealed by X-ray crystallogra-
phy. Nature 362:814–820

Varady J, Wu X, Fang X, Min J, Hu Z, Levant B (2003) Molecular modeling of the three-
dimensional structure of dopamine 3 (D3) subtype receptor: discovery of novel and potent D3
ligands through a hybrid pharmacophore- and structure-based database searching approach. J
Med Chem 46(21):4377–4392

Winkler FK, D’Arcy A, Hunziker W (1990) Structure of human pancreatic lipase. Nature 343:771–
774

Xiong F, Xiaoyu D, Hao Z, Xiaomin L, Kaixian C, Hualiang J, Cheng L, Xu H (2021) Discovery of
novel reversible monoacylglycerol lipase inhibitors via docking-based virtual screening. Bioorg
Med Chem Lett 41:127986

Xu J, Liangqin G, Huiqing L, Shaoliang Z, Penghua L, Shaodong C (2021) Evidence for the anti-
NAFLD effectiveness of chlorogenic acid as a HAT inhibitor using in vivo experiments
supported by virtual molecular docking. Phytomed Plus 1(4):100055

Yang Y, Tian JY, Ye F, Xiao Z (2020) Identification of natural products as selective PTP1B
inhibitors via virtual screening. Bioorg Chem 98:103706

4 Recent Updates on In Silico Screening of Natural Products as Potential. . . 123


	Chapter 4: Recent Updates on In Silico Screening of Natural Products as Potential Inhibitors of Enzymes of Biomedical and Phar...
	4.1 Introduction
	4.2 Molecular Docking with AutoDock
	4.2.1 Computational Tools Required for Docking
	4.2.1.1 Starting with a Set of Preliminary and Important Requirements
	4.2.1.2 Download the PDB (Protein Data Bank) File
	4.2.1.3 Download the Computational Tools
	AutoDock 4.2.6
	MGL/AutoDockTools
	Method-Docking Approach


	4.2.2 Preparation of Protein for Autodock
	4.2.3 Preparation of Ligand for Autodock
	4.2.4 Docking Approach
	4.2.4.1 Preparation of Grid Parameter File (GPF)
	4.2.4.2 Preparation of Docking Parameter File (DPF)
	4.2.4.3 Running AutoGrid4 and AutoDock4
	4.2.4.4 Analyzing Docking Results


	4.3 Significance of Molecular Docking in Inhibitor Screening for Biomedical Applications
	4.4 Limitations of Molecular Docking
	References


